[Defeted] VLC and movie player broken and few other issues

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

[Defeted] VLC and movie player broken and few other issues

Postby Linux n00b on Mon Dec 27, 2010 11:56 pm

I just gave this new LMDE 64bit a try. Clean install to a Dell Inspiron 6400 laptop. The first problem hit me was the "cannot find root" during install. A quick google and couple of mouse click later, everything went through.

But I then went on to test media play back, install a few my "must have". The real problem started.

1. Media playback is broken, only player works is the GONME MPlayer. For example playback qt files is only possible in GONME MPlayer. I searched this topic, it seems it is a problem that I may have to give up VLC. I assume other players are the same. It is really shame since I always use VLC. Is there any fix out there? VLC cannot even auto open removable media (eg. CD/DVD) now, it can no longer find the correction location (manually point to the location works).

2. K9copy cannot be started from the menu, It is listed after installing, but the only way I can start it is to open a terminal. Did I miss something?

3. Soundkonverter no longer work either. start it will throw a message says some files cannot be decoded (affected file %25i), and when I try to convert flac to mp3 (for a test), soundkonverter just crashed out.

So far above are the major issues. I haven't tested K3b and a few other yet, I have a bad feeling I will find more problem with media and KDE related software.
Last edited by Linux n00b on Sun Jan 09, 2011 5:00 am, edited 2 times in total.
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Linux Mint is funded by ads and donations.
 

Re: VLC and movie player broken and few other issues

Postby JCMan on Tue Dec 28, 2010 1:38 am

Am going to try to remove and reinstall manually and see if it fixes it. I can't evening point the the drive atm. Soon as it auto mounts the CD of choice to desktop as an Icon it disappears in the manual selection window in VLC like if you didn't even have a cd rom drive.
JCMan
Level 1
Level 1
 
Posts: 2
Joined: Thu Dec 23, 2010 10:13 pm

Re: VLC and movie player broken and few other issues

Postby Linux n00b on Tue Dec 28, 2010 9:22 pm

remove and reinstall doesn't work. Tried already. Another odd thing, I think some how VLC is at least partly responsible for k9copy. When I removed VLC, there was a positive change to other softwares.
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: VLC and movie player broken and few other issues

Postby linmint777 on Wed Dec 29, 2010 12:08 am

k9copy, k3b and soundkonverter in gnome?

not a good idea if you want a real experience kde, use a kde desktop.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: VLC and movie player broken and few other issues

Postby Linux n00b on Wed Dec 29, 2010 1:22 am

Why not? It doesn't matter what desktop I use, they should work, For the record, I do NOT want KDE desktop. I use what ever the best application to do the job, that's all.

And can you name something better? k3b is lightyears better than brasero, soundkonverter is miles better than soundconverter, and there is nothing close to k9copy.

By they way, I have been looking for a linux alternative of IrfanView, for these years, I thought someone might already coded one. Yet, there is still nothing out there (have to install WINE just for this).
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: VLC and movie player broken and few other issues

Postby terdon on Wed Dec 29, 2010 10:25 am

Well, according to this : http://forum.videolan.org/viewtopic.php?f=13&t=70719 the debian.multimedia repository can cause problems for vlc. You could try the fix suggested there (I have no problems on a 32 bit LMDE with this respoitory however):

Code: Select all
sudo gedit /etc/apt/sources.list
sudo apt-get update
sudo apt-get remove libavutil*
sudo apt-get install vlc
User avatar
terdon
Level 4
Level 4
 
Posts: 276
Joined: Tue Jan 13, 2009 2:52 pm
Location: Marseille

Re: VLC and movie player broken and few other issues

Postby CiaW on Wed Dec 29, 2010 12:18 pm

There was another thread about not seeing K3B as a menu item after it's installed. I suspect someone was listening to me when I complained on another forum that something pulled in a bunch of KDEPIM stuff and added a bunch of menu items that made a mess of things. (I now won't install anything that wants to pull in kdepim for my gnome desktop...)

At any rate, all you need to do is either open alacarte in a terminal or right click on Menu and select edit menu, then under Sound & Video you'll probably see K3B and K9copy etc. without a check in the box, just check it and close and they should now show up on your menu.
CiaW
Level 3
Level 3
 
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: VLC and movie player broken and few other issues

Postby drzoo2 on Wed Dec 29, 2010 12:42 pm

terdon wrote:Well, according to this : http://forum.videolan.org/viewtopic.php?f=13&t=70719 the debian.multimedia repository can cause problems for vlc. You could try the fix suggested there (I have no problems on a 32 bit LMDE with this respoitory however):

Code: Select all
sudo gedit /etc/apt/sources.list
sudo apt-get update
sudo apt-get remove libavutil*
sudo apt-get install vlc




Problem with this is there quite a few packages that are removed with no installation candidate.

libavcore0
gstreamer0.10-plugins-really-bad
libavcore0
libavutil50
libmjpegtools-1.9

Code: Select all
scott@linux-main:~/Desktop$ sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-plugins-really-bad libasound2-plugins libavcodec52 libavcore0 libavformat52 libavutil49 libavutil50 libpostproc51 libquicktime1 libswscale0 vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse libmjpegtools-1.9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gstreamer0.10-plugins-really-bad is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  gstreamer0.10-plugins-good gstreamer0.10-plugins-bad

Package libavcore0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libavutil50 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gstreamer0.10-plugins-really-bad' has no installation candidate
E: Package 'libavcore0' has no installation candidate
E: Package 'libavutil50' has no installation candidate
E: Package 'libmjpegtools-1.9' has no installation candidate
scott@linux-main:~/Desktop$


Is there another repo with non-broken versions of these?
z
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: VLC and movie player broken and few other issues

Postby Linux n00b on Thu Dec 30, 2010 2:52 am

k9copy does show up in the menu, but it cannot be started there (click does nothing). Only way to start it, is to start a terminal.
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: VLC and movie player broken and few other issues

Postby malligt on Sat Jan 01, 2011 3:04 pm

Here's a link to resolving the broken VLC program:

http://linuxbsdos.com/forum/thread-61.html

Hope it helps.
malligt
Level 4
Level 4
 
Posts: 254
Joined: Sat Sep 11, 2010 12:58 pm

Re: VLC and movie player broken and few other issues

Postby Linux n00b on Sun Jan 02, 2011 8:52 am

The major problem I have with LMDE (at least for my clean installation) is there is deeper misconfiguration issue with certain software, particularly KDE related. What Mint uses as desktop manager shouldn't be a problem, as I know that KDE libs are included anyway.

VLC cannot auto play CD/DVD is simple to fix, it is only matter of setting the location right. However, it cannot play back certain files (eg. QT video) is the problem. This failed to playback is not VLC only, Totem is broken too (however they broke differently).

The same with K9copy, I'm not afraid to fire up a terminal, but I cannot start it anyother way is the problem. And the fact that soundkonverter reported problem at start up with media handling really indicated there is something really wrong with configuration.

My own search didn't find anything useful yet (I want the misconfiguration fixed, not just remove packages).

Does anyone heard any possible fix?
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: VLC and movie player broken and few other issues

Postby Linux n00b on Wed Jan 05, 2011 5:21 am

An update:

1. VLC change input DVD to /dev/scd0 (that's what on my laptop) doesn't fix the auto play issue, I'm lost on this one.
2. Start KDE software works fine now, it turned out some options installed by default won't work (eg. %i).
3. Soundkonverter still gave me error I cannot fix.
4. media playback issue is linked to ratelimit.c (found from log, by help of experienced Linux user). Google search pointed to driver related. New kernel may fix it (current LMDE 2.6.32-5-amd64 doesn't seem to be the latest). Or I could try my luck for newer intel driver.
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby Linux n00b on Sun Jan 09, 2011 5:07 am

I wave the white flag now.

It seems there is no easy way to get LMDE going smoothly as I'd hope.

The root problem I now believe is down to:

1. Intel hates Linux. The Intel graphics drivers are retarded (tried the latest from LMDE).
2. Newer kernel would likely fix the intel driver issue, but LMDE is nowhere near there (latest stable 2.6.37, LMDE 2.6.32).
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby axxer on Sun Jan 09, 2011 6:13 am

Linux n00b wrote:I wave the white flag now.

It seems there is no easy way to get LMDE going smoothly as I'd hope.

The root problem I now believe is down to:

1. Intel hates Linux. The Intel graphics drivers are retarded (tried the latest from LMDE).
2. Newer kernel would likely fix the intel driver issue, but LMDE is nowhere near there (latest stable 2.6.37, LMDE 2.6.32).

i'm using intel, and never had any problem whatsoever with any distro i tested.. and about that kernel, if u want to be in bleeding edge side u can use liquorix kernel, as per today its 2.6.36-3.dmz.1-liquorix :wink:
axxer
Level 1
Level 1
 
Posts: 25
Joined: Sat Sep 18, 2010 4:12 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby linmint777 on Tue Jan 11, 2011 2:35 am

1. Intel hates Linux. The Intel graphics drivers are retarded (tried the latest from LMDE).


stop it, wrong ++++, i have an Gateway with intel integrated chipset gma x4500 and mint debian (201012) x64 installed.from the first commencement without changing anything, I have excellent graphics acceleration, in this moment I'm playing super mario wii with dolphin emulator that I compile.
believe me, kde libs + gnome libs = new problems ..... tested by me.
so I have at same time the 2 desktops, aptosid (kde based) and mint-debian on dual boot.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
User avatar
linmint777
Level 5
Level 5
 
Posts: 648
Joined: Thu Nov 26, 2009 11:00 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby Linux n00b on Tue Jan 11, 2011 6:42 am

Please, you are not helping and this is partly what give Linux users bad name. Just because your PC didn't have problem, doesn't mean everyone else or Intel itself doesn't.

Intel is still universally known for NOT having good graphics driver for Linux. There are still some Intel gears can only use 2D driver reliable. My test laptop (this one I'm typing) has i945GM chipset, this chipset is not known for Linux friendly. Certain Intel branded mainboard won't "play ball" unless you turn certain kernel function off, no matter what you do. The list of known Intel issue with Linux is endless.

The problem I have now, started right from beginning (after clean install LMDE). Partial 3D part of the driver is clearly missing or not working. Give you example, Google earth requires some 3D capacity, it won't even start on this machine. On other hand, I can play 3D FPS game just fine.

Media playback issue was traced right back to kernel (ratelimit.c) component. Do a search yourself, it is either driver or kernel itself. I suspect it is similar issue as Google earth. The fact that Mplayer works but VLC and Totem won't, clearly identified some calls made to the driver by VLC/Totem was not answered (or not correctly), while Mplayer doesn't do them, so it functions fine.

I will either try compile my own kernel (would go 2.6.37 stable if possible), or try something like Mint 10 (which has 2.6.35 kernel) later.
The difference between genius and stupidity is that genius has its limits.
-- Albert Einstein
User avatar
Linux n00b
Level 3
Level 3
 
Posts: 144
Joined: Sat Jul 05, 2008 9:55 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby axxer on Tue Jan 11, 2011 8:43 am

same goes to u, please stop blaming intel and make a conclusion like "Intel hates Linux" just because it didnt work on yours.

Linux n00b wrote:Intel is still universally known for NOT having good graphics driver for Linux.

and u saying this based on what? source please.....
axxer
Level 1
Level 1
 
Posts: 25
Joined: Sat Sep 18, 2010 4:12 am

Re: [Defeted] VLC and movie player broken and few other issu

Postby hemimaniac on Tue Jan 11, 2011 9:11 am

axxer wrote:same goes to u, please stop blaming intel and make a conclusion like "Intel hates Linux" just because it didnt work on yours.

Linux n00b wrote:Intel is still universally known for NOT having good graphics driver for Linux.

and u saying this based on what? source please.....


a basic google search on graphic driver for linux would be a very good indication, if that is not enough for you a quick search of the intel home site for linux stuff would be another indicator, most of it links to off site stuff that is 3rd party like intel doesnt want to even be associated.

research is good
"Linux allows for one thing above all else - 'A user can truly be themselves!'"
Image
User avatar
hemimaniac
Level 5
Level 5
 
Posts: 508
Joined: Thu Feb 04, 2010 1:26 pm
Location: London ON

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests