Unable to auto play audio CDs with VLC

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Unable to auto play audio CDs with VLC

Postby drzoo2 on Wed Dec 29, 2010 2:29 pm

Getting the following error.

Your input can't be opened:
VLC is unable to open the MRL 'cdda://sr0/'. Check the log for details.


This is happening on my Desktop and Laptop both running LMDE.

I have tried creating a symbolic link in /dev/
Code: Select all
ln -s /dev/sr0 /dev/cdrom


This seems to be an issue with the way gnome mounts audio CDs. Opening VLC and selecting audio CD (/dev/cdrom or /dev/sr0) will play the CD fine.

edit: How to recreate.
Make VLC default for audio CDs in Nautilus. Insert AudioCD
or
Right click mounted AudioCD. Select Play in VLC
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Linux Mint is funded by ads and donations.
 

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Wed Dec 29, 2010 3:44 pm

Open Menu>Settings>Removable Drives and Media> Multimedia Tab. Find device for it using the "Folder" box at the end of the Line.
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby drzoo2 on Wed Dec 29, 2010 10:55 pm

bobcollard wrote:Open Menu>Settings>Removable Drives and Media> Multimedia Tab. Find device for it using the "Folder" box at the end of the Line.


Either I'm a total noob, or I'm having a moment because I don't follow you. I haven't seen "Removable drives and Media" since Hardy. Do you mean this?



z
Attachments
Screenshot-1.png
Screenshot-1.png (25.77 KiB) Viewed 5293 times
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Wed Dec 29, 2010 11:41 pm

Well, mine looks a little different (see screenshot) but you should be able to work with that, what do you get when you click on Custom? You could use the same command that mine has.
Screenshot-Removable Drives and Media.png
Screenshot-Removable Drives and Media.png (60.08 KiB) Viewed 5289 times
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby drzoo2 on Thu Dec 30, 2010 12:07 am

The problem isn't getting VLC to open when media is inserted. It's getting past this error. The audio CD isn't mounted in a folder but is handled by gnome. For some reason, VLC can't open this and spits the following error. Not sure what log it is referring to.
Attachments
Screenshot.png
Screenshot.png (13.47 KiB) Viewed 5284 times
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Thu Dec 30, 2010 12:25 am

Okay, Open VLC>Tools>Preferences>Input and Codecs and change Optical Drive to:
Screenshot.png
Screenshot.png (93.04 KiB) Viewed 5281 times


Restart VLC.
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby drzoo2 on Fri Dec 31, 2010 3:31 pm

Robert, your not understanding me. Please read my first post. I understand how get vlc to open a drive. This issue is gvfs and passing this mount to non aware gvfs programs.
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Fri Dec 31, 2010 3:46 pm

drzoo2 wrote:Robert, your not understanding me. Please read my first post. I understand how get vlc to open a drive. This issue is gvfs and passing this mount to non aware gvfs programs.

Sorry, don't use virtual file system. Wouldn't know where to begin, and you did not mention that in the first Post. I answered according to what you did write, VLC and AudioCD Player.
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby CiaW on Sat Jan 01, 2011 7:34 pm

I took at look at this thread, and since I don't often play CD's on my pc I thought I'd grab one and try it and I'm getting the same error. It does open VLC, but it has that error and when I hit the play it comes up with the same error. I right clicked on the CD that showed up on the desktop, and on the 'open with' tab it shows: Select an application to open / and other files of type "unknown". The desktop icon does show 'Audio Disc'.

So it has something to do with the associations (mime types?). Of course I'm also not sure where gvfs may figure into it, either. Maybe a bug report is in order? I'm going to log into my lmde 32bit install from Sept and see what happens (as soon as this song is over!).

Edit: I logged into the 32bit lmde, and when I inserted the CD it offered the option to copy the cd and wanted to know the medium to copy it to. The desktop icon shows 'Audio Disc' under a shape of a CD. If I right click on it and select 'open with > VLC' it gives the same error: "Your input can't be opened: VLC is unable to open the MRL 'cdda://sr0/'. Check the log for details." (same error as before). I just tried an external usb dvd drive, since my internal LG drive can be a little flaky with DVD's, and it gave me an error that there were no audio files on the disk, then that went away and it's offering the option to 'Copy CD/DVD'. So basically, same issue on both installs.
Last edited by CiaW on Sat Jan 01, 2011 8:04 pm, edited 1 time in total.
CiaW
Level 3
Level 3
 
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Sat Jan 01, 2011 7:54 pm

Here's a link to resolving the broken VLC program:
http://linuxbsdos.com/forum/thread-61.html
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby drzoo2 on Sat Jan 01, 2011 8:45 pm

Robert, My first post wasn't as clear as it should have been. My apologies. If your using gnome, your using the gnome virtual file system. Look for the folder .gvfs in your home directory. This is a lot like mounting a network share in gnome and trying to browse it in vlc or other non-gnome programs.

If found this..
http://arstechnica.com/civis/viewtopic.php?f=16&t=1110093

Only thing is I don't see the CD as mounted in this folder.
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Sat Jan 01, 2011 9:26 pm

drzoo2 wrote:Robert, My first post wasn't as clear as it should have been. My apologies. If your using gnome, your using the gnome virtual file system. Look for the folder .gvfs in your home directory. This is a lot like mounting a network share in gnome and trying to browse it in vlc or other non-gnome programs.

If found this..
http://arstechnica.com/civis/viewtopic.php?f=16&t=1110093

Only thing is I don't see the CD as mounted in this folder.

It's blank.
Screenshot.png
Screenshot.png (34.03 KiB) Viewed 5235 times
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Sat Jan 01, 2011 9:33 pm

My VLC works fine with the fixes provided here. We are talking about VLC in LMDE x86_64? I just added the XFCE desktop, but it is still basically Gnome, nothing in Gnome has been removed.
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby bobcollard on Sun Jan 02, 2011 10:17 am

You may be pleased to note the recent upgrade, today:
The following packages will be upgraded:

ghostscript ghostscript-cups ghostscript-x gs-common gvfs gvfs-backends

gvfs-bin libgs8 totem totem-common totem-mozilla totem-plugins
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64
User avatar
bobcollard
Level 5
Level 5
 
Posts: 717
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: Unable to auto play audio CDs with VLC

Postby tonyr63 on Mon Mar 07, 2011 2:40 am

Hi Robert

You have reported the "good news" of the upgrades however does this address the problem reported on this thread?

I have the same issue on two separate installations of Ubuntu 10.04 and I was hoping that i might get some pointers why this is widely reported but no definitive resolution?
tonyr63
Level 1
Level 1
 
Posts: 1
Joined: Mon Mar 07, 2011 2:27 am

Re: Unable to auto play audio CDs with VLC

Postby clem on Wed Sep 07, 2011 7:39 am

It might not be the fix everybody wants, but as far as I can see there's two issues here:

- The default application for playing/ripping audio CDs should be banshee (it's set as rhythmbox and because it can't find it, VLC gets the call)
- VLC fails to play the right device

This will be fixed in the stable release. If you want to fix it in your installation, edit /etc/gnome/defaults.list, and replace all occurences of rhythmbox.desktop with banshee-audiocd.desktop.

Inserting an Audio CD should then launch Banshee in CDDA mode and play it automatically. No need to restart your Gnome session.
Image
User avatar
clem
Level 15
Level 15
 
Posts: 5580
Joined: Wed Nov 15, 2006 8:34 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests