Can't play audio CDs

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Can't play audio CDs

Postby GravityGilly on Wed Jan 12, 2011 1:59 pm

Well, I can only play them in a very roundabout way.

I'm running LMDE 32-bit, and whenever I insert an audio CD it does seem to be mounted ("Audio Disc" icon on the desktop). If I open the CD in Nautilus, I'm prompted to open Rhythmbox, which is where the problems come in.

If I open Rhythmbox and tell it to play the CD, it promptly crashes with no error messages or anything descriptive at all. Exaile is a similar story.
If I open Totem, and tell it to play the CD, I get "The playback of this movie requires a Audio CD source plugin which is not installed." I have no idea what plugin that could be - as far as I can tell all the gstreamer plugins are installed, just looking at Synaptic.
Lastly, I can get CDs to play in VLC, but not from Nautilus. If I try right click > open with > VLC, I get "VLC is unable to open the MRL 'cdda://sr0/Track%201.wav'. Check the log for details." However, if I open VLC first, select Open Disc, select Audio CD and press play, I finally get playback (after applying this fix: http://linuxbsdos.com/forum/thread-61.html).

Obviously something's wrong here, as I used to be able to play CDs on my old Mint 9 installation. Any ideas?
GravityGilly
Level 1
Level 1
 
Posts: 12
Joined: Thu Apr 08, 2010 7:16 am

Linux Mint is funded by ads and donations.
 

SATA Drive?

Postby EchoLynx on Sat Jan 15, 2011 9:51 pm

I am having the exact same problem. Thought I couldn't play audio cds at all until I found the fix you posted.

I was wondering... does your optical drive happen to be a SATA optical drive?
Saturday August 9th, 2008: Acquired Technician-class Amateur Radio License. Assigned call KB3ROH.
February (?) 2010: Acquired General-class Amateur Radio License.
Image
EchoLynx
Level 3
Level 3
 
Posts: 159
Joined: Mon Jul 07, 2008 8:49 am

Re: Can't play audio CDs

Postby CiaW on Sat Jan 15, 2011 10:18 pm

I have a similar issue, though when I insert an audio CD VLC comes up with the message: "VLC is unable to open the MRL 'cdda://sr0/.' Check the log for details." (What log?) , if I then select >file >open disc it's defaulting to DVD, if I then select Audio CD then play, it'll play. Or if I close VLC and right click on the audio cd icon on my desktop and ask it to open with rhythmbox, it'll open then I can play from there too.

So, it appears that VLC and perhaps totem is defaulting to DVD instead of CD when an audio cd is put into a dvd drive; even though the icon says 'audio CD'? I'm not sure how to fix it, at least I can get it to play after clicking a few things.
CiaW
Level 3
Level 3
 
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: Can't play audio CDs

Postby drzoo2 on Sat Jan 15, 2011 10:26 pm

http://forums.linuxmint.com/viewtopic.php?f=141&t=62779

I had a similar problem. Never got it fixed.
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: Can't play audio CDs

Postby Morrog on Sat Nov 12, 2011 1:26 pm

i have the same on a 32 bit LMDE. i found the trailing / is causing problems. so i created a custom command in nautilus > edit > preferences > media > cd audio

Code: Select all
vlc cdda:///dev/sr0


this seems to solve it for me. there must be a more elegant solution involving a conf file somewhere or a gconf setting, but i haven't found that for now.
Morrog
Level 1
Level 1
 
Posts: 27
Joined: Mon Aug 22, 2011 9:15 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests