Pulse audio 100% CPU Usage

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Pulse audio 100% CPU Usage

Postby srikar137 on Fri Feb 11, 2011 4:23 am

What may be the fix?? I attached the image.
Attachments
Screenshot-1.jpg
Screenshot-1.jpg (143.67 KiB) Viewed 3518 times
srikar137
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 11, 2011 4:19 am

Linux Mint is funded by ads and donations.
 

Re: Pulse audio 100% CPU Usage

Postby kwevej on Fri Feb 11, 2011 9:20 am

User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Pulse audio 100% CPU Usage

Postby srikar137 on Fri Feb 11, 2011 11:05 am

kwevej wrote:http://forums.linuxmint.com/viewtopic.php?f=141&t=58616&hilit=pulse


That's already in the file.Still facing the problem :(
srikar137
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 11, 2011 4:19 am

Re: Pulse audio 100% CPU Usage

Postby kwevej on Fri Feb 11, 2011 3:58 pm

You can exists without pulseaudio.
So try to uninstall it.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Pulse audio 100% CPU Usage

Postby srikar137 on Sat Feb 12, 2011 2:12 am

I un-installed it , but experience with my 5.1 with alsa is quite poor compared to pulse.Pulse is good,But pulse is taking a lot of CPU(i can literally hear CPU fan noise,along with the music i hear :( .
srikar137
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 11, 2011 4:19 am

Re: Pulse audio 100% CPU Usage

Postby kwevej on Sat Feb 12, 2011 5:24 pm

User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Pulse audio 100% CPU Usage

Postby Nick_Djinn on Sun Feb 13, 2011 9:08 pm

Pulse Audio is a rainbows disaster. Theoretically its cool and it has potential, but leave it to people who need it and know how to trouble shoot it. Its not ready for point and click users.

I would like some instructions for the best way to remove it from Julia please.

Some poor guy thought his CPU was toast and replaced it because of this unicorns.
Nick_Djinn
Level 5
Level 5
 
Posts: 646
Joined: Sat May 15, 2010 7:12 am

Re: Pulse audio 100% CPU Usage

Postby specmod1 on Sun Feb 13, 2011 9:23 pm

I had this happen to me a few times.....
specmod1
Level 2
Level 2
 
Posts: 82
Joined: Sun Feb 13, 2011 8:02 pm

Re: Pulse audio 100% CPU Usage

Postby Nick_Djinn on Mon Feb 14, 2011 2:12 am

This is happening to me 100% of the time lately.
Nick_Djinn
Level 5
Level 5
 
Posts: 646
Joined: Sat May 15, 2010 7:12 am

Re: Pulse audio 100% CPU Usage

Postby srikar137 on Thu Feb 17, 2011 1:43 am

Lets hope this gets fixed very soon.
srikar137
Level 1
Level 1
 
Posts: 4
Joined: Fri Feb 11, 2011 4:19 am

Re: Pulse audio 100% CPU Usage

Postby kwevej on Thu Feb 17, 2011 4:38 am

Folks, follow these instructions:
viewtopic.php?f=42&t=60485&start=0

And get rid of the Pulse.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Pulse audio 100% CPU Usage

Postby Nick_Djinn on Fri Feb 18, 2011 8:15 am

The problem has temporarily resolved, but next sign of trouble I wont hesitate to upgrade to a PulseAudio free setup.

Are there some polished alternatives I could add that are more stable besides vanilla ALSA?
Nick_Djinn
Level 5
Level 5
 
Posts: 646
Joined: Sat May 15, 2010 7:12 am

Re: Pulse audio 100% CPU Usage

Postby the7erm on Mon Sep 09, 2013 1:27 am

I had the same problem. I'm not sure if I fixed it the right way or not.

I was having problems with skype notifications static, sizzling and crackling so I changed a line in /etc/pulse/default.pa:
Code: Select all
load-module module-udev-detect use_ucm=0

to
Code: Select all
load-module module-udev-detect use_ucm=0 tsched=0

This solved the crackling problem, but created another one. The cpu was running at 24%, and that wasn't going to do at all.

So I just changed the line in /etc/pulse/default.pa to:
Code: Select all
load-module module-udev-detect


Code: Select all
sudo /etc/init.d/pulseaudio force-reload
pulseaudio -k


To further reduce cpu usage you can edit /etc/pulse/daemon.conf:
Code: Select all
high-priority = no
realtime-scheduling = no


Then restart your server again:
Code: Select all
sudo /etc/init.d/pulseaudio force-reload
pulseaudio -k


Using those settings seems to reduce cpu-usage for me drastically. Keep in mind I have no clue what those settings in /etc/pulse/ change. I simply found them on a forum. Just like you are now :)
the7erm
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 02, 2007 9:32 pm

Re: Pulse audio 100% CPU Usage

Postby the7erm on Mon Sep 09, 2013 1:27 am

I had the same problem. I'm not sure if I fixed it the right way or not.

I was having problems with skype notifications static, sizzling and crackling so I changed a line in /etc/pulse/default.pa:
Code: Select all
load-module module-udev-detect use_ucm=0

to
Code: Select all
load-module module-udev-detect use_ucm=0 tsched=0

This solved the crackling problem, but created another one. The cpu was running at 24%, and that wasn't going to do at all.

So I just changed the line in /etc/pulse/default.pa to:
Code: Select all
load-module module-udev-detect


Code: Select all
sudo /etc/init.d/pulseaudio force-reload
pulseaudio -k


To further reduce cpu usage you can edit /etc/pulse/daemon.conf:
Code: Select all
high-priority = no
realtime-scheduling = no


Then restart your server again:
Code: Select all
sudo /etc/init.d/pulseaudio force-reload
pulseaudio -k


Using those settings seems to reduce cpu-usage for me drastically. Keep in mind I have no clue what those settings in /etc/pulse/ change. I simply found them on a forum. Just like you are now :)
the7erm
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 02, 2007 9:32 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests