[Solved] Problems with flash and java

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[Solved] Problems with flash and java

Postby biaxident on Mon May 23, 2011 11:03 am

Hello to all you Linux users at the LMDE forums.

I have been running LMDE for a couple of months now and am very satisfied. However, I recently experienced a couple of problems.

First my Java shows jagged images and wrong colours etc. in both Firefox (3.6.13) and Chromium (6.0.472.63). From the Java Console, I get the following
Code: Select all
sun.awt.image.ImageFormatException: Bogus marker length
   at sun.awt.image.JPEGImageDecoder.readImage(Native Method)
   at sun.awt.image.JPEGImageDecoder.produceImage(JPEGImageDecoder.java:119)
   at sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:246)
   at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:172)
   at sun.awt.image.ImageFetcher.run(ImageFetcher.java:136)
sun.awt.image.ImageFormatException: Invalid component ID 97 in SOS
   at sun.awt.image.JPEGImageDecoder.readImage(Native Method)
   at sun.awt.image.JPEGImageDecoder.produceImage(JPEGImageDecoder.java:119)
   at sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:246)
   at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:172)
   at sun.awt.image.ImageFetcher.run(ImageFetcher.java:136)
sun.awt.image.ImageFormatException: Bogus marker length
   at sun.awt.image.JPEGImageDecoder.readImage(Native Method)
   at sun.awt.image.JPEGImageDecoder.produceImage(JPEGImageDecoder.java:119)
   at sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:246)
   at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:172)
   at sun.awt.image.ImageFetcher.run(ImageFetcher.java:136)
sun.awt.image.ImageFormatException: Invalid progressive parameters Ss=7 Se=112 Ah=7 Al=7
   at sun.awt.image.JPEGImageDecoder.readImage(Native Method)
   at sun.awt.image.JPEGImageDecoder.produceImage(JPEGImageDecoder.java:119)
   at sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:246)
   at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:172)
   at sun.awt.image.ImageFetcher.run(ImageFetcher.java:136)
 
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
getSymfoniProperties gameId: 'DUMMY'


Second my sound is messed up when I listen to tracks from soundcloud.com (and some other sites are affected as well, though not youtube) - there is a strange clicking sound in the background. This also appears in both Firefox and Chromium.

I think these issues became present a little over a week ago. I am using 2.6.38-2-amd64 and the problems were there before I updated from 2.6.32-5-amd64.

Any help is truly appreciated, thanks.

Regards
Peter
Last edited by biaxident on Tue May 24, 2011 4:47 am, edited 1 time in total.
biaxident
Level 1
Level 1
 
Posts: 2
Joined: Mon May 23, 2011 10:14 am

Linux Mint is funded by ads and donations.
 

Re: Problems with flash and java

Postby scottlinux on Mon May 23, 2011 3:49 pm

re: flash player noise and pops

viewtopic.php?f=141&p=425153

A bug in current 64bit flash player.
scottlinux
Level 1
Level 1
 
Posts: 27
Joined: Sun May 15, 2011 12:00 am

Re: Problems with flash and java

Postby biaxident on Tue May 24, 2011 4:46 am

Sorry about that one. I hadn't found that topic. The solution with mymemcpy.so works like a charm.

It seems that this solved my Java problem as well.

Thank you very much!

Regards
Peter
biaxident
Level 1
Level 1
 
Posts: 2
Joined: Mon May 23, 2011 10:14 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: Zyzz and 2 guests