no sound in lmde

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

no sound in lmde

Postby codemaster on Sat Jun 25, 2011 10:35 pm

I've installed LMDE on an old computer bought in 2003 and on a newer one bought in 2008. Both these computers have identical sound cards, Creative SoundBlaster Audigy SE, but the speakers conected to the soundcard of the older computer, don't receive any signals in LMDE, only in Windows XP. I checked the volume and it is not set to mute.
codemaster
Level 1
Level 1
 
Posts: 3
Joined: Sat Jun 25, 2011 10:27 pm

Linux Mint is funded by ads and donations.
 

Re: no sound in lmde

Postby codemaster on Sun Jun 26, 2011 1:29 pm

I found out what the problem is. The old motherboard doesn't have the option to disable the onboard audio chipset in BIOS. Therefore, the solution is to blacklist the onboard audio software-wise. I found a guide for this, but it's for Ubuntu, and I can't manage to adapt it to Mint Debian... because I'm a beginner in Linux, and I just transitioned from Windows 7 to Mint Debian a week ago.
codemaster
Level 1
Level 1
 
Posts: 3
Joined: Sat Jun 25, 2011 10:27 pm

Re: no sound in lmde

Postby codemaster on Mon Jun 27, 2011 9:02 am

in PulseAudio Volume Control, the default audio card is the onboard audio card, and if I select the PCI audio card, then I have sound, but the problem is that I have to select the PCI sound card everytime I open VLC, Flash Player, etc... How can I change the default card to PCI audio card instead of onboard ?
codemaster
Level 1
Level 1
 
Posts: 3
Joined: Sat Jun 25, 2011 10:27 pm

Re: no sound in lmde

Postby Gerd50 on Mon Jun 27, 2011 7:53 pm

Hello codemaster,

what you want to do is a science for itself in Debian. Take a look at this:

http://wiki.debian.org/ALSA
section 'Troubleshooting'.

A file 'sound' you have to create in /etc/modprobe.d and fill it with what

Code: Select all
 cat /proc/asound/cards

says.

On my system it would look like this:

Code: Select all
options snd-Audigy2 - SB Audigy 4 [SB0610] index=0


Sorry for my english, in german i could explain it better. But maybe this gives you an idea what to do :wink:
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: no sound in lmde

Postby mikebravo on Thu Jun 30, 2011 9:49 pm

CODEMASTER, I would suggest you look for a different distribution. In LMDE sound did not work for me BUT in Fedora 14 sound just worked. In CentOS sound just worked. In OpenSUSE sound just worked. In Scientific Linux sound just worked. Think LMDE has a little problem?
mikebravo
Level 1
Level 1
 
Posts: 12
Joined: Sat May 28, 2011 10:07 pm

Re: no sound in lmde

Postby lmintnewb on Thu Jun 30, 2011 10:33 pm

Might try opening a terminal and typing alsamixer

Play around with the settings in there. m key to mute/unmute something, right or left arrows keys to navigate. up/down arrows keys to adjust something and esc key to exit it. When I hear of no sound troubles in nix. Usually think one of the 1st places to check is alsamixer's controls and settings.
lmintnewb
Level 7
Level 7
 
Posts: 1574
Joined: Fri Apr 01, 2011 5:13 pm


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests