Startup Sounds Don't Work

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Startup Sounds Don't Work

Postby aybesea on Thu Jul 07, 2011 8:14 pm

I'm new to LMDE, though I've been using Linux for 8 years and Ubuntu/Debian for 5 years. So far It's been quite easy to get things up and running to my satisfaction, but one minor issue is bugging me. Startup sounds do not work for me. Sound, in general, is fine. The "Gnome Login Sound" is listed in the Startup section of preferences, and enabled. If I run the command (/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login") in a terminal window, it plays a wonderful login sound. Other startup apps are fine. But for some reason "Gnome Login Sound" does not play at login.

Has anyone else hit this?

Thanks.

NOTE: I also tried prepending a "sleep 10" to the command to make certain that it wasn't an ordering issue in startup apps, but that didn't work either. I'm really puzzled.
aybesea
Level 1
Level 1
 
Posts: 7
Joined: Thu Jul 07, 2011 8:07 pm

Linux Mint is funded by ads and donations.
 

Re: Startup Sounds Don't Work

Postby The Diamond Geezer on Fri Jul 08, 2011 4:31 am

Seconded, I have the same issue. Could not find any further info on the forums, any hep appreciated :)
The Diamond Geezer
Level 1
Level 1
 
Posts: 35
Joined: Thu Jun 23, 2011 3:47 am

Re: Startup Sounds Don't Work

Postby twa on Fri Jul 08, 2011 4:51 am

Hi,
same issue for me too (LMDE 32 bits now changed to latest repo).
:?:
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Startup Sounds Don't Work

Postby malligt on Fri Jul 08, 2011 4:52 am

Maybe I can help you. I posted this problem on june 18th.

Here's a reply to my posting:

viewtopic.php?f=141&t=67502&start=600#p436686
malligt
Level 4
Level 4
 
Posts: 247
Joined: Sat Sep 11, 2010 12:58 pm

Re: Startup Sounds Don't Work

Postby The Diamond Geezer on Fri Jul 08, 2011 8:54 am

Maybe I can help you. I posted this problem on june 18th.

Here's a reply to my posting:

viewtopic.php?f=141&t=67502&start=600#p436686


Thanks, and before we go ahead with this, did it fix the issue?
The Diamond Geezer
Level 1
Level 1
 
Posts: 35
Joined: Thu Jun 23, 2011 3:47 am

Re: Startup Sounds Don't Work

Postby malligt on Sat Jul 09, 2011 10:58 am

I could never get the mint-theme sounds that I originally heard upon start-up/login... never returned after that breakage. My LMDE system was busted after that, and I moved over to Mint 10/11, at least and until the LMDE "new-and-improved" re-spin is released in a week or so.

I am currently enjoying not having all the seemingly daily/weekly stresses and breakages of LMDE by using Mint 10 and/or Mint 11...and I am enjoying a gorgeous Michigan summer. I do foresee myself trying the LMDE-2 (respin) after it is released...but I will not get serious with it until after the end of summer...(after Labor Day).

Regards!
malligt
Level 4
Level 4
 
Posts: 247
Joined: Sat Sep 11, 2010 12:58 pm

Re: Startup Sounds Don't Work

Postby aybesea on Sun Jul 10, 2011 12:50 am

I tried applying the patch and recompiling... but no luck. :(
aybesea
Level 1
Level 1
 
Posts: 7
Joined: Thu Jul 07, 2011 8:07 pm

Re: Startup Sounds Don't Work

Postby twa on Sun Jul 10, 2011 9:15 am

Hi,
not working..
:|
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Startup Sounds Don't Work

Postby ginjabunny on Sun Jul 31, 2011 2:32 pm

I installed LMDE last week and noticed no login sound, been having a play today, it looks like a bug and I can't see how to fix it properly BUT I have a workaround.

open terminal
run
Code: Select all
gnome-session-properties

untick "Gnome Login Sound" and close it

then run
Code: Select all
gedit '.config/autostart/libcanberra-login-sound.desktop'

you should see
Code: Select all
[Desktop Entry]
Type=Application
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
OnlyShowIn=GNOME;
AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
X-GNOME-Autostart-Phase=Application
X-GNOME-Provides=login-sound
X-GNOME-Autostart-enabled=false

delete the line starting "AutostartCondition=" and change the last line to true, then save it.

then run
Code: Select all
chmod +x '.config/autostart/libcanberra-login-sound.desktop'


it should now work.

Two things to consider
1. if you tick the "Gnome Login Sound" box again it destroys everything you just did.
2. you could save it as something else and it should work as well, e.g. my-login-sound.desktop then chmod +x it.

Background
I noticed that when you untick something in Startup Application Preferences it put a non-executable .desktop file in the autostart folder, but when you tick it then it disappears but I can't figure out where it stores it! I found out the other day when playing with LXDE to run commands at login you can create an executable .desktop file in that folder.
User avatar
ginjabunny
Level 3
Level 3
 
Posts: 106
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: Startup Sounds Don't Work

Postby zerozero on Mon Aug 01, 2011 6:55 am

hi, ginjabunny
tried your solution in a full updated incoming-tracking LMDE and it works :)
if you don't mind i'm going to post this solution here viewtopic.php?f=141&t=67502&start=880
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Startup Sounds Don't Work

Postby twa on Mon Aug 01, 2011 1:52 pm

ginjabunny,
your workaround solved my same problem.
many thanks
:D
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Startup Sounds Don't Work

Postby The Diamond Geezer on Tue Aug 02, 2011 3:15 am

Yup, same here, thanks a lot :D
The Diamond Geezer
Level 1
Level 1
 
Posts: 35
Joined: Thu Jun 23, 2011 3:47 am

Re: Startup Sounds Don't Work

Postby jcbrinfo on Tue Nov 22, 2011 8:33 pm

The almost same workaround, but without using the terminal :
  1. Launch the control center.
  2. Go to "Applications on starting" (or something like that).
  3. In the list, select "Gnome Login Sound".
  4. Click on "Edit...".
  5. Copy the command.
  6. Click on "Cancel".
  7. Uncheck "Gnome Login Sound".
  8. Click on "Add".
  9. Give a significant name to this "program" (this "program" will be used as an alternative to "Gnome Login Sound").
  10. Past the command in the appropriate field.
  11. Click on "Add". The new "program" will be checked by default.
  12. Click on "Close".

Note : Because I have tried this with the french version of the GUI, the name of the features may not be what I wrote.
Note 2 : The differences between the "Gnome Login Sound" and the new "program" are invisible when you use the "GUI" way to do the trick. In fact, these differences correspond to the "X-GNOME-", the "AutostartCondition" and the "OnlyShowIn" lines in thier *.desktop file.
Note 3: You can switch between the two "programs" by checking / unchecking them in the "Applications on starting" dialog.
Note 4 : Try to avoid to have the two "programs" checked at the same time.
Last edited by jcbrinfo on Mon Apr 09, 2012 11:14 am, edited 1 time in total.
JCBR Info
jcbrinfo
Level 1
Level 1
 
Posts: 12
Joined: Tue Nov 22, 2011 7:27 pm

Re: Startup Sounds Don't Work

Postby GregE on Fri Nov 25, 2011 7:33 am

jcbrinfo wrote:The almost same workaround, but without using the terminal :
  1. Launch the control center.
  2. Go to "Applications on starting" (or something like that).
  3. In the list, select "Gnome Login Sound".
  4. Click on "Edit...".
  5. Copy the command.
  6. Click on "Cancel".
  7. Uncheck "Gnome Login Sound".
  8. Click on "Add".
  9. Give a significant name to this "program" (this "program" will be used as an alternative to "Gnome Login Sound").
  10. Past the command in the appropriate field.
  11. Click on "Add". The new "program" will be checked by default.
  12. Click on "Close".

Note : Because I have tried this with the french version of the GUI, the name of the features may not be what I wrote.
Note 2 : The differences between the "Gnome Login Sound" and the new "program" are invisible when you use the "GUI" way to the trick. In fact, these differences correspond to the "X-GNOME-", the "AutostartCondition" and the "OnlyShowIn" lines in thier *.desktop file.
Note 3: You can switch between the two "programs" by checking / unchecking them in the "Applications on starting" dialog.
Note 4 : Try to avoid to have the two "programs" checked at the same time.


Hi, I also used your method but there were two problems on my system. The command to play the sound was not installed and the Gnome Login sound file did not exist. So I just created a new Autostart entry with the command

aplay /usr/share/sounds/linuxmint-login.wav

And now it plays.

:)
User avatar
GregE
Level 4
Level 4
 
Posts: 440
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Startup Sounds Don't Work

Postby fslap on Thu Dec 01, 2011 3:59 pm

Hi, I also used your method but there were two problems on my system. The command to play the sound was not installed and the Gnome Login sound file did not exist. So I just created a new Autostart entry with the command

aplay /usr/share/sounds/linuxmint-login.wav

And now it plays.


Of all the solutions I've tried, this simple fix is the only one that works.
fslap
Level 1
Level 1
 
Posts: 1
Joined: Thu Dec 01, 2011 3:57 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests