Pulseaudio - No Sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Pulseaudio - No Sound

Postby Mr. R on Thu Aug 04, 2011 8:13 pm

Hello, I am great having difficulty fixing this issue. I have looked everywhere on Launchpad, Google, and the forums, but there are no solutions. Running Linux Mint Xfce. The loss I am at cannot be comprehended. No solutions and I'm not sure what exactly is wrong. But at least the system is still usable, so I just have to keep trying to figure out what is wrong.

I have tried some things, such as using the file .asoundrc and rebooting the pulseaudio daemon, but nothing is working.
This may have happened when I tried another Display Manager and reinstalled it back again because I was having problems. I think gdm3, not gdm, is installed, so I hope that is the right one.

Here are some important snippets on info that you may need:

Code: Select all
$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)


Code: Select all
$ lsmod | grep snd
snd_hda_codec_realtek   283734  1
snd_hda_intel          25946  4
snd_hda_codec          67865  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13148  1 snd_hda_codec
snd_pcm_oss            40662  0
snd_mixer_oss          17905  1 snd_pcm_oss
snd_pcm                67276  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_midi           12848  0
snd_rawmidi            22963  1 snd_seq_midi
snd_seq_midi_event     13316  1 snd_seq_midi
snd_seq                44678  2 snd_seq_midi,snd_seq_midi_event
snd_timer              22658  2 snd_pcm,snd_seq
snd_seq_device         13155  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    52324  18 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              13014  1 snd
snd_page_alloc         12969  2 snd_hda_intel,snd_pcm


Code: Select all
$ pulseaudio -vv
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: core-rtclock.c: Timer slack is set to 50 us.
I: core-util.c: Failed to acquire high-priority scheduling: No such file or directory
I: main.c: This is PulseAudio 0.9.21
D: main.c: Compilation host: x86_64-pc-linux-gnu
D: main.c: Compilation CFLAGS: -g -O2 -g -O2 -Wall -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: main.c: Running on host: Linux x86_64 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011
D: main.c: Found 2 CPUs.
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Running in VM: no
D: main.c: Optimized build: yes
D: main.c: All asserts enabled.
I: main.c: Machine ID is 3c57545fd9007fcac1f08fcd00001118.
I: main.c: Session ID is 3c57545fd9007fcac1f08fcd00001118-1312476802.772119-1277093340.
I: main.c: Using runtime directory /home/mrrhq/.pulse/3c57545fd9007fcac1f08fcd00001118-runtime.
I: main.c: Using state directory /home/mrrhq/.pulse.
I: main.c: Using modules directory /usr/lib/pulse-0.9.21/modules.
I: main.c: Running in system mode: no
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.


Code: Select all
$ cat .asoundrc
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}


Code: Select all
$ pulseaudio --dump-conf
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
cpu-limit = no
enable-shm = yes
flat-volumes = yes
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-0.9.21/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = auto
enable-remixing = yes
enable-lfe-remixing = no
default-sample-format = s16le
default-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 4
default-fragment-size-msec = 25
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000


-- PulseAudio Manager --
Sinks: auto_null -- Dummy Output
Sources: auto_null.monitor -- Monitor of Dummy Output
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Linux Mint is funded by ads and donations.
 

Re: Pulseaudio - No Sound

Postby zerozero on Thu Aug 04, 2011 8:19 pm

try this http://www.webupd8.org/2010/11/fix-hda- ... qus_thread
worst case scenario, it would do nothing, solved my issues with the same card.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pulseaudio - No Sound

Postby Mr. R on Thu Aug 04, 2011 8:50 pm

zerozero wrote:try this http://www.webupd8.org/2010/11/fix-hda- ... qus_thread
worst case scenario, it would do nothing, solved my issues with the same card.


Hi, zerozero.

I have just tried that fix, but it did not seem to work. The output from pulseaudio -vv is the same.

Code: Select all
$ groups
[...snip...] cdrom sudo audio video users fuse lpadmin pulse


So I am already in the "pulse" group.

Code: Select all
 $ pulseaudio -D
E: main.c: Daemon startup failed.


And I just added it to the end and rebooted. Here is the file:

Code: Select all
$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel index=0 model=auto
options snd-hda-intel model=generic
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Re: Pulseaudio - No Sound

Postby zerozero on Thu Aug 04, 2011 8:57 pm

i guess you have already checked this viewtopic.php?f=141&t=58616 and this viewtopic.php?f=42&t=60485
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pulseaudio - No Sound

Postby Mr. R on Thu Aug 04, 2011 9:14 pm

zerozero wrote:i guess you have already checked this viewtopic.php?f=141&t=58616 and this viewtopic.php?f=42&t=60485


Well I have seen the first one.
I am still not sure whether or not to remove it. It's controversial. I've heard that it can fix problems, but it will cause a lot of problems too since multimedia programs use lots of different audio plugins like ALSA, OSS and ESS. I wouldn't do that myself unless I had the best reason to, since it will take time configuring everything (audio ports, volumes, sound quality, buffering, etc...) to work with all the sound servers, and that's more ideal for someone using Gentoo instead of Debian.

I'm going to try the other options. So I did this:
Code: Select all
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
  Subdevices: 0/1


I guess this means that I do have the generic version? I'm not sure what audio chipset it is exactly, just that it's ICH 7. I'm on an HP Pavilion PC so I'm gong to try "hp" next.
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Re: Pulseaudio - No Sound

Postby zerozero on Thu Aug 04, 2011 9:21 pm

in the webup8 post, they link to here http://ubuntuforums.org/showthread.php?t=314383 for further troubleshooting if the generic option doesn't work
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pulseaudio - No Sound

Postby wyrdoak on Thu Aug 04, 2011 9:27 pm

Sorry if I'm stepping on anyone, just my 2cents,I had to use the auto option.

gksu gedit /etc/modprobe.d/alsa-base.conf

add at the very end:

options snd-hda-intel index=0 model=auto
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Pulseaudio - No Sound

Postby Mr. R on Thu Aug 04, 2011 9:31 pm

zerozero wrote:in the webup8 post, they link to here http://ubuntuforums.org/showthread.php?t=314383 for further troubleshooting if the generic option doesn't work


I saw that. But the other options didn't work, so "generic", "auto" and "hp" don't work.
If I really want to give up, I might just uninstall Pulse for now. If I get any problems I can reinstall it or fix problems without it.

wyrdoak wrote:Sorry if I'm stepping on anyone, just my 2cents,I had to use the auto option.

gksu gedit /etc/modprobe.d/alsa-base.conf

add at the very end:

options snd-hda-intel index=0 model=auto


Yes, that was already in the file, and it doesn't work for me...
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Re: Pulseaudio - No Sound

Postby zerozero on Thu Aug 04, 2011 9:38 pm

first of all tks wyrdoak for steeping in 8)
now about pulse, i guess it all depends on the hardware as well- i removed it in the paltop, and was the best thing to do then to solve the sound issues, but here in the desktop managed to get everything working with it
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pulseaudio - No Sound

Postby wyrdoak on Thu Aug 04, 2011 9:51 pm

I just noted I have (rev 02) that could be the difference.

And in LMDE I don't use a .asoundrc file

Also hadn't had to add the lines yet for: /etc/modprobe.d/alsa-base.conf in LMDE

In Mint 10 and 11 I did.

Of course I do threaten to rap the computer wires to the trailer hitch and drag it around town if it don't behave, maybe it just too afraid to break. :lol:
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Pulseaudio - No Sound

Postby Mr. R on Thu Aug 04, 2011 9:55 pm

So I looked at the post here: http://ubuntuforums.org/showpost.php?p= ... stcount=29
The person quoted had the same soundcard as me, nearly, so I am trying the other options now. I really don't like finding the right option without knowing if I can determine which ones work. But I'm not sure if the issue is "auto" not working, because it was working fine, and I've held off fixing this issue for 2 weeks so far. I don't rememebr when it happened. Anyways, more output...

Code: Select all
$ sudo lspci -vnn
[...]
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
   Subsystem: Hewlett-Packard Company Device [103c:2a5e]
   Flags: bus master, fast devsel, latency 0, IRQ 41
   Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [130] Root Complex Link
   Kernel driver in use: HDA Intel


Right now I'm trying:
Code: Select all
$ pulseaudio --kill
$ pulseaudio -vv


I am stuck at the end of this:
Code: Select all
[...]
I: source.c:     device.description = "Monitor of Dummy Output"
I: source.c:     device.class = "monitor"
I: source.c:     device.icon_name = "audio-input-microphone"
D: module-null-sink.c: Thread starting up
I: module.c: Loaded "module-null-sink" (index: #11; argument: "sink_name=auto_null sink_properties='device.description="Dummy Output"'").
I: module.c: Loaded "module-always-sink" (index: #12; argument: "").
I: module.c: Loaded "module-intended-roles" (index: #13; argument: "").
D: module-suspend-on-idle.c: Sink auto_null becomes idle, timeout in 5 seconds.
I: module.c: Loaded "module-suspend-on-idle" (index: #14; argument: "").
I: client.c: Created 0 "ConsoleKit Session /org/freedesktop/ConsoleKit/Session4"
D: module-console-kit.c: Added new session /org/freedesktop/ConsoleKit/Session4
I: module.c: Loaded "module-console-kit" (index: #15; argument: "").
I: module.c: Loaded "module-position-event-sounds" (index: #16; argument: "").
D: dbus-util.c: Successfully connected to D-Bus session bus 323a19ecddd29a4c3a6c37b1000004ba as :1.46
D: main.c: Got org.pulseaudio.Server!
I: main.c: Daemon startup complete.
D: core-subscribe.c: Dropped redundant event due to change event.
I: module-suspend-on-idle.c: Sink auto_null idle for too long, suspending ...
D: sink.c: Suspend cause of sink auto_null is 0x0004, suspending
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Re: Pulseaudio - No Sound

Postby wyrdoak on Thu Aug 04, 2011 10:33 pm

If this helps here's mine:

Code: Select all
sudo lspci -vnn


00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
   Subsystem: Acer Incorporated [ALI] Device [1025:0349]
   Flags: bus master, fast devsel, latency 0, IRQ 44
   Memory at 98200000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [130] Root Complex Link
   Kernel driver in use: HDA Intel


sudo gedit /etc/modprobe.d/alsa-base.conf

Code: Select all
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2


Code: Select all
pulseaudio -vv
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: core-rtclock.c: Timer slack is set to 50 us.
I: core-util.c: Failed to acquire high-priority scheduling: No such file or directory
I: main.c: This is PulseAudio 0.9.21
D: main.c: Compilation host: x86_64-pc-linux-gnu
D: main.c: Compilation CFLAGS: -g -O2 -g -O2 -Wall -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: main.c: Running on host: Linux x86_64 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011
D: main.c: Found 2 CPUs.
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Running in VM: no
D: main.c: Optimized build: yes
D: main.c: All asserts enabled.
I: main.c: Machine ID is 3c57545fd9007fcac1f08fcd00001118.
I: main.c: Session ID is 3c57545fd9007fcac1f08fcd00001118-1312500722.123148-1284340509.
I: main.c: Using runtime directory /home/wyrdoak/.pulse/3c57545fd9007fcac1f08fcd00001118-runtime.
I: main.c: Using state directory /home/wyrdoak/.pulse.
I: main.c: Using modules directory /usr/lib/pulse-0.9.21/modules.
I: main.c: Running in system mode: no
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Pulseaudio - No Sound

Postby Mr. R on Fri Aug 05, 2011 10:50 pm

After consideration I followed the instructions from a link in zerozero's post to uninstall PulseAudio in place of alsa-mixer.
As expected, the sound is at least working again. Thanks everyone here for helping.
Mr. R
Level 1
Level 1
 
Posts: 13
Joined: Sat Oct 09, 2010 6:44 pm

Re: Pulseaudio - No Sound

Postby wyrdoak on Fri Aug 05, 2011 10:55 pm

Glad to have you up and running again!
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Pulseaudio - No Sound

Postby zerozero on Sat Aug 06, 2011 6:34 am

Glad as well you got it working, swapping pulse for alsa is probably the best thing you can do, you loose no functionality and get a much more stable sound back-end.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests