LMDE 201108 RC - FFmpeg mencoder broken packages

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

LMDE 201108 RC - FFmpeg mencoder broken packages

Postby sacha@debian on Tue Aug 23, 2011 2:59 am

Hello!

Sorry for my bad english...

I've installed LMDE gnome 201108 RC. It rocks... but...

If i try to install k9copy or dvd95, synaptic said that packages are broken or dependencies fails...

If i try to install ffmpeg or mencoder directly, a "!" red appears...

It's a problem of dependencies from debian or from latest repos.?
I've turn on a nex server, i've activated romeo and backport, nothing, packages broken... Packages could be missing on debian repos. or on mint repos.?
A fix possible?

Thank's!

PS : Without this problem, LMDE RC is very fast! Good job!
sacha@debian
Level 1
Level 1
 
Posts: 7
Joined: Tue Aug 23, 2011 2:31 am

Linux Mint is funded by ads and donations.
 

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby Gerd50 on Tue Aug 23, 2011 4:51 am

Some dependencie pks are not available in the Debian repos:

http://packages.debian.org/en/wheezy/ffmpeg
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby sacha@debian on Tue Aug 23, 2011 5:16 am

Thank's!

So, this package ffmpeg is older than mine with synaptic. And forcing the older package make synaptic become crazy!

And mencoder? I don't have internet presently but, if if force the older testing version, synaptic seems to be download and install (fails due to internet connexion not present).

Same reaction with your LMDE install?

Wath's your sourcelist?
sacha@debian
Level 1
Level 1
 
Posts: 7
Joined: Tue Aug 23, 2011 2:31 am

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby Gerd50 on Tue Aug 23, 2011 5:36 am

My LMDE i've installed with the 201009 ISO nearly one year ago, no problems with the connection here.

mencoder is in the testing repos and it is installable.

My sources.list is that one in point 1.5:

viewtopic.php?f=141&t=79533
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby sacha@debian on Tue Aug 23, 2011 7:20 am

Thank's

Ok for the .2 mencoder, not .3 proposed by default.
sacha@debian
Level 1
Level 1
 
Posts: 7
Joined: Tue Aug 23, 2011 2:31 am

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby lmdeman on Tue Aug 23, 2011 9:13 am

This brings up a problem in the current implementation of the new LMDE repositories.
The linuxmint "latest" repository is meant to avoid temporary breakages you would frequently face to if you used the debian "testing" repo directly.
AFAIK "latest" is a snapshot of the official debian testing repo *only*, while the (unofficial) debian-multimedia is left rolling on its own. debian-multimedia contains packages (i.e. ffmpeg, mplayer, mencoder etc) that in turn have dependencies on the official debian testing repo.
This way, "latest" may itself cause (rather than avoid) breakages in the multimedia area when it cannot satisfy the dependecies of more recent debian-multimedia packages.
IMHO the debian-multimedia repo should be included in the linuxmint "latest" snapshot to ensure the consistency of LMDE. Otherwise debian-multimedia should be removed from the default sources.list.
User avatar
lmdeman
Level 1
Level 1
 
Posts: 38
Joined: Fri May 27, 2011 6:12 am

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby Gerd50 on Tue Aug 23, 2011 10:01 am

With ffmpeg and gstreamer0.10-ffmpeg the problem is, that both are not installable with the current version of
libavcodec52 5:0.6.3-0.0 in the testing repos and libavcodec-extra-52 is not available at all.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby lmdeman on Tue Aug 23, 2011 11:03 am

Gerd50 wrote:With ffmpeg and gstreamer0.10-ffmpeg the problem is, that both are not installable with the current version of
libavcodec52 5:0.6.3-0.0 in the testing repos and libavcodec-extra-52 is not available at all.


Hmm, I replaced the linuxmint latest repository with debian testing in sources.list and I was able to select ffmpeg for installation without breaking anything, just upgrading and installing a bunch of packages. Note that libavcodec52 is being replaced by libavcodec53 and libasound2 is updated.
Code: Select all
$ sudo apt-get install ffmpeg
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno inoltre installati:
  libasound2 libasound2-plugins libavdevice53 libavfilter2 libavformat53
  libcv2.1 libdnet libroar-compat1 libroar1
Pacchetti suggeriti:
  nvidia-libvdpau1 pinentry libmuroar0 roaraudio-server slpd
Pacchetti raccomandati:
  dnet-common
I seguenti pacchetti NUOVI saranno installati:
  ffmpeg libavdevice53 libavfilter2 libavformat53 libcv2.1 libdnet
  libroar-compat1 libroar1
I seguenti pacchetti saranno aggiornati:
  libasound2 libasound2-plugins
2 aggiornati, 8 installati, 0 da rimuovere e 449 non aggiornati.
È necessario scaricare 4421 kB di archivi.
Dopo quest'operazione, verranno occupati 10,2 MB di spazio su disco.
Continuare [S/n]?

Compare with "latest":
Code: Select all
sudo apt-get install ffmpeg
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 ffmpeg : Dipende: libavdevice53 (>= 5:0.8) ma non sta per essere installato
E: Pacchetti danneggiati

So I assume it is safe to say that, in this occurrence, linuxmint latest broke at least ffmpeg.
Further I was able to request to install mencoder and update mplayer without breakage.
(Note that I didn't actually install anything because I like to keep aligned with latest, for now).

Even though this will probably be fixed when the next update pack will be out (soon I think), I wish to stress once more that the current default sources as of 201108 RC may cause breakage and I'd like to ask the LM Team to consider this problem.
User avatar
lmdeman
Level 1
Level 1
 
Posts: 38
Joined: Fri May 27, 2011 6:12 am

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby zerozero on Tue Aug 23, 2011 11:19 am

this issue was also approached in this thread viewtopic.php?f=141&t=79803
and, yes, as lmdeman said above, i too think that debian-multimedia should be mirrored in the latest/incoming packs;
this is something that has to be brought to Clem's attention
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6475
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby Gerd50 on Tue Aug 23, 2011 12:27 pm

@lmdeman, you are right with ffmpeg. I've uninstalled it, wanted to reinstall it, but that didn't work at first. Tried it again
now after a reboot and the installation works as you said.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: LMDE 201108 RC - FFmpeg mencoder broken packages

Postby sacha@debian on Wed Aug 24, 2011 2:36 am

Hello! Thank's!

I've installed the older version package of mencoder with synpatic (by forcing the version). It works. But, synaptic is not happy, "!" red and package broken. If i want to install k9copy, the mencoder package must be locked on this version! ThIs is not pretty... ;-) But, k9copy works fine...

I'm on latest repos only, not incoming. So, ffmepg is uninstallable! I'm stressed too with this breakage of some packages with this "secure way' to update LMDE.

The new freeze of incoming in latest is for the end of this month... i hope that!

How can we inform Clem and "the lmde debug team"?
sacha@debian
Level 1
Level 1
 
Posts: 7
Joined: Tue Aug 23, 2011 2:31 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests