[SOLVED]Cant install ffmpeg

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[SOLVED]Cant install ffmpeg

Postby hairybiker on Fri Sep 16, 2011 9:44 am

Using the testing resources:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import backport
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free

As suggested by zerozero in another post.

I am trying to install ffmpeg to re-encode some flv's.
But I get:-
Depends on libavdevices53 but it isn't going to be installed.
& if I try and install libavdevice53
Depends on libasound2 (>1.024.1)

Any way round this?
Last edited by hairybiker on Tue Sep 20, 2011 5:49 am, edited 1 time in total.
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Linux Mint is funded by ads and donations.
 

Re: Cant install ffmpeg

Postby proxima_centauri on Fri Sep 16, 2011 9:49 am

Are you using the latest respin 201109?
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Cant install ffmpeg

Postby hairybiker on Fri Sep 16, 2011 10:07 am

No I installed it from the 201108 iso, it is fully upto date as far as Mint Update is concerned anyway. (Sp 2 installed)
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Re: Cant install ffmpeg

Postby Gerd50 on Fri Sep 16, 2011 12:29 pm

I think you'll have to wait for update pack 3 or if you don't want to wait, change the latest testing source to testing.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Cant install ffmpeg

Postby hairybiker on Fri Sep 16, 2011 1:45 pm

Hmm this LMDE for a supposedly stable base (Debian) seems lacking in a lot of things. I don't have much installed in it apart from the base install (sabnzbd and get-iplayer are about it) so I was looking forward to having it continue to run without too much intervention, but if I can't even get a "normal" package like ffmpeg to install ...
I may just reformat back to Mint 11 which was stable on that machine. :shock:
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Re: Cant install ffmpeg

Postby Gerd50 on Fri Sep 16, 2011 2:13 pm

You are right, the situation is not optimal at the moment. But it's only a question of hours or a few days until the new
update system should work better.

viewtopic.php?f=141&t=81449

I wrote about how to handle the sources.list here

viewtopic.php?f=141&t=79533

Once understood it's not too hard to handle :wink:
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Cant install ffmpeg

Postby hairybiker on Sat Sep 17, 2011 5:46 am

So let me get this straight, the update of the existing iso's is broken?
Should I d/l the release image and install that over the current one? (Bit of a pain if I have to do that as this system doesn't have a separate /home, due to being on a small SSD) I can do it by backing the /home up and restoring the "missing" config files.

I missed your post on the "bug" in the repositories yesterday, and was unaware that the "final" iso had been released (yesterday again)
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Re: Cant install ffmpeg

Postby zerozero on Sat Sep 17, 2011 5:51 am

the update though multimedia or security is broken, yes, but you don't need to d/l a new iso to fix the issue, as soon as up3 comes out will be a matter of tune up your sources.list and you'll be fine to go
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cant install ffmpeg

Postby hairybiker on Sat Sep 17, 2011 11:53 am

Ok have removed the "offending" repo's and will wait for UP3 and see if I can install ffmeg then, if not then Mint 11 Main edition is getting re-installed. :(
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Re: Cant install ffmpeg

Postby bwat47 on Sat Sep 17, 2011 11:58 pm

I had a similar issue. I switched to the "incoming" repos so I could test update pack 3 early, updated, removed the packages that were complaining about dependencies, and then installed them all, including ffmpeg and it seems to work fine now.

Update pack 3 should be hitting latest soon I'd imagine.
bwat47
Level 2
Level 2
 
Posts: 63
Joined: Sun May 01, 2011 1:31 am

Re: Cant install ffmpeg

Postby craigevil on Mon Sep 19, 2011 4:56 pm

Or just add a Debian Testing line to your sources.list rather than the lmde update repo.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: [SOLVED]Cant install ffmpeg

Postby MasterPassion on Tue Sep 20, 2011 3:36 pm

Similar problems, trying to install ffmpeg 0.8.2 . But it tells that I should install some older libs:
Code: Select all
7)      gstreamer0.10-ffmpeg [1:0.10.11-4.1 (now) -> 0.10.11-4 (testing)]
8)      libavcodec52 [5:0.6.3-0.0 (now) -> 4:0.6.2-3 (testing)]           
9)      libavformat52 [5:0.6.3-0.0 (now) -> 4:0.6.2-3 (testing)]         
10)     libavutil50 [5:0.6.3-0.0 (now) -> 4:0.6.2-3 (testing)]           
11)     libpostproc51 [5:0.8.2-0.1 (now, testing) -> 4:0.6.2-3 (testing)]
12)     libswscale0 [5:0.6.3+git20110613-0.1 (now) -> 4:0.6.2-3 (testing)]


What's about those update pack or what? Should I try to get some headache with deps and install ffmpeg or will it be better to wait?

P. S. My English is very bad, sorry.
Bad russian.
MasterPassion
Level 1
Level 1
 
Posts: 8
Joined: Tue Sep 20, 2011 3:29 pm

Re: [SOLVED]Cant install ffmpeg

Postby hairybiker on Wed Sep 21, 2011 5:47 am

I added the testing repo's and it installed.
BUT I have given up on it as being to user unfriendly at the moment and gone back to "normal" Mint 11.
hairybiker
Level 3
Level 3
 
Posts: 157
Joined: Mon Nov 03, 2008 12:16 pm

Re: [SOLVED]Cant install ffmpeg

Postby MasterPassion on Thu Sep 29, 2011 3:59 pm

All is OK now. There was a big update today (over 400MBytes), after it I successfully installed ffmpeg.
Bad russian.
MasterPassion
Level 1
Level 1
 
Posts: 8
Joined: Tue Sep 20, 2011 3:29 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests