Remove the annoying system-beep.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Remove the annoying system-beep.

Postby fransje on Tue Sep 20, 2011 9:26 am

Dear all,

I was trying to remove the over-annoying system beep I got using LMDE-Xfce edition.
I tried a few things which didn't work, including adding
Code: Select all
blacklist pcspkr

to the /etc/modprobe.d/blacklist file, but to no avail.

I also tried muting the beep in alsamixer but couldn't because pulseaudio seem to have overwritten my alsamixer configuration. It's actually so bad that I can't even choose if I want to play music to my headphones without having also my laptop speakers enabled. So if I mute the speakers, I just loose all the sound.. Just great. So now, if I unplug my headphones, tadaa, the sound will blast out my speakers. Just what I don't want.
Under Archlinux, I used to be able to choose through which outputs I would re-direct my sound, but not anymore... :-( Anyways.. Wandering of my original topic here...

I finally did find that by running xset b off I could temporarily get rid of the system beep. Until the next reboot that is.
Well great! I thought. A leap in the right direction! I'll just add it to my .xinit script, and I'm in business, problem solved! Well... Wrong! Thinking again..
Gdm3 doesn't read .xinit. Neither does it read .Xsession. And no matter which script I would run, I would always keep that beep at logon anyways. :x
So I tried to add xset b off to an init.d script, but that didn't work either, because it needs an active terminal with a screen to connect to, and that is loaded (I think?) by gdm3... Adding it to the init.d gdm3 script didn't help either, for the same reasons.

Well, I finally find another tip on this forum, namely installing gnome-alsamixer and mute the beep there. It seems to have worked for the time being, but I still have to reboot to find out whether it will also have muted the logon screen beep. (I soo do hope it did..) And it also solved the headphones/speakers issue. :-D

Anyways, all this semi-ranting for a few simple philosophical questions...
  1. Why is it so difficult to remove a system beep I didn't want in the first place?
  2. Where did my Linux-user freedom go to? If I wanted somebody else to decide I needed a system beep, and that my sound should come out of my speakers when there are no headphones plugged in, I would have stayed with Windows...
  3. Why do I have to install yet another program to solve that problem, while it should be a user-transparent thing to do?
  4. Is nobody else concerned that the program I had to install was gnome-related, meaning that if I hadn't already had a few gnome programs installed, it would probably have come with some dependencies I didn't want in the first place?

Mmm.. Well perhaps this is a bit of a complain from a luxury standpoint.. If I wanted a dependency-lean system, I could always set it up myself from scratch and avoid gnome/xfce/things-I-didn't-want but I felt a bit lazy this time, and I really like the new grey mint-theme...

So please don't take this post as an attack, but as an invitation to experience exchanges and constructive thoughts.

Kind regards,

Francois.
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Linux Mint is funded by ads and donations.
 

Re: Remove the annoying system-beep.

Postby ThistleWeb on Tue Sep 20, 2011 11:40 am

What triggers the beep? There are motherboard sounds, that will come from a little speaker on the motherboard itself, not through the OS to your speakers or headphones. As far as I know, those beeps are for serious or hardware errors, like a POST error. I don't think you can disable those or even redirect them. Your only option is to disable the motherboard speaker, which is not advised. You should only hear those beeps if there's something badly needing attention, in which case the longer term solution would be find out what hardware is causing it and replace it.

If those are not the beeps you mean, then don't follow any of the above advice.
Crivens!
User avatar
ThistleWeb
Level 5
Level 5
 
Posts: 900
Joined: Fri Mar 25, 2011 9:59 am
Location: Scotland

Re: Remove the annoying system-beep.

Postby fransje on Tue Sep 20, 2011 11:56 am

Dear ThistleWeb,

Thank you for reply!
No, definitely no motherboard sound. Just an annoying beep when the Gdm loginscreen pops up for instance, or when you get to the lowest path level in Thunar, or have multiple options when hitting tab in a terminal... Luckily I could bypass the terminal beep with the local options of my terminal emulator otherwise I would have went completely crazy by now..
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: Remove the annoying system-beep.

Postby ThistleWeb on Tue Sep 20, 2011 1:33 pm

There is somewhere you can disable sound on login, or before it. The point is to draw your attention that the login screen is ready to be dealt with, but many, including me don't like it. Try the control panel. The terminals have audible bells which trigger when things happen, again you can disable those too.
Crivens!
User avatar
ThistleWeb
Level 5
Level 5
 
Posts: 900
Joined: Fri Mar 25, 2011 9:59 am
Location: Scotland

Re: Remove the annoying system-beep.

Postby redhead on Sun Dec 25, 2011 1:28 pm

I have been receiving this annoying system been when reaching GDM on my Dell 6400 and 6410 laptops. This issue is the same on Debian stable and Debian testing so it seems to be coming from there. I have not been able to get rid of this sound even by disabling the login sound in GDM. In Debian KDE there is no such issue which is a bit confusing. This is annoying be to the stage where I several times have wiped my LMDE although I otherwise really like it.

Just after i wrote this I found this on Frederik's BlogRandom thoughts of a Linux sysadmin on his experience with his Dell E6400:

Speaker noise
Another problem was that as soon as the sound drivers were loaded, a loud noise came out of the speakers. To fix this, open the volume control in LInux, and deactivate the Analog Loopback 1 and 2 switches (in GNOME, you will need to click on the Preferences button first, and check the checkboxes next to Analog Loopback 1 and 2 to show these switches). I also completely muted PC Beep because even on the lowest level, the console beep was still extremely loud.
redhead
Level 1
Level 1
 
Posts: 1
Joined: Tue Jul 19, 2011 1:33 am

Re: Remove the annoying system-beep.

Postby xircon on Sun Dec 25, 2011 2:01 pm

Code: Select all
sudo apt-get install gnome-alsamixer && gnome-alsamixer


Mute "Beep" or "PC Beep".
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Remove the annoying system-beep.

Postby ormu on Wed Jan 25, 2012 5:39 pm

I had the same problem on my laptop with LMDE + Xfce and I was able to solve it by adding the xset command to Xfce autostart list...

Go to Menu -> Settings -> Settings (the upper one) (...or something, I have Finnish menus)

-> Session and startup -> Autostart tab -> click Add...

Name and description: type whatever you want
Command: xset b off

-> click OK.

Reboot (or just restart X?), no more beeping.
ormu
Level 1
Level 1
 
Posts: 24
Joined: Mon Dec 19, 2011 3:42 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests