Sound muted when I start up/login?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Sound muted when I start up/login?

Postby affirmedatheist on Thu Sep 22, 2011 7:35 pm

It's minor, but I'm finding the fact that my box is automatically setting sound to 'mute' upon login to be, well, annoying.

It's about the only problem. Sound otherwise works fine, I'm just wondering if there's some sort of command I can set to run at startup to rid myself of this annoyance.

As I say, everything else works fine - great even. Multiple programs are running sound concurrently, even (I had previously been having the issue of only being able to have sound from one application at a time, but when I switched to the Mint Incoming repos (and updated to the latest software) this issue seems to have solved itself. This is more or less the last niggling problem I have with audio.
LMDE XFCE x86_64, Kernel 3.0.0.1, XFCE 4.8 | Gentoo Linux, Kernel 3.0.6, KDE 4.7.2, -march:core2 | Windows Vista Home Premium x64
Core 2 Quad Q9400, Kingston (value) 8GB DDR2 800MHz, GeForce GTX 550Ti, 320GB + 250GB HDD, ASUS P5Q-Pro motherboard.
affirmedatheist
Level 1
Level 1
 
Posts: 11
Joined: Thu Apr 29, 2010 7:20 pm

Linux Mint is funded by ads and donations.
 

Re: Sound muted when I start up/login?

Postby impuwat on Tue Dec 06, 2011 10:30 pm

Any answers? I've had the same exact problem. Love Mint overall but this little problem is wearing on me. Having to go to "preferences" then "sound" then unchecking "mute" on a regular basis.
impuwat
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 06, 2011 10:26 pm

Re: Sound muted when I start up/login?

Postby Gerd50 on Wed Dec 07, 2011 8:08 am

Hi impuwat,

you read this? - viewtopic.php?f=90&t=83444 - Point 5 - Deatails! Details! Details!
No help possible without details. For the specs of your soundcard please post the output of

Code: Select all
cat /proc/asound/cards

Are you member of the group audio?

Code: Select all
grep "^audio" /etc/group | grep "$USER" | wc -l


Do you use alsa, pulseaudio or both?
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Sound muted when I start up/login?

Postby bootmakr on Thu Dec 22, 2011 8:33 pm

I have a similar problem ..... I AM a member of the audio group, and I have an Intel sound card;
Code: Select all
cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel

Linux 2.6.39-2-486 #1 Tue Jul 5 02:52:23 UTC 2011 i686 GNU/Linux

                      (irq and hex deleted for security reasons)



Here are the symptoms I experience:
My alsa mixer defaults to the master slide being all the way down (muted?) with the headphone,speaker, PCM, line in, and beep slides all the way to the top (max sound?). This happens every time I change from one audio/video to another (whether You Tube, news sites, or other sites having mp3 sound, etc.). The only way I can listen with the headphones when this happens is to open the Alsa Mixer, slide the master all the way to the top, slide the speaker all the way down, mute the speaker, then unmute it again, and the headphones will work without the speaker! If I don't mute/unmute the speaker, the headphones won't work at all :?
bootmakr
Level 2
Level 2
 
Posts: 69
Joined: Sat Dec 17, 2011 8:13 pm

Re: Sound muted when I start up/login?

Postby Brian49 on Fri Dec 23, 2011 6:40 am

Perhaps your ALSA mixer settings aren't being saved between sessions. Once you have chosen your preferred settings, run this command in a terminal:

Code: Select all
alsactl store


If it is any consolation, it took me ages to find this solution when I had the same problem!
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Re: Sound muted when I start up/login?

Postby bootmakr on Fri Dec 23, 2011 2:02 pm

Thanks Brian49, I'll try that.
Found out that I had to use sudo
Code: Select all
sudo alsactl store
put ion my password, and then it seemed to accept it ..... I'll test it now.

That didn't work, I'm back to square one!
bootmakr
bootmakr
Level 2
Level 2
 
Posts: 69
Joined: Sat Dec 17, 2011 8:13 pm

Re: Sound muted when I start up/login?

Postby bootmakr on Fri Dec 30, 2011 1:51 pm

Now that I've removed pulseaudio and alsa, and re-installed alsa, then used the command you posted, everything works fine! THX
bootmakr
Level 2
Level 2
 
Posts: 69
Joined: Sat Dec 17, 2011 8:13 pm

Re: Sound muted when I start up/login?

Postby Brian49 on Fri Dec 30, 2011 7:12 pm

I've never liked PulseAudio - an unnecessary additional layer of software. One of the good things about LMDE is that you can completely remove PulseAudio with no negative effects; I could never manage that on standard Linux Mint, probably because Ubuntu is so heavily committed to PulseAudio.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest