[solved] Asus Xonar does not work in LMDE Update Pack 3

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[solved] Asus Xonar does not work in LMDE Update Pack 3

Postby Stormy667 on Mon Oct 03, 2011 8:15 am

Hi there!

I was using LM 11 (Katya) before and everything worked out-of-the-box.

Now I have installed LMDE with update pack 3 (64 bit version, XFCE) and my Asus Xonar DX sound card no longer works.
Other system specs: CPU 6-core Phenom II, 4 Gb memory

I have verified that the sound mixer is turned up and set to "Asus Xonar"
Tested program was Banshee player.

I have tried quite some things, including purging pulseaudio, but sound only works on
onboard sound card :-(

Output from lspci:

Code: Select all
00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:09.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port E)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: ATI Technologies Inc SB700/SB800 PCI to PCI bridge (PCIE port 1)
00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 PCI bridge: PLX Technology, Inc. PEX8112 x1 Lane PCI Express-to-PCI Bridge (rev aa)
03:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
05:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
06:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
07:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)
07:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)


Output from lspci -vvnn:

Code: Select all
03:04.0 Multimedia audio controller [0401]: C-Media Electronics Inc CMI8788 [Oxygen HD Audio] [13f6:8788]
   Subsystem: ASUSTeK Computer Inc. Virtuoso 100 (Xonar DX) [1043:8275]
   Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 64 (500ns min, 6000ns max)
   Interrupt: pin A routed to IRQ 17
   Region 0: I/O ports at c800 [size=256]
   Capabilities: [c0] Power Management version 2
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Kernel driver in use: AV200


Output from lsmod | grep snd:

Code: Select all
snd_hda_codec_hdmi     26321  4
snd_usb_audio          84855  3
snd_usbmidi_lib        23475  1 snd_usb_audio
snd_hda_codec_via      56995  1
snd_virtuoso           35006  4
snd_oxygen_lib         32825  1 snd_virtuoso
snd_hda_intel          26140  8
snd_hda_codec          72699  3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep              13186  2 snd_usb_audio,snd_hda_codec
snd_pcm_oss            41257  0
snd_mixer_oss          17969  3 snd_pcm_oss
snd_pcm                68104  6 snd_hda_codec_hdmi,snd_usb_audio,snd_oxygen_lib,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_mpu401_uart        13507  1 snd_oxygen_lib
snd_seq_midi           12848  0
snd_seq_midi_event     13316  1 snd_seq_midi
snd_rawmidi            23297  3 snd_usbmidi_lib,snd_mpu401_uart,snd_seq_midi
snd_seq                45208  2 snd_seq_midi,snd_seq_midi_event
snd_timer              22581  2 snd_pcm,snd_seq
snd_seq_device         13137  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    52823  43 snd_hda_codec_hdmi,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec_via,snd_virtuoso,snd_oxygen_lib,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              13152  3 snd
snd_page_alloc         13043  2 snd_hda_intel,snd_pcm
usbcore               124242  11 carl9170,uvcvideo,snd_usb_audio,snd_usbmidi_lib,usb_storage,usbhid,uas,xhci_hcd,ohci_hcd,ehci_hcd


The driver seems to be in use (snd_virtuoso)...

Output from cat /proc/asound/cards

Code: Select all
0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfbdf8000 irq 16
 1 [DX             ]: AV200 - Xonar DX
                      Asus Virtuoso 100 at 0xc800, irq 17
 2 [U0x46d0x81b    ]: USB-Audio - USB Device 0x46d:0x81b
                      USB Device 0x46d:0x81b at usb-0000:00:12.2-2.3, high speed
 3 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe97c000 irq 19


Xonar DX seems to be recognized...

But still no sound :(

I am pretty new to linux, how can I proceed from here?

Maybe a newer version of alsa or pulseaudio?

Thanks in advance!

Stormy667
Last edited by Stormy667 on Fri Oct 07, 2011 3:11 pm, edited 1 time in total.
Stormy667
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 03, 2011 8:05 am

Linux Mint is funded by ads and donations.
 

Re: Asus Xonar does not work in LMDE Update Pack 3

Postby Stormy667 on Fri Oct 07, 2011 3:10 pm

Hi folks!

Pulseaudio 1.0-4 did the trick! :D

I enabled Sid-Repo, used Synaptic to upgrade Pulseaudio and then disabled the repo again.

My Xonar DX works again (tested with Banshee and Flash-Video in Firefox).

Stormy 667
Stormy667
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 03, 2011 8:05 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest