howto googleearth in LMDE latesttestingsid

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

howto googleearth in LMDE latesttestingsid

Postby Gerd50 on Sun Oct 13, 2013 5:22 pm

After a period of not using GE, yesterday i wanted to use it. As always after such periods on my three
years old installations, there was an error. Something like "can't connecct //http" while searching for
places with an old lucid version i had installed. In the past i always got it working again within a short
time, when GE was on strike. But yesterday, no chance.

First i searched our forums which presented 14 result sites. That's too much i thought, but in
order to find a solution, i fought through it - without result. Then i searched googel, all i found was,
try this version, try that version, do some bin/bash in the startscript and so on. I tried it with the
googleearth-package, a tar package from the google site and a google entry in my sources.list.
But always the same - can't connect http or network error.

All in all it took me three ours, my head was smoking like a chimney and at least a nice little hint i found
was the best:

google google maps, go on satellite on the upper right

Bye bye GE :mrgreen:
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Linux Mint is funded by ads and donations.
 

Re: howto googleearth in LMDE latesttestingsid

Postby tdockery97 on Sun Oct 13, 2013 8:31 pm

Is your error the little popup box that says: invalid HTTP request?

If that's the problem, the solution is simple. If Google Earth is in the directory /opt/google/earth/free open it (as root) and rename the file libcurl.so.4 to back_libcurl.so.4

Run Google Earth again and it should now work properly.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4869
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: howto googleearth in LMDE latesttestingsid

Postby Gerd50 on Mon Oct 14, 2013 5:56 am

Yes, in two versions i tried, "invalid http request" was the error. In another version the error was
"network error, check your network connection".

I just installed google-earth-stable_6.0.3.2197_r0_i386.deb got from sourceforge. In this version a
window pops up very quickly, something like "loading myplaces impossible" and searching for places
gives me the http request error. If i rename libcurl.so.4, GE doesn't start.

I'll try other versions later, although the maps solution is good for me. Let's see, which version will
work.

Edit:

A sources.list entry



and then (as root or in a root terminal)



installs the same package via synaptic as above. With the same error.

The solution is:

apt-get install libcurl3
mv /opt/google/earth/free/libcurl.so.4 /opt/google/earth/free/libcurl.so.4-alt

This version is a little bit jerky with a slow connection.

--------------------------------------------------------------------------------------------------------------------------------------

A deb package build with google-earth package, which is in the repos, in /opt/google/earth/free
the only content is back_libcurl.so.4 and produces the http request error.

I didn't try but guess, installing libcurl3 should fix it.

-------------------------------------------------------------------------------------------------------------------------------------

Today the package available on the GE site

http://www.google.de/intl/de/earth/down ... agree.html

works out of the box without libcurl3 installed. Seems like the error was fixed. But this version isn't
useable for people with slow connection. It jerks and hangs, takes long time for searches. A nervkiller.

-------------------------------------------------------------------------------------------------------------------------------------------

In my archives i found GE 5.1. The names of the packages are:

Google_Earth_5_1_Ubuntu_Instal_by_NikolaiRach.zip

unzipped:

googleearth-data_5.1.3509.4636-0medibuntu1_all.deb

googleearth_5.1.3533.1731-0medibuntu1_i386.deb

The solution of the invalid http request is:

apt-get install libcurl3
mv /usr/lib/googleearth/libcurl.so.4 /usr/lib/googleearth/libcurl.so.4-alt
ln -s /usr/lib/i386-linux-gnu/libcurl.so.4 /usr/lib/googleearth/libcurl.so.4

This good old version has good fonts and works proper with a slow connection.

Thank's for the libcurl.so.4 hint tdockerey, that made the search for a solution easier :wink:
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany


Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 5 guests