Wakeup from sleep, fails to connect to wifi

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Wakeup from sleep, fails to connect to wifi

Postby wulftone on Thu Apr 19, 2012 7:12 pm

Hey all,

I just updated to Update Pack 4, and installed cinnamon.. pretty decent so far, though I do miss compiz's flexibility and ease-of-configuration. My issue is with the wifi. Here's the symptoms: I connect to wifi, then I close my laptop lid, then I open it and it tries to re-connect to the same network, but fails with "Authentication Required" and _no_ popup box for password or anything. I have to turn _off_ my wifi and turn it back on in order to connect. No idea what's going on or how to diagnose it... help?

Thanks!
wulftone
Level 1
Level 1
 
Posts: 18
Joined: Thu Aug 18, 2011 5:22 pm

Linux Mint is funded by ads and donations.
 

Re: Wakeup from sleep, fails to connect to wifi

Postby äxl on Sat Apr 21, 2012 3:15 am

What goes on when suspending is logged in /var/log/pm-suspend.log

As a general note: A good way to find out what's going on is to look at the output of
Code: Select all
dmesg | tail

This will basically give you the last lines of /var/log/kern.log
If that does not give a hint leave the '| tail' away or open the file directly and post the whole content.

:D http://torvalds-family.blogspot.de/2008 ... -hell.html
http://wiki.debian.org/Suspend
http://wiki.debian.org/Hibernation
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Wakeup from sleep, fails to connect to wifi

Postby wulftone on Wed Apr 25, 2012 4:34 pm

Output of `cat /var/log/pm-suspend.log`
Code: Select all
Wed Apr 25 13:18:36 PDT 2012: Awake.
Wed Apr 25 13:18:36 PDT 2012: Running hooks for resume
Running hook /usr/lib/pm-utils/sleep.d/99video resume suspend:

/usr/lib/pm-utils/sleep.d/99video resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend:

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95packagekit resume suspend:
method return sender=:1.412 -> dest=:1.441 reply_serial=2

/usr/lib/pm-utils/sleep.d/95packagekit resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led resume suspend:

/usr/lib/pm-utils/sleep.d/95led resume suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq resume suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock resume suspend:

/usr/lib/pm-utils/sleep.d/90clock resume suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/75modules resume suspend:
Reloaded unloaded modules.

/usr/lib/pm-utils/sleep.d/75modules resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant resume suspend:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

/usr/lib/pm-utils/sleep.d/60_wpa_supplicant resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend:
Having NetworkManager wake interfaces back up...Failed.

/usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend: success.
Running hook /etc/pm/sleep.d/20_samsung-tools resume suspend:

/etc/pm/sleep.d/20_samsung-tools resume suspend: success.
Running hook /etc/pm/sleep.d/10_unattended-upgrades-hibernate resume suspend:

/etc/pm/sleep.d/10_unattended-upgrades-hibernate resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave resume suspend:

/usr/lib/pm-utils/sleep.d/00powersave resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00logging resume suspend:

/usr/lib/pm-utils/sleep.d/00logging resume suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/000kernel-change resume suspend:

/usr/lib/pm-utils/sleep.d/000kernel-change resume suspend: success.
Wed Apr 25 13:18:36 PDT 2012: Finished.


And this is from `dmesg`
Code: Select all
...
[22912.999584] Restarting tasks ... done.
[22913.021562] video LNXVIDEO:00: Restoring backlight state
[22913.656067] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[22913.669729] sky2 0000:07:00.0: eth1: enabling interface
[22913.671396] ADDRCONF(NETDEV_UP): eth1: link is not ready
[23056.886822] wlan0: authenticate with 00:1b:12:5a:42:21 (try 1)
[23056.888836] wlan0: authenticated
[23056.908551] wlan0: associate with 00:1b:12:5a:42:21 (try 1)
[23056.914085] wlan0: RX AssocResp from 00:1b:12:5a:42:21 (capab=0x431 status=0 aid=6)
[23056.914092] wlan0: associated
[23056.921650] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[23067.798633] wlan0: no IPv6 routers present


The part that starts at 23056 is after I manually re-started the wifi--at which point everything was fine, but it should have done that automatically. : \ Not sure what's going wrong.
wulftone
Level 1
Level 1
 
Posts: 18
Joined: Thu Aug 18, 2011 5:22 pm

Re: Wakeup from sleep, fails to connect to wifi

Postby äxl on Mon Apr 30, 2012 5:54 pm

wulftone wrote:
Code: Select all
/usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend: success.
Running hook /etc/pm/sleep.d/20_samsung-tools resume suspend:

/etc/pm/sleep.d/20_samsung-tools resume suspend: success.
Running hook /etc/pm/sleep.d/10_unattended-upgrades-hibernate resume suspend:

Besides the Samsung part it looks the same for me. Do you know where you have samsung-tools from and could you reinstall it please?
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Wakeup from sleep, fails to connect to wifi

Postby dgrant on Wed May 09, 2012 2:14 am

I have the exact same problem that you do, and it only started happening after I upgraded to the latest update pack. Did you ever manage to fix the problem?
dgrant
Level 1
Level 1
 
Posts: 3
Joined: Wed May 09, 2012 2:13 am

Re: Wakeup from sleep, fails to connect to wifi

Postby wulftone on Fri May 25, 2012 12:52 am

I removed samsung-tools, and there's no change in the behavior. It still fails to re-connect unless I cycle the wireless off/on.

@dgrant: Nope. Never fixed it! I've just been living with it... annoying, but whatever. I like Cinnamon regardless. Did you ever fix it?
wulftone
Level 1
Level 1
 
Posts: 18
Joined: Thu Aug 18, 2011 5:22 pm

Re: Wakeup from sleep, fails to connect to wifi

Postby wulftone on Tue Jun 05, 2012 8:43 pm

Anyone got any more ideas on this topic? I'm fresh out. It still fails to reconnect, and if I cycle the wifi power, it asks me for a password for my own network, even though it's stored. I just have to press enter after I cycle the wifi power, but it should just connect without the dialog box if the password is stored, right?
wulftone
Level 1
Level 1
 
Posts: 18
Joined: Thu Aug 18, 2011 5:22 pm

Re: Wakeup from sleep, fails to connect to wifi

Postby thesilverring on Sat Sep 22, 2012 11:34 pm

I too had this problem. I fixed it by checking the "Available to all users" box in the "Wireless security" tab of the network options.

Network settings -> Wireless -> (select your network) -> options -> "wireless Security"
check the "Available to all users" box at the bottom.
thesilverring
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 22, 2012 11:29 pm

Re: Wakeup from sleep, fails to connect to wifi

Postby wulftone on Sun Sep 23, 2012 4:17 am

Ah, great. Thanks for that tidbit. Unfortunately I'm not using LMDE right now, so I can't verify. I installed regular Mint 13 Maya Cinnamon and it worked fine out of the box. I figured it was a permissions-esque thing.
wulftone
Level 1
Level 1
 
Posts: 18
Joined: Thu Aug 18, 2011 5:22 pm

Re: Wakeup from sleep, fails to connect to wifi

Postby ChipHobart on Sun Sep 23, 2012 12:14 pm

Hi there,

just encountered this issue, too, on one out of three laptops and your hint:

thesilverring wrote:I fixed it by checking the "Available to all users" box in the "Wireless security" tab of the network options.

Network settings -> Wireless -> (select your network) -> options -> "wireless Security"
check the "Available to all users" box at the bottom.


did do the trick! :-)

Thanks for sharing & Cheers, Erik
ChipHobart
Level 1
Level 1
 
Posts: 8
Joined: Sat Sep 22, 2012 5:43 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests