<solved> Added Repository: now get an error message.

Post your update and upgrade related errors here
Forum rules
Before you post please read this

<solved> Added Repository: now get an error message.

Postby chrism66 on Wed May 02, 2012 7:48 pm

I was missing the following repoistiry in my sources list:



Now when I run the update manager and click the refresh button I get the following messsage:

W: GPG error: http://debian.linuxmint.com testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907


When I remove the added repository the message goes away. I have searched and tried many things too fix this message but it will not go away.

For help here is the output for $ inxi -Sr

System: Host blackbox Kernel 3.2.0-2-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
Last edited by chrism66 on Wed May 02, 2012 8:54 pm, edited 1 time in total.
chrism66
Level 1
Level 1
 
Posts: 13
Joined: Tue Apr 10, 2012 8:51 am

Linux Mint is funded by ads and donations.
 

Re: Added Repository: now get an error message.

Postby zerozero on Wed May 02, 2012 8:38 pm

sorry, a bit unclear, with the repos you posted in the end of your post you are getting that "missing key error"?
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Added Repository: now get an error message.

Postby chrism66 on Wed May 02, 2012 8:43 pm

Yes.
chrism66
Level 1
Level 1
 
Posts: 13
Joined: Tue Apr 10, 2012 8:51 am

Re: Added Repository: now get an error message.

Postby zerozero on Wed May 02, 2012 8:47 pm

what is the output of
Code: Select all
apt-cache policy debian-multimedia-keyring
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Added Repository: now get an error message.

Postby chrism66 on Wed May 02, 2012 8:48 pm

debian-multimedia-keyring:
Installed: (none)
Candidate: 2010.12.26
Version table:
2010.12.26 0
500 http://debian.linuxmint.com/latest/multimedia/ testing/main amd64 Packages
chrism66
Level 1
Level 1
 
Posts: 13
Joined: Tue Apr 10, 2012 8:51 am

Re: Added Repository: now get an error message.

Postby zerozero on Wed May 02, 2012 8:49 pm

Code: Select all
apt install debian-multimedia-keyring
Code: Select all
apt update
(now the error should be gone)
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Added Repository: now get an error message.

Postby chrism66 on Wed May 02, 2012 8:54 pm

Thanks zerozero! that fixed it.
chrism66
Level 1
Level 1
 
Posts: 13
Joined: Tue Apr 10, 2012 8:51 am

Re: Added Repository: now get an error message.

Postby zerozero on Wed May 02, 2012 8:55 pm

good :D
though it's strange because that pkg should be installed by default :shock: nevermind, the fix was easy.
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Added Repository: now get an error message.

Postby altscribe on Fri May 25, 2012 6:43 pm

chrism66 wrote:Thanks zerozero! that fixed it.


This is what I get when I try to update the repositories, and I have the debian-multimedia keyring properly installed and working. I have also tried to import the GPG key from a working Mint Debian machine...

W: GPG error: http://packages.linuxmint.com debian Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3EE67F3D0FF405B2
E: Release file expired, ignoring http://debian.linuxmint.com/latest/dist ... ng/Release (invalid since 59d 7h 8min 34s)

The affected repository is:

deb http://packages.linuxmint.com/ debian main upstream import

Why is such a simple thing, the GPG key for the repository, so IMPOSSIBLE to find on the Linux Mint website?? When I search for "Mint Debian pubkey" I get "not found, did you mean PUKE?"

Not very encouraging.
They say cut back, we say FIGHT BACK! Solidarity for The People now, and FOREVER!
altscribe
Level 1
Level 1
 
Posts: 14
Joined: Sun May 13, 2012 4:22 pm
Location: Athens, GA USA

Re: <solved> Added Repository: now get an error message.

Postby zerozero on Fri May 25, 2012 6:52 pm

Not very encouraging.

no need to :)
linuxmint-keyring is here http://packages.linuxmint.com/list.php?release=Debian (but should be in your repos as well)
Code: Select all
apt policy linuxmint-keyring
linuxmint-keyring:
  Installed: 2009.04.29
  Candidate: 2009.04.29
  Version table:
 *** 2009.04.29 0
        500 http://packages.linuxmint.com/ debian/main amd64 Packages
        100 /var/lib/dpkg/status

the other error (yes, you have 2 there)
E: Release file expired, ignoring http://debian.linuxmint.com/latest/dist ... ng/Release (invalid since 59d 7h 8min 34s)
look here (in the known issues part) viewtopic.php?f=187&t=76556
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: <solved> Added Repository: now get an error message.

Postby altscribe on Fri Jul 27, 2012 10:52 pm

Neglected to thank you for this good advice - am not a churlish lout, just occasionally lax...

Thx very much!

altscribe
They say cut back, we say FIGHT BACK! Solidarity for The People now, and FOREVER!
altscribe
Level 1
Level 1
 
Posts: 14
Joined: Sun May 13, 2012 4:22 pm
Location: Athens, GA USA

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests