Can't install Mate or okular

Post your update and upgrade related errors here
Forum rules

Can't install Mate or okular

Postby mcenno on Thu May 10, 2012 11:05 am

Hello,


I updated LMDE today to update pack 4. I'd like to install Mate (package mate-desktop-environment), but all I get from synaptic is

mate-desktop-environment:
Depends: mate-core but it is not going to be installed

and if I try to install that a lot of other failed dependencies surface.

Also I'd like to install okular (KDE document viewer), but with similar consequences:

okular:
Depends: kde-runtime but it is not going to be installed
Depends: libkio5 but it is not going to be installed
Depends: libkparts4 but it is not going to be installed
Depends: libkprintutils4 but it is not going to be installed
Depends: libokularcore1 but it is not going to be installed
Depends: phonon but it is not going to be installed


What's going on here? Why can't these dependencies be resolved? The system is up to date, and I have reloaded the repository contents over and over again. They are

cat /etc/apt/sources.list
deb http://linux-mint.froonix.org/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free


Best regards,

Enno
mcenno
Level 1
Level 1
 
Posts: 2
Joined: Thu May 10, 2012 10:48 am

Linux Mint is funded by ads and donations.
 

Re: Can't install Mate or okular

Postby zerozero on Thu May 10, 2012 11:28 am

well, you should follow the news
http://blog.linuxmint.com/?p=1836
http://blog.linuxmint.com/?p=1818
viewtopic.php?f=185&t=82346
result: try changing the repos as advised in those links:
they should be like this
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

do a
Code: Select all
apt update
try again (and let's hope that tracking those repos out of sync won't bring incompatible lib)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

Re: Can't install Mate or okular

Postby mcenno on Fri May 11, 2012 2:58 am

Hello,


thanks, I hadn't realised I needed to manually change repositories (and googling the error didn't help).

Worked like a charm, I'm on Mate now and also have okular.


Cheers,

Enno
mcenno
Level 1
Level 1
 
Posts: 2
Joined: Thu May 10, 2012 10:48 am

Re: Can't install Mate or okular

Postby zerozero on Fri May 11, 2012 6:05 am

hi mcenno,
glal it's sorted the way you wanted :D enjoy
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests