Software Manager doesn't open items in search or browse

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Software Manager doesn't open items in search or browse

Postby prower on Sun Jun 03, 2012 9:23 pm

First time post on this forum, been lurking for some weeks.

I'm running LMDE 12, and I'm having this weird problem with Software Manager; essentially what happens is if I search for or browse to some items, clicking on it does nothing. For example, avidemux. However, other items such as graphthing do work.

I've tried searching around, and I've found posts like http://forums.linuxmint.com/viewtopic.php?f=175&t=101998 and found others who had similar, but not quite the same problems (mostly hanging SM). I've tried the suggestions such as
Code: Select all
    sudo bash
    apt-get clean
    cd /var/lib/apt
    mv lists lists.old
    mkdir -p lists/partial
    apt-get clean
    apt-get update

with no effect.

If you have any suggestions, workarounds, etc. that would be appreciated. Not a Linux newbie, but I am getting back into it after ~1yr away from *nix. I'm trying to love LMDE but it just doesn't feel like home anymore :?
prower
Level 1
Level 1
 
Posts: 6
Joined: Sun Apr 29, 2012 10:03 pm

Linux Mint is funded by ads and donations.
 

Re: Software Manager doesn't open items in search or browse

Postby prower on Sun Jul 01, 2012 6:34 pm

Anybody? I'm happy to help you help me if you have suggestions or workarounds.
prower
Level 1
Level 1
 
Posts: 6
Joined: Sun Apr 29, 2012 10:03 pm

Re: Software Manager doesn't open items in search or browse

Postby zerozero on Sun Jul 01, 2012 6:57 pm

let's see, lmde 12 doesn't exist :wink: so, first things first:
Code: Select all
inxi -Sr

now (still with the terminal open) type (please)
Code: Select all
mintinstall
and give us back the output.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Software Manager doesn't open items in search or browse

Postby prower on Sun Jul 01, 2012 7:36 pm

LMDE 12 referred to the era I installed it :wink:

EDIT: I searched on 'avidemux' and selected the top result, which failed then 'avidemux-common' which succeeded.

Output below. Looks like broken packages, which is something I still haven't been able to resolve.
Code: Select all
****@****:~$ inxi -Sr
System:    Host **** Kernel 2.6.39-2-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import romeo
           deb-src http://packages.linuxmint.com/ debian main upstream import romeo #Added by software-properties
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           Active apt sources in file: /etc/apt/sources.list.d/bimsebasse-cinnamonextras.list
           deb http://ppa.launchpad.net/bimsebasse/cinnamonextras/ubuntu oneiric main
           deb-src http://ppa.launchpad.net/bimsebasse/cinnamonextras/ubuntu oneiric main
****@****:~$ mintinstall
/usr/lib/linuxmint/mintInstall/mintinstall.py:250: SyntaxWarning: import * only allowed at module level
  def get_status_description(self, transaction):
/usr/lib/linuxmint/mintInstall/mintinstall.py:258: SyntaxWarning: import * only allowed at module level
  def get_role_description(self, transaction):
add_categories took 25.338 ms
build_matched_packages took 0.286 ms
15644
add_packages took 1958.749 ms
add_reviews took 773.168 ms
/usr/lib/linuxmint/mintInstall/mintinstall.py:525: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  wTree.get_widget("main_window").show_all()
__init__ took 4233.122 ms
show_category took 120.435 ms
Overwriting reviews file in /home/****/.linuxmint/mintinstall/reviews.list
update_reviews took 380.684 ms
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 766, in show_selected
    self.show_package(self.selected_package)
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 38, in wrapper
    res = func(*arg)
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 1417, in show_package
    pkg.mark_install()
  File "/usr/lib/python2.7/dist-packages/apt/package.py", line 1278, in mark_install
    fixer.resolve(True)
SystemError: E:Unable to correct problems, you have held broken packages.
show_package took 451.200 ms
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 766, in show_selected
    self.show_package(self.selected_package)
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 38, in wrapper
    res = func(*arg)
  File "/usr/lib/linuxmint/mintInstall/mintinstall.py", line 1417, in show_package
    pkg.mark_install()
  File "/usr/lib/python2.7/dist-packages/apt/package.py", line 1278, in mark_install
    fixer.resolve(True)
SystemError: E:Unable to correct problems, you have held broken packages.
Killed
prower
Level 1
Level 1
 
Posts: 6
Joined: Sun Apr 29, 2012 10:03 pm

Re: Software Manager doesn't open items in search or browse

Postby zerozero on Sun Jul 01, 2012 8:02 pm

the issue is the sources.list: with UP3 the repos changed http://blog.linuxmint.com/?p=1836 (security and multimedia are now mirrored by the mint repos) but not in your setup; you kept updating (specially from multimedia) and now have a mismatch (and broken packages)

now it's not easy to fix this (sorry :oops: ) your best option (keeping the system as-is) is a full upgrade to testing;

but that has to be an assisted upgrade and evaluating a couple items in the way.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Software Manager doesn't open items in search or browse

Postby jjaythomas on Sun Jul 01, 2012 10:58 pm

LMDE 12 referred to the era I installed it :wink:


I would refer to it as UP3 (era)


testing spell-check on re-install (disregard man behind curtain) :mrgreen:
J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Software Manager doesn't open items in search or browse

Postby prower on Sun Jul 01, 2012 11:46 pm

zerozero wrote:now it's not easy to fix this (sorry :oops: ) your best option (keeping the system as-is) is a full upgrade to testing;


Thanks! I don't think I have the heart to do an upgrade yet, but at least now I know what the issue is. I can live with it for now.
prower
Level 1
Level 1
 
Posts: 6
Joined: Sun Apr 29, 2012 10:03 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests