[SOLVED] Auto login by changing from gdm3 to mdm in LMDE

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[SOLVED] Auto login by changing from gdm3 to mdm in LMDE

Postby Niks on Sat Jun 16, 2012 8:37 am

After finding out that user login menu is in fact broken and you can't automatically login in at boot I needed help.
XCHAT Thank you very much Danko8321 for talking me through the whole procedure and solving this issue.
I thought I would make a short list of the procedure and not having the instructions any more ( log to short :( ) I started to look for them ........oh dear :roll:

This is what worked for me on a PC running LMDE 32 one using 64 and a EEEPC in 32 all with update 4 installed.
My 64 bit has been "rock n rolling" from update 2 onwards :mrgreen:

So here is the "simple" way!

    Start PC and at grub OS selection ( the grey and white menu ) choose recovery
login as root
Type
Code: Select all
apt-get remove gdm3

after reading everything answer yes to all the questions
type
Code: Select all
apt-get remove aptitude

after reading everything answer yes to all questions
type
Code: Select all
apt-get install mdm

restart PC
You should have a nice pretty flower on your log on screen :D
login ( you can select which language or desktop you wish to use with the first two buttons on the bottom left of the screen).
Start software manager
Search for mdm
select mint themes
install
Close software manager
open a terminal
type
Code: Select all
sudo mdmsetup

Click on local tab and select Linux mint
If you wish your PC to auto login ( the whole reason I started this research )
then select
Security
Enable automatic log in and fill in the user name you want to log into.
Close

LOGOUT

You should now see the sparkling MDM login screen . :mrgreen:
Select the desktop you wish to use, it may ask you to confirm "for this session only or make default"
login in
The next time you boot up PC it should just go all the way through, so you can get coffee, come back and it should be done ( depending on the speed of the PC, coffee machine, person making it and the type of coffee. I recommend cappuccino :lol: ).

Disclaimer
Like I said this is simple and it worked for me on 3 PC's but please don't be angry if it's not your solution.At least all the basic commands are on one page and not buried in a pile of hieroglyphics,instructions on how to fry a chicken while reassembling a gear box or how paint a Bob Ross portrait of your mother in law!
Being a true GUI believer, the only simple way is being asked "do you wish to change to mdm" and you click the "YES" button ! Oh well I can dream. :wink:
User avatar
Niks
Level 3
Level 3
 
Posts: 164
Joined: Thu Feb 11, 2010 6:59 am
Location: Netherlands

Linux Mint is funded by ads and donations.
 

Re: [SOLVED] Auto login by changing from gdm3 to mdm in LMDE

Postby elmo on Thu Aug 09, 2012 2:19 am

Nice!
I would like to change to mdm and will soon give it a try.
But before I would like to understand, why I have to remove aptitude?! What's got that to do with gdm3/mdm?

Thanks!

Elmo
elmo
Level 1
Level 1
 
Posts: 1
Joined: Thu Aug 09, 2012 2:13 am

Re: [SOLVED] Auto login by changing from gdm3 to mdm in LMDE

Postby Niks on Sat Aug 18, 2012 5:44 pm

HI Elmo
I have no idea why..

Maybe you can hunt down Danko8321 and ask but if if works I question no more :D

Good luck with it :mrgreen:
User avatar
Niks
Level 3
Level 3
 
Posts: 164
Joined: Thu Feb 11, 2010 6:59 am
Location: Netherlands


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: abickerton and 5 guests