UP5 request: libfontconfig1 version >= 2.9.0

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP5 request: libfontconfig1 version >= 2.9.0

Postby TomRoche on Mon Jul 23, 2012 6:59 pm

Hear my plea, lords of LMDE:

For the third time recently, Your Humble Servant (a mere student of atmospheric modeling) has found himself needing libfontconfig1 version >= 2.9.0, this time for GNU Data Language. First I tried "straight" LMDE:

Code: Select all
me@it:~$ cat /etc/apt/sources.list
> deb http://packages.linuxmint.com/ debian main upstream import
> deb http://debian.linuxmint.com/latest testing main contrib non-free
> #deb http://security.debian.org/ testing/updates main contrib non-free
> # Per recommendation for Update Pack 3
> deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
> #deb http://www.debian-multimedia.org testing main non-free
> # Per recommendation for Update Pack 3
> deb http://debian.linuxmint.com/latest/multimedia testing main non-free
> deb http://mirrors.ibiblio.org/pub/mirrors/CRAN/bin/linux/debian squeeze-cran/
> # to get iceweasel==debian firefox more up-to-date than LMDE's: see
> # http://forum.linuxmint.com/viewtopic.php?f=190&t=84123
> deb http://mozilla.debian.net/ squeeze-backports iceweasel-release
> # for emacs 24 stable: see http://emacs.naquadah.org/
> deb http://emacs.naquadah.org/ stable/
> deb-src http://emacs.naquadah.org/ stable/
> # for wheezy/testing, used to install GDAL prereqs ~20 Jul 12, 3.2.21-3 kernel 22 Jul 2012
> deb http://ftp.debian.org/debian/ testing main contrib non-free
me@it:~$ sudo aptitude update ; sudo aptitude -s full-upgrade
...
> No packages will be installed, upgraded, or removed.
...
me@it:~$ sudo aptitude -s install gnudatalanguage
> No candidate version found for gnudatalanguage
> No candidate version found for gnudatalanguage
> No packages will be installed, upgraded, or removed.


So I tried wheezy:

Code: Select all
me@it:~$ sudo cp /etc/apt/sources.list /etc/apt/sources.list_20120723_1824
me@it:~$ sudo chmod a-w /etc/apt/sources.list_20120723_1824
me@it:~$ sudo emacs -nw -q /etc/apt/sources.list
me@it:~$ sudo diff -wB  /etc/apt/sources.list_20120723_1824 /etc/apt/sources.list
20c20
< #deb http://ftp.debian.org/debian/ testing main contrib non-free
---
> deb http://ftp.debian.org/debian/ testing main contrib non-free
me@it:~$ sudo aptitude update
...
> Current status: 1406 updates [+1406], 38825 new [+3226].
...
me@it:~$ sudo aptitude -s install gnudatalanguage
> The following NEW packages will be installed:
gnudatalanguage
libcsiro0{a}
libgrib-api-1.9.16{a}
libmagick++5{ab}
libmagickcore5{ab}
libplplot-c++10{a}
libplplot11{a}
libqhull5{a}
libqsastime0{a}
plplot11-driver-xwin{a}
pslib1{a}
> 0 packages upgraded, 11 newly installed, 0 to remove and 1406 not upgraded.
> Need to get 7,500 kB of archives. After unpacking 26.2 MB will be used.
> The following packages have unmet dependencies:
>   libmagickcore5: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
>                   Depends: liblzma5 (>= 5.1.1alpha+20120614) but 5.1.1alpha+20110809-3 is installed and it is kept back.
>   libmagick++5: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
>                 Depends: libmagickwand5 (>= 8:6.7.7.10) but it is not going to be installed.
me@it:~$ sudo aptitude -s install libmagickwand5
> The following NEW packages will be installed:
>   libmagickwand5{b}
> 0 packages upgraded, 1 newly installed, 0 to remove and 1406 not upgraded.
> Need to get 462 kB of archives. After unpacking 1,284 kB will be used.
> The following packages have unmet dependencies:
>   libmagickwand5: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
>                   Depends: libmagickcore5 (>= 8:6.7.7.10) but it is not going to be installed.


But libfontconfig1 is a Mighty Package with multitudes of Reverse Dependencies:

Code: Select all
me@it:~$ apt-cache showpkg libfontconfig1 | wc -l
> 1990
me@it:~$ apt-cache showpkg libfontconfig1 | head -n 28
> Package: libfontconfig1
> Versions:
> 2.9.0-6 (/var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-amd64_Packages)
>  Description Language: en
>                  File: /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_i18n_Translation-en
>                   MD5: 79e15bc25852b501452288a133d57a43
>  Description Language:
>                  File: /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-amd64_Packages
>                   MD5: 79e15bc25852b501452288a133d57a43

> 2.8.0-3.1 (/var/lib/apt/lists/debian.linuxmint.com_latest_dists_testing_main_binary-amd64_Packages)
>  Description Language: en
>                  File: /var/lib/apt/lists/debian.linuxmint.com_latest_dists_testing_main_i18n_Translation-en
>                   MD5: 79e15bc25852b501452288a133d57a43
>  Description Language:
>                  File: /var/lib/apt/lists/debian.linuxmint.com_latest_dists_testing_main_binary-amd64_Packages
>                   MD5: 79e15bc25852b501452288a133d57a43

> 2.8.0-2.1ubuntu3 (/var/lib/apt/lists/packages.linuxmint.com_dists_debian_upstream_binary-amd64_Packages) (/var/lib/dpkg/status)
>  Description Language: en
>                  File: /var/lib/apt/lists/debian.linuxmint.com_latest_dists_testing_main_i18n_Translation-en
>                   MD5: 79e15bc25852b501452288a133d57a43
>  Description Language:
>                  File: /var/lib/apt/lists/packages.linuxmint.com_dists_debian_upstream_binary-amd64_Packages
>                   MD5: 79e15bc25852b501452288a133d57a43


> Reverse Depends:


Thus Your Humble Servant beseeches Your Lordships to deliver unto us UP5 with libfontconfig1 (>= 2.9.0).
TomRoche
Level 3
Level 3
 
Posts: 177
Joined: Thu Jan 13, 2011 2:52 pm

Linux Mint is funded by ads and donations.
 

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby GeneC on Mon Jul 23, 2012 7:09 pm

Hi Tom

Don't know if it will make UP5, but just out of curiosity I checked my LMDE/SID partition and found I have it through normal updates tracking Debian SID repos.

Code: Select all
gene@zordon:~$ apt-cache policy  libfontconfig1
libfontconfig1:
  Installed: 2.9.0-6
  Candidate: 2.9.0-6
  Version table:
 *** 2.9.0-6 0
        700 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2.8.0-2.1ubuntu3 0
        700 http://mirror.csclub.uwaterloo.ca/linuxmint-packages/ debian/upstream amd64 Packages
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky XFCE (Debian Testing)
Sparky Gnome 3.14 (SID)
EvolveOS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1565
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby Sonsum on Mon Jul 23, 2012 7:20 pm

I also have it tracking Testing. It looks like the same version that's in Sid.
Sonsum
Level 3
Level 3
 
Posts: 111
Joined: Fri Jun 24, 2011 9:03 pm

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby TomRoche on Mon Jul 23, 2012 8:24 pm

GeneC wrote:Don't know if [libfontconfig1 version >= 2.9.0] will make UP5, but just out of curiosity I checked my LMDE/SID partition and found I have it through normal updates tracking Debian SID repos.


Sonsum wrote:I also have it tracking Testing. It looks like the same version that's in Sid.


Correct! and if you read post# 1 above, you'll see that I have already noted that--look at the 3rd code block. Unfortunately, the problem is not "how to get libfontconfig1 version >= 2.9.0?" The problems are

  1. "OMG: lots of packages depend on libfontconfig1!"
  2. "OMG: installed packages that depend on libfontconfig1 include cinnamon, emacs, gnome-shell, mate-*, nautilus, and xulrunner!"

To clarify: if I wanted to just bring in libfontconfig1 version >= 2.9.0 from testing, I could do that. But I'd also hafta upgrade code that is very important to my daily productive life--emacs, firefox/iceweasel, all my shells (or whatever is the collective term for cinnamon, GNOME shell, and MATE).

If I was ready to update those myself, I'd quit running LMDE, and just run debian testing. But ISTM (please correct me if/where wrong), the whole point of LMDE is to have Folks Who Know What They Are Doing shield me from the risks and extra work of running debian testing (or, god forbid, Sid) on a daily basis. Am I missing something?
TomRoche
Level 3
Level 3
 
Posts: 177
Joined: Thu Jan 13, 2011 2:52 pm

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby zerozero on Mon Jul 23, 2012 9:43 pm

TomRoche wrote:[...]the whole point of LMDE is to have Folks Who Know What They Are Doing shield me from the risks and extra work of running debian testing (or, god forbid, Sid) on a daily basis.[...]

:lol: :wink:

regarding libfontconfig1 fwiw this what i get:
Code: Select all
zerozero:~$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import backport romeo
           deb-src http://packages.linuxmint.com/ debian main upstream import backport romeo #Added by software-properties
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
           deb-src http://debian.linuxmint.com/latest testing main contrib non-free
           deb-src http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb-src http://debian.linuxmint.com/latest/multimedia testing main non-free
           deb http://ftp.fr.debian.org/debian/ testing main contrib non-free

Code: Select all
zerozero:~$ sudo apt-get -s install libfontconfig1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libfontconfig1 is already the newest version.
The following packages were automatically installed and are no longer required:
  libv8-3.6.6.14 libglew1.6
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1294 not upgraded.

Code: Select all
zerozero:~$ apt policy libfontconfig1
libfontconfig1:
  Installed: 2.8.0-2.1ubuntu3
  Candidate: 2.8.0-2.1ubuntu3
  Version table:
     2.9.0-6 0
        500 http://ftp.fr.debian.org/debian/ testing/main amd64 Packages
     2.8.0-3.1 0
        500 http://debian.linuxmint.com/latest/ testing/main amd64 Packages
 *** 2.8.0-2.1ubuntu3 0
        700 http://packages.linuxmint.com/ debian/upstream amd64 Packages
        100 /var/lib/dpkg/status

Code: Select all
zerozero:~$ sudo apt-get -s install libfontconfig1=2.9.0-6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libfontconfig1 : Depends: fontconfig-config (= 2.9.0-6) but 2.8.0-2.1ubuntu3 is to be installed
E: Broken packages

Code: Select all
zerozero:~$ sudo apt-get -s install libfontconfig1=2.9.0-6 fontconfig-config=2.9.0-6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcanberra-gtk-common-dev gir1.2-gnomedesktop-3.0 libxrandr-dev
  x11proto-resource-dev libexpat1-dev libxdamage-dev libxfixes-dev
  libv8-3.6.6.14 libglew1.6 x11proto-xinerama-dev x11proto-render-dev
  libxi-dev libpixman-1-dev libnss3-dev x11proto-randr-dev libxinerama-dev
  gir1.2-ebook-1.2 libatk1.0-dev libcanberra-dev libgdk-pixbuf2.0-dev
  x11proto-fixes-dev libcairo-script-interpreter2 libdrm-dev
  x11proto-damage-dev libxcb-shm0-dev libebook1.2-dev libfreetype6-dev
  libcamel1.2-dev gir1.2-rsvg-2.0 libxcomposite-dev libsqlite3-dev
  libxcb-render0-dev libxrender-dev x11proto-composite-dev libkms1
  libxres-dev libxcursor-dev libpng12-dev libebackend-1.2-2
  libedata-book-1.2-13 libedata-cal-1.2-15
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  eog evolution-data-server-common gir1.2-cogl-1.0 gir1.2-coglpango-1.0
  gir1.2-folks-0.6 gir1.2-gdkpixbuf-2.0 gir1.2-gnomebluetooth-1.0
  gir1.2-gnomedesktop-3.0 gir1.2-gtk-3.0 gir1.2-pango-1.0 gir1.2-rsvg-2.0
  gir1.2-soup-2.4 glib-networking glib-networking-common
  glib-networking-services gnome-bluetooth gnome-desktop-data
  gnome-desktop3-data gnome-themes-standard libcamel-1.2-33 libcanberra-dev
  libcanberra-gtk3-0 libcanberra0 libcogl9 libebackend-1.2-2 libebook-1.2-13
  libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15
  libedataserver-1.2-16 libedataserverui-3.0-1 libfolks-dev libfolks25
  libgail-3-0 libgdata13 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgdk-pixbuf2.0-dev libglib2.0-0 libglib2.0-bin libglib2.0-dev
  libgnome-bluetooth10 libgnome-desktop-3-2 libgnutls26 libgtk-3-0
  libgtk-3-bin libgtk-3-common libical-dev libical0
  libjavascriptcoregtk-3.0-0 libpango1.0-0 libpcre3 libpcre3-dev libpcrecpp0
  librsvg2-2 librsvg2-common libsoup-gnome2.4-1 libsoup2.4-1 libsoup2.4-dev
  libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libx11-6 libx11-dev libxft2
Suggested packages:
  libcanberra-pulse libglib2.0-doc ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp librsvg2-bin
  libsoup2.4-doc
Recommended packages:
  libcanberra-gtk3-module
The following packages will be REMOVED:
  evolution-data-server libcairo2-dev libcanberra-gtk3-dev
  libclutter-1.0-dev libcogl-dev libcogl-pango-dev libedataserverui-3.0-dev
  libfolks-eds25 libfontconfig1-dev libgnome-bluetooth-dev
  libgnome-desktop-3-dev libgtk-3-dev libgtk2.0-dev libmuffin-dev
  libpango1.0-dev librsvg2-dev libwnck-dev libxft-dev
The following NEW packages will be installed:
  libcamel-1.2-33 libcogl9 libebackend-1.2-2 libebook-1.2-13 libecal-1.2-11
  libedata-book-1.2-13 libedata-cal-1.2-15 libedataserver-1.2-16
  libgnome-bluetooth10 libpcre3-dev libpcrecpp0
The following packages will be upgraded:
  eog evolution-data-server-common fontconfig-config gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-folks-0.6 gir1.2-gdkpixbuf-2.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gtk-3.0
  gir1.2-pango-1.0 gir1.2-rsvg-2.0 gir1.2-soup-2.4 glib-networking
  glib-networking-common glib-networking-services gnome-bluetooth
  gnome-desktop-data gnome-desktop3-data gnome-themes-standard
  libcanberra-dev libcanberra-gtk3-0 libcanberra0 libedataserverui-3.0-1
  libfolks-dev libfolks25 libfontconfig1 libgail-3-0 libgdata13
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgdk-pixbuf2.0-dev
  libglib2.0-0 libglib2.0-bin libglib2.0-dev libgnome-desktop-3-2
  libgnutls26 libgtk-3-0 libgtk-3-bin libgtk-3-common libical-dev libical0
  libjavascriptcoregtk-3.0-0 libpango1.0-0 libpcre3 librsvg2-2
  librsvg2-common libsoup-gnome2.4-1 libsoup2.4-1 libsoup2.4-dev
  libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libx11-6 libx11-dev libxft2
57 upgraded, 11 newly installed, 18 to remove and 1226 not upgraded.
Remv libfolks-eds25 [0.6.6-1]
Remv evolution-data-server [3.2.2-1]
Remv libwnck-dev [2.30.7-1]
Remv libcanberra-gtk3-dev [0.28-3]
Remv libgnome-desktop-3-dev [3.2.1-3]
Remv libgnome-bluetooth-dev [3.2.2-1]
Remv libedataserverui-3.0-dev [3.2.2-1]
Remv libmuffin-dev [1.0.2-lmde1]
Remv libgtk-3-dev [3.2.3-1]
Remv libgtk2.0-dev [2.24.10-1]
Remv libclutter-1.0-dev [1.8.4-1]
Remv libcogl-pango-dev [1.8.2-1]
Remv libpango1.0-dev [1.29.4-3]
Remv librsvg2-dev [2.34.2-3]
Remv libcairo2-dev [1.10.2-2ubuntu2]
Remv libcogl-dev [1.8.2-1]
Remv libxft-dev [2.2.0-3]
Remv libfontconfig1-dev [2.8.0-2.1ubuntu3]
Inst libgnutls26 [2.12.16-1] (2.12.20-1 Debian:testing [amd64])
Inst libpcre3 [8.12-4] (1:8.30-5 Debian:testing [amd64])
Inst libfontconfig1 [2.8.0-2.1ubuntu3] (2.9.0-6 Debian:testing [amd64]) []
Inst fontconfig-config [2.8.0-2.1ubuntu3] (2.9.0-6 Debian:testing [all])
Inst libx11-dev [2:1.4.4-4] (2:1.5.0-1 Debian:testing [amd64]) []
Inst libx11-6 [2:1.4.4-4] (2:1.5.0-1 Debian:testing [amd64])
Inst libxft2 [2.2.0-3] (2.3.1-1 Debian:testing [amd64])
Inst libpango1.0-0 [1.29.4-3] (1.30.0-1 Debian:testing [amd64]) []
Inst librsvg2-common [2.34.2-3] (2.36.1-1 Debian:testing [amd64]) []
Inst libgdk-pixbuf2.0-dev [2.24.1-1] (2.26.1-1 Debian:testing [amd64]) []
Inst libgdk-pixbuf2.0-common [2.24.1-1] (2.26.1-1 Debian:testing [all]) [libgdk-pixbuf2.0-0:amd64 ]
Inst libgdk-pixbuf2.0-0 [2.24.1-1] (2.26.1-1 Debian:testing [amd64]) []
Inst librsvg2-2 [2.34.2-3] (2.36.1-1 Debian:testing [amd64]) []
Inst libvte-2.90-9 [1:0.30.1-3] (1:0.32.2-1 Debian:testing [amd64]) []
Inst libwebkitgtk-3.0-0 [1.6.3-1] (1.8.1-2 Debian:testing [amd64]) []
Inst libgtk-3-bin [3.2.3-1] (3.4.2-2 Debian:testing [amd64]) []
Inst libgtk-3-common [3.2.3-1] (3.4.2-2 Debian:testing [all]) [libgtk-3-0:amd64 ]
Inst libgail-3-0 [3.2.3-1] (3.4.2-2 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst eog [3.2.2-2+b1] (3.4.2-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst libglib2.0-dev [2.30.2-6] (2.32.3-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst libglib2.0-bin [2.30.2-6] (2.32.3-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst glib-networking-services [2.30.2-1] (2.32.3-1 Debian:testing [amd64]) [libgtk-3-0:amd64 glib-networking:amd64 ]
Inst glib-networking-common [2.30.2-1] (2.32.3-1 Debian:testing [all]) [libgtk-3-0:amd64 glib-networking:amd64 ]
Inst glib-networking [2.30.2-1] (2.32.3-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst libglib2.0-0 [2.30.2-6] (2.32.3-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst gnome-themes-standard [3.2.1-2] (3.4.2-1 Debian:testing [amd64]) [libgtk-3-0:amd64 ]
Inst libgtk-3-0 [3.2.3-1] (3.4.2-2 Debian:testing [amd64]) []
Inst libvte-2.90-common [1:0.30.1-3] (1:0.32.2-1 Debian:testing [all]) []
Inst libjavascriptcoregtk-3.0-0 [1.6.3-1] (1.8.1-2 Debian:testing [amd64]) []
Inst libsoup-gnome2.4-1 [2.34.3-1] (2.38.1-2 Debian:testing [amd64]) []
Inst libsoup2.4-dev [2.34.3-1] (2.38.1-2 Debian:testing [amd64]) []
Inst gir1.2-soup-2.4 [2.34.3-1] (2.38.1-2 Debian:testing [amd64]) []
Inst libpcrecpp0 (1:8.30-5 Debian:testing [amd64]) []
Inst libpcre3-dev (1:8.30-5 Debian:testing [amd64]) []
Inst libsoup2.4-1 [2.34.3-1] (2.38.1-2 Debian:testing [amd64]) []
Inst libwebkitgtk-3.0-common [1.6.3-1] (1.8.1-2 Debian:testing [all]) []
Inst gnome-desktop-data [2.32.1-1] (2.32.1-2 Debian:testing [all]) []
Inst libgnome-desktop-3-2 [3.2.1-3] (3.4.2-1 Debian:testing [amd64]) []
Inst gnome-desktop3-data [3.2.1-3] (3.4.2-1 Debian:testing [all]) []
Inst gir1.2-gdkpixbuf-2.0 [2.24.1-1] (2.26.1-1 Debian:testing [amd64])
Inst gir1.2-pango-1.0 [1.29.4-3] (1.30.0-1 Debian:testing [amd64])
Inst gir1.2-gtk-3.0 [3.2.3-1] (3.4.2-2 Debian:testing [amd64])
Inst libgnome-bluetooth10 (3.4.2-1 Debian:testing [amd64])
Inst gnome-bluetooth [3.2.2-1] (3.4.2-1 Debian:testing [amd64]) []
Inst gir1.2-gnomebluetooth-1.0 [3.2.2-1] (3.4.2-1 Debian:testing [amd64])
Inst libcanberra-dev [0.28-3] (0.28-4 Debian:testing [amd64]) []
Inst libcanberra0 [0.28-3] (0.28-4 Debian:testing [amd64])
Inst libcanberra-gtk3-0 [0.28-3] (0.28-4 Debian:testing [amd64])
Inst libcogl9 (1.10.2-6 Debian:testing [amd64])
Inst evolution-data-server-common [3.2.2-1] (3.4.3-1 Debian:testing [all])
Inst gir1.2-coglpango-1.0 [1.8.2-1] (1.10.2-6 Debian:testing [amd64]) []
Inst gir1.2-cogl-1.0 [1.8.2-1] (1.10.2-6 Debian:testing [amd64])
Inst libfolks-dev [0.6.6-1] (0.6.9-1+b1 Debian:testing [amd64]) []
Inst libfolks25 [0.6.6-1] (0.6.9-1+b1 Debian:testing [amd64]) []
Inst gir1.2-folks-0.6 [0.6.6-1] (0.6.9-1+b1 Debian:testing [amd64])
Inst gir1.2-gnomedesktop-3.0 [3.2.1-3] (3.4.2-1 Debian:testing [amd64])
Inst gir1.2-rsvg-2.0 [2.34.2-3] (2.36.1-1 Debian:testing [amd64])
Inst libcamel-1.2-33 (3.4.3-1 Debian:testing [amd64])
Inst libedataserver-1.2-16 (3.4.3-1 Debian:testing [amd64])
Inst libebackend-1.2-2 (3.4.3-1 Debian:testing [amd64])
Inst libebook-1.2-13 (3.4.3-1 Debian:testing [amd64])
Inst libical-dev [0.44-3] (0.48-2 Debian:testing [amd64]) []
Inst libical0 [0.44-3] (0.48-2 Debian:testing [amd64])
Inst libecal-1.2-11 (3.4.3-1 Debian:testing [amd64])
Inst libedata-book-1.2-13 (3.4.3-1 Debian:testing [amd64])
Inst libedata-cal-1.2-15 (3.4.3-1 Debian:testing [amd64])
Inst libedataserverui-3.0-1 [3.2.2-1] (3.4.3-1 Debian:testing [amd64])
Inst libgdata13 [0.10.2-1] (0.12.0-1 Debian:testing [amd64])
Conf libgnutls26 (2.12.20-1 Debian:testing [amd64])
Conf libpcre3 (1:8.30-5 Debian:testing [amd64])
Conf fontconfig-config (2.9.0-6 Debian:testing [all])
Conf libfontconfig1 (2.9.0-6 Debian:testing [amd64])
Conf libx11-6 (2:1.5.0-1 Debian:testing [amd64])
Conf libx11-dev (2:1.5.0-1 Debian:testing [amd64])
Conf libxft2 (2.3.1-1 Debian:testing [amd64])
Conf libglib2.0-0 (2.32.3-1 Debian:testing [amd64])
Conf libpango1.0-0 (1.30.0-1 Debian:testing [amd64])
Conf libgdk-pixbuf2.0-common (2.26.1-1 Debian:testing [all])
Conf libgdk-pixbuf2.0-0 (2.26.1-1 Debian:testing [amd64])
Conf librsvg2-2 (2.36.1-1 Debian:testing [amd64])
Conf librsvg2-common (2.36.1-1 Debian:testing [amd64])
Conf gir1.2-gdkpixbuf-2.0 (2.26.1-1 Debian:testing [amd64])
Conf libglib2.0-bin (2.32.3-1 Debian:testing [amd64])
Conf libpcrecpp0 (1:8.30-5 Debian:testing [amd64])
Conf libpcre3-dev (1:8.30-5 Debian:testing [amd64])
Conf libglib2.0-dev (2.32.3-1 Debian:testing [amd64])
Conf libgdk-pixbuf2.0-dev (2.26.1-1 Debian:testing [amd64])
Conf libgtk-3-common (3.4.2-2 Debian:testing [all])
Conf libgtk-3-0 (3.4.2-2 Debian:testing [amd64])
Conf libvte-2.90-common (1:0.32.2-1 Debian:testing [all])
Conf libvte-2.90-9 (1:0.32.2-1 Debian:testing [amd64])
Conf libjavascriptcoregtk-3.0-0 (1.8.1-2 Debian:testing [amd64])
Conf libgail-3-0 (3.4.2-2 Debian:testing [amd64])
Conf glib-networking-common (2.32.3-1 Debian:testing [all])
Conf glib-networking-services (2.32.3-1 Debian:testing [amd64])
Conf glib-networking (2.32.3-1 Debian:testing [amd64])
Conf libsoup2.4-1 (2.38.1-2 Debian:testing [amd64])
Conf libwebkitgtk-3.0-common (1.8.1-2 Debian:testing [all])
Conf libwebkitgtk-3.0-0 (1.8.1-2 Debian:testing [amd64])
Conf libgtk-3-bin (3.4.2-2 Debian:testing [amd64])
Conf gnome-desktop3-data (3.4.2-1 Debian:testing [all])
Conf libgnome-desktop-3-2 (3.4.2-1 Debian:testing [amd64])
Conf gir1.2-pango-1.0 (1.30.0-1 Debian:testing [amd64])
Conf gir1.2-gtk-3.0 (3.4.2-2 Debian:testing [amd64])
Conf eog (3.4.2-1 Debian:testing [amd64])
Conf gnome-themes-standard (3.4.2-1 Debian:testing [amd64])
Conf libsoup-gnome2.4-1 (2.38.1-2 Debian:testing [amd64])
Conf gir1.2-soup-2.4 (2.38.1-2 Debian:testing [amd64])
Conf libsoup2.4-dev (2.38.1-2 Debian:testing [amd64])
Conf gnome-desktop-data (2.32.1-2 Debian:testing [all])
Conf libgnome-bluetooth10 (3.4.2-1 Debian:testing [amd64])
Conf gir1.2-gnomebluetooth-1.0 (3.4.2-1 Debian:testing [amd64])
Conf gnome-bluetooth (3.4.2-1 Debian:testing [amd64])
Conf libcanberra0 (0.28-4 Debian:testing [amd64])
Conf libcanberra-dev (0.28-4 Debian:testing [amd64])
Conf libcanberra-gtk3-0 (0.28-4 Debian:testing [amd64])
Conf libcogl9 (1.10.2-6 Debian:testing [amd64])
Conf evolution-data-server-common (3.4.3-1 Debian:testing [all])
Conf gir1.2-cogl-1.0 (1.10.2-6 Debian:testing [amd64])
Conf gir1.2-coglpango-1.0 (1.10.2-6 Debian:testing [amd64])
Conf libfolks25 (0.6.9-1+b1 Debian:testing [amd64])
Conf gir1.2-folks-0.6 (0.6.9-1+b1 Debian:testing [amd64])
Conf libfolks-dev (0.6.9-1+b1 Debian:testing [amd64])
Conf gir1.2-gnomedesktop-3.0 (3.4.2-1 Debian:testing [amd64])
Conf gir1.2-rsvg-2.0 (2.36.1-1 Debian:testing [amd64])
Conf libcamel-1.2-33 (3.4.3-1 Debian:testing [amd64])
Conf libedataserver-1.2-16 (3.4.3-1 Debian:testing [amd64])
Conf libebackend-1.2-2 (3.4.3-1 Debian:testing [amd64])
Conf libebook-1.2-13 (3.4.3-1 Debian:testing [amd64])
Conf libical0 (0.48-2 Debian:testing [amd64])
Conf libical-dev (0.48-2 Debian:testing [amd64])
Conf libecal-1.2-11 (3.4.3-1 Debian:testing [amd64])
Conf libedata-book-1.2-13 (3.4.3-1 Debian:testing [amd64])
Conf libedata-cal-1.2-15 (3.4.3-1 Debian:testing [amd64])
Conf libedataserverui-3.0-1 (3.4.3-1 Debian:testing [amd64])
Conf libgdata13 (0.12.0-1 Debian:testing [amd64])

just a couple notes on those outputs:
- i wouldn't bother to much about the removals, eventually they won't be replicated in any other setup, they are all -dev pkgs (apart from evolution-data-server);
- in the newly installed and upgraded sessions yes, we have problems :mrgreen:
  • the *colg pkgs break cinnamon
  • they will break gnome-shell as well because it won't be updated to a compatible version
  • i see also worrying updates in *networking and gtk3, so i would check carefully NM and themes
tl;dr: i believe it's not doable per se, not as easy as upgrade a kernel :roll:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby Monsta on Tue Jul 24, 2012 3:32 am

BTW... correct me if I'm wrong, but I believe libfontconfig1 is one of the four packages LMDE takes from Ubuntu to make fonts look nicer than they are in Debian (the other three are fontconfig, fontconfig-config and libcairo2; I didn't count -dev, -dbg, or -doc packages).
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby squeezy on Tue Jul 24, 2012 9:25 am

Monsta wrote:BTW... correct me if I'm wrong, but I believe libfontconfig1 is one of the four packages LMDE takes from Ubuntu to make fonts look nicer than they are in Debian (the other three are fontconfig, fontconfig-config and libcairo2; I didn't count -dev, -dbg, or -doc packages).


You are correct. I have an install of ubuntu quantal, their next release that's in development. I'll check the version of this file when I get to that computer later this morning.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby squeezy on Tue Jul 24, 2012 11:21 am

OK, fresh update of my Ubuntu 12.10 install and libfontconfig1 shows version 2.8.0-3ubuntu9. If Mint takes this file as they normally do for font rendering in LMDE it looks like you're out of luck.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby Monsta on Tue Jul 24, 2012 12:35 pm

I usually check such info via their package search - though I don't know how often they update it. :)
Okay, so Ubuntu is currently behind Debian Testing on this package. They may upgrade it before October comes, but I doubt Clem will wait till autumn... :)
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP5 request: libfontconfig1 version >= 2.9.0

Postby Monsta on Tue Aug 07, 2012 10:48 pm

Just checked it again and found these packages upgraded to version 2.10.1-0ubuntu2 in Quantal... wow :)
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests