LMDE Mate issues after update

Post your update and upgrade related errors here
Forum rules
Before you post please read this

LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 9:25 am

I see a couple of threads with people having issues after this latest round of updates, but I didn't see anyone having the issue I am.

I just updated my LMDE Mate system, everything reported to update/install successfully. After I updated I noticed that my system had been up and running for 130 days, so I figured why not reboot it. Now I get the login screen, but after I enter my username and password I just get a black screen with the mouse cursor.

I did ctrl-alt-f1 , and ran apt-get to see if there were any more updates and there were not.

Anyone have any ideas on how to get Mate running correctly again?
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Linux Mint is funded by ads and donations.
 

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 9:33 am

Also, just to put out more info of my issue...

If I tell it to use cinnamon when I login, it works fine, it only seems to have affected Mate.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby Vargas on Mon Sep 17, 2012 9:37 am

I have the same problem. Mate has dissapeared from the login menu.
Vargas
Level 1
Level 1
 
Posts: 23
Joined: Tue Feb 12, 2008 9:12 am

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 9:42 am

Actually now that you mention it, Mate isn't showing as an available option when logging in. I didn't catch that before.

So hopefully it is just a bug in the update and they will release a fix soon. At least Cinnamon still works in the mean time.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby rbnielsen on Mon Sep 17, 2012 10:27 am

Hey

I'm experiencing the same thing. Updated Mint (3 times actually, this seemed weird) and everything seemed to go well. Then I wanted to open a terminal using a shortcut, but that gave back an error, saying mate-terminal didn't exist. Alt+F2 run command didn't work either, so I figured I'd reboot my system. Shutdown command in the laucher did nothing, and Ctrl+Alt+Del did nothing either. I rebooted by going to Ctrl+Alt+F1, and typing 'reboot', and after that when I log in to Mate, I get a black screen and a cursor. Cinnamon works fine, but after logging in to Cinnamon Mate is gone.

I noticed afterwards in 'sudo apt-get upgrade' that a lot of mate-* stuff was being held back.

Also I just tried upgrade again just now, and a whole lot of stuff is popping up. About 914 packages will be upgraded. I haven't upgraded it yet, as to I'm not sure what will happen.

Anyone else, experiencing this?
rbnielsen
Level 1
Level 1
 
Posts: 8
Joined: Mon Sep 17, 2012 10:19 am
Location: Aalborg, Denmark

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 10:39 am

Yeah I just got a lot more updates that were available, they are downloading and installing now. We'll see if it fixes the issue with Mate.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby theophrastus on Mon Sep 17, 2012 11:11 am

If i'm happily on mint Xfce do i even want these substantial mate libraries? that is, isn't "mate" ((development folks: please pick names that aren't common nouns)) yet another desktop ('environment')? thankee.
theophrastus
Level 1
Level 1
 
Posts: 17
Joined: Sat Jul 02, 2011 7:17 pm

Re: LMDE Mate issues after update

Postby naughty_bit on Mon Sep 17, 2012 11:49 am

Have you installed meta mate and meta cinnamon?
naughty_bit
Level 1
Level 1
 
Posts: 44
Joined: Fri Sep 07, 2012 6:33 am

Re: LMDE Mate issues after update

Postby theophrastus on Mon Sep 17, 2012 12:09 pm

if this is directed at me:
naughty_bit wrote:Have you installed meta mate and meta cinnamon?
(who was moaning about a sudden download of libmate stuff (and which reminds me of a sudden download of a bunch of "mono" libraries)) then no, i have no cinnamon nor meta-cinnamon installed. i've no idea what dependency triggered a sudden download of mate matters.
theophrastus
Level 1
Level 1
 
Posts: 17
Joined: Sat Jul 02, 2011 7:17 pm

Re: LMDE Mate issues after update

Postby naughty_bit on Mon Sep 17, 2012 12:18 pm

theophrastus wrote:if this is directed at me:


Whoops, skimmed the rest of the posts and actually skipped yours, I was asking OP.
naughty_bit
Level 1
Level 1
 
Posts: 44
Joined: Fri Sep 07, 2012 6:33 am

Re: LMDE Mate issues after update

Postby rbnielsen on Mon Sep 17, 2012 1:27 pm

HiTechRedneck82 wrote:Yeah I just got a lot more updates that were available, they are downloading and installing now. We'll see if it fixes the issue with Mate.


Any news? How did it go?
rbnielsen
Level 1
Level 1
 
Posts: 8
Joined: Mon Sep 17, 2012 10:19 am
Location: Aalborg, Denmark

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 2:57 pm

It took FOREVER to download the updates. It is just now actually installing them. I guess the servers were busy. I'll post an update as soon as everything is installed.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 3:23 pm

Well.... the X server just crashed and won't start back up. Judging by the amount of hard drive activity I think it is still trying to install the updates. I guess I'll let it sit for awhile and see if the hard drive settles down. Then I'll reboot and see what happens.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby HiTechRedneck82 on Mon Sep 17, 2012 3:51 pm

Ok, so all hard drive activity stopped. So I rebooted the system, it failed to start X on the reboot. I pressed ctrl-alt-f1 and logged in as root. I ran "dpkg --configure -a" and found that it continued on with the install of the updates. At some point tried to start the X session, I tried to log in only to find that Mate still didn't work. I again pressed ctrl-alt-f1 which took me back to the session that was still installing and configuring updates. Once it finished I ran "apt-get upgrade" and "apt-get update" to make sure there were no more updates then rebooted.

After the reboot X started fine, but Mate was still not available in the list of session options. Cinnamon is still working fine.
~~~~~~ Excuses are the only thing that get in the way of solutions ~~~~~~

http://www.jrmarshall.com -~-~-~-~- http://www.hitechredneck.us
User avatar
HiTechRedneck82
Level 1
Level 1
 
Posts: 27
Joined: Thu Jun 21, 2012 11:46 am
Location: Southern Maryland

Re: LMDE Mate issues after update

Postby rbnielsen on Mon Sep 17, 2012 4:04 pm

Hm, odd.. I think it might have something to do with UP5, with some updates being released to early. Updates depending on others that aren't updated. And thus b0rking it.. I dunno.. :/
rbnielsen
Level 1
Level 1
 
Posts: 8
Joined: Mon Sep 17, 2012 10:19 am
Location: Aalborg, Denmark

Re: LMDE Mate issues after update

Postby rbnielsen on Mon Sep 17, 2012 6:47 pm

Alrighty, I got my MATE back!

I installed all 1300-something updates (I suppose this is UP5?), successfully. I had no errors, so this was just good. However, after install I still didn't have MATE. So I went to Synaptic and installed mate-desktop-environment (along with its dependencies) as per instructions in http://wiki.mate-desktop.org/download, and now MATE shows up as one of the available desktop environment.
rbnielsen
Level 1
Level 1
 
Posts: 8
Joined: Mon Sep 17, 2012 10:19 am
Location: Aalborg, Denmark

Re: LMDE Mate issues after update

Postby zerozero on Mon Sep 17, 2012 7:39 pm

1- most of the issues here, i believe, are from trying to install incomplete updates: UP5 was just released, the servers are under heavy load, if you notice that it's unstable to finish the upgrade please don't do it, wait a couple days, we waited several months for this UP so a few more days to preserve your systems is more than fair :)

2- the update method: why not use mintupdate? you have there access to a lot of info that eventually is relevant to you; if you want/desire to use the cli please update with dist-upgrade otherwise you won't get UP5 and might get a broken system
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE Mate issues after update

Postby melbo on Mon Sep 17, 2012 8:09 pm

Make sure you follow the post upgrade instructions to get MATE or Cinnamon working:

Update Pack 5

2012.09.17
Questions asked during the upgrade

Always choose "keep file" (as opposed to "install new version").
When asked where to set up Grub, make sure to choose your current grub location (for most people that's /dev/sda, not /dev/sda1 or /dev/sda2)
New metapackages

If you're running MATE, install mint-meta-debian-mate after the upgrade:
apt install mint-meta-debian-mate

If you're running Cinnamon, install mint-meta-debian-cinnamon after the upgrade:
apt install mint-meta-debian-cinnamon

If you're running Xfce, install mint-meta-debian-xfce after the upgrade:
apt install mint-meta-debian-xfce

Maya backgrounds
If you want to add the Linux Mint 14 backgrounds, install the package mint-backgrounds-maya-extra
apt install mint-backgrounds-maya-extra

Cinnamon theme and background
Make sure you install mint-meta-debian-cinnamon after the upgrade to properly set the default theme for Cinnamon
If your background is black, simply right-click on the desktop and set the background again.
melbo
Level 2
Level 2
 
Posts: 67
Joined: Fri Jan 04, 2008 11:57 pm
Location: WA, USA

Re: LMDE Mate issues after update

Postby rbnielsen on Tue Sep 18, 2012 2:11 am

zerozero wrote:1- most of the issues here, i believe, are from trying to install incomplete updates: UP5 was just released, the servers are under heavy load, if you notice that it's unstable to finish the upgrade please don't do it, wait a couple days, we waited several months for this UP so a few more days to preserve your systems is more than fair :)

2- the update method: why not use mintupdate? you have there access to a lot of info that eventually is relevant to you; if you want/desire to use the cli please update with dist-upgrade otherwise you won't get UP5 and might get a broken system


I must've hit a low spot. It took me 15 minutes to download, so I didn't feel much. :) I'm guessing "mintupdate" is the Update Manager, which is what I used.


melbo wrote:Make sure you follow the post upgrade instructions to get MATE or Cinnamon working:

Update Pack 5

2012.09.17
Questions asked during the upgrade

Always choose "keep file" (as opposed to "install new version").
When asked where to set up Grub, make sure to choose your current grub location (for most people that's /dev/sda, not /dev/sda1 or /dev/sda2)
New metapackages

If you're running MATE, install mint-meta-debian-mate after the upgrade:
apt install mint-meta-debian-mate

[...]


The updates seemed to do nothing other than change som documentation errors, so I just installed the newer versions. Nothing has happened yet though. I also installed mate-desktop-environment (as according to http://mate-desktop.org) is there a difference in this and mint-meta-debian-mate?
rbnielsen
Level 1
Level 1
 
Posts: 8
Joined: Mon Sep 17, 2012 10:19 am
Location: Aalborg, Denmark

Re: LMDE Mate issues after update

Postby zerozero on Tue Sep 18, 2012 5:35 am

rbnielsen wrote:I must've hit a low spot. It took me 15 minutes to download, so I didn't feel much. :) I'm guessing "mintupdate" is the Update Manager, which is what I used.

yes, but here
rbnielsen wrote:Hm, odd.. I think it might have something to do with UP5, with some updates being released to early. Updates depending on others that aren't updated. And thus b0rking it.. I dunno.. :/
it looks like you couldn't download all the package information due to server overload, UP5 is a whole and doesn't have missing dep unless you couldn't fetch all the packages from the server.


rbnielsen wrote:The updates seemed to do nothing other than change som documentation errors, so I just installed the newer versions. Nothing has happened yet though. I also installed mate-desktop-environment (as according to http://mate-desktop.org) is there a difference in this and mint-meta-debian-mate?

one is mate's metapackage and the other is mint's mate metapackage.
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests