Xfce + Update Pack 5: GDM3 wants unnecessary packages

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby ormu on Wed Sep 19, 2012 4:40 pm

I just installed the updates of UP5. Everything else went fine (ok, the window/scrollbar/button appearance settings were reset to ugly defaults after update but that was easy to fix) but Gnome Display Manager (GDM3) wants to install Nautilus and lots of other extra stuff which I don't want. These extra packages are not even listed in the dependency list of GDM3. The repositories should be OK - I installed the repository update before other updates.
ormu
Level 1
Level 1
 
Posts: 24
Joined: Mon Dec 19, 2011 3:42 pm

Linux Mint is funded by ads and donations.
 

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby rolandpish on Thu Sep 20, 2012 2:26 pm

I'm having the same problem in my LMDE+Xfce

I still haven't upgraded because it wants to install lots of gnome extra stuff that I don't think I need (i.e. gnome-shell).

Is there a workaround for this?

Thanks!
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby GeneBenson on Thu Sep 20, 2012 5:14 pm

Gnome-shell is a dependency (suggested) of GDM3. Mint switched from GDM3 to MDM as the default DM a while ago. MDM does not have all those Gnome dependencies.
I'm also using LMDE XFCE and made the switch manually awhile ago and am not having any Gnome dependency issues. To make the switch do the following:

Install MDM. If you do this via Synaptic then you should get a pop-up asking which one you want as default, GDM3 or MDM. Choose MDM.
Reboot.
You should then get the MDM login screen.

If all went well you can then uninstall GDM3. Then try the upgrade again.

Hope this helps. :wink:
GeneBenson
Level 3
Level 3
 
Posts: 131
Joined: Fri Sep 17, 2010 9:55 pm

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby rolandpish on Thu Sep 20, 2012 5:41 pm

Hi Gene. Thanks for the reply.

My LMDE+Xfce came with MDM when I first installed it. It's weird that all gnome dependencies claimed to be installed. I checked and GDM3 is not installed at all in my system.
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby squeezy on Thu Sep 20, 2012 6:18 pm

I reported this during the beta testing for UP5, viewtopic.php?p=620349#p620349

Nothing you can do about it due to dependencies being dragged in. And it has naught to do with GDM3 being installed or not.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby zerozero on Thu Sep 20, 2012 6:51 pm

this nautilus issue in xfce is old, actually is not a true nautilus problem in the beginning: it is not installed in the default iso but some libs that later will pull it are like libnautilus-extension1a
check the issue with
Code: Select all
dpkg --get-selections | grep nautilus
uninstall as much as you can from the findings and nautilus shouldn't come back.
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Xfce + Update Pack 5: GDM3 wants unnecessary packages

Postby ormu on Mon Sep 24, 2012 3:16 am

Ok, I installed MDM and removed GDM and everything seems to be OK now. However, MDM installation failed when GDM was installed so I had to remove it first. The package manager sent an error message when it tried to replace a file that was belonging to GDM.

By the way, what's the "Previous session" setting in the login menu, and what's the difference between it and "Xfce session"?
ormu
Level 1
Level 1
 
Posts: 24
Joined: Mon Dec 19, 2011 3:42 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 6 guests