Broken, packages and depenencies.

Post your update and upgrade related errors here
Forum rules

Broken, packages and depenencies.

Postby Baddream on Thu Sep 20, 2012 11:10 am

hi im still pretty new to Linux.
I got a problem each time i try to update i get this error message:

W: Erro GPG: http://debian.linuxmint.com testing InRelease: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY AED4B06F473041FA
W: Erro GPG: http://debian.linuxmint.com testing/updates InRelease: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY AED4B06F473041FA


and when i try to install any sort of program i guet dependencies error.

i tried to solve the problem by disabling software sources on the update manager, the error messages dissapeared but so did the updates.
And i need almost to install all dependencies one by one to manage to install software.

I tried http://community.linuxmint.com/tutorial/view/482 and http://ubuntuforums.org/showthread.php?t=965882

although it helped a bit the most of error messages still remain.


largely apreciate any help.


cumps
and
Baddream
Level 1
Level 1
 
Posts: 2
Joined: Thu Sep 20, 2012 11:04 am

Linux Mint is funded by ads and donations.
 

Re: Broken, packages and depenencies.

Postby alanmoore on Fri Sep 21, 2012 10:29 am

Hi, Baddream! I'm facing a very similar problem. The error I get is:

Code: Select all
W: Error de GPG: http://mirror.rts-informatique.fr testing InRelease: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY AED4B06F473041FA
W: Error de GPG: http://mirror.rts-informatique.fr testing/updates InRelease: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY AED4B06F473041FA
W: Error de GPG: http://packages.linuxmint.com debian Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 3EE67F3D0FF405B2
W: Error de GPG: http://mirror.rts-informatique.fr testing Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 07DC563D1F41B907


I'm not an expert by any means, but I think it's not about broken packages or dependencies, but about missing security keys. I have no idea why they are missing, and don't know how to fix it. Without them, I can't do a proper upgrade to UP5. I've googled around for a little bit in search of a solution and found out that reinstalling the package debian-archive-keyring solved part of the issue. Maybe that could help you. Open a terminal and paste two commands:

Code: Select all
sudo apt-get install debian-archive-keyring
and
Code: Select all
sudo apt-get update


For me, it was not enough. After reinstalling debian-archive-keyring and updating my sources.list, I got this message:

Code: Select all
Error de GPG: http://packages.linuxmint.com debian Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 3EE67F3D0FF405B2
W: Error de GPG: http://mirror.rts-informatique.fr testing Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 07DC563D1F41B907


Which means that there are still missing keys. Any suggestions? Thank you in advance!
alanmoore
Level 1
Level 1
 
Posts: 14
Joined: Sun Oct 18, 2009 9:19 am

Re: Broken, packages and depenencies.

Postby alanmoore on Fri Sep 21, 2012 11:11 am

Hi! It's me again.

I've read somewhere that debian multimedia is now deb-multimedia, so there's another package that can be installed to partially solve my problem, called 'deb-multimedia-keyring':
Code: Select all
sudo apt-get install deb-multimedia-keyring

Code: Select all
sudo apt-get update


With that I remove one of my error messages, but this one still remains:

Code: Select all
W: Error de GPG: http://packages.linuxmint.com debian Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 3EE67F3D0FF405B2


Suggestions are welcome.
alanmoore
Level 1
Level 1
 
Posts: 14
Joined: Sun Oct 18, 2009 9:19 am

Re: Broken, packages and depenencies.

Postby alanmoore on Fri Sep 21, 2012 11:16 am

Finally! It turns out that I only had to reinstall the linuxmint-keyring package.
What I still don't understand is why this has happened and how can I prevent it from happening again. Thanks!
alanmoore
Level 1
Level 1
 
Posts: 14
Joined: Sun Oct 18, 2009 9:19 am

Re: Broken, packages and depenencies.

Postby Baddream on Sun Sep 23, 2012 9:14 am

thank you very much for all your replies,
i still got a problem, i typeD: sudo apt-get install deb-multimedia-keyring


after i try to update i get this error:
W: Erro GPG: http://debian.linuxmint.com testing InRelease: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY AED4B06F473041FA
W: Erro GPG: http://debian.linuxmint.com testing/updates InRelease: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY AED4B06F473041FA.
Baddream
Level 1
Level 1
 
Posts: 2
Joined: Thu Sep 20, 2012 11:04 am

Re: Broken, packages and depenencies.

Postby killer de bug on Sun Sep 23, 2012 12:06 pm

Can you post the output of

Code: Select all
inxi -r
Image
If it ain't broke, fix it until it is.
User avatar
killer de bug
Level 11
Level 11
 
Posts: 3563
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests