[solved] nvidia 302.17 driver crash while playing game

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

[solved] nvidia 302.17 driver crash while playing game

Postby micsas on Thu Sep 20, 2012 3:42 pm

I'v UP5 my system today. Nvidia non-free drivers were updated from 295.xx to 302.17ver. My system become unstable while playing some simple game (teeworlds). It crashes after several minutes of playing. I can see nothing in logs that could be related to my problem. I remember that the same thing was on Debian Wheezy and Fedora 17 which i tested like a month ago. I'm sure both of this distros used nvidia 302.xx drivers back then. Thus that i believe my problem is about nvidia.
Code: Select all
inxi -v1
System:    Host mintmic Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
CPU:       Single core AMD Athlon 64 4000+ (-UP-) clocked at 1000.00 MHz
Graphics:  Card NVIDIA NV43 [GeForce 6600 GT] X.Org Res: 1280x1024@85.0hz
           GLX Renderer GeForce 6600 GT/AGP/SSE2 GLX Version 2.1.2 NVIDIA 302.17
Disks:     HDD Total Size: 245.9GB (-)
Info:      Processes 105 Uptime 15 min Memory 731.8/1001.8MB Client Shell inxi 1.4.23

How can i rollback to previous nvidia drivers?
Edit 24.09.2012
I downgraded nvidia binary drivers.
Here is what to do if u want rollback nvidia drivers.
  • Find and download appropriate drivers form nvidia site i used NVIDIA 295.75
  • Do the .run file executable
    Code: Select all
    chmod +x NVIDIA-Linux-....run
  • Switch to the console CTRL+ALT+F1
  • Log in
  • stop window menager
    Code: Select all
    /etc/init.d/mdm stop
  • Remove current nvidia drivers.
    Code: Select all
    sudo aptitude purge nvidia~i
  • Execute NVIDIA instalation script.
    Code: Select all
    sudo ./NVIDIA-Linux-x86_64-295.75.run
If the script says that u have difrent version of gcc execute command:
Code: Select all
export CC=gcc-4.x

where x stands for appropriate version.
I run into the problem with /tmp directory being to small. Its because /tmp directory is set as a ramdisk and its size is limited. In my case it was 210MB which was not good enough. I have set "RAMTMP=no" option at "/etc/default/rcS" which disable using ramdisk for /tmp.
Level 1
Level 1
Posts: 2
Joined: Fri Aug 31, 2012 5:17 am

Linux Mint is funded by ads and donations.

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests