frezze after sleep mode use [solved --> Nvidia 302.xx pb]

Post your update and upgrade related errors here
Forum rules
Before you post please read this

frezze after sleep mode use [solved --> Nvidia 302.xx pb]

Postby killer de bug on Sun Sep 23, 2012 7:19 am

Hello,

I have upgraded to UP5 sooner in the week and I have installed Cinnamon 1.6 and Nemo. I have deleted Nautilus.
Everything is working fine excepted that I can't recover anymore from the sleep mode.

I was using it everyday with Cinnamon 1.4 and UP4. Now when I want to wake up my laptop, the screen stays black but I can see it's a little lighter, so I know the power is on.
I had to kill the power to restart. Nor the mouse or the keyboard are responding anymore. I tried ctrl + alt + backspace, but the screen stays in the same state.
I tried booting with the old kernel but sleep mode is not working either. Hibernate is working well.

So it can be related to UP5 (and Nividia drivers for exemple), or to Cinnamon 1.6 or Nemo.

I would like to know if other peoples have the same behavior as my laptop.

Code: Select all
emmanuel@manu-laptop ~ $ inxi -F
System:    Host manu-laptop Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
CPU:       Dual core Intel Core2 Duo T5900 (-MCP-) cache 2048 KB flags (lm nx sse sse2 sse3 ssse3) bmips 8782.04
           Clock Speeds: (1) 800.00 MHz (2) 800.00 MHz
Graphics:  Card NVIDIA G96 [GeForce GT 130M] X.Org 1.12.1.902 Res: 1366x768@60.0hz
           GLX Renderer GeForce GT 130M/PCIe/SSE2 GLX Version 3.3.0 NVIDIA 302.17 Direct Rendering Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card-1 Atheros AR928X Wireless Network Adapter (PCI-Express) driver ath9k BusID: 03:00.0
           Card-2 Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI at port e800 BusID: 08:00.0
Disks:     HDD Total Size: 500.1GB (26.8% used) 1: /dev/sda ST9500325AS 500.1GB
Partition: ID:/ size: 24G used: 9.0G (41%) fs: rootfs ID:/ size: 24G used: 9.0G (41%) fs: ext4
           ID:/home size: 432G used: 125G (31%) fs: ext3 ID:swap-1 size: 4.09GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A gpu: 0.0:50C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes 152 Uptime 2:20 Memory 597.7/3967.9MB Runlevel 2 Client Shell inxi 1.4.23






By the way, even if it's not related directly I have a message for Clem and all the Cinnamon team :

Please consider adding the opportunity to change the behavior of the power button in Cinnamon. I would like it to be shutdown and not sleep. In gnome 2 I had the opportunity to do that, but I don't see it in Cinnamon.
Last edited by killer de bug on Mon Sep 24, 2012 3:38 pm, edited 1 time in total.
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 6
Level 6
 
Posts: 1077
Joined: Tue Jul 08, 2008 1:49 pm
Location: France

Linux Mint is funded by ads and donations.
 

Re: frezze after sleep mode use

Postby Monsta on Sun Sep 23, 2012 7:57 am

killer de bug wrote:I tried booting with the old kernel but sleep mode is not working either.

Well, this may indicate that Nvidia drivers cause this, and
killer de bug wrote:NVIDIA 302.17

this may just confirm that since people are experiencing problems with this particular version.

Here's the similar (at least I think so) thread: http://forums.debian.net/viewtopic.php?f=5&t=81649
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: frezze after sleep mode use

Postby killer de bug on Sun Sep 23, 2012 8:06 am

Yeppp that's exactly the same...

WIll have to learn how to downgrade my Nvidia drivers when I will have some time ;)
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 6
Level 6
 
Posts: 1077
Joined: Tue Jul 08, 2008 1:49 pm
Location: France

Re: frezze after sleep mode use

Postby Monsta on Sun Sep 23, 2012 9:44 am

Downgrade to what version? :)
Wheezy already has version 304.48-1, it's probably easier to cherry-pick it from there (this is at your own risk though; watch the dependencies).
IIRC, people are reporting that 304.xx branch has less problems that 302.xx.

Or you can use sgfxi to choose the suitable driver version, download it and rebuild the needed kernel modules (either for your current kernel or for all the kernels installed - you can choose).
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: frezze after sleep mode use

Postby killer de bug on Sun Sep 23, 2012 12:00 pm

The last version I was using 298."I don't remember what" was working fine... I will consider trying the 304.x family. Thanks :wink:
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 6
Level 6
 
Posts: 1077
Joined: Tue Jul 08, 2008 1:49 pm
Location: France

Re: frezze after sleep mode use [solved --> Nvidia 302.xx pb

Postby Freigeist85 on Thu Sep 27, 2012 5:12 pm

I had the same Problem, installed current Nvidia driver (304.51) with smxi, sleep mode works fine now!
Freigeist85
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 21, 2011 2:10 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 10 guests