[solved] sgfxi after big update

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[solved] sgfxi after big update

Postby chris_722 on Sun Sep 23, 2012 8:23 am

Hi, i've just updated my LMDE and I hava a problem.
After kernel update there's no GUI in my LMDE.
Before update I forgot to check the option in Network Manager "enable to all users" so I get a wget error while trying to type sgfxi in terminal.

Here's my question. How to enable that option in Network Manager via terminal OR how to connect with internet in terminal before using sgfxi? My goal is simply to be able to connect with internet so I can use sgfxi.

Last time this method worked nice

Any help appreciated.

Chris:)
Last edited by chris_722 on Thu Oct 18, 2012 3:44 pm, edited 1 time in total.
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Linux Mint is funded by ads and donations.
 

Re: sgfxi after big update

Postby Monsta on Sun Sep 23, 2012 9:52 am

chris_722 wrote:Before update I forgot to check the option in Network Manager "enable to all users" so I get a wget error while trying to type sgfxi in terminal.

If you log in there as root (that's what people usually have to do when some issue leaves them w/o GUI...), try logging in as yourself. And vice versa. :)

EDIT: I wrote that because I thought sgfxi has an option to "only download" drivers which would've been executed as a normal user. Seems like it's not so. But you can try one of the following:

1. Reboot and run the previous kernel version. Since you haven't run sgfxi successfully after the upgrade, the old driver should still be there, and you'll boot into GUI.

2. Try using this option:
Code: Select all
-W Skip all wget downloads. Only use this to reinstall a driver
   that has already been downloaded using sgfxi at least once previously.
to rebuild the modules from the old driver for the new kernel.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Sun Sep 23, 2012 11:16 am

Well, This is my second kernel update so I have 3 versions of LMDE in GRUB. None of them has GUI ;/

I tried the second option you mentioned and the driver has been installed succesfully. In the end of installation I had two options to choose from: quit and run GUI. I chose the second one but again, a command line appeared.

Any ideas?
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Sun Sep 23, 2012 1:11 pm

Quite strange...
What if you manually stop and then start your display manager after sgfxi finishes? Or just reboot the system?

To start/stop your DM just run
Code: Select all
service <your_dm_name> start
or
Code: Select all
service <your_dm_name> stop

If nothing of that works, post your /var/log/Xorg.0.log here. Don't forget to wrap it in the "code" tag - it can be quite long. :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Mon Sep 24, 2012 8:23 am

My dm is turned on by default. I tried to start it (failed), so I stopped it (success) and started again (success). After this, still command line.

This is the /var/log/Xorg.0.log :

Code: Select all
[   169.249]
X.Org X Server 1.12.1.902 (1.12.2 RC 2)
Release Date: 2012-05-19
[   169.249] X Protocol Version 11, Revision 0
[   169.249] Build Operating System: Linux 2.6.32-5-686-bigmem i686 Debian
[   169.249] Current Operating System: Linux msi 2.6.39-2-486 #1 Tue Jul 5 02:52:23 UTC 2011 i686
[   169.249] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.39-2-486 root=UUID=38053d1f-ef1b-4f93-a960-f4baf8893ee3 ro quiet nomodeset nouveau.modeset=0
[   169.249] Build Date: 20 May 2012  10:23:38AM
[   169.249] xorg-server 2:1.12.1.902-1 (Cyril Brulebois <kibi@debian.org>)
[   169.249] Current version of pixman: 0.26.0
[   169.249]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   169.249] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   169.250] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 24 14:52:55 2012
[   169.250] (==) Using config file: "/etc/X11/xorg.conf"
[   169.250] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   169.250] (==) ServerLayout "X.org Configured"
[   169.250] (**) |-->Screen "Screen0" (0)
[   169.250] (**) |   |-->Monitor "Monitor0"
[   169.250] (**) |   |-->Device "Card0"
[   169.250] (**) |-->Screen "Screen1" (1)
[   169.250] (**) |   |-->Monitor "Monitor1"
[   169.251] (**) |   |-->Device "Card1"
[   169.251] (**) |-->Screen "Screen2" (2)
[   169.251] (**) |   |-->Monitor "Monitor2"
[   169.251] (**) |   |-->Device "Card2"
[   169.251] (**) |-->Input Device "Mouse0"
[   169.251] (**) |-->Input Device "Keyboard0"
[   169.251] (==) Automatically adding devices
[   169.251] (==) Automatically enabling devices
[   169.251] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   169.251]    Entry deleted from font path.
[   169.251] (**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[   169.251] (**) ModulePath set to "/usr/lib/xorg/modules"
[   169.251] (**) Extension "Composite" is enabled
[   169.251] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   169.251] (WW) Disabling Mouse0
[   169.251] (WW) Disabling Keyboard0
[   169.251] (II) Loader magic: 0xb770a5a0
[   169.251] (II) Module ABI versions:
[   169.251]    X.Org ANSI C Emulation: 0.4
[   169.251]    X.Org Video Driver: 12.0
[   169.251]    X.Org XInput driver : 16.0
[   169.251]    X.Org Server Extension : 6.0
[   169.269] (--) PCI:*(0:2:0:0) 10de:0844:1462:6720 rev 162, Mem @ 0xfc000000/16777216, 0xd8000000/134217728, 0xd6000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
[   169.274] (II) Open ACPI successful (/var/run/acpid.socket)
[   169.275] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[   169.275] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[   169.275] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   169.275] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[   169.275] (II) "dri" will be loaded by default.
[   169.275] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[   169.275] (II) LoadModule: "extmod"
[   169.275] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   169.275] (II) Module extmod: vendor="X.Org Foundation"
[   169.275]    compiled for 1.12.1.902, module version = 1.0.0
[   169.275]    Module class: X.Org Server Extension
[   169.275]    ABI class: X.Org Server Extension, version 6.0
[   169.275] (II) Loading extension SELinux
[   169.275] (II) Loading extension MIT-SCREEN-SAVER
[   169.275] (II) Loading extension XFree86-VidModeExtension
[   169.275] (II) Loading extension XFree86-DGA
[   169.275] (II) Loading extension DPMS
[   169.275] (II) Loading extension XVideo
[   169.275] (II) Loading extension XVideo-MotionCompensation
[   169.275] (II) Loading extension X-Resource
[   169.280] (II) LoadModule: "record"
[   169.280] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   169.280] (II) Module record: vendor="X.Org Foundation"
[   169.280]    compiled for 1.12.1.902, module version = 1.13.0
[   169.280]    Module class: X.Org Server Extension
[   169.280]    ABI class: X.Org Server Extension, version 6.0
[   169.280] (II) Loading extension RECORD
[   169.280] (II) LoadModule: "dbe"
[   169.280] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   169.280] (II) Module dbe: vendor="X.Org Foundation"
[   169.280]    compiled for 1.12.1.902, module version = 1.0.0
[   169.280]    Module class: X.Org Server Extension
[   169.280]    ABI class: X.Org Server Extension, version 6.0
[   169.280] (II) Loading extension DOUBLE-BUFFER
[   169.280] (II) LoadModule: "glx"
[   169.281] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   169.336] (II) Module glx: vendor="NVIDIA Corporation"
[   169.336]    compiled for 4.0.2, module version = 1.0.0
[   169.336]    Module class: X.Org Server Extension
[   169.336] (II) NVIDIA GLX Module  285.05.09  Fri Sep 23 19:13:43 PDT 2011
[   169.336] (II) Loading extension GLX
[   169.336] (II) LoadModule: "dri2"
[   169.336] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   169.336] (II) Module dri2: vendor="X.Org Foundation"
[   169.336]    compiled for 1.12.1.902, module version = 1.2.0
[   169.336]    ABI class: X.Org Server Extension, version 6.0
[   169.336] (II) Loading extension DRI2
[   169.336] (II) LoadModule: "dri"
[   169.337] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   169.337] (II) Module dri: vendor="X.Org Foundation"
[   169.337]    compiled for 1.12.1.902, module version = 1.0.0
[   169.337]    ABI class: X.Org Server Extension, version 6.0
[   169.337] (II) Loading extension XFree86-DRI
[   169.337] (II) LoadModule: "nvidia"
[   169.337] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   169.338] (II) Module nvidia: vendor="NVIDIA Corporation"
[   169.338]    compiled for 4.0.2, module version = 1.0.0
[   169.338]    Module class: X.Org Video Driver
[   169.338] ================ WARNING WARNING WARNING WARNING ================
[   169.338] This server has a video driver ABI version of 12.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[   169.338] =================================================================
[   169.338] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[   169.338] (II) UnloadModule: "nvidia"
[   169.338] (II) Unloading nvidia
[   169.338] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
[   169.338] (EE) No drivers available.
[   169.338]
Fatal server error:
[   169.338] no screens found
[   169.338]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   169.338] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   169.338]
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Mon Sep 24, 2012 8:54 am

chris_722 wrote:
Code: Select all
[   169.336] (II) NVIDIA GLX Module  285.05.09  Fri Sep 23 19:13:43 PDT 2011
Code: Select all
[   169.338] ================ WARNING WARNING WARNING WARNING ================
[   169.338] This server has a video driver ABI version of 12.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.

Oh noes... this driver is too old for your shiny new Xorg 1.12... even sgfxi tells us:
Code: Select all
Xorg 1.12 - 304/295/173 latest. 96.43.23. Nothing for 71xx
Xorg 1.11 - 304.xx/173/ latest. 96.43.23. Nothing for 71xx

Now I understand why you couldn't get GUI with any kernel.

Okay, maybe console networkmanager tool will do something at least. If nmcli is installed, what's the output of
Code: Select all
LC_ALL=C nmcli nm
and
Code: Select all
LC_ALL=C nmcli con
?
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Mon Sep 24, 2012 9:41 am

Code: Select all
LC_ALL=C nmcli con


I have 3 connections listed there with following information.

Code: Select all
Name:
UUID:
Type:
Timestamp-real:


There do not seem to be any error, only connections' parameters that's all.

************************************************

Code: Select all
LC_ALL=C nmcli con


Code: Select all
RUNNING: running
STATE: disconnected
WIFI-HARDWARE: enabled
WIFI: enabled
WWAN-HARDWARE: enabled
WWAN:disabled


Thanks for the help
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Mon Sep 24, 2012 10:03 am

Try to activate the connection you've been using before by running either
Code: Select all
nmcli con up id <connection name>
or
Code: Select all
nmcli con up uuid <connection UUID>

Look at the command reference (man nmcli) if you need more info.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Mon Sep 24, 2012 11:56 am

Unfortunately I've recently changed my router and I have a new connection which I've been connected to only once under Linux.

I played around with nmcli options and my new wifi connection is not avilable after typing:
Code: Select all
LC_ALL=C nmcli con


Then I typed something like:
Code: Select all
nmcli dev wifi list


and my new connection appeared but then:

Code: Select all
nmcli con up id <new_con_id>


and it told me that this is an unknown connection....

Is there any help for this?
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Tue Sep 25, 2012 3:40 am

Try activating it by UUID, not by id.
Code: Select all
nmcli con up uuid <connection UUID>

I've found nmcli may get confused if the connection name has spaces in it, even if I use quotes or backslashes to escape them. UUIDs do not have spaces. :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Tue Sep 25, 2012 6:50 am

I would try this if I only knew what the UUID of my connection is. My new connection is not avilable at:
Code: Select all
LC_ALL=C nmcli con


My connection id has no spaces in its name, so there shouldn't be any problem IMO.

What's more, when I try:

Code: Select all
nmcli con up <my-id>


It says that it couldn't initialize nmclient and gives four possible causes including broken connection.

The last option and the least optimistic is to install a new LMDE on my HDD, but I would like to avoid that (it's not Windows :) )

Any help greatly appreciated :)
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Tue Sep 25, 2012 7:57 am

*sigh* The quest is getting harder :D

Is your connection listed here?
Code: Select all
ls -l /etc/NetworkManager/system-connections/
If it is, you can look into the file to find its parameters (including UUID).

If it's not... well... let's try another configuration storage. Run this command
Code: Select all
gconftool-2 --dump /system/networking/connections
and post its output here.
Then re-login as yourself and do the same.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Wed Sep 26, 2012 5:02 pm

So...
My new connection is not listed here:
Code: Select all
ls -l /etc/NetworkManager/system-connections/


I tried:
Code: Select all
gconftool-2 --dump /system/networking/connections


When logged in as root, this command shows nothing. It's just:

Code: Select all
<gconfentryfile>
   <entrylistbase="/system/networking/connections"
   </entrylist>
</gconfentryfile>


The situation changes when I log in as user. Big list of code appears (including my new connection id and uuid) but unfortunately I'm still unable to connect (I tried id and uuid).

I'd post the entire code here but it's to much to rewrite on the paper and then once again here;p
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Thu Sep 27, 2012 3:38 am

chris_722 wrote:The situation changes when I log in as user. Big list of code appears (including my new connection id and uuid) but unfortunately I'm still unable to connect (I tried id and uuid).

Still unable to connect even if you log in as a normal user? That's not good... Are the error messages the same as before?

But at least your connection is saved in your configuration files.
Let's try to convert it to the system-wide configuration. Do this as root:

  1. cd /etc/NetworkManager/system-connections/
  2. nano <your connection id> (e.g. nano "My New Connection" - don't forget the quotes if it contains any spaces)
  3. Place your connection data (the data obtained via gconftool-2 as a normal user) there.

    The format is different here, it's not XML this time, it looks more like *.ini files from Windows. :) The parameter names should be the same though, e.g. id, uuid, timestamp, etc. You can use other files from this directory as samples.

    EDIT: regarding gconftool-2 - I've totally missed another command line option while skimming through its usage message. You can run
    Code: Select all
    gconftool-2 -R /system/networking/connections
    to print all the settings in more convenient format. :)

    Here's what your file may look like in the end:

    • if you're using wired connection
      Code: Select all
      [802-3-ethernet]
      duplex=full

      [connection]
      id=<your connection id>
      uuid=<your connection UUID>
      type=802-3-ethernet
      timestamp=<10-digit number>

      [ipv6]
      method=ignore

      [ipv4]
      method=manual
      dns=<DNS server IP>;
      dns-search=<local domain>;
      addresses1=<your static IP>;<mask>;<gateway IP>;

      This is for static IPv4 address, without using IPv6, and in a local network with a domain. Of course, your connection settings may be different. Note the semicolons.

    • if you're using wireless connection
      Code: Select all
      [connection]
      id=<your connection id>
      uuid=<your connection UUID>
      type=802-11-wireless
      timestamp=<10-digit number>

      [802-11-wireless]
      ssid=<your access point's SSID>
      mode=infrastructure
      seen-bssids=<your access point's BSSID>;
      security=802-11-wireless-security

      [802-11-wireless-security]
      key-mgmt=wpa-psk
      psk=<your access point's passphrase>

      [ipv4]
      method=auto

      [ipv6]
      method=auto

      This is for connecting to the access point using WPA2-PSK. IP settings are obtained automatically.
      Note that the passphrase is stored in plain text! This is probably because the connection is made available for all users.
  4. Save the file.
  5. Just in case, set its permissions so only root can read/write it:
    Code: Select all
    chmod 600 <file name>
  6. Restart network-manager:
    Code: Select all
    service network-manager restart
    or
    Code: Select all
    /etc/init.d/network-manager restart
  7. I don't know if it activates your new connection automatically. If not, try nmcli to activate it.
  8. If nothing changes, just reboot and login as root. :)

chris_722 wrote:I'd post the entire code here but it's to much to rewrite on the paper and then once again here;p

:D Somehow I thought you're writing this from some other PC so there'd be an option to use a thumb drive to copy the data there :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: sgfxi after big update

Postby chris_722 on Wed Oct 03, 2012 8:34 am

Well, I managed to be in one of the places where I used to connect to wifi using LMDE. I typed sgfxi in terminal and it worked!:)
The driver has been installed successfully and now I'm writing from my new LMDE with so refreshed look.

Thanks for your time and attention, It was very helpful.

Chris :)
chris_722
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 18, 2011 5:19 am

Re: sgfxi after big update

Postby Monsta on Thu Oct 04, 2012 5:38 am

:D Looks like it was a connection marked as "available for all users".

Well, glad the problem is finally solved. You can mark this thread as [solved] to indicate that.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Google [Bot] and 3 guests