UP5 : fglrx + wine = fail

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP5 : fglrx + wine = fail

Postby sobrus on Mon Sep 24, 2012 2:11 am

I've come across problems with running wine on UP5 with fglrx.
My graphics card is HD5670.

Linux 3D and Compiz works perfectly good. Video acceleration in VLC works (didn't in UP4).
Windows 2D applications run just fine also, but there is no working 3D acceleration under wine (both mepis 1.5.12 and LMDE multiarch 1.4.1)

Dragon Age setup reports ATI Radeon 8500 (instead of 5600 Series), other games just don't launch at all.

Temporary solution is to prevent fglrx 12.2 driver (thus also new x.org) and UP4 kernel from upgrading (about 24 packages total).
Wine runs fine with UP5 + old fglrx and kernel.

This is probably debian upstream bug. I don't expect it to be fixed by LMDE team, just giving a warning.
sobrus
Level 2
Level 2
 
Posts: 87
Joined: Thu Aug 30, 2012 1:36 am

Linux Mint is funded by ads and donations.
 

Re: UP5 : fglrx + wine = fail

Postby esben_aaberg on Mon Sep 24, 2012 11:01 pm

I have the same problem, and it seems to be 32bit OpenGL on 64bit architecture in my case.

I did a partly update off the following packets form UP5, and that broke 32bit OpenGL for me. I have late done at full UP5 distribution upgrade, and tried switching to multiarch and back to ia32-libs without luck.
Code: Select all
Commit Log for Tue Sep 18 18:16:12 2012

De følgende pakker er blevet fjernet:
libxvbaw1

De følgende pakker er blevet opgraderet:
eog (3.2.2-2+b1) to 3.4.2-1
fglrx-atieventsd (1:12-2-2) to 1:12-6+point-1
fglrx-control (1:12-2-2) to 1:12-6+point-1
fglrx-driver (1:12-2-2) to 1:12-6+point-1
fglrx-glx-ia32 (1:12-2-2) to 1:12-6+point-1
fglrx-modules-dkms (1:12-2-2) to 1:12-6+point-1
fontconfig-config (2.8.0-2.1ubuntu3) to 2.9.0-6
glib-networking (2.30.2-1) to 2.32.3-1
glib-networking-common (2.30.2-1) to 2.32.3-1
glib-networking-services (2.30.2-1) to 2.32.3-1
gnome-themes-standard (3.2.1-2) to 3.4.2-1
libatk1.0-0 (2.2.0-2) to 2.4.0-2
libatk1.0-data (2.2.0-2) to 2.4.0-2
libcairo2 (1.10.2-2ubuntu2) to 1.12.2-2
libdrm-radeon1 (2.4.30-1) to 2.4.33-3
libfglrx (1:12-2-2) to 1:12-6+point-1
libfontconfig1 (2.8.0-2.1ubuntu3) to 2.9.0-6
libfontconfig1-dev (2.8.0-2.1ubuntu3) to 2.9.0-6
libgail-3-0 (3.2.3-1) to 3.4.2-2
libgdk-pixbuf2.0-0 (2.24.1-1) to 2.26.1-1
libgdk-pixbuf2.0-common (2.24.1-1) to 2.26.1-1
libgl1-fglrx-glx (1:12-2-2) to 1:12-6+point-1
libglib2.0-0 (2.30.2-6) to 2.32.3-1
libglib2.0-bin (2.30.2-6) to 2.32.3-1
libglib2.0-cil (2.12.10-3) to 2.12.10-4
libgnutls-dev (2.12.16-1) to 2.12.20-1
libgnutls-openssl27 (2.12.16-1) to 2.12.20-1
libgnutls26 (2.12.16-1) to 2.12.20-1
libgnutlsxx27 (2.12.16-1) to 2.12.20-1
libgtk-3-0 (3.2.3-1) to 3.4.2-2
libgtk-3-bin (3.2.3-1) to 3.4.2-2
libgtk-3-common (3.2.3-1) to 3.4.2-2
libgtk2.0-cil (2.12.10-3) to 2.12.10-4
libjavascriptcoregtk-3.0-0 (1.6.3-1) to 1.8.1-2
libpango1.0-0 (1.29.4-3) to 1.30.0-1
libsoup2.4-1 (2.34.3-1) to 2.38.1-2
libvte-2.90-9 (1:0.30.1-3) to 1:0.32.2-1
libvte-2.90-common (1:0.30.1-3) to 1:0.32.2-1
libwebkitgtk-3.0-0 (1.6.3-1) to 1.8.1-2
libwebkitgtk-3.0-common (1.6.3-1) to 1.8.1-2
libx11-6 (2:1.4.4-4) to 2:1.5.0-1
libx11-dev (2:1.4.4-4) to 2:1.5.0-1
xserver-common (2:1.11.4-1) to 2:1.12.1.902-1
xserver-xorg-core (2:1.11.4-1) to 2:1.12.1.902-1
xserver-xorg-input-evdev (1:2.6.0-2+b2) to 1:2.7.0-1+b1
xserver-xorg-input-synaptics (1.5.0-2) to 1.6.2-1
xserver-xorg-input-wacom (0.12.0-1) to 0.15.0+20120515-1
xserver-xorg-video-apm (1:1.2.3-2+b2) to 1:1.2.3-3
xserver-xorg-video-ark (1:0.7.3-2+b2) to 1:0.7.4-1+b1
xserver-xorg-video-ati (1:6.14.3-2) to 1:6.14.4-5
xserver-xorg-video-chips (1:1.2.4-1+b2) to 1:1.2.4-2
xserver-xorg-video-cirrus (1:1.3.2-4+b2) to 1:1.4.0-1+b1
xserver-xorg-video-fbdev (1:0.4.2-4+b2) to 1:0.4.2-4+b3
xserver-xorg-video-i128 (1:1.3.4-2+b2) to 1:1.3.5-1+b1
xserver-xorg-video-i740 (1:1.3.2-4+b2) to 1:1.3.2-4+b3
xserver-xorg-video-intel (2:2.18.0-1) to 2:2.19.0-4
xserver-xorg-video-mach64 (6.9.0-1+b1) to 6.9.1-2
xserver-xorg-video-mga (1:1.4.13.dfsg-4) to 1:1.5.0-1
xserver-xorg-video-neomagic (1:1.2.5-2+b2) to 1:1.2.6-1
xserver-xorg-video-nouveau (1:0.0.16+git20111201+b5534a1-1) to 1:0.0.16+git20120322+ab7291d-1
xserver-xorg-video-openchrome (1:0.2.904+svn1050-1) to 1:0.2.906-2
xserver-xorg-video-r128 (6.8.1-5+b2) to 6.8.2-1
xserver-xorg-video-radeon (1:6.14.3-2) to 1:6.14.4-5
xserver-xorg-video-rendition (1:4.2.4-2+b2) to 1:4.2.4-3
xserver-xorg-video-s3 (1:0.6.3-4+b2) to 1:0.6.3-4+b3
xserver-xorg-video-s3virge (1:1.10.4-4+b2) to 1:1.10.4-5
xserver-xorg-video-savage (1:2.3.3-1) to 1:2.3.4-1
xserver-xorg-video-siliconmotion (1:1.7.5-1+b2) to 1:1.7.6-1
xserver-xorg-video-sis (1:0.10.3-3+b2) to 1:0.10.4-1
xserver-xorg-video-sisusb (1:0.9.4-2+b2) to 1:0.9.4-3
xserver-xorg-video-tdfx (1:1.4.3-4+b2) to 1:1.4.4-1
xserver-xorg-video-trident (1:1.3.4-2+b2) to 1:1.3.5-1
xserver-xorg-video-tseng (1:1.2.4-2+b2) to 1:1.2.4-3
xserver-xorg-video-vesa (1:2.3.0-7+b1) to 1:2.3.1-1+b1
xserver-xorg-video-vmware (1:11.0.99.901-1) to 1:12.0.2-1+b1
xserver-xorg-video-voodoo (1:1.2.4-2+b2) to 1:1.2.4-2+b3

Installerede de følgende pakker:
libfglrx-amdxvba1 (1:12-6+point-1)
libmtdev1 (1.1.2-1)
esben_aaberg
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 08, 2012 6:41 am

Re: UP5 : fglrx + wine = fail

Postby sobrus on Tue Sep 25, 2012 1:42 am

Yes, I guess this is a problem with 32-bit packages.
But since I don't have any 32-bit application other than wine, it's just a guess.

There is already new flgrx driver version in SID. I wonder if it is fixed already.
sobrus
Level 2
Level 2
 
Posts: 87
Joined: Thu Aug 30, 2012 1:36 am

Re: UP5 : fglrx + wine = fail

Postby sobrus on Tue Oct 02, 2012 2:03 am

This is known upstream bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683853

It has beed fixed in 12.6 point-2 drivers
http://bugs.debian.org/cgi-bin/pkgrepor ... t=unstable

Hope to see them soon in LMDE :)
sobrus
Level 2
Level 2
 
Posts: 87
Joined: Thu Aug 30, 2012 1:36 am


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests