[SOLVED] PHP update broke PHP in Apache

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[SOLVED] PHP update broke PHP in Apache

Postby Ken_g6 on Mon Sep 24, 2012 4:07 pm

So, first of all, I have LMDE running with XFCE. I just noticed this UP5 today, but I didn't want to mess with it until next weekend. But I needed to install some software.

So I installed drupal7 from Synaptic, and it required several upgrades. PHP in particular got upgraded from 4.3 to 4.4. But now when I browse to any page with PHP on it, I get a blank page - or at least a blank section where the PHP should be filling in stuff. I tried upgrading Apache too, but it didn't help. So how do I get PHP working again? Do I have to do the whole Update Pack thing?

Edit: /var/log/apache2/error.log says:
[notice] Apache/2.2.22 (Debian) PHP/5.4.4-2 configured -- resuming normal operations
Which I assume is normal.

Edit: Solved. I had to install libapache2-mod-php5. It might have gotten uninstalled somehow during installation of Drupal.
Ken_g6
Level 1
Level 1
 
Posts: 23
Joined: Fri May 11, 2012 12:43 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests