LMDE Breakages (Tracking SID)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

LMDE Breakages (Tracking SID)

Postby GeneC on Tue May 07, 2013 3:05 pm

NOTE:
May 7th = Starting a brand new thread, and asking for the old one to be locked. Its getting too long, and out of hand.
Plus, since Wheezy has just gone stable, mean old SID has just woken up with lots of updates and potential breakages.

(OLD Thread for reference)
viewtopic.php?f=198&t=70230

==============================

LMDE = (Linux Mint Debian Edition) Breakages

I wanted to start this thread in hopes that the few of us who are using LMDE tracking the Debian “ SID” or "Experimental" repositories.
Can have a place to post problems and fixes.
--------------------------

This thread is for LMDE tracking SID (SID/Experimental)only

For Breakages related to LMDE tracking "Testing", please look here.
viewtopic.php?f=198&t=67502
--------------------------
For Breakages related to LMDE tracking "Update Packs", please look here
viewforum.php?f=185


===================================================================
===================================================================



Its gotten to the point that the standard Mint apt-pinning is no longer tenable while tracking SID.
Distribution-Upgrades will be held back by the Mint Repo


1. Just delete the etc/apt/preferences file.


OR:
2. As ROOT edit etc/apt/preferences from
[/b][/color]
ORIGINAL:
Code: Select all
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500


CHANGE TO:
Code: Select all
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 700



====================================================================================================================
====================================================================================================================


My Active SID sources list
Code: Select all
deb http://mirror.csclub.uwaterloo.ca/linuxmint-packages/ debian main upstream import backport romeo
deb http://http.us.debian.org/debian/ unstable main contrib non-free #"SID"
deb http://www.deb-multimedia.org sid main non-free #"SID Multimedia"


Craigevils' BIG sources list.

https://sites.google.com/site/mydebiansourceslist/

-------------------------------------------------------


Other helpful Forums

I find it of great value to track the
The SIDUCTION 'upgrade warnings' forum
http://siduction.org/index.php?name=PNp ... 62572eecb7

The APTOSID forum
http://aptosid.com/index.php?name=PNphp ... c27c096455

And the Debian main forum (actually not that helpful maybe even hostile to SID).. :P
http://forums.debian.net/viewforum.php?f=20

-------------------------------------------------------

Other helpful links

LMDE "Testing" Breakages"
viewtopic.php?f=198&t=67502

Debian Weather
http://edos.debian.net/weather/

Status of Gnome 3.12 in Debian
https://www.0d.be/debian/debian-gnome-3.12-status.html

"Gerd50's" Souces.list (s)
viewtopic.php?f=197&t=79533

The "New" LMDE FAQ
viewtopic.php?f=197&t=159257

"borgio3's" LMDE User's Guide
http://livelinux.altervista.org/Guida_L ... ex_en.html

=================================================================


Please post any problems or questions that you may be having, and hopefully someone with more experience than me will join in and help.

Also to post warnings to help us avoid upgrades that will bork our systems. If you find this of interest, just subscribe to this thread for notifications.

Thanks.

Edited:
updated 7.16.14
Last edited by GeneC on Wed Jul 16, 2014 11:09 am, edited 5 times in total.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Tue May 07, 2013 3:07 pm

GeneC wrote:Bug with : ifupdown 0.7.41

http://aptosid.com/index.php?name=PNphp ... pic&t=2584
http://www.mail-archive.com/debian-bugs ... 17963.html

Suggested to put on hold until ifupdown 0.7.43


OK to upgrade. ifupdown 0.7.43 has already hit the repos.
Code: Select all
gene@solydx64:~$ apt-cache policy ifupdown
ifupdown:
  Installed: 0.7.43
  Candidate: 0.7.43
  Version table:
 *** 0.7.43 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Lots of updates today. One for libc6
Code: Select all
gene@solydx64:~$ apt-cache policy libc6
libc6:
  Installed: 2.17-1
  Candidate: 2.17-1
  Version table:
 *** 2.17-1 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Pop-up screen appears. I just hit enter, and continued. No issues on re-boot.
Image
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby SirSelim on Tue May 07, 2013 8:31 pm

Dist-upgrade wants to remove Libreoffice amongst others.
Code: Select all
miles@miles_lappy:~$ sudo apt-get dist-upgrade
[sudo] password for miles:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libcaca0:i386 libcups2:i386 libdrm-intel1:i386 libfontconfig1:i386 libfreetype6:i386 libgdk-pixbuf2.0-0:i386 libgl1-mesa-dri:i386 libglib2.0-0:i386 libgnutls26:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libmng1:i386 libnss3:i386 libpciaccess0:i386 libpng12-0:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386
  libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386 libreoffice libreoffice-base libreoffice-report-builder-bin libsdl1.2debian:i386 libssl1.0.0:i386 libtiff4:i386 libxml2:i386 skype:i386 zlib1g:i386
The following packages have been kept back:
  libexttextcat-data
The following packages will be upgraded:
  debhelper freeglut3 gir1.2-gtk-2.0 gtk2-engines-pixbuf lib32z1 libfribidi0 libgail-common libgail18 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtk2.0-dev libhsqldb-java libmuparser2 zlib-bin
  zlib1g zlib1g-dbg zlib1g-dev
18 upgraded, 0 newly installed, 31 to remove and 1 not upgraded.
Need to get 14.5 MB of archives.
After this operation, 221 MB disk space will be freed.
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Tue May 07, 2013 11:52 pm

zlib1g 32-bit is lagging behind zlib1g 64-bit (Debian's 32-bit repos seem to lag behind the 64-bit repos quite often, apparently...), which would be why those 32-bit packages want to be removed.

libexttextcat-data needs to be updated for LibreOffice as libreoffice-core now depends on libexttextcat-2.0-0 rather than libexttextcat0, and libexttextcat-2.0-0 needs a matching version of libexttextcat-data. (I also ran into some issues with libgraphite2-2.0.0 conflicting with libgraphite2-3, another changed dependency of libreoffice-core, so if you run into trouble you may have to manually remove libgraphite2-2.0.0 so libgraphite2-3 can be installed.)
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby SirSelim on Wed May 08, 2013 12:09 am

karashata wrote:zlib1g 32-bit is lagging behind zlib1g 64-bit (Debian's 32-bit repos seem to lag behind the 64-bit repos quite often, apparently...), which would be why those 32-bit packages want to be removed.

libexttextcat-data needs to be updated for LibreOffice as libreoffice-core now depends on libexttextcat-2.0-0 rather than libexttextcat0, and libexttextcat-2.0-0 needs a matching version of libexttextcat-data. (I also ran into some issues with libgraphite2-2.0.0 conflicting with libgraphite2-3, another changed dependency of libreoffice-core, so if you run into trouble you may have to manually remove libgraphite2-2.0.0 so libgraphite2-3 can be installed.)


Thanks karashata. I've resolved the libexttextcat-data/libreoffice issue by pulling the latest LibreOffice from experimental (solving all the other dependencies at the same time).

Cheers for the heads up on zlib1g, I'll hold this for now.
User avatar
SirSelim
Level 1
Level 1
 
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

LMDE Breakages (Tracking SID) May 8, 2013

Postby karashata on Wed May 08, 2013 4:05 am

zlib1g:i386 is finally in the repo, it should be safe to update it (and the amd64 package) now.

gcc4.8-base:i386, however, is not, so gcc4.8 updates for multiarch users will have to wait until that shows up.

That is all.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Thu May 09, 2013 4:04 am

From a working Debian Wheezy, I change the repos to tracking Debian sid,

Code: Select all
####################
## Debian Unstable ##
####################
# Debian sid FAQ - http://wiki.debian.org/DebianUnstable#FAQ
# There is no security, volatile or backports repo for unstable.
# Unstable Sid
deb http://ftp.jp.debian.org/debian/ unstable main contrib non-free
# Unstable Sources
deb-src http://ftp.jp.debian.org/debian/ unstable main contrib non-free



Now, trying to d.u , capture all here, just in case :mrgreen:
Calculating upgrade... Done
The following packages will be REMOVED:
libreoffice libreoffice-base libreoffice-report-builder-bin
The following NEW packages will be installed:
firmware-linux-free gcc-4.8-base libcloog-ppl1 libffi6 libfftw3-double3
libfftw3-single3 libgcc-4.7-dev libgmpxx4ldbl libintl-perl libmozjs17d
libmpc3 libppl-c4 libppl12 libprocps1 libtext-unidecode-perl
libxml-libxml-perl libxml-namespacesupport-perl libxml-sax-base-perl
libxml-sax-expat-perl libxml-sax-perl libxtables10
linux-headers-3.8-1-686-pae linux-headers-3.8-1-common
linux-image-3.8-1-686-pae linux-kbuild-3.8 xserver-xorg-input-mouse
xserver-xorg-input-vmmouse xulrunner-17.0
The following packages have been kept back:
libexttextcat-data
The following packages will be upgraded:
alsa-base apt apt-utils base-files bash bc bsdmainutils busybox cpp-4.6
cpp-4.7 dbus dbus-x11 dc debconf debconf-i18n diffutils dmidecode dmsetup
dnsmasq-base dosfstools fglrx-atieventsd fglrx-control fglrx-driver
fglrx-modules-dkms file fonts-opensymbol fuse g++-4.7 gcc-4.6 gcc-4.6-base
gcc-4.7 gcc-4.7-base geoip-database gir1.2-freedesktop gir1.2-gdkpixbuf-2.0
gir1.2-glib-2.0 glib-networking glib-networking-common
glib-networking-services glx-alternative-fglrx glx-alternative-mesa
glx-diversions groff-base grub-common grub-pc grub-pc-bin grub2-common
gtk2-engines-pixbuf hyphen-en-us iceweasel ifupdown info initramfs-tools
install-info iproute iptables isc-dhcp-client isc-dhcp-common iso-codes
libaacs0 libapt-inst1.5 libapt-pkg4.12 libatasmart4 libaudiofile1 libc-bin
libc-dev-bin libc6 libc6-dev libc6-i686 libcairo-gobject2 libcairo2
libcommons-beanutils-java libcurl3-gnutls libdbus-1-3 libdc1394-22 libdca0
libdevmapper-event1.02.1 libdevmapper1.02.1 libdiscid0 libdvdnav4
libdvdread4 libenca0 libexpat1 libexpat1-dev libfftw3-3 libfglrx
libfglrx-amdxvba1 libfribidi0 libfuse2 libgail18 libgcc1 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-common libgeoip1 libgfortran3 libgimp2.0
libgirepository-1.0-1 libgl1-fglrx-glx libglib2.0-0 libglib2.0-data libgmp10
libgomp1 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgusb2 libhsqldb-java
libhyphen0 libieee1284-3 libio-socket-ip-perl libitm1 libkeybinder0
libkeyutils1 liblapack3 liblapack3gf liblvm2app2.2 libmagic1 libmozjs10d
libmpfr4 libmtdev1 libmtp-common libmtp-runtime libmtp9 libnm-glib-vpn1
libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libnspr4 libnspr4-0d
liborc-0.4-0 libpipeline1 libpng12-0 libquadmath0 libquvi-scripts
libraptor2-0 librasqal3 libraw1394-11 libreadline5 libreoffice-base-core
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-emailmerge libreoffice-filter-binfilter
libreoffice-filter-mobiledev libreoffice-gtk libreoffice-help-en-us
libreoffice-impress libreoffice-java-common libreoffice-math
libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer librtmp0
libsensors4 libsmbclient libsnmp-base libsnmp15 libsqlite3-0 libstdc++6
libstdc++6-4.7-dev libtar0 libtie-ixhash-perl libusb-1.0-0 libv4l-0
libv4lconvert0 libvisio-0.0-0 libvlc5 libvlccore5 libwbclient0 libwpd-0.9-9
libwps-0.2-2 libzvbi-common libzvbi0 linux-headers-686-pae
linux-image-686-pae linux-libc-dev lm-sensors locales m4 man-db mime-support
mobile-broadband-provider-info multiarch-support netbase network-manager
network-manager-gnome ntfs-3g nvidia-installer-cleanup openssh-client
plymouth plymouth-drm plymouth-themes-all plymouth-themes-fade-in
plymouth-themes-glow plymouth-themes-script plymouth-themes-solar
plymouth-themes-spinfinity plymouth-themes-spinner plymouth-x11 poppler-data
procps python python-apt python-apt-common python-dbus python-dbus-dev
python-dev python-gi python-gobject python-minimal python-pkg-resources
python-setuptools python-six python-uno python2.6 python2.6-minimal
samba-common samba-common-bin smbclient synaptic tar task-desktop
task-english task-laptop task-print-server task-xfce-desktop tasksel
tasksel-data texinfo traceroute unattended-upgrades uno-libs3 unzip ure
usb-modeswitch usb-modeswitch-data usbutils vim-common vim-tiny vlc vlc-data
vlc-nox vlc-plugin-notify vlc-plugin-pulse whois x11-common xdg-utils xorg
xserver-xorg xserver-xorg-input-all xserver-xorg-video-all xulrunner-10.0
zlib1g zlib1g-dev
257 upgraded, 28 newly installed, 3 to remove and 1 not upgraded.
Need to get 311 MB of archives.
After this operation, 174 MB of additional disk space will be used.
Do you want to continue [Y/n]?



EDIT:
Reboot, oh well, it works.. :mrgreen:

check a few things
1. fglrx no issue, was running well on Debian Wheezy, can resume from suspend.


Now with kernel 3.8.1, no issue running fglrx,
Code: Select all
wayne@debian:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5450     
OpenGL version string: 4.2.12217 Compatibility Profile Context 8.982.13

wayne@debian:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
5385 frames in 5.0 seconds = 1077.000 FPS
6393 frames in 5.0 seconds = 1278.600 FPS
6371 frames in 5.0 seconds = 1274.200 FPS


and ati temp is quite cool :mrgreen: around 54degC, saved 10 degC if using radeon driver.
Code: Select all
wayne@debian:~$ aticonfig --odgt

Default Adapter - ATI Radeon HD 5450     
                  Sensor 0: Temperature - 54.00 C




2. Libreoffice removed as expected after reading posts above and watching d.u message.

3. youtubem video/sound all OK

but I lost the ability of using the keyboard's volume thumb-wheel to adjust volume.

4. all previous configurations seem to stay , lm-sensors , sensors applets all works.

:lol:
wayne128
Level 10
Level 10
 
Posts: 3320
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby gcp on Thu May 09, 2013 7:19 am

.
The python-gi update breaks software-properties-gtk (does not start).

python-gi:amd64 (3.2.2-2, 3.8.1-2
python-gi-cairo:amd64 (3.2.2-2, 3.8.1-2)

and it breaks thumbnail-generation in Nautilus, generating a permanent 100% cpu load on one core.
In /var/log/messages i can see:
kernel: [53942.928595] python[10870]: segfault at 7fcebb9d6d4a ip 00007fcec0de1456 sp 00007fff0faf05d8 error 4 in libc-2.17.so[7fcec0cb7000+1a4000]

forcefully rolling back with dpkg -i solves all problems.
I rolled back to these packages from testing (because of many dependencies):

gir1.2-freedesktop_1.32.1-1_amd64.deb libgdk-pixbuf2.0-0_2.26.1-1_i386.deb libnm-gtk-common_0.9.4.1-5_all.deb
gir1.2-gdkpixbuf-2.0_2.26.1-1_amd64.deb libgdk-pixbuf2.0-common_2.26.1-1_all.deb libnm-util2_0.9.4.0-10_amd64.deb
gir1.2-glib-2.0_1.32.1-1_amd64.deb libgirepository-1.0-1_1.32.1-1_amd64.deb python3-gi_3.2.2-2_amd64.deb
gir1.2-networkmanager-1.0_0.9.4.0-10_amd64.deb libglib2.0-0_2.33.12+really2.32.4-5_amd64.deb python-gi_3.2.2-2_amd64.deb
glib-networking_2.32.3-1_amd64.deb libglib2.0-0_2.33.12+really2.32.4-5_i386.deb python-gi-cairo_3.2.2-2_amd64.deb
glib-networking-common_2.32.3-1_all.deb libglib2.0-bin_2.33.12+really2.32.4-5_amd64.deb python-gobject_3.2.2-2_all.deb
glib-networking-services_2.32.3-1_amd64.deb libnm-glib4_0.9.4.0-10_amd64.deb
libgdk-pixbuf2.0-0_2.26.1-1_amd64.deb libnm-gtk0_0.9.4.1-5_amd64.deb

Am i the only one with these problems? :roll:
<login2 debianSID><sudo apt-get dist-upgrade><DONTTHINK><ENTER><WHOCARES><ENTER><OOHHNOO!><HAVENOBACKUP,IM-A-MAN><reinstalling,Windowslike...>
User avatar
gcp
Level 1
Level 1
 
Posts: 27
Joined: Sat Jul 02, 2011 6:24 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Thu May 09, 2013 7:28 am

gcp wrote:.
The python-gi update breaks software-properties-gtk (does not start).

python-gi:amd64 (3.2.2-2, 3.8.1-2
python-gi-cairo:amd64 (3.2.2-2, 3.8.1-2)

and it breaks thumbnail-generation in Nautilus, generating a permanent 100% cpu load on one core.

Am i the only one with these problems? :roll:



hmm, not sure since I do not use nautilus.
Mine is Debian XFCE.
No issues on all the thumbnail in file manager Thunar

Code: Select all
wayne@debian:~$ apt-cache policy python-gi python-gi-cairo thunar
python-gi:
  Installed: 3.8.1-2
  Candidate: 3.8.1-2
  Version table:
 *** 3.8.1-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
python-gi-cairo:
  Installed: (none)
  Candidate: 3.8.1-2
  Version table:
     3.8.1-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
thunar:
  Installed: 1.2.3-4+b1
  Candidate: 1.2.3-4+b1
  Version table:
 *** 1.2.3-4+b1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
wayne128
Level 10
Level 10
 
Posts: 3320
Joined: Tue Jul 13, 2010 12:15 am

LMDE Breakages (Tracking SID) May 9, 2013

Postby karashata on Thu May 09, 2013 6:27 pm

@gcp: I installed software-properties-gtk (and all of its dependencies) from Ubuntu Raring some time ago when it broke on my Experimental system, it's not a perfect solution but it works. The Mint maintainers will have to clean it up a little for LMDE with their next update pack, most likely.

I also don't see any issues with Nautilus thumbnail generation, but then I'm also running GNOME 3.8 (and Nautilus 3.8 ) from Experimental. It may be a good idea to update GNOME and its various components to version 3.8 if you haven't already, since they have been built to work with those packages now entering SID when they first showed up in Experimental.

EDIT: @wayne128: It would appear that LibreOffice has been updated and should now be available in SID, you should be able to install it from there now. (If you caught my previous message stating to install it from Experimental, don't bother now, it's older than the version recently added to SID.)

EDIT #2: Apparently the python-gi update that was mentioned earlier also broke software-properties-gtk from Ubuntu Raring, though it was fairly easily fixed by installing the slightly older python-gi package from Ubuntu Raring (version 3.8.0-2), then updating python3 and python3-minimal to version 3.3.0-3 from Experimental.

libselinux and libwayland0 currently held back on amd64 multiarch due to i386 lagging behind amd64, hopefully it will catch up shortly.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 9, 2013

Postby wayne128 on Fri May 10, 2013 12:24 am

karashata wrote:EDIT: @wayne128: It would appear that LibreOffice has been updated and should now be available in SID, you should be able to install it from there now. (If you caught my previous message stating to install it from Experimental, don't bother now, it's older than the version recently added to SID.)



Hi karashata,

thanks for your message.

There is some interesting observation.
As you knew from my post, when I d-u, the message said Libreoffice will be removed.

and, this is true
Code: Select all
wayne@debian:~$ apt-cache policy libreoffice
libreoffice:
  Installed: (none)
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
     1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages


But then, the libreoffice is still "working".??
I am puzzled, I seldom use libre office because epdf-viewer, abiword etc were enough for simple viewing of pdf file and word file.

If I click menu>office>libreoffice, it still open the apps and allows me to click and open those apps like presentation/text document/spreadsheet/etc..
Code: Select all
wayne@debian:~$ apt-cache policy libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gtk libreoffice-impress
libreoffice-base-core:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-calc:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-common:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-core:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-draw:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-gtk:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-impress:
  Installed: 1:3.5.4+dfsg2-1
  Candidate: 1:3.5.4+dfsg2-1
  Version table:
 *** 1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status



so, it was removed, yet it is still functional... hmm, perhaps 'partially?' :mrgreen:
wayne128
Level 10
Level 10
 
Posts: 3320
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Fri May 10, 2013 12:49 am

@wayne128: Ah, you're on i386... amd64 has recently been upped to 1:4.0.3-1, so expect that to show up in i386 SID soon.

(Why is Debian's i386 arch repository lagging so long behind the amd64 arch repository..?)

EDIT: I gaffed earlier, libwayland0 is held back due to libegl1-mesa and libegl1-mesa-drivers dependency issues with the newer version, not due to i386 lagging. libselinux:i386 has shown up so that update can be installed now on multiarch systems.

EDIT #2: python-gi from SID seems to work fine now with software-properties-gtk from Ubuntu Raring and python3 version 3.3.0-3, there's no need to install python-gi from Ubuntu Raring anymore to make it work, just in case anyone's wondering.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby arcorreia on Sun May 12, 2013 10:57 am

As of this morning and after an update can't open repositories dialogue in synaptic, it complains that the repos have changed and must be reloaded but even after reloading (no error messages either in synaptic or apt-get) nothing changes and it gives the same message. Any ideas on how to fix this?

PS - I didn't change anything in sources.list and it was working fine until now.

Best regards,
arcorreia
Image
User avatar
arcorreia
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 07, 2012 9:44 am
Location: Cascais, Portugal

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Sun May 12, 2013 3:04 pm

I'm not 100% sure, but I think the version of software-properties-gtk that LMDE currently ships doesn't work properly with a lot of the recent updates flooding into SID. I run on the Experimental repos myself and had to grab software-properties-gtk from Ubuntu Raring some time ago when updates in Experimental broke the version LMDE currently ships with, the version in Raring has been updated to work with a lot of the newer packages that were first showing up in Experimental, a lot of which are now being updated in SID, so perhaps grabbing software-properties-gtk (and all of its dependencies) from Raring might help you (and anyone else having issues with it).

For you (and anyone else who might want to consider it), here's a list of all of the packages you'll need to grab:

python-software-properties (0.92.17)
python3-aptdaemon (1.0-0ubuntu9)
python3-aptdaemon.gtk3widgets (1.0-0ubuntu9)
python3-software-properties (0.92.17)
python3-xkit (0.5.0ubuntu1)
software-properties-common (0.92.17)
software-properties-gtk (0.92.17)
ubuntu-drivers-common (1:0.2.76)

You'll also need to install python3 and python3-minimal 3.3.0-3 from Experimental, and you should already have python-gi 3.8.1-3 installed as part of a recent update in SID.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby Regulus74 on Sun May 12, 2013 5:57 pm

When I launch alacarte:

Traceback (most recent call last):
File "/usr/bin/alacarte", line 23, in <module>
from Alacarte.MainWindow import MainWindow
File "/usr/share/alacarte/Alacarte/MainWindow.py", line 32, in <module>
from Alacarte.MenuEditor import MenuEditor
File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 23, in <module>
from Alacarte import util
File "/usr/share/alacarte/Alacarte/util.py", line 25, in <module>
from gi._glib import GError
ImportError: cannot import name GError

and Nautilus Search button does not work :( :evil:
Arch Linux user
User avatar
Regulus74
Level 2
Level 2
 
Posts: 62
Joined: Mon Oct 03, 2011 6:07 pm
Location: Mantova - Italy

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Sun May 12, 2013 6:04 pm

Try installing the version of Alacarte shipping in the GNOME 3 PPA for Ubuntu Raring (https://launchpad.net/~gnome3-team/+archive/gnome3). It's already up-to-date with the changes in the gi repository that are breaking Alacarte in Debian.

I already filed a bug report on Alacarte in Debian Experimental related to this issue, you can read and add to the report here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=705387

Nautilus search button works fine here (Nautilus 3.80.1 from Experimental, mind you), what version are you currently running..?
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby Regulus74 on Sun May 12, 2013 6:11 pm

karashata wrote:Nautilus search button works fine here (Nautilus 3.80.1 from Experimental, mind you), what version are you currently running..?


Nautilus 3.4.2-1+build1
Arch Linux user
User avatar
Regulus74
Level 2
Level 2
 
Posts: 62
Joined: Mon Oct 03, 2011 6:07 pm
Location: Mantova - Italy

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby karashata on Sun May 12, 2013 6:20 pm

Hm. I doubt if that version is ready for a lot of the changes coming down the line in SID, it may be time to (temporarily) add Experimental to your repos list and update everything to GNOME 3.8. Most of the changes that seem to be happening in SID right now have been in Experimental for a while and most of the GNOME components have already been updated to use those newer packages. Alacarte is currently the only package I've had to pull from the Ubuntu GNOME 3 PPA because Debian's version is too far out-of-date for the newer versions of the gi repository, at least based on what I can figure...

I suspect GNOME 3.8 will probably make its way into SID soon, so you could potentially just wait it out, if you can put up with a few breakages here and there as they update everything else that GNOME 3.8 will depend on.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby GeneC on Sun May 12, 2013 7:38 pm

Thanks for the updates folks..

Some minor issues but nothing very serious.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE Breakages (Tracking SID) May 7, 2013

Postby wayne128 on Sun May 12, 2013 10:33 pm

Took 10 minutes to clone with fsarchiver.

now, trying to d-u
Code: Select all
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libexttextcat0 libgraphite2-2.0.0 libreoffice-filter-binfilter
The following NEW packages will be installed:
  fonts-dejavu fonts-dejavu-core fonts-dejavu-extra libboost-date-time1.49.0
  libboost-date-time1.53.0 libcdr-0.0-0 libcmis-0.3-3 libee0 libestr0
  libexttextcat-2.0-0 libgraphite2-3 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 liblangtag-common liblangtag1 liblognorm0 libmspub-0.0-0
  liborcus-0.4-0 libtasn1-6 libzip2
The following packages will be upgraded:
  alsa-utils cdrdao console-setup console-setup-linux fonts-droid
  fonts-opensymbol gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-glib-2.0
  grub-common grub-pc grub-pc-bin grub2-common gtk2-engines-oxygen
  gtk3-engines-oxygen hpijs hplip hplip-data icedtea-netx-common
  keyboard-configuration less libasound2 libatk1.0-0 libatk1.0-data
  libbonobo2-0 libbonobo2-common libcurl3-gnutls libdatrie1 libestools2.1
  libexttextcat-data libffi6 libgirepository-1.0-1 libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-data libglu1-mesa
  libgnome2-0 libgnome2-common libgnomevfs2-0 libgnomevfs2-common
  libgnomevfs2-extra libgnutls26 libhpmud0 libhtml-parser-perl
  liblightdm-gobject-1-0 libmimic0 libncurses5 libncursesw5 libnettle4 libogg0
  libopus0 libparted0debian1 libpcsclite1 libppl-c4 libppl12 libquvi-scripts
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-filter-mobiledev
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-math libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer libsane-hpaio libsdl-image1.2
  libselinux1 libsemanage-common libsemanage1 libsepol1 libshout3 libsmbclient
  libsoundtouch0 libsoup-gnome2.4-1 libsoup2.4-1 libthai-data libthai0
  libtinfo5 libwbclient0 libwpd-0.9-9 libxapian22 lightdm lightdm-gtk-greeter
  linux-headers-3.8-1-686-pae linux-headers-3.8-1-common
  linux-image-3.8-1-686-pae linux-libc-dev mime-support ncurses-base
  ncurses-bin ncurses-term net-tools nfs-common openssh-client
  printer-driver-hpcups printer-driver-hpijs printer-driver-postscript-hp
  python-gi python-gobject python-gobject-2 python-uno python-webkit rsyslog
  samba-common samba-common-bin sed smbclient ttf-dejavu ttf-dejavu-core
  ttf-dejavu-extra uno-libs3 ure whois xserver-xorg-video-geode
123 upgraded, 20 newly installed, 3 to remove and 0 not upgraded.
Need to get 187 MB of archives.
After this operation, 22.1 MB disk space will be freed.
Do you want to continue [Y/n]?




Edit:
@ karashata » Fri May 10, 2013 1:49 pm
it seems libreoffice -32bit has updated itself ti 1:4.0.3-1
@wayne128: Ah, you're on i386... amd64 has recently been upped to 1:4.0.3-1, so expect that to show up in i386 SID soon.

(Why is Debian's i386 arch repository lagging so long behind the amd64 arch repository..?)



Code: Select all
wayne@debian:~$ apt-cache policy libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gtk libreoffice-impress
libreoffice-base-core:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-calc:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-common:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.4+dfsg2-1 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
libreoffice-core:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-draw:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-gtk:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
libreoffice-impress:
  Installed: 1:4.0.3-2
  Candidate: 1:4.0.3-2
  Version table:
 *** 1:4.0.3-2 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status



Also, now grub2 is version 2.00.

All works.
wayne128
Level 10
Level 10
 
Posts: 3320
Joined: Tue Jul 13, 2010 12:15 am

Linux Mint is funded by ads and donations.
 
Next

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests