UP7 ERROR pkgProblemResolver::Resolve generated breaks

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby drcasper on Tue Sep 24, 2013 3:13 am

hi,

Im trying to upgrade to UP7 but i get this message:

after $ sudo apt-get upgrade
Code: Select all
Setting up mint-debian-mirrors (2013.09.23) ...
Traceback (most recent call last):
  File "/var/lib/dpkg/info/mint-debian-mirrors.postinst", line 4, in <module>
    import pycurl
ImportError: /usr/lib/pymodules/python2.7/pycurl.so: undefined symbol: _PyTrash_thread_destroy_chain
dpkg: error processing mint-debian-mirrors (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mint-debian-mirrors
E: Sub-process /usr/bin/dpkg returned an error code (1)


after $ sudo apt-get dist-upgrade
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 gstreamer0.10-plugins-good : Depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) but it is not going to be installed or
                                       libjack-0.116
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


/etc/apt/sources.list
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.lth.se/lmde/latest testing main contrib non-free
deb http://debian.lth.se/lmde/latest/security testing/updates main contrib non-free
deb http://debian.lth.se/lmde/latest/multimedia testing main non-free
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Linux Mint is funded by ads and donations.
 

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby casper956 on Tue Sep 24, 2013 3:52 am

I have the same problem and haven't find the solution yet.
casper956
Level 1
Level 1
 
Posts: 10
Joined: Sun Jan 27, 2013 8:27 am
Location: Amsterdam

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby Monsta on Tue Sep 24, 2013 7:47 am

  1. Forget about apt-get upgrade and only use apt-get dist-upgrade.

  2. Try
    Code: Select all
    sudo dpkg --configure mint-debian-mirrors

  3. For more info about the unmet dependencies, try
    Code: Select all
    sudo aptitude full-upgrade
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby drcasper on Thu Sep 26, 2013 2:25 am

I am not sure if this did it, but i renamed

Code: Select all
/usr/share/python-apt/templates/LinuxMint.mirrors
to LinuxMint.mirrors.old


and then run
Code: Select all
apt-get dist-upgrade
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby toad on Tue Oct 01, 2013 11:56 am

Suffering from the same problem.
Code: Select all
Setting up mint-debian-mirrors (2013.09.23) ...
Traceback (most recent call last):
  File "/var/lib/dpkg/info/mint-debian-mirrors.postinst", line 4, in <module>
    import pycurl
ImportError: /usr/lib/pymodules/python2.7/pycurl.so: undefined symbol: _PyTrash_thread_destroy_chain
dpkg: error processing mint-debian-mirrors (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mint-debian-mirrors
E: Sub-process /usr/bin/dpkg returned an error code (1)


/usr/share/python-apt/templates/LinuxMint.mirrors didn't exist, so I created it but no joy...
never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::
User avatar
toad
Level 1
Level 1
 
Posts: 49
Joined: Sun Feb 20, 2011 10:04 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby Monsta on Tue Oct 01, 2013 1:23 pm

Please post the output of:
Code: Select all
apt-cache policy python-pycurl
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby toad on Tue Oct 01, 2013 1:30 pm

Code: Select all
toad@laptoad ~ $ apt-cache policy python-pycurl
python-pycurl:
  Installed: 7.19.0-7
  Candidate: 7.19.0-7
  Version table:
 *** 7.19.0-7 0
        500 http://mirror.rts-informatique.fr/linuxmint/debian/latest/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::
User avatar
toad
Level 1
Level 1
 
Posts: 49
Joined: Sun Feb 20, 2011 10:04 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby Monsta on Tue Oct 01, 2013 2:20 pm

Try reinstalling it:
Code: Select all
sudo apt-get install --reinstall python-pycurl
and then configure mint-debian-mirrors:
Code: Select all
sudo dpkg --configure mint-debian-mirrors
Monsta
Level 8
Level 8
 
Posts: 2447
Joined: Fri Aug 19, 2011 3:46 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby toad on Thu Oct 03, 2013 3:01 am

Thanks very much for your reply. Did the reinstall as you suggested but no improvement. I'm still getting the same error message.

The problem occurs on my Thinkpad T61 only - the update went through fine on my desktop (using the http://tux.rainside.sk/ mirror).

Will experiment further and am always grateful for new suggestions.
never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::
User avatar
toad
Level 1
Level 1
 
Posts: 49
Joined: Sun Feb 20, 2011 10:04 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby quixote on Wed Oct 09, 2013 6:04 pm

I had the same error message after sudo apt-get update on a new install of downloaded LMDE 201303 64-bit Mate. This solution worked for me:
drcasper wrote:I am not sure if this did it, but i renamed
Code: Select all
/usr/share/python-apt/templates/LinuxMint.mirrors
to LinuxMint.mirrors.old

and then run
Code: Select all
apt-get dist-upgrade

Now, I was trying it in a virtual machine. I'm not sure I would have had the courage to do something like that on my production machine! But at least on the VM, it worked.
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby nbxmike on Wed Oct 16, 2013 8:43 am

quixote wrote:I had the same error message after sudo apt-get update on a new install of downloaded LMDE 201303 64-bit Mate. This solution worked for me:
drcasper wrote:I am not sure if this did it, but i renamed
Code: Select all
/usr/share/python-apt/templates/LinuxMint.mirrors
to LinuxMint.mirrors.old

and then run
Code: Select all
apt-get dist-upgrade

Now, I was trying it in a virtual machine. I'm not sure I would have had the courage to do something like that on my production machine! But at least on the VM, it worked.


Has anyone tested this on a live system, I really don't want to wipe my disk and I have the same problem.
nbxmike
Level 1
Level 1
 
Posts: 1
Joined: Sun Apr 29, 2012 10:37 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby drcasper on Wed Oct 16, 2013 9:23 am

nbxmike wrote:
quixote wrote:I had the same error message after sudo apt-get update on a new install of downloaded LMDE 201303 64-bit Mate. This solution worked for me:
drcasper wrote:I am not sure if this did it, but i renamed
Code: Select all
/usr/share/python-apt/templates/LinuxMint.mirrors
to LinuxMint.mirrors.old

and then run
Code: Select all
apt-get dist-upgrade

Now, I was trying it in a virtual machine. I'm not sure I would have had the courage to do something like that on my production machine! But at least on the VM, it worked.


Has anyone tested this on a live system, I really don't want to wipe my disk and I have the same problem.


Yes, i did this on "live installation" not on Virtual Machine
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby quixote on Sun Oct 27, 2013 10:27 pm

Good to know. I've now tried it on a live system, and it worked for me too. :D
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: UP7 ERROR pkgProblemResolver::Resolve generated breaks

Postby pallando on Sun Nov 03, 2013 6:40 pm

I just ran into this on virtual machine install. I managed to fix it by doing the following

Code: Select all
mv /usr/share/python-apt/templates/LinuxMint.mirrors{,.old}
sudo apt-get install --reinstall python2.7 python-pycurl


This should trigger a reconfigure of mint-debian-mirrors; but if not you can manually do so.

Code: Select all
sudo dpkg --configure mint-debian-mirrors


Hope that helps.
pallando
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 03, 2013 6:24 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests