UP 7 ...well but ...missing system fonts [solved]

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP 7 ...well but ...missing system fonts [solved]

Postby xfrank on Tue Sep 24, 2013 9:30 am

I have just update LMDE to 7. All went fine (unbelievably!), I'm happy :P , but strangely the system don't "see" anymore the system fonts, only the fonts in the /home/.font folder are active. So, the default "sans" font has changed to a serif font. :shock:
I did check in synaptic, the missing fonts are indeed marked as installed. To be sure, I reinstalled some fonts (Droid, Liberation) but nothing, they are not recognized by the system. I did check also in usr/share/fonts and seems that fonts are all there.
Finally, gtk2fontsel (a font viewer) don't work properly.

¿How I can fix this?


*forgot to mention: Libreoffice "see" the system fonts. :!:
Last edited by xfrank on Sat Oct 26, 2013 10:10 am, edited 2 times in total.
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Linux Mint is funded by ads and donations.
 

Re: UP 7 ...well but ...missing system fonts

Postby teatime on Tue Sep 24, 2013 4:44 pm

Hi

Have you already tried to rebuild the font cache?

fc-cache -fv
teatime
Level 2
Level 2
 
Posts: 65
Joined: Thu Aug 16, 2012 12:47 pm

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Tue Sep 24, 2013 7:38 pm

thanks teatime, but still no system fonts:

Code: Select all
 xflmde xfrank # fc-cache -fv
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 135: Having multiple values in <test> isn't supported and may not work as expected
/usr/share/fonts: caching, new cache contents: 0 fonts, 5 dirs
/usr/share/fonts/X11: caching, new cache contents: 0 fonts, 4 dirs
/usr/share/fonts/X11/Type1: caching, new cache contents: 36 fonts, 0 dirs
/usr/share/fonts/X11/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/X11/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/misc: caching, new cache contents: 95 fonts, 0 dirs
/usr/share/fonts/X11/util: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap: caching, new cache contents: 0 fonts, 5 dirs
/usr/share/fonts/cmap/adobe-cns1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-gb1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-japan1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-japan2: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-korea1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/opentype: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/opentype/cantarell: caching, new cache contents: 2 fonts, 0 dirs
/usr/share/fonts/truetype: caching, new cache contents: 0 fonts, 11 dirs
/usr/share/fonts/truetype/dejavu: caching, new cache contents: 21 fonts, 0 dirs
/usr/share/fonts/truetype/droid: caching, new cache contents: 18 fonts, 0 dirs
/usr/share/fonts/truetype/freefont: caching, new cache contents: 12 fonts, 0 dirs
/usr/share/fonts/truetype/gentium: caching, new cache contents: 4 fonts, 0 dirs
/usr/share/fonts/truetype/gentium-basic: caching, new cache contents: 8 fonts, 0 dirs
/usr/share/fonts/truetype/liberation: caching, new cache contents: 16 fonts, 0 dirs
/usr/share/fonts/truetype/msttcorefonts: caching, new cache contents: 60 fonts, 0 dirs
/usr/share/fonts/truetype/openoffice: caching, new cache contents: 1 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-dejavu: caching, new cache contents: 21 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-liberation: caching, new cache contents: 16 fonts, 0 dirs
/usr/share/fonts/truetype/ubuntu-font-family: caching, new cache contents: 4 fonts, 0 dirs
/usr/share/fonts/type1: caching, new cache contents: 0 fonts, 2 dirs
/usr/share/fonts/type1/gsfonts: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/type1/mathml: caching, new cache contents: 1 fonts, 0 dirs
/usr/X11R6/lib/X11/fonts: skipping, no such directory
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/cache/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Tue Sep 24, 2013 7:59 pm

if this can help someone to help me, this is the content of my fonts.conf file:

Code: Select all
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
   DO NOT EDIT THIS FILE.
   IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
   LOCAL CHANGES BELONG IN 'local.conf'.

   The intent of this standard configuration file is to be adequate for
   most environments.  If you have a reasonably normal environment and
   have found problems with this configuration, they are probably
   things that others will also want fixed.  Please submit any
   problems to the fontconfig bugzilla system located at fontconfig.org

   Note that the normal 'make install' procedure for fontconfig is to
   replace any existing fonts.conf file with the new version.  Place
   any local customizations in local.conf which this file references.

   Keith Packard
-->

<!-- Font directory list -->

   <dir>/usr/share/fonts</dir>
   <dir>/usr/X11R6/lib/X11/fonts</dir> <dir>/usr/local/share/fonts</dir>
   <dir prefix="xdg">fonts</dir>
   <!-- the following element will be removed in the future -->
   <dir>~/.fonts</dir>

<!--
  Accept deprecated 'mono' alias, replacing it with 'monospace'
-->
   <match target="pattern">
      <test qual="any" name="family">
         <string>mono</string>
      </test>
      <edit name="family" mode="assign" binding="same">
         <string>monospace</string>
      </edit>
   </match>

<!--
  Accept alternate 'sans serif' spelling, replacing it with 'sans-serif'
-->
   <match target="pattern">
      <test qual="any" name="family">
         <string>sans serif</string>
      </test>
      <edit name="family" mode="assign" binding="same">
         <string>sans-serif</string>
      </edit>
   </match>

<!--
  Accept deprecated 'sans' alias, replacing it with 'sans-serif'
-->
   <match target="pattern">
      <test qual="any" name="family">
         <string>sans</string>
      </test>
      <edit name="family" mode="assign" binding="same">
         <string>sans-serif</string>
      </edit>
   </match>

<!--
  Load local system customization file
-->
   <include ignore_missing="yes">/etc/fonts/conf.d</include>

<!-- Font cache directory list -->

   <cachedir>/var/cache/fontconfig</cachedir>
   <cachedir prefix="xdg">fontconfig</cachedir>
   <!-- the following element will be removed in the future -->
   <cachedir>~/.fontconfig</cachedir>

   <config>
<!--
  These are the default Unicode chars that are expected to be blank
  in fonts.  All other blank chars are assumed to be broken and
  won't appear in the resulting charsets
 -->
      <blank>
         <int>0x0020</int>   <!-- SPACE -->
         <int>0x00A0</int>   <!-- NO-BREAK SPACE -->
         <int>0x00AD</int>   <!-- SOFT HYPHEN -->
         <int>0x034F</int>   <!-- COMBINING GRAPHEME JOINER -->
         <int>0x0600</int>   <!-- ARABIC NUMBER SIGN -->
         <int>0x0601</int>   <!-- ARABIC SIGN SANAH -->
         <int>0x0602</int>   <!-- ARABIC FOOTNOTE MARKER -->
         <int>0x0603</int>   <!-- ARABIC SIGN SAFHA -->
         <int>0x06DD</int>   <!-- ARABIC END OF AYAH -->
         <int>0x070F</int>   <!-- SYRIAC ABBREVIATION MARK -->
         <int>0x115F</int>   <!-- HANGUL CHOSEONG FILLER -->
         <int>0x1160</int>   <!-- HANGUL JUNGSEONG FILLER -->
         <int>0x1680</int>   <!-- OGHAM SPACE MARK -->
         <int>0x17B4</int>   <!-- KHMER VOWEL INHERENT AQ -->
         <int>0x17B5</int>   <!-- KHMER VOWEL INHERENT AA -->
         <int>0x180E</int>   <!-- MONGOLIAN VOWEL SEPARATOR -->
         <int>0x2000</int>   <!-- EN QUAD -->
         <int>0x2001</int>   <!-- EM QUAD -->
         <int>0x2002</int>   <!-- EN SPACE -->
         <int>0x2003</int>   <!-- EM SPACE -->
         <int>0x2004</int>   <!-- THREE-PER-EM SPACE -->
         <int>0x2005</int>   <!-- FOUR-PER-EM SPACE -->
         <int>0x2006</int>   <!-- SIX-PER-EM SPACE -->
         <int>0x2007</int>   <!-- FIGURE SPACE -->
         <int>0x2008</int>   <!-- PUNCTUATION SPACE -->
         <int>0x2009</int>   <!-- THIN SPACE -->
         <int>0x200A</int>   <!-- HAIR SPACE -->
         <int>0x200B</int>   <!-- ZERO WIDTH SPACE -->
         <int>0x200C</int>   <!-- ZERO WIDTH NON-JOINER -->
         <int>0x200D</int>   <!-- ZERO WIDTH JOINER -->
         <int>0x200E</int>   <!-- LEFT-TO-RIGHT MARK -->
         <int>0x200F</int>   <!-- RIGHT-TO-LEFT MARK -->
         <int>0x2028</int>   <!-- LINE SEPARATOR -->
         <int>0x2029</int>   <!-- PARAGRAPH SEPARATOR -->
         <int>0x202A</int>   <!-- LEFT-TO-RIGHT EMBEDDING -->
         <int>0x202B</int>   <!-- RIGHT-TO-LEFT EMBEDDING -->
         <int>0x202C</int>   <!-- POP DIRECTIONAL FORMATTING -->
         <int>0x202D</int>   <!-- LEFT-TO-RIGHT OVERRIDE -->
         <int>0x202E</int>   <!-- RIGHT-TO-LEFT OVERRIDE -->
         <int>0x202F</int>   <!-- NARROW NO-BREAK SPACE -->
         <int>0x205F</int>   <!-- MEDIUM MATHEMATICAL SPACE -->
         <int>0x2060</int>   <!-- WORD JOINER -->
         <int>0x2061</int>   <!-- FUNCTION APPLICATION -->
         <int>0x2062</int>   <!-- INVISIBLE TIMES -->
         <int>0x2063</int>   <!-- INVISIBLE SEPARATOR -->
         <int>0x206A</int>   <!-- INHIBIT SYMMETRIC SWAPPING -->
         <int>0x206B</int>   <!-- ACTIVATE SYMMETRIC SWAPPING -->
         <int>0x206C</int>   <!-- INHIBIT ARABIC FORM SHAPING -->
         <int>0x206D</int>   <!-- ACTIVATE ARABIC FORM SHAPING -->
         <int>0x206E</int>   <!-- NATIONAL DIGIT SHAPES -->
         <int>0x206F</int>   <!-- NOMINAL DIGIT SHAPES -->
         <int>0x2800</int>   <!-- BRAILLE PATTERN BLANK -->
         <int>0x3000</int>   <!-- IDEOGRAPHIC SPACE -->
         <int>0x3164</int>   <!-- HANGUL FILLER -->
         <int>0xFEFF</int>   <!-- ZERO WIDTH NO-BREAK SPACE -->
         <int>0xFFA0</int>   <!-- HALFWIDTH HANGUL FILLER -->
         <int>0xFFF9</int>   <!-- INTERLINEAR ANNOTATION ANCHOR -->
         <int>0xFFFA</int>   <!-- INTERLINEAR ANNOTATION SEPARATOR -->
         <int>0xFFFB</int>   <!-- INTERLINEAR ANNOTATION TERMINATOR -->
      </blank>
<!--
  Rescan configuration every 30 seconds when FcFontSetList is called
 -->
      <rescan>
         <int>30</int>
      </rescan>
   </config>

</fontconfig>


this is a serious problem, now my fonts are all messed up. I can't arrange a good combination of default fonts because the system don't see or render well them! :(

*update: I cannot find any solution by myself. This issue is not covered in the forum (maybe because is new, caused by UP 7?). Good proper fonts are too important to work daily with an OS. If I can't fix this problem, sadly, I will have to quit LMDE and install another distro. :(
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Wed Sep 25, 2013 5:51 am

Could you please read the point 4 from Monsta : viewtopic.php?f=187&t=144198#p761238

I think it should help.
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Wed Sep 25, 2013 10:28 am

thanks killer,
I tried to follow the Monsta's thread. I created a bash script modified to the new font config path:

Code: Select all
 #!/bin/sh

WHOAMI=`whoami`
if [ x$WHOAMI != xroot ]; then
    echo Please run me as root.
    exit 1
fi

cd /usr/share/fontconfig/conf.avail

ln -s ../conf.avail/10-antialias.conf 10-antialias.conf
ln -s ../conf.avail/10-hinting.conf 10-hinting.conf
ln -s ../conf.avail/10-hinting-slight.conf 10-hinting-slight.conf
ln -s ../conf.avail/11-lcdfilter-default.conf 11-lcdfilter-default.conf
ln -s ../conf.avail/53-monospace-lcd-filter.conf 53-monospace-lcd-filter.conf


...but nothing happens. Maybe I'm doing something wrong.
As Monsta indicate, there is a new path for the font configuration: /usr/share/fontconfig/conf.avail instead of /etc/fonts/conf.avail.
Is possible that the updated system don't "see" the new path? I'm just guessing. If so, what I have to change in order to fix that?
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Wed Sep 25, 2013 11:36 am

I will give you the exact path you should use as soon as I get back from work in some hours.
Now, fonts are stored in /usr/share/font but I think you need to create the link to the old folder.

Could you try with these kind of link ?
ln -s /etc/fonts/conf.avail/10-antialias.conf 10-antialias.conf
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Wed Sep 25, 2013 2:45 pm

OK

Please create a link between the file present in /usr/share/fontconfig/conf.avail to /etc/fonts/conf.d

it should look like this :

Code: Select all
cd /etc/fonts/conf.d

ln -s /usr/share/fontconfig/conf.avail/10-antialias.conf 10-antialias.conf
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 11:09 am

hi killer,
I'm not sure I have done it correctly. I opened usr/share/fontconfig/conf.avail, here there is NOT any archive "10-antialias.conf" nor a repeated (why?) "10-antialias.conf 10-antialias.conf". I created one empty with the name "10-antialias.conf", put in the text "cd/etc/fonts/conf.d" (but the archive is plain text, not xml). Nothing happens, apparently.
Last edited by xfrank on Sat Sep 28, 2013 11:28 am, edited 2 times in total.
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 11:38 am

update:
I tried in the terminal. In
/etc/fionts/conf.d
I entered
ln -s /etc/fonts/conf.avail/10-antialias.conf 10-antialias.conf

still nothing happens.
------------------------------

update.
I did search in the directory etc/fonts/conf.d
there are 38 symlynks that poin to the directory /etc/fonts/conf.avail
Then, I searched in this directory and there are indeed 38 files with the same names. For example, there is 10-antialias.conf. This file contain this text:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Use the Antialiasing -->
<match target="font">
<edit name="antialias" mode="assign"><bool>true</bool></edit>
</match>
</fontconfig>
Last edited by xfrank on Sat Sep 28, 2013 11:53 am, edited 1 time in total.
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Sat Sep 28, 2013 11:51 am

xfrank wrote:hi killer,
I'm not sure I have done it correctly. I opened usr/share/fontconfig/conf.avail, here there is NOT any archive "10-antialias.conf"


That's the problem. Font configuration files should be there !
Are they stored in
Code: Select all
/etc/fonts/conf.avail



Could you please check that these package are installed ?
Code: Select all
fonconfig fontconfig-config


xfrank wrote:nor a repeated (why?) "10-antialias.conf 10-antialias.conf".

Obviously you don't understand what you are doing. Could you please read monsta post carefully ?
In a terminal type :
Code: Select all
man ln
and read carefully.
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Sat Sep 28, 2013 11:57 am

Perfect !

As a root, could you please copy the content of
Code: Select all
/etc/fonts/conf.avail
in
Code: Select all
usr/share/fontconfig/conf.avail
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 12:16 pm

killer de bug wrote:Perfect !

As a root, could you please copy the content of
Code: Select all
/etc/fonts/conf.avail
in
Code: Select all
usr/share/fontconfig/conf.avail



I did it (except the indian fonts like "Telugu" or "Gujarati")
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 12:17 pm

Could you please check that these package are installed ?
Code: Select all
fonconfig fontconfig-config

yes they are
installed
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby killer de bug on Sat Sep 28, 2013 12:18 pm

And ? Did you restarted ? Is it better ?

at the end of this page : https://wiki.debian.org/Fonts
Section sub-pixel hinting. Do this help ?


edit : stupid question but... did you selected the right option in the font parameter menu in the config center ?
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 12:36 pm

killer de bug wrote:And ? Did you restarted ? Is it better ?

at the end of this page : https://wiki.debian.org/Fonts
Section sub-pixel hinting. Do this help ?


edit : stupid question but... did you selected the right option in the font parameter menu in the config center ?


No, I restarted twice and nothing improved.
I checked the debian wiki (hinting subpixel), but I can't see any help to fix this problem.

If I open the config center, appearance, fonts, I have my preferences (translated from spanish):
font rendering supixel is on.
Typography for the applicaton: Droid Sans Light SemiExtended
Typography for the documents: Droid Sans Light SemiExtended
Typography for the escritory: Droid Sans Light SemiExtended
Typography for the window: Arial Black
Fixed widht typograpy: Monospace

Now, if I try to change that fonts, I have only few options: Droid Sans, Monospace, Sans, Serif. All the other fonts are not showed, they are not "seen" by the system.
-----------------
update. I did search in the usr/share/fonts directory. The fonts are indeed there! If I open any of the subdirectory (opentype, truetype, type1) the fonts appears and if I click on each them, they are showed.
Apparently the system for some reason can't "see" properly the fonts in this directory, and use only few default fonts (also bad rendering them, expecially the monospace).
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts

Postby xfrank on Sat Sep 28, 2013 7:10 pm

still trying to fix this problem, no good. This is beyond the logic, or I'm missing something.
----------------

well... solved (apparently). How? I renamed font.conf to font.conf.old, then reinstalled by synaptic all fontconfig packages, and finally, renamed again font.conf.old to the original name.
Now the fonts are showed again properly. :shock:

Just persist one issue: apparently not all the fonts in .fonts directory in /home are "seen" by the system. For example openlogos.ttf is not recognized by conky.
*update: in fact, several fonts either in the /home/.fonts directory or in the /usr/share/fonts, are not recognized by the system. Strange. LibreOffice sees everything, LMDE not. :?:
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts [almost SOLVED]

Postby killer de bug on Sun Sep 29, 2013 11:12 am

Could you please watch this file
Code: Select all
/etc/fonts/fonts.conf


And see in the section font directory if /usr/share/font is mentioned ?

I must admit I am running out of ideas...
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UP 7 ...well but ...missing system fonts [almost SOLVED]

Postby xfrank on Sun Sep 29, 2013 11:41 am

Thanks killer, this is the part of the file that refers to directories:

Code: Select all
<!-- Font directory list -->

   <dir>/usr/share/fonts</dir>
   <dir>/usr/X11R6/lib/X11/fonts</dir> <dir>/usr/local/share/fonts</dir>
   <dir prefix="xdg">fonts</dir>
   <!-- the following element will be removed in the future -->
   <dir>~/.fonts</dir>


...seems that the home .fonts directory is missing
Linux: LMDE (Mate), Mint13 (Xfce), Peppermint 3 (LXDE), Manjaro (Xfce and Netbook Edition)
xfrank
Level 4
Level 4
 
Posts: 249
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico

Re: UP 7 ...well but ...missing system fonts [almost SOLVED]

Postby killer de bug on Sun Sep 29, 2013 12:05 pm

I have the same file...
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1795
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Linux Mint is funded by ads and donations.
 
Next

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests