Broken packages after update

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Broken packages after update

Postby refp16 on Wed Sep 25, 2013 1:51 am

Today the update manager showed I had > 1GB worth of updates. I went along and hit the "install updates" button. That seemed to go without any problems. After that, I received another notice saying even more updates were available. Hit the "install updates" button again, but this time was greeted with a "You have broken packages on your system... Fix broken packages first".

I opened Synaptic looked for the broken packages and tried reinstalling one of them (with the right-click option). The required changes for this reinstall involves removing packages like cinnamon, gnome-panel, etc. These seem very important packages so I didn't go along with the reinstall. I wouldn't want to mess up the system more than it could already be. The required changes are very much the same for all broken packages (16 of them). I've searched the forums for the "broken packages" error and it is common but I have not yet seen a case where someone is asked to uninstall cinnamon.

I tried

Code: Select all
sudo apt-get update


which gave this output

Code: Select all
Hit http://debian.lth.se testing InRelease                                     
Hit http://debian.lth.se testing/updates InRelease           
Hit http://debian.lth.se testing InRelease                   
Hit http://debian.lth.se testing/main amd64 Packages/DiffIndex
Hit http://debian.lth.se testing/contrib amd64 Packages/DiffIndex
Hit http://debian.lth.se testing/non-free amd64 Packages/DiffIndex
Hit http://debian.lth.se testing/main i386 Packages/DiffIndex
Get:1 ftp://ftp.pucpr.br debian InRelease
Hit http://debian.lth.se testing/contrib i386 Packages/DiffIndex
Hit http://debian.lth.se testing/non-free i386 Packages/DiffIndex
Hit http://debian.lth.se testing/contrib Translation-en/DiffIndex
Ign ftp://ftp.pucpr.br debian InRelease
Hit http://debian.lth.se testing/main Translation-en/DiffIndex
Hit ftp://ftp.pucpr.br debian Release.gpg
Hit http://debian.lth.se testing/non-free Translation-en/DiffIndex
Hit http://debian.lth.se testing/updates/main amd64 Packages
Hit ftp://ftp.pucpr.br debian Release
Hit http://debian.lth.se testing/updates/contrib amd64 Packages
Hit http://debian.lth.se testing/updates/non-free amd64 Packages
Hit ftp://ftp.pucpr.br debian/main amd64 Packages
Hit http://debian.lth.se testing/updates/main i386 Packages
Hit ftp://ftp.pucpr.br debian/upstream amd64 Packages
Hit http://debian.lth.se testing/updates/contrib i386 Packages
Hit http://debian.lth.se testing/updates/non-free i386 Packages
Hit ftp://ftp.pucpr.br debian/import amd64 Packages
Hit http://debian.lth.se testing/updates/contrib Translation-en
Hit ftp://ftp.pucpr.br debian/main i386 Packages
Hit http://debian.lth.se testing/updates/main Translation-en
Hit http://debian.lth.se testing/updates/non-free Translation-en
Hit http://debian.lth.se testing/main amd64 Packages
Hit ftp://ftp.pucpr.br debian/upstream i386 Packages
Hit http://debian.lth.se testing/non-free amd64 Packages
Hit http://debian.lth.se testing/main i386 Packages
Hit ftp://ftp.pucpr.br debian/import i386 Packages
Hit http://debian.lth.se testing/non-free i386 Packages
Get:2 ftp://ftp.pucpr.br debian/import Translation-en_US
Get:3 ftp://ftp.pucpr.br debian/import Translation-en
Get:4 ftp://ftp.pucpr.br debian/main Translation-en_US
Get:5 ftp://ftp.pucpr.br debian/main Translation-en
Ign http://debian.lth.se testing/main Translation-en_US
Ign http://debian.lth.se testing/main Translation-en
Ign http://debian.lth.se testing/non-free Translation-en_US
Get:6 ftp://ftp.pucpr.br debian/upstream Translation-en_US
Ign http://debian.lth.se testing/non-free Translation-en
Get:7 ftp://ftp.pucpr.br debian/upstream Translation-en
Get:8 ftp://ftp.pucpr.br debian/import Translation-en_US
Get:9 ftp://ftp.pucpr.br debian/import Translation-en
Get:10 ftp://ftp.pucpr.br debian/main Translation-en_US
Get:11 ftp://ftp.pucpr.br debian/main Translation-en
Get:12 ftp://ftp.pucpr.br debian/upstream Translation-en_US
Get:13 ftp://ftp.pucpr.br debian/upstream Translation-en
Get:14 ftp://ftp.pucpr.br debian/import Translation-en_US
Get:15 ftp://ftp.pucpr.br debian/import Translation-en
Get:16 ftp://ftp.pucpr.br debian/main Translation-en_US
Get:17 ftp://ftp.pucpr.br debian/main Translation-en
Get:18 ftp://ftp.pucpr.br debian/upstream Translation-en_US
Get:19 ftp://ftp.pucpr.br debian/upstream Translation-en
Get:20 ftp://ftp.pucpr.br debian/import Translation-en_US
Get:21 ftp://ftp.pucpr.br debian/import Translation-en
Get:22 ftp://ftp.pucpr.br debian/main Translation-en_US
Get:23 ftp://ftp.pucpr.br debian/main Translation-en
Get:24 ftp://ftp.pucpr.br debian/upstream Translation-en_US
Get:25 ftp://ftp.pucpr.br debian/upstream Translation-en
Get:26 ftp://ftp.pucpr.br debian/import Translation-en_US
Ign ftp://ftp.pucpr.br debian/import Translation-en_US
Get:27 ftp://ftp.pucpr.br debian/import Translation-en
Ign ftp://ftp.pucpr.br debian/import Translation-en
Get:28 ftp://ftp.pucpr.br debian/main Translation-en_US
Ign ftp://ftp.pucpr.br debian/main Translation-en_US
Get:29 ftp://ftp.pucpr.br debian/main Translation-en
Ign ftp://ftp.pucpr.br debian/main Translation-en
Get:30 ftp://ftp.pucpr.br debian/upstream Translation-en_US
Ign ftp://ftp.pucpr.br debian/upstream Translation-en_US
Get:31 ftp://ftp.pucpr.br debian/upstream Translation-en
Ign ftp://ftp.pucpr.br debian/upstream Translation-en
Reading package lists... Done


and

Code: Select all
sudo apt-get upgrade


which gave this output

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 dconf-gsettings-backend : Depends: libdconf1 (= 0.16.1-1) but it is not installed
 dconf-service : Depends: libdconf1 (= 0.16.1-1) but it is not installed
 gnome-control-center : Depends: libcolord1 (>= 0.1.29) but 0.1.21-1 is installed
                        Depends: libgnome-bluetooth11 (>= 3.4.0) but it is not installed
                        Depends: libgnomekbd8 (>= 3.6.0) but it is not installed
                        Depends: gnome-control-center-data (>= 1:3.4.3.1-5) but 1:3.4.2+git20121016.29d7c0-1 is installed
                        Recommends: gnome-online-accounts but it is not installed
                        Recommends: gnome-session but it is not installed
 gnome-panel : Depends: libdconf1 (>= 0.14.0) but it is not installed
               Depends: gnome-panel-data (= 3.4.2.1-5) but 3.4.2.1-3 is installed
               Recommends: gnome-applets but it is not installed
               Recommends: gnome-session (>= 2.26) but it is not installed
               Recommends: evolution-data-server but it is not installed
               Recommends: alacarte but it is not installed
 gvfs-backends : Depends: libarchive13 but it is not installed
                 Depends: libgoa-1.0-0 (>= 3.7.90) but 3.4.2-1 is installed
                 Depends: libmtp9 (>= 1.1.5) but 1.1.3-35-g0ece104-4 is installed
 gvfs-daemons : Depends: libsecret-1-0 (>= 0.7) but it is not installed
                Depends: libudisks2-0 (>= 2.0.91) but it is not installed
                Depends: udisks2
 gvfs-libs : Depends: libsecret-1-0 (>= 0.7) but it is not installed
 libexttextcat0 : Depends: libexttextcat-data (= 3.2.0-2) but 3.4.0-4 is installed
 libglib2.0-0:i386 : Depends: libffi6:i386 (>= 3.0.4) but it is not installed
 libglib2.0-bin : Depends: libelfg0 (>= 0.8.12) but it is not installed
 libgnome-desktop-3-2 : Depends: gnome-desktop3-data (>= 3.4.2-2) but 3.4.2-1 is installed
 libreoffice-base : Depends: libhsqldb1.8.0-java but it is not installed
 libreoffice-draw : Depends: libcdr-0.0-0 but it is not installed
                    Depends: libmspub-0.0-0 but it is not installed
 openjdk-7-jre-lib : Depends: openjdk-7-jre-headless (>= 7~b130~pre0) but it is not installed
 pulseaudio-esound-compat : Depends: libpulse0 (= 4.0-6) but 2.0-6 is installed
                            Depends: pulseaudio (= 4.0-6)
 python-gi : Depends: gir1.2-glib-2.0 (>= 1.34.2) but 1.32.1-1 is installed
E: Unmet dependencies. Try using -f.


What is going on? Why am I asked to uninstall cinnamon, etc? Is it dangerous to run
Code: Select all
apt-get -f install
? Any help is appreciated.

I'm attaching two images of my Synaptic.
Attachments
required_changes.png
required changes
broken_packages.png
broken packages
refp16
Level 1
Level 1
 
Posts: 4
Joined: Fri Sep 13, 2013 3:56 pm

Linux Mint is funded by ads and donations.
 

Re: Broken packages after update

Postby nomko on Wed Sep 25, 2013 3:50 am

there's a tutorial available:
http://community.linuxmint.com/tutorial/view/482

Maybe this will help you.


Just found another howto:
http://linuxmint.tumblr.com/post/227875 ... n-packages
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)

My personal website
User avatar
nomko
Level 8
Level 8
 
Posts: 2284
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Broken packages after update

Postby Monsta on Wed Sep 25, 2013 6:47 am

Just do apt-get -f install, it's not dangerous at all.
Monsta
Level 8
Level 8
 
Posts: 2345
Joined: Fri Aug 19, 2011 3:46 am

Re: Broken packages after update

Postby palimmo on Wed Sep 25, 2013 2:58 pm

My update went bad, too (probably due to nvidia drivers).
After the reboot, I could see just the command line.
I solved running:
sudo apt-get -f install
LMDE 64bit Cinnamon & SolydK 64bit
User avatar
palimmo
Level 3
Level 3
 
Posts: 186
Joined: Sun Feb 03, 2013 9:55 am

Re: Broken packages after update

Postby refp16 on Wed Sep 25, 2013 5:22 pm

Thank you all.

Code: Select all
sudo apt-get -f install


did just fine. Problem solved.
refp16
Level 1
Level 1
 
Posts: 4
Joined: Fri Sep 13, 2013 3:56 pm

Re: Broken packages after update

Postby Biran Jackson on Sun Apr 13, 2014 9:07 pm

We followed the instruction using Terminal. However, we met with another hitch as indicated in the screenshot of the Terminal result in the screenshot here:

http://imgur.com/RjAMACQ
Biran Jackson
Level 1
Level 1
 
Posts: 3
Joined: Fri Apr 04, 2014 7:45 pm

Re: Broken packages after update

Postby Chipshotz on Mon Apr 14, 2014 2:04 am

Biran Jackson wrote:We followed the instruction using Terminal. However, we met with another hitch as indicated in the screenshot of the Terminal result in the screenshot here:

http://imgur.com/RjAMACQ


I feel your pain.
I'm getting the same error. I loaded SolydK on a new SSD, installed gnome-shell and it's running like LMDE used to. :)
Chipshotz
Level 1
Level 1
 
Posts: 26
Joined: Wed Mar 02, 2011 10:35 pm

Re: Broken packages after update

Postby py-thon on Mon Apr 14, 2014 11:58 am

Biran Jackson wrote:We followed the instruction using Terminal.

This thread is/was about LMDE. You are obviously using Mint 16.
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 221
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests