UP7 Breaks Bluetooth?

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

UP7 Breaks Bluetooth?

Postby genosensor on Sat Sep 28, 2013 2:24 am

After updating from UP6 to UP7, I find that I can no longer connect to any of my bluetooth devices.
I had been using blueman in UP6.
Now, on connect to the headset service of a PLT_Legend (headset), it reports

Connection Failed: Connect failed

On "Refresh Connection" is seems to connect for about 5 seconds, then it disconnects.
(the headset never indicates it is connected, so I doubt the PC ever did)

Has anyone managed to connect to bluetooth devices after updating to UP7?

If so, please send details of whatever worked for you.
genosensor
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 25, 2012 12:33 am

Linux Mint is funded by ads and donations.
 

Re: UP7 Breaks Bluetooth?

Postby Monsta on Sat Sep 28, 2013 8:40 am

genosensor wrote:Connection Failed: Connect failed

Looks like this upstream bug: http://bugs.debian.org/705800

No fix provided yet.
Since the last comment appeared there in May, and the issue seems abandoned, I suggest adding another comment (you can at least ask if there's a workaround available).
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: UP7 Breaks Bluetooth?

Postby genosensor on Sun Sep 29, 2013 2:15 am

The version in the Debian repo LMDE UP7 is pulling appears to be patched.
One workaround seems to be to build the unpatched v1.23 blueman from source found here:

http://download.tuxfamily.org/blueman/b ... .23.tar.gz

Thanks for the tip!
I'll raise the issue on the appropriate dev lists after I've tested a bit more.
genosensor
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 25, 2012 12:33 am

Re: UP7 Breaks Bluetooth?

Postby genosensor on Sun Sep 29, 2013 3:34 am

Further testing shows that blueman v1.21 is better than v1.23 for two reasons:

1) Does not require service bluetooth restart before first connection can be made

2) tool tip on applet icon in status bar does not flicker

get it at:

http://download.tuxfamily.org/blueman/b ... .21.tar.gz
genosensor
Level 1
Level 1
 
Posts: 4
Joined: Tue Dec 25, 2012 12:33 am

Re: UP7 Breaks Bluetooth?

Postby Monsta on Tue Oct 01, 2013 2:14 am

I don't know if there are any problems with the Debian patches, but you can get 1.21 or 1.23 or any other version from this snapshot.debian.org page. No need to compile from the upstream source.
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: UP7 Breaks Bluetooth?

Postby abtygwyn on Fri Oct 04, 2013 12:26 pm

I followed the links and ended up being told it was safer to download the package using the the normal synaptic package manager.
I installed blueman as instructed and hey presto, it now works again.

Thanks
:D
abtygwyn
Level 3
Level 3
 
Posts: 157
Joined: Mon Apr 25, 2011 4:33 am

Re: UP7 Breaks Bluetooth?

Postby LZux on Sat Oct 19, 2013 8:37 am

I did a quick look as I recently went to UP7, the error was about the obex client.
So I downgraded the packages below to the "debian stable" respository version and it seems to work for us.
Please note that I dont know if this is a good/safe solution to use.

Downgraded the following packages:
libopenobex1 1.5-2.1
obexd-client 0.46-1+b1
LZux
Level 1
Level 1
 
Posts: 8
Joined: Sun Sep 09, 2012 6:43 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests