LMDE Mate 64-bit hosed by UP7. CLI install of Mate themes

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

LMDE Mate 64-bit hosed by UP7. CLI install of Mate themes

Postby quixote on Sun Oct 13, 2013 5:41 pm

Update 2013-10-21: I've collected the gist here so you don't have to glean it from the whole thing if you need this information. To avoid this whole issue make sure a GTK 3.8-compatible theme, like Mint-X, is selected BEFORE upgrading.

Boot into user command line mode, without launching graphical user interface X and Mate.
My workaround to do this in Mate:
You don't want recovery mode, because that's root, and you're trying to change your user's theme.
Mate's login screen does not give an option for an X-less login. So:
login to recovery mode.
Edit /etc/default/grub
(using, for instance nano you'd type
#nano /etc/default/grub)
change the line GRUB_CMDLINE_LINUX="quiet splash" to
GRUB_CMDLINE_LINUX="quiet text"
In nano, you hit Ctrl-x to exit editing, y to answer yes to the save question, and return to confirm the filename.
Then run
#update-grub
and type reboot to, ahem, reboot .
(Once everything is all fixed, remember to change "text" back to "splash" and run "sudo update-grub" again.)


You should see a text-based login and your user's command prompt, such as quixote@bryum:$
Make sure you have a GTK 3.8 theme installed:
Code: Select all
sudo apt-get install mint-themes mint-themes-gtk3

The following commands are all done as user.
Code: Select all
dbus-launch --exit-with-settings gsettings set org.mate.interface gtk-theme 'Mint-X'
dbus-launch --exit-with-settings gsettings set org.mate.interface icon-theme 'Mint-X'
dbus-launch --exit-with-settings gsettings set org.mate.Marco.general theme 'Mint-X'


Reboot, which returns you to the text-based login (just in case things haven't worked), and type
Code: Select all
startx

to see if the normal desktop loads. If it doesn't, hit Ctrl-Alt-Backspace to kill X, return to command line, and type startx again. In my case, on the third try, this usually loads a functional Mate. It's the same idea if you've set grub back to normal, except then ctrl-alt-backspace takes you to login screen. Login again and ctrl-alt-bksp repeatedly until Mate recovers its tiny mind.

After booting, I get this rigamarole of having to cycle through repeated startx until Mate loads. Don't ask me why. It comes back from suspend just fine, though.

One last thing: the updated Mate is reset not to show desktop for some reason. To fix that, open a terminal and type:
Code: Select all
gsettings set org.mate.background show-desktop-icons true

(Or "dbus-launch --exit-with-settings gsettings set org.mate.background show-desktop-icons true" if X wasn't started.)

============Original question=====================================================================
Okay. I've been going around and around on the forums, trying things, doing reboots and more reboots, and I have hereby officially given up. The attraction of LMDE was NOT having to reinstall the system. This install has had numerous specialty packages installed, and my friend's world will end if he has to reinstall. (I'm trying to do this for a Linux newbie, but I think it's a case of the blind leading the blind.)

Anyway. The situation is this: Based on a 201303 LMDE 64-bit Mate iso, some upgrades may have been applied but mostly it was not up to date. A few days ago I put it through the big upgrade using
Code: Select all
sudo apt-get update
sudo apt-get upgrade && sudo apt-get dist-upgrade
It finished with no errors. When I rebooted, it was sometimes okay, but sometimes flaky in that the wireless wouldn't work or the desktop icons wouldn't show up. Then it finally settled on not finishing the boot at all. There's the spinning circle, a black background, and an empty panel that jitters.

Looking around, this is some kind of issue with GTK3 and themes or something? There is no indication how to fix this from the command line. The problem is that I have no GUI. I can't "simply change theme." If I select "run Xclient script" as the session, sometimes it boots into a GUI desktop. When I then tried to change the theme under Prefs > Appearances, it doesn't seem to help, nor will it let me install any other themes.

From what I've seen on the forums, it sounds like this is some arcane conflict instroduced by something or other (GTK3? Mate's default theme? Something else entirely?). There has got to be some commands I can use in recovery mode that will deal with that! What are they?

I should add: that install tracks testing.

Update: Title changed to more accurately reflect the question (I hope!). But I may have the whole thing misdiagnosed, so I don't even know if Mate themes are the problem. I hope someone can help!
Last edited by quixote on Tue Oct 22, 2013 12:41 am, edited 4 times in total.
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Linux Mint is funded by ads and donations.
 

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Tue Oct 15, 2013 9:54 am

(Bump? I'm dead in the water and really need some help here. Even telling me I'm done for and can just concentrate on reinstalling would help. That way I could stop wasting time trying to find a solution :? )
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby ddurdle on Tue Oct 15, 2013 8:18 pm

I don't think there is anything you can do then to restore a clonezilla backup and start over.

I thought I saw a warning thread about actions to take before upgrading. Many themes won't work in GTK 3.6, so you need to make have a GTK 3.6 safe theme BEFORE upgrading. A bad theme will causes applications to crash on their startup and viola, you become stuck.
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Tue Oct 15, 2013 9:54 pm

and voila, you become stuck
Sure describes my situation.

So there's no way to retroactively install a theme? :shock: Aaaaarrgh.

Note to self: read the warnings more carefully. Although I did try to check and I didn't see anything about this. The first I saw about problematic themes was after some two solid days of searching when trying to fix the problem. Obviously at this point I think they need a big flashing red sticky pinned at the top of the forums.

Thanks for the feedback!
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Tue Oct 15, 2013 9:57 pm

Oh yes: which are the GTK 3.6 friendly themes?? I've got the impression Clearlooks is one. Also Mint-X? Any others?

Edited to add: I think I've found something: http://wiki.mate-desktop.org/plugins. mate-themes-extras-3 package. When I unpack it on my system, there are about 10 themes in there. I'm going to see if maybe I can move it over to the problem system into /usr/share/themes/ and see if I can do something with it then. It's an adventure.
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby Monsta on Tue Oct 15, 2013 11:16 pm

GTK+ 3.6 themes won't help you as the version of GTK+ in UP7 is 3.8.
Mint-X theme is compatible with it now (make sure you have the latest version).


Here's how to set the appearance from the command line. For example:

Code: Select all
gsettings set org.mate.interface gtk-theme 'Mint-X'
gsettings set org.mate.interface icon-theme 'Mint-X'
gsettings set org.mate.Marco.general theme 'Mint-X'

This will change GTK+ theme, icon theme and window border theme to Mint-X.
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby ddurdle on Wed Oct 16, 2013 12:07 pm

Monsta wrote:GTK+ 3.6 themes won't help you as the version of GTK+ in UP7 is 3.8.
Mint-X theme is compatible with it now (make sure you have the latest version).


Here's how to set the appearance from the command line. For example:

Code: Select all
gsettings set org.mate.interface gtk-theme 'Mint-X'
gsettings set org.mate.interface icon-theme 'Mint-X'
gsettings set org.mate.Marco.general theme 'Mint-X'

This will change GTK+ theme, icon theme and window border theme to Mint-X.


Thanks, good tips with the command lines there.

So it guess it is ensure you have a GTK 3.8+ safe-theme. I was using a theme that the author commented was not compliant with GTK 3.6 or higher. Hence I ran into problems. But the theme I settled on before doing the final upgrade to UP7 I ensured was GTK 3.6 compliant (it just as mentions it is 3.8+ compliant as well, having been updated as recent as Sept 30, 2013).

I have seen compliancy issues in past upgrades (with GTK2 etc), but in the past the worst case I ran into was that a window would not display with the proper look. It was nearly not as bad as with this upgrade where I had apps instantly crashing. I couldn't even get on the network as my nm-applet would dive immediately on startup :)
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Wed Oct 16, 2013 12:24 pm

Monsta, thanks a million for the commands! I'm off to try them right now. Will report back. Holding my hands and praying for a panel :mrgreen: .
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Wed Oct 16, 2013 11:50 pm

The continuing saga:
I installed mint-x-theme. It insisted on removing mint-themes to do that, but, oh well. When I told it to go ahead, it returned
Code: Select all
error processing /var/cache/apt/archives//mint-x-theme_1.0.7_all.deb (--unpack):
trying to overwrite '/usr/share/themes/Mint-X/gtk-3.0/gtk.css', which is also in package mint-themes-gtk3 3.8-1
and dpkg returned "error 1".

So, I thought I'd try moving the whole Mint-X theme dir somewhere for a while and try again. It gave me the same error message (!), but it did say that I could autoremove mint-themes-gtk3. So I ran
Code: Select all
sudo spt-get autoremove mint-themes-gtk3
Then it finally let me install mint-x-theme.

However, now that I could finally run the gsettings commands, it just returned yet another error:
Code: Select all
(process:3415): dconf-warning **: failed to commit changes to dconf: Error spawning command line `dbus-launch --autolaunch=3c57545fd9007fcac1f08fcd00001118 --binary-syntax --close-stderr': Child process exited with code 1

I get the same error for all three gsettings commands and whether I run them as user or sudo.

I thought maybe they're just warnings and I can do "startx". But no. Same old jittering empty panel bar, black desktop, and little white circle whirligig.

I checked .xsession-errors to see what's in there. There were some warnings about gnome-keyring couldn't connect to keyring directories. Then:
Code: Select all
Window manager warning: Got request to focus the no_focus_window with a timestamp of 0. This shouldn't happen!
mate-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Same for mate-volume-control-applet, mate-screensaver, polkit-mate-authentication agent-1, update-notifier, nm-applet, most of which would be in the panel, I think? And then at the end, also x-session-manager: Fatal IO error 11 etc.

I feel like this is progress, because at least I'm getting different errors :D , but I'm not there yet. If anyone has any further ideas...?
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby Monsta on Thu Oct 17, 2013 5:40 am

quixote wrote:The continuing saga:
I installed mint-x-theme. It insisted on removing mint-themes to do that, but, oh well. When I told it to go ahead, it returned
Code: Select all
error processing /var/cache/apt/archives//mint-x-theme_1.0.7_all.deb (--unpack):
trying to overwrite '/usr/share/themes/Mint-X/gtk-3.0/gtk.css', which is also in package mint-themes-gtk3 3.8-1
and dpkg returned "error 1".

So, I thought I'd try moving the whole Mint-X theme dir somewhere for a while and try again. It gave me the same error message (!), but it did say that I could autoremove mint-themes-gtk3. So I ran
Code: Select all
sudo spt-get autoremove mint-themes-gtk3
Then it finally let me install mint-x-theme.

Cool. You've just killed GTK+ 3.8-compatible theme to get yourself a very old version of Mint-X, not compatible even with GTK+ 3.4.

Dammit. I told them the users will mistakenly install the obsolete mint-x-theme package instead of the new mint-themes (+ mint-themes-gtk3), but it seems that the Mint section at Launchpad is abandoned, so no one paid attention. Should've just written a message to Clem instead.
Monsta
Level 9
Level 9
 
Posts: 2514
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Thu Oct 17, 2013 12:21 pm

Oops. :oops: Well, I'll go back and see if I can reinstall mint-themes and mint-themes-gtk3. I thought it was odd that such a relevant-sounding package had to be uninstalled. But I'm at that point of frustration where you just hit return and hope for the best.

I told them the users will mistakenly install the obsolete mint-x-theme package instead of the new mint-themes (+ mint-themes-gtk3), but it seems that the Mint section at Launchpad is abandoned, so no one paid attention. Should've just written a message to Clem instead.


You were right. You can tell 'em I said so. :mrgreen:
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Thu Oct 17, 2013 1:43 pm

Mint-themes and mint-themes-gtk3 installed without any problem using "sudo apt-get install mint-themes and mint-themes-gtk3". It removed mint-x-theme. So far so good. But when I run the gsettings command, I get the same dconf-warning error:
Code: Select all
(process:3255): dconf-warning **: failed to commit changes to dconf: Error spawning command line `dbus-launch --autolaunch=3c57545fd9007fcac1f08fcd00001118 --binary-syntax --close-stderr': Child process exited with code 1

:?: Anything I can do? Or is it time to give up?
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Re: LMDE Mate 64-bit hosed by UP7. CLI install of Mate theme

Postby quixote on Thu Oct 17, 2013 2:09 pm

Searching around, http://askubuntu.com/questions/276509/change-gsettings-without-running-x-and-unity seemed worth trying. It seems that dbus-launch is expecting the full graphical interface to be running somewhere, and, of course, my whole problem is that I can't run it and am trying to get to work from a purely text-based interface. Adding to the beginning of the command:
Code: Select all
dbus-launch --exit-with-settings gsettings set org.mate.interface gtk-theme 'Mint-X'

allows the command to run and returns me to the command prompt with no messages. I'm assuming that means it ran correctly. I ran the other two gsettings commands the same way.

Sadly, though, after rebooting and running "startx", I'm still not getting a functioning Mate. One change: the desktop wallpaper now shows up. Don't know if that means improvement or not. Maybe I still don't have the actual gtk3.8 Mint-X theme itself installed??

Edited to add: I tried repeated cycles of startx: I close down the non-functioning desktop with Ctrl-Alt-Backspace which returns me to the text-based level, and type startx again. On about the third try, it seems to find most of its bits and pieces and actually gives me a functioning desktop. Yowser.

However, none of the desktop files and no right-click functionality to get at desktop options. I noticed on one of ddurdle's threads he mentions how everything has been set to system defaults. So, following instructions here: http://wiki.mate-desktop.org/docs:gsettings, I restarted X until I had a functioning desktop, then opened a terminal and typed
Code: Select all
gsettings list-recursively org.mate.background
which showed that show-desktop-icons was indeed set to "false". So then I entered
Code: Select all
gsettings set org.mate.background show-desktop-icons true
and there everything is.

So, my question now becomes what do I have to do to make sure that I can reliably boot into my updated LMDE? It's too fraught, never knowing whether you'll get a working OS or not.

Update 2013-10-21: See top of first post for summary of solution so far.
quixote
Level 1
Level 1
 
Posts: 49
Joined: Fri May 06, 2011 12:38 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Google [Bot] and 1 guest