"gnome-shell : Depends: gjs (>=1.35.4) but it is not going to be

Post your update and upgrade related errors here
Forum rules
Before you post please read this

"gnome-shell : Depends: gjs (>=1.35.4) but it is not going to be

Postby jackmetal on Mon Oct 28, 2013 2:46 am

Wow.... It's been about a month since I upgraded (I had noticed there were about 900+ packages to be updated so I held off until I was at home). Well, now I'm no longer able to get a graphical desktop. Tried the debian-system-adjustments fix, no go.. Determined my gnome-shell was a problem.. At the moment I'm getting the unmet dependencies error "gnome-shell : Depends: gjs (>=1.35.4) but it is not going to be installed" error.

This was a clean install, with gnome-shell, gnome-session, extensions and tweak-tool added. Any ideas?
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Linux Mint is funded by ads and donations.
 

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby Monsta on Mon Oct 28, 2013 9:30 am

Have you read the UP release notes before the upgrade?
Monsta
Level 8
Level 8
 
Posts: 2387
Joined: Fri Aug 19, 2011 3:46 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby jackmetal on Tue Oct 29, 2013 5:45 am

Morning Monsta!

Thanks for the reply. Yes, I saw that before I did the upgrade but unfortunately that didn't resolve the issue. When I try to install the older version I get the following:
Code: Select all
$ sudo apt-get install -t testing gnome-shell libgjs0c gjs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgjs0c is already the newest version.
libgjs0c set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell : Depends: gir1.2-mutter-3.0 (>= 3.4.1) but it is not going to be installed
               Depends: gir1.2-soup-2.4 but it is not going to be installed
               Depends: libcogl-pango0 (>= 1.7.4) but it is not going to be installed
               Depends: libcogl9 (>= 1.7.4) but it is not going to be installed
               Depends: libebook-1.2-13 (>= 3.4.4) but it is not going to be installed
               Depends: libecal-1.2-11 (>= 3.4.4) but it is not going to be installed
               Depends: libedataserver-1.2-16 (>= 3.4.4) but it is not going to be installed
               Depends: libedataserverui-3.0-1 (>= 3.4.4) but it is not going to be installed
               Depends: libmutter0 (>= 3.4) but it is not going to be installed
               Depends: libmutter0 (< 3.5) but it is not going to be installed
               Depends: libsoup2.4-1 (>= 2.4.0) but it is not going to be installed
               Depends: gnome-shell-common (= 3.4.2-12) but 3.8.4-4 is to be installed
               Depends: gnome-settings-daemon (>= 3.4.0) but it is not going to be installed
               Depends: gsettings-desktop-schemas (>= 3.3.2) but it is not going to be installed
               Recommends: gnome-contacts but it is not going to be installed
               Recommends: gnome-control-center but it is not going to be installed
               Recommends: gnome-session-fallback but it is not going to be installed
               Recommends: gnome-user-guide but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I've been using LMDE since day one, even following testing and sid, and this is the first time it's hosed me.
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby Monsta on Tue Oct 29, 2013 5:52 am

Try aptitude, it will tell you more about the dependencies:
Code: Select all
sudo aptitude -t testing install gnome-shell
Monsta
Level 8
Level 8
 
Posts: 2387
Joined: Fri Aug 19, 2011 3:46 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby jackmetal on Tue Oct 29, 2013 5:57 am

Monsta wrote:Try aptitude, it will tell you more about the dependencies:
Code: Select all
sudo aptitude -t testing install gnome-shell


Good Idea... I've stayed clear of aptitude for a couple years.

It looks like if I remove mdm it will work..Got the following option:
Code: Select all
The following actions will resolve these dependencies:

     Remove the following packages:     
1)     mdm                               

     Install the following packages:     
2)     gjs [1.36.1-2 (testing, unstable)]
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby Monsta on Tue Oct 29, 2013 6:04 am

That's strange. One of my virtual machines with LMDE has both MDM and gjs 1.36 installed, so they can coexist.
Did aptitude offer any other options?
Monsta
Level 8
Level 8
 
Posts: 2387
Joined: Fri Aug 19, 2011 3:46 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby jackmetal on Tue Oct 29, 2013 6:58 am

Monsta wrote:That's strange. One of my virtual machines with LMDE has both MDM and gjs 1.36 installed, so they can coexist.
Did aptitude offer any other options?


Yes, I tried a couple of the options it offered. First, removing mdm - still gave issues even with gdm3.. Then I attempted the other option it gave which was to downgrade mdm and now all I get is a black screen. :-( I'm really beginning to miss my plain Debian install (I should have done the upgrade in one of my VM's before doing it on my production laptop), now for the first time in years I'm having to boot into Windows to get work done today. Hopefully I'll have some time tonight to dig into it and try to fix it before I blow it away and move back to debian (or maybe I'll try the new solydx I just downloaded - although that's a bummer.. I really liked LMDE, at least until they moved away from the real gnome environment and started cobbling together the current one - although it's not completely horrible. ;-)
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Re: "gnome-shell : Depends: gjs (>=1.35.4) but it is not goi

Postby Monsta on Tue Oct 29, 2013 7:20 am

You can also try LightDM. It doesn't have many dependencies, I think there shouldn't be any conflicts with gnome-shell.
Monsta
Level 8
Level 8
 
Posts: 2387
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests