UP8 issue with Mate desktop on LMDE x64

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 5:32 am

My system is LMDE x64 with MATE desktop.
I did an upgrade for 2 times and both times I have got the same as in answers 9 and 12 here (http://blog.linuxmint.com/?p=2544):
- absolutely new login screen with no prompt for user, but with prompt for password;
- after login there is no interface loaded; I see only background image but no windows, panels or something else;
- screen is periodically blinking (not too frequently, about 1 time for 10-15 seconds);
- cursor is forever in the “loading” state;
- I see a strange panel in the right-up corner with button for shutdown, but it’s definitely NOT the Mate’s panel; seems more like a Gnome interface.

Also I can see mate-session, caja, and mate applets in processes (ps aux), but no application is loading.
In /var/log/syslog, BTW, I’ve found the next:
http://pastebin.com/GPN0XmA4
There are many errors with mention of libfreetype.so.
My .xsession-errors is:
http://pastebin.com/v1rBctFf
but I don’t know what has written her at which time, so I can’t match upgrade-related errors.

Now I’m on backed up system with updates ready to install.
What can I do to fix my upgrade issue?
Thanks a lot!
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Linux Mint is funded by ads and donations.
 

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Thu Feb 06, 2014 6:05 am

Do the necessary actions described in the UP notes, then run apt dist-upgrade from the terminal and let it run. If it breaks on something, post the output here. When it finishes, make sure there are no more updates by running apt dist-upgrade once again - it should say something like this:
Code: Select all
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 6:58 am

Hello, Monsta

First time my upgrade was broken by open-vm-tools package which hasn't been compiled because of a bug.
Then I recovered my system from backup, removed open-vm-tools package and run upgrade again (from UP7 on current system to UP8).
The second time was without any breakages. apt-get informed me that no more upgraded needed.
And after reboot the situation was the same as for the first time: no obvious login screen, no applications running, "waiting" cursor etc.

May it be somehow related to libfreetype.so error messages in my /var/log/syslog file described in the previous post?
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Thu Feb 06, 2014 8:36 am

Can you get to the system console using Ctrl-Alt-F1? If you can, try installing mint-meta-debian-mate from there.
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 9:24 am

Yes, I was able to login and to do operations in console mode. But, as I remember, this package has already been installed. I'll try one more time, though, and will post status here.
Thank you in advance!
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby py-thon on Thu Feb 06, 2014 1:00 pm

dbz wrote:- after login there is no interface loaded; I see only background image but no windows, panels or something else;

dbz wrote:- I see a strange panel in the right-up corner with button for shutdown, but it’s definitely NOT the Mate’s panel; seems more like a Gnome interface.

There was a somewhat similar situation for a user here http://www.linuxmintusers.de/index.php?topic=17260.0 (in German). It was solved adding
Code: Select all
Greeter=/usr/lib/mdm/mdmgreeter

to /etc/mdm/mdm.conf after [daemon].
Maybe this can help. But I am not sure, because I don't have this line in mdm.conf and no problems at all.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 262
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 1:03 pm

Well, right now I'm writing from my system upgraded with UP8.
As I understood, the source of my troubles was libfreetype library, so I did upgrade for everything but this lib.

The good things are:
- I can login;
- things in desktop session seems to be OK;
- no critical errors in /var/sys/log

The bad ones are:
- my old login window has gone, there are only two standard login windows in settings (the one of them is the one I wrote about before); (UPD: it was changed group from GDM to HTML; everything else is on the right place)
- I have been prompted to enter password to mount some media (though I've been set this up long time ago to not enter any passwords);
- hotkeys to change keyboard layout was changed (why???); (UPD: seems this was I one-time-issue; everything is going OK now)
- something else? don't know yet...

So, almost everything seems to be OK, and those little troubles I faced with are not the troubles at all, 'cauze I can fix them easily. A half-hour of googling and everything will be nice, BUT...
But this is strange that my upgrading experience this time was so long and difficult... I thought that system upgrade should be smooth and clear for everyone.
And I'm surprised that no one else faced same problem with libfreetype library...

And one more time. Monsta, thank you very much for your help!
Last edited by dbz on Thu Feb 06, 2014 2:59 pm, edited 1 time in total.
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 1:09 pm

There was a somewhat similar situation for a user here http://www.linuxmintusers.de/index.php?topic=17260.0 (in German). It was solved adding
Code: Select all
Greeter=/usr/lib/mdm/mdmgreeter

to /etc/mdm/mdm.conf after [daemon].
Maybe this can help. But I am not sure, because I don't have this line in mdm.conf and no problems at all.[/quote]

Wow, yes, the "greeter" setting helped with seeing normal login screen :)
Thank you!!!
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Thu Feb 06, 2014 2:24 pm

dbz wrote:As I understood, the source of my troubles was libfreetype library, so I did upgrade for everything but this lib.

So you solved the whole problem simply by holding libfreetype from upgrade and upgrading the rest of the system?

dbz wrote:I thought that system upgrade should be smooth and clear for everyone.

It can't be smooth for everyone for various reasons.
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Thu Feb 06, 2014 2:45 pm

Monsta wrote:
dbz wrote:As I understood, the source of my troubles was libfreetype library, so I did upgrade for everything but this lib.

So you solved the whole problem simply by holding libfreetype from upgrade and upgrading the rest of the system?

Yep :)

Monsta wrote:
dbz wrote:I thought that system upgrade should be smooth and clear for everyone.

It can't be smooth for everyone for various reasons.

Well... I understand that linux is pretty much complex than windows, and that linux is very... umm... odd, or separate, by its nature. But there is no limit for perfection! :)
I'll wait for an update on libfreetype and then I'll try to update again. Hope this issue will be discovered and fixed.
Thank you very much for help!

UPD. Now all the little issues described before are resolved. The system is very responsive and even more responsive than before :)
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Fri Feb 07, 2014 2:29 am

That's not because Linux is complex or not. That's because:
  1. LMDE is based on Debian Testing where something will always be broken.
  2. There are not so many people who join us in testing the Update Packs by setting their sources list to Incoming. We can't cover all the system configurations, all the upgrade cases, all the desktop environment combinations.
For example, we totally missed this case with libfreetype. No one complained about it. Everyone who uses MATE upgraded successfully. No one came and told us "you know guys, Caja segfaults because of libfreetype, we need to fix it before UP8 goes into production".

BTW, what is your hardware? Please post the output of
Code: Select all
inxi -SGx
I don't know if I can figure anything out, but it's possible that this bug in libfreetype is triggered by some specific hardware.
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Fri Feb 07, 2014 4:53 am

Monsta,

Yes, I understand. And I thought this is a hardware-related issue, too.

An output for 'inxi -SGx' is:
Code: Select all
System:    Host: dbzix Kernel: 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1)
           Desktop: MATE 1.6.1 (Gtk 3.8.4) Distro: LinuxMint 1 debian
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.14.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Intel Sandybridge Desktop GLX Version: 3.0 Mesa 9.2.2 Direct Rendering: Yes
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Sun Feb 09, 2014 4:10 am

A little googling show me that the segfault in libfreetype could be caused not by a certain hardware, but by some fonts. And this thread and this bug report tell me the problem has been fixed in version 2.5.2. If you wish to try it, you can get it from Debian Testing repos. If you need a place to get the older version from (in case the experiment with version 2.5.2 fails), there's always snapshot.debian.org.
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Sun Feb 09, 2014 5:06 am

Thank you, Monsta!

I'll set up apt-pinning and try a version from Debian testing. Hope it'll help! ;)
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Tue Feb 11, 2014 6:56 pm

Woo-hoo!
Pinning apt to debian-testing and installing the latest libfreetype6 from there saved me as well as the latest (and also fixed) youtube-dl :)

Thank you for useful piece of advice, Monsta!
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby Monsta on Wed Feb 12, 2014 3:30 am

Glad it's solved. Don't forget to remove Debian Testing repos from your sources list to avoid accidental upgrade to Testing. :)
Monsta
Level 8
Level 8
 
Posts: 2483
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8 issue with Mate desktop on LMDE x64

Postby dbz on Wed Feb 12, 2014 4:37 am

Monsta wrote:Glad it's solved. Don't forget to remove Debian Testing repos from your sources list to avoid accidental upgrade to Testing. :)


Sure, already did it =)
dbz
Level 1
Level 1
 
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: UP8 issue with Cinnamon desktop on LMDE x86

Postby lokee on Sun Mar 09, 2014 11:27 am

I had this problem too (with libfreetype6), but I use Cinnamon on x86.
Code: Select all
$dmesg
...
[   95.813663] cinnamon-sessio[2487]: segfault at 184 ip b67ec653 sp bfc9a610 error 4 in libfreetype.so.6.11.0[b67cf000+9c000]
...

Code: Select all
$ inxi -SGx
System:    Host: lokeez-mint Kernel: 3.11-2-486 i686 (32 bit, gcc: 4.8.1)
           Desktop: Cinnamon 2.0.14  Distro: Linux Mint Debian Edition
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
           X.Org: 1.14.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2 GLX Version: 2.1 Mesa 9.2.2 Direct Rendering: Yes


After update package libfreetype6 to version 2.5.2 I can login in Gnome. Cinnamon still wan't load - it show error Failed to load session "cinnamon".

Also I forget to install package mint-meta-debian-cinnamon :oops: , after installing it - cinnamon works fine :-)
lokee
Level 1
Level 1
 
Posts: 1
Joined: Sat Jan 04, 2014 4:51 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests