mdm upgrade troubles

Post your update and upgrade related errors here
Forum rules
Before you post please read this

mdm upgrade troubles

Postby Brian49 on Wed Feb 12, 2014 11:05 am

I currently have mdm 1.0.8; this has been the case since I first installed LMDE back in 2011. It works fine.

I see that the latest version is 1.4.11. I thought I would try it out, but two things happen when I go to upgrade it via Synaptic:

(1) for some unknown reason, the upgrade would involve installing thirteen additional packages;

(2) when I click to apply the upgrade, this message appears:

mdm:
Depends: libwebkitgtk-1.0-0 but it is not going to be installed
Depends: gir1.2-webkit-3.0 but it is not going to be installed


Would some kind person help me understand what is going on, please? I would also be glad to know whether version 1.4.11 offers anything that version 1.0.8 lacks. By the way, I'm tracking Debian Unstable. Many thanks.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Linux Mint is funded by ads and donations.
 

Re: mdm upgrade troubles

Postby Monsta on Wed Feb 12, 2014 1:07 pm

Ah, so you're tracking Sid... that probably makes it more complicated. But anyway, try to do it from the command line:
Code: Select all
apt install mdm

If it doesn't work then post the full output here.
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: mdm upgrade troubles

Postby Brian49 on Wed Feb 12, 2014 2:32 pm

Thanks for responding. The message in the terminal is pretty much the same as in Synaptic, namely:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mdm : Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
Depends: gir1.2-webkit-3.0 but it is not going to be installed
E: Broken packages


The message is the same with the Testing and Stable repositories enabled.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Re: mdm upgrade troubles

Postby Monsta on Wed Feb 12, 2014 2:44 pm

Well, one method to find the root of the problem is to try installing these packages one by one. If apt-get says "depends on xxx but it is not going to be installed", then try to install package xxx, see what apt-get says again, and so on down the dependency chain.
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests