[SOLVED] Mintsources Error

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[SOLVED] Mintsources Error

Postby dclement on Fri Feb 28, 2014 10:51 am

Hi,

I've just applied UP8 and I was checking everything. I noticed that mintsources was not installed, so I installed it.

But it won't run, I get this error:
Code: Select all
daniel@m6400 ~ $ mintsources
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintSources/mintSources.py", line 1217, in <module>
    Application().run()
  File "/usr/lib/linuxmint/mintSources/mintSources.py", line 594, in __init__
    self.mirrors = self.read_mirror_list(self.config["mirrors"]["mirrors"])
  File "/usr/lib/linuxmint/mintSources/mintSources.py", line 743, in read_mirror_list
    mirrorsfile = open(path, "r")
IOError: [Errno 2] Aucun fichier ou dossier de ce type: '/usr/share/python-apt/templates/LinuxMint.mirrors'
It appears to want a file, LinuxMint.mirrors, which isn't there. Is this the problem? How could I have this file created?

TIA - best regards, Daniel
Last edited by dclement on Sat Mar 01, 2014 11:32 am, edited 1 time in total.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Re: Mintsources Error

Postby viking777 on Fri Feb 28, 2014 12:25 pm

Moved here by moderator. Please don't attach support questions to FAQ's. Thanks.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Mintsources Error

Postby Monsta on Fri Feb 28, 2014 12:56 pm

Code: Select all
apt install mint-mirrors
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Mintsources Error

Postby dclement on Sat Mar 01, 2014 10:58 am

Oh, I'm sorry for posting in the wrong place and not reading the FAQ till the end. I really thought I had been thorough this time... My apology to the moderators.

Well, just two more thoughts:
* perhaps mint-mirrors should be made a dependency of mintsources?
* now it's mintsources that appears when one chooses "software sources" in mintupdate. But Synaptic still has the old interface (software-properties, I believe): is this one also deprecated and to be removed?

Best regards, Daniel
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Mintsources Error

Postby Monsta on Sat Mar 01, 2014 11:19 am

dclement wrote:* perhaps mint-mirrors should be made a dependency of mintsources?

Well, when I've learned of this bug, I've reported it to Clem and immediately suggested to add that dependency. Clem replied that it won't happen because mintSources is written as a cross-distro tool (it's intended also for Snow Linux and some other distro I forgot about) and cannot depend on a Mint-specific package.
Instead, it will be modified to check for the mirrors file in runtime. I don't know when it will be fixed though.

dclement wrote:* now it's mintsources that appears when one chooses "software sources" in mintupdate. But Synaptic still has the old interface (software-properties, I believe): is this one also deprecated and to be removed?

Well, you need to understand that mintSources is Mint's own tool and the upstream software knows nothing about it. Synaptic is upstream, software-properties-gtk is upstream. Synaptic knows about software-properties-gtk and calls it when you tell it to edit the repos; Synaptic doesn't know about mintSources and will never call it.
You can remove software-properties-gtk if you want. Synaptic then will use its own built-in repo editor. Be warned though that this editor is buggy, for example, it crashes when you try to delete a repo.
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Mintsources Error

Postby dclement on Sat Mar 01, 2014 11:32 am

Monsta wrote:[...]
You can remove software-properties-gtk if you want. Synaptic then will use its own built-in repo editor. Be warned though that this editor is buggy, for example, it crashes when you try to delete a repo.

Oh, I thought it was the converse (software-properties-gtk being the more buggy). No problem, I'm fine with software-properties-gtk, I find it rather more flexible than Synaptic's built-in repo. editor. I'm gladly keeping it.

Once again, many thanks, Monsta, for all your help. I'm marking the thread solved.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 1 guest