UP8: ipod Touch or ipod Phone won't mount

Post your update and upgrade related errors here
Forum rules
Before you post please read this

UP8: ipod Touch or ipod Phone won't mount

Postby ddurdle on Wed Mar 05, 2014 3:44 pm

Since upgrading to UP8, I'm no longer able to mount my ipod Touch 2G 3.1.3 or iphone 3GS 6.1.4. Both devices used to appear as a mounted device when plugged in, and I could use gtkpod to sync to. Since the upgrade, when I plug in either device, I get a DBUS timeout error. The devices appear as unmounted, and when I try mount them via caja, I get a DBUS timeout error.

I've spotted a french user who posted on a french forum the same issue after upgrading to UP8 and there was no resolution.
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Linux Mint is funded by ads and donations.
 

Re: UP8: ipod Touch or ipod Phone won't mount

Postby Monsta on Sun Mar 09, 2014 3:59 am

Post the output of
Code: Select all
dmesg | tail
after plugging in the device and getting a timeout message.
Monsta
Level 8
Level 8
 
Posts: 2443
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby sergio67 on Wed Mar 12, 2014 11:02 am

ipod Touch 4th generation
Code: Select all
[  670.425121] usb 3-2: new high-speed USB device number 8 using xhci_hcd
[  670.443573] usb 3-2: New USB device found, idVendor=05ac, idProduct=129e
[  670.443575] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  670.443577] usb 3-2: Product: iPod
[  670.443578] usb 3-2: Manufacturer: Apple Inc.
[  670.443579] usb 3-2: SerialNumber: 1a4526c5cae18007b17804d4a89be01d5600eb92
[  670.443692] usb 3-2: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
[  670.443696] usb 3-2: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
[  670.448015] usb 3-2: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
[  670.448019] usb 3-2: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
sergio67
Level 1
Level 1
 
Posts: 3
Joined: Wed Mar 12, 2014 10:59 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby sergio67 on Fri Mar 14, 2014 2:54 pm

Hi Monsta
I have the same problem than ddurdle since upgrading UP8.
I use LMDE with cinnamon 2.
I leave the code in previous post.
Can you help me ?
Thank's
sergio67
Level 1
Level 1
 
Posts: 3
Joined: Wed Mar 12, 2014 10:59 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby Monsta on Fri Mar 14, 2014 2:59 pm

Your dmesg output doesn't contain any errors, so I can't give any advice here. You might want to see this post though. The mentioned ifuse tool might work for you.
Monsta
Level 8
Level 8
 
Posts: 2443
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby sergio67 on Fri Mar 14, 2014 3:34 pm

With this post, I succeed to mount ipod only as root. If I write : " ifuse /mnt/ipod", I have an error message : "fuse: failed to open /dev/fuse: Permission denied".
An other problem : I can't mount the second partition "documents" with this method.
Before with UP7, ipod and document were mounted when plugged in.
sergio67
Level 1
Level 1
 
Posts: 3
Joined: Wed Mar 12, 2014 10:59 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby Monsta on Sat Mar 15, 2014 3:48 am

sergio67 wrote:With this post, I succeed to mount ipod only as root. If I write : " ifuse /mnt/ipod", I have an error message : "fuse: failed to open /dev/fuse: Permission denied".

You probably need to add yourself to the fuse group, then re-login.
Monsta
Level 8
Level 8
 
Posts: 2443
Joined: Fri Aug 19, 2011 3:46 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby ddurdle on Fri Apr 04, 2014 9:47 pm

I've always been a member of "fuse"

durdle@x61-ssd [69C] [0.0 W] ~ $ groups
durdle sudo src fuse test

dmesg output:

usb 6-1: new high-speed USB device number 3 using ehci-pci
usb 6-1: New USB device found, idVendor=05ac, idProduct=1294
usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 6-1: Product: iPhone
usb 6-1: Manufacturer: Apple Inc.
usb 6-1: SerialNumber: <<>>
ipheth 6-1:4.2: Apple iPhone USB Ethernet device attached
usbcore: registered new interface driver ipheth
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
pool[5534]: segfault at 300000003 ip 00007fc287ff8cd6 sp 00007fc283ffbc50 error 6 in libimobiledevice.so.4.0.1[7fc287fed000+1a000]
pool[5558]: segfault at 300000003 ip 00007f61bd848cd6 sp 00007f61b984bc50 error 6 in libimobiledevice.so.4.0.1[7f61bd83d000+1a000]

sounds familiar to this 2012 issue? https://bugs.archlinux.org/task/26710

It definitely worked pre UP8. I'm able to get it working on a UP7 system, but fails on 3 UP8 systems
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Re: UP8: ipod Touch or ipod Phone won't mount

Postby ddurdle on Fri Apr 04, 2014 10:05 pm

this worked for me:

http://beautifulajax.dip.jp/?p=536

Scroll down to "My solution"
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests