LMDE update / repository problem? SOLVED

Post your update and upgrade related errors here
Forum rules
Before you post please read this

LMDE update / repository problem? SOLVED

Postby kbkatz1 on Sun Aug 03, 2014 3:23 pm

I try to perform an "update" and encounter this error (see attachment).

Here are my current repositories:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free


Thoughts?
Attachments
update_error.png
Last edited by kbkatz1 on Sun Aug 24, 2014 12:15 am, edited 1 time in total.
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Linux Mint is funded by ads and donations.
 

Re: LMDE update / repository problem?

Postby nomko on Sun Aug 03, 2014 4:19 pm

Maybe the server you try to use is down. Happens more often, not only with LMDE but also mainstream Mint.
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2880
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: LMDE update / repository problem?

Postby grizzler on Sun Aug 03, 2014 4:24 pm

Very old versions, by the looks of it. No longer in the repository. Try running apt update in a terminal and see if retrieving the package lists works without errors.
grizzler
Level 4
Level 4
 
Posts: 435
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: LMDE update / repository problem?

Postby nomko on Sun Aug 03, 2014 4:26 pm

grizzler wrote:Try running apt update in a terminal

Quoting the topic starter:
I try to perform an "update" and encounter this error (see attachment).

So, what will fix your solution grizzler??
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2880
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: LMDE update / repository problem?

Postby kbkatz1 on Sun Aug 03, 2014 4:58 pm

Results of apt update:

ken@inspiron531s:~$ apt update
[sudo] password for ken:
Hit http://debian.linuxmint.com testing InRelease
Ign http://packages.linuxmint.com debian InRelease
Ign http://dl.google.com stable InRelease
Hit http://debian.linuxmint.com testing/updates InRelease
Get:1 http://packages.linuxmint.com debian Release.gpg [198 B]
Hit http://debian.linuxmint.com testing InRelease
Ign http://dl.google.com stable InRelease
Get:2 http://packages.linuxmint.com debian Release [16.8 kB]
Hit http://dl.google.com stable Release.gpg
Hit http://dl.google.com stable Release.gpg
Hit http://debian.linuxmint.com testing/main i386 Packages/DiffIndex
Hit http://dl.google.com stable Release
Hit http://debian.linuxmint.com testing/contrib i386 Packages/DiffIndex
Get:3 http://packages.linuxmint.com debian/main i386 Packages [26.1 kB]
Hit http://dl.google.com stable Release
Hit http://debian.linuxmint.com testing/non-free i386 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/contrib Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/main Translation-en/DiffIndex
Get:4 http://packages.linuxmint.com debian/upstream i386 Packages [18.1 kB]
Get:5 http://packages.linuxmint.com debian/import i386 Packages [53.6 kB]
Hit http://debian.linuxmint.com testing/non-free Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/updates/main i386 Packages
Hit http://debian.linuxmint.com testing/updates/contrib i386 Packages
Hit http://debian.linuxmint.com testing/updates/non-free i386 Packages
Hit http://debian.linuxmint.com testing/updates/contrib Translation-en
Hit http://debian.linuxmint.com testing/updates/main Translation-en
Hit http://debian.linuxmint.com testing/updates/non-free Translation-en
Hit http://debian.linuxmint.com testing/main i386 Packages
Hit http://debian.linuxmint.com testing/non-free i386 Packages
Hit http://dl.google.com stable/main i386 Packages
Hit http://dl.google.com stable/main i386 Packages
Ign http://debian.linuxmint.com testing/main Translation-en_US
Ign http://debian.linuxmint.com testing/main Translation-en
Ign http://debian.linuxmint.com testing/non-free Translation-en_US
Ign http://debian.linuxmint.com testing/non-free Translation-en
Ign http://packages.linuxmint.com debian/import Translation-en_US
Ign http://packages.linuxmint.com debian/import Translation-en
Ign http://packages.linuxmint.com debian/main Translation-en_US
Ign http://dl.google.com stable/main Translation-en_US
Ign http://packages.linuxmint.com debian/main Translation-en
Ign http://dl.google.com stable/main Translation-en
Ign http://packages.linuxmint.com debian/upstream Translation-en_US
Ign http://dl.google.com stable/main Translation-en_US
Ign http://packages.linuxmint.com debian/upstream Translation-en
Ign http://dl.google.com stable/main Translation-en
Fetched 115 kB in 3s (30.7 kB/s)
Reading package lists... Done
ken@inspiron531s:~$
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby forre on Sun Aug 03, 2014 5:03 pm

I've been trying to install new linuxmint.

Seens to be that all packages from .. linuxmint.com suffers somekind of download problem.
Connection to server is very slow (some bits per second).

All other downloads (packets from ubuntu and so on) works perfectly.

-Förre-
forre
Level 1
Level 1
 
Posts: 1
Joined: Sun Aug 03, 2014 4:58 pm

Re: LMDE update / repository problem?

Postby gtsfer on Sun Aug 03, 2014 6:15 pm

I think there's more in your repository settings than shown in your first post. Do this command from terminal to see everything you have in there...

Code: Select all
inxi -r
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Sun Aug 03, 2014 6:38 pm

ken@inspiron531s:~$ inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb http://dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/google-musicmanager.list
deb http://dl.google.com/linux/musicmanager/deb/ stable main
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby gtsfer on Sun Aug 03, 2014 8:18 pm

kbkatz1 wrote:ken@inspiron531s:~$ inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb http://dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/google-musicmanager.list
deb http://dl.google.com/linux/musicmanager/deb/ stable main

1) Has it been a lonnnnng time sine you've done an update? Since UP8 which occurred months ago your default repository list is now located in...
/etc/apt/sources.list.d/official-package-repositories.list, not in /etc/apt/sources.list as indicated from your inxi command. Mine looks as shown below (this is the default). The /etc/apt/sources.list file is now essentially empty, just a comment line since UP8.

Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com debian main upstream import
deb http://debian.linuxmint.com/latest/ testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://extra.linuxmint.com debian main

2) Neither of those two repos for google-chrome or google-musicmanager exist. Just try clicking on those two links you'll see what I mean. You must have added these, maybe they worked at one time. But they are dead now.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Sun Aug 03, 2014 10:10 pm

It has been a while since I did an update. Any suggestions?
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby kbkatz1 on Sun Aug 03, 2014 10:18 pm

says I'm on UP8.
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby grizzler on Mon Aug 04, 2014 1:55 am

nomko wrote:So, what will fix your solution grizzler??

It makes sure all the package lists are up to date and reports any that can't be retrieved. Looking for old packages is often a sign of a package list not being updated.

gtsfer wrote:2) Neither of those two repos for google-chrome or google-musicmanager exist.

Actually, those two still work fine. Got four package lists (2 amd64, 2 i386) from them just now. The apt update listing above would have shown an error if they were bad.

kbkatz1 wrote:Any suggestions?

Sorry, no. I was expecting something in one of those google package lists to ask for something old, but I just checked them and they don't seem to be doing so (unless it's one of the dependency's dependencies...). You could try disabling them and see if that changes anything.

It's an odd set of old items that your system wants. I mean, gnome shell and inxi? Weird.
grizzler
Level 4
Level 4
 
Posts: 435
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: LMDE update / repository problem?

Postby gtsfer on Mon Aug 04, 2014 7:52 am

kbkatz1 wrote:It has been a while since I did an update. Any suggestions? says I'm on UP8.

UP8 is good at least. I would go into Software Sources in Control Center and restore the defaults for starters. You might want to save your added repositories, or actually, you have a copy of them posted right here. right? After you restore to defaults, check that /etc/apt/sources.list just has a comment line in it. It should if you are on UP8. Also check /etc/apt/sources.list.d/official-package-repositories.list and see if it looks right.

Then do an update. After that you can add that Google stuff back in. (fwiw.. clicking on either of those Google links in your "inxi -r" post results in "that's an error, that's all we know").
Last edited by gtsfer on Thu Aug 07, 2014 7:43 pm, edited 1 time in total.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Thu Aug 07, 2014 7:37 pm

Control Center? what should the comment line in /etc/apt/sources.list say?
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby gtsfer on Thu Aug 07, 2014 7:52 pm

kbkatz1 wrote:Control Center? what should the comment line in /etc/apt/sources.list say?

It looks exactly like this since UP8.
#/etc/apt/sources.list

But restoring default settings should fix it all for you I would imagine. Yes, it's called "Control Center" right off the main menu. I have Mate, maybe Cinnamon is a little different if that's what you have. But I know there's a "Control Center", there has to be. Then go to Software Sources, "restore default settings". And try an update again.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Thu Aug 07, 2014 8:05 pm

Fix:
Commented out all sources listed in "/etc/apt/sources.list" and added the correct repos to "/etc/apt/sources.list.d/official-package-repositories.list". Updated and everything worked. Thanks for the assistance gtsfer.
Last edited by kbkatz1 on Fri Aug 08, 2014 6:32 pm, edited 1 time in total.
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby gtsfer on Thu Aug 07, 2014 8:10 pm

Cool, glad that worked for you. Can you edit your first post and add <SOLVED> in the subject. It might help someone else. :)
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Fri Aug 08, 2014 6:39 pm

My mistake, NOT SOLVED. Rebooted today and was able to get to the login screen and then the screen just goes dark. So the updating essentially "broke" logging into a GUI. I can login "recovery mode" to get to a CLI though.

when I run apt-get dist-upgrade I get the following errors:

The following packages have been kept back:
caja-gksu caja-open-terminal libatril libcaja-extention libmatebluetooth libmatewnck-common mate-calc mate-dialogs mate-keyring mate-netspeed mate-notification-daemon mate-system-monitor mdm mint-meta-codecs
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded; N: Ignoring file 'official-package-repositories' in directory 'etc/apt/sources.list.d/' as it has no filename extension.
N: Ignoring file 'official-package-repositories' in directory 'etc/apt/sources.list.d/' as it has no filename extension.
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Re: LMDE update / repository problem?

Postby gtsfer on Fri Aug 08, 2014 8:36 pm

I don't know how, but your your source file appears to be missing the ".list" extension from the error messages huh? Don't know how that would have happened at all. If you can get to console mode, login as 'root' and try this. (this is being creative mind you).

Code: Select all
mv /etc/apt/sources.list.d/official-package-repositories /etc/apt/sources.list.d/official-package-repositories.list
apt update
shutdown -r now

The shutdown command like that will do a restart. Maybe restoring defaults in Software Sources was the best idea after all. But you would have had to add your extra "stuff" back from scratch that way.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE Mate, Cinnamon 17, KDE 17, Debian 7.6.0. Edit your first post and add SOLVED to the Subject if it's resolved.
User avatar
gtsfer
Level 7
Level 7
 
Posts: 1692
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: LMDE update / repository problem?

Postby kbkatz1 on Sun Aug 10, 2014 11:08 pm

applied the above method with some success and some hiccups...

The rename worked and many updates took affect, the problem is I ended up with an Xorg error. Not usually a big problem, I usually (if this occurs) just reinstall my NVIDIA driver and all is good. Not this time though when I go to install it it says I now have a newer GCC (4.6?) than what the NVIDIA driver was compiled for GCC 4.4? and It says I can proceed if I know what I am doing. Long story short, it didn't work, even when I restored my xorg.conf to the previous backup.

Thoughts? I feel it is close........
LMDE
LM17 "Quiana"
Peppermint 5
ClearOS Server
User avatar
kbkatz1
Level 3
Level 3
 
Posts: 146
Joined: Tue Jun 15, 2010 4:28 pm
Location: U.S.A

Linux Mint is funded by ads and donations.
 
Next

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 4 guests