upgraded and something went wrong (solved)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

upgraded and something went wrong (solved)

Postby feddds on Wed Sep 15, 2010 10:01 pm

I am not an experienced linux user but updating debian mint, something went wrong:

dds@m740tu(n)/m760tu(n)/w7x0tun-laptop ~ $ sudo apt-get install openoffice.org-l10n-es
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
apt-utils: Depende: libapt-pkg4.10
aptitude: Depende: libapt-pkg4.10
Recomienda: aptitude-doc-en pero no va a instalarse o
aptitude-doc
Recomienda: apt-xapian-index pero no va a instalarse
Recomienda: libparse-debianchangelog-perl pero no va a instalarse
libapt-pkg-perl: Depende: libapt-pkg4.10
libept1: Depende: libapt-pkg4.10
python-apt: Depende: libapt-pkg4.10
synaptic: Depende: libapt-pkg4.10
Recomienda: apt-xapian-index pero no va a instalarse
E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).
dds@m740tu(n)/m760tu(n)/w7x0tun-laptop ~ $

---
I really do not have a clue about this.
I can not install anything from synaptic or apt.
I updated debian mint yesterday on other laptop and it went Ok.
I ran as system suggestion:
dds@m740tu(n)/m760tu(n)/w7x0tun-laptop ~ $ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Se instalarán los siguientes paquetes extras:
apt
Paquetes sugeridos:
apt-doc
Se actualizarán los siguientes paquetes:
apt
1 actualizados, 0 se instalarán, 0 para eliminar y 199 no actualizados.
7 no instalados del todo o eliminados.
Se necesita descargar 0B/1.965kB de archivos.
Se utilizarán 377kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
AVISO: ¡No se han podido autenticar los siguientes paquetes!
apt
Aviso de autenticación ignorado.
Traceback (most recent call last):
File "/usr/bin/apt-listchanges", line 28, in <module>
import apt_pkg
ImportError: libapt-pkg.so.4.10: cannot open shared object file: No such file or directory
apt-extracttemplates: error while loading shared libraries: libapt-pkg.so.4.10: cannot open shared object file: No such file or directory
debconf: fallo al ejecutar «apt-extracttemplates»: Descriptor de fichero erróneo
Configurando debian-archive-keyring (2010.08.28) ...
gpg: clave F42584E6: "Lenny Stable Release Key <debian-release@lists.debian.org>" sin cambios
gpg: clave 55BE302B: "Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster@debian.org>" sin cambios
gpg: clave 6D849617: "Debian-Volatile Archive Automatic Signing Key (5.0/lenny)" sin cambios
gpg: failed to create temporary file `/etc/apt/.#lk0xa124ac0.m740tu(n)/m760tu(n)/w7x0tun-laptop.3441': No existe el fichero o el directorio
gpg: can't allocate lock for `/etc/apt/trusted.gpg'
gpg: failed to create temporary file `/etc/apt/.#lk0xa124a58.m740tu(n)/m760tu(n)/w7x0tun-laptop.3441': No existe el fichero o el directorio
gpg: can't allocate lock for `/etc/apt/secring.gpg'
gpg: error escribiendo anillo `/etc/apt/trusted.gpg': Error general
gpg: clave B98321F9: clave pública "[ID de usuario no encontrado]" importada
gpg: error leyendo `[stdin]': Error general
gpg: import from `[stdin]' failed: Error general
gpg: Cantidad total procesada: 3
gpg: importadas: 1 (RSA: 1)
gpg: sin cambios: 3
dpkg: error al procesar debian-archive-keyring (--configure):
el subproceso installed post-installation script devolvió el código de salida de error 2
Se encontraron errores al procesar:
debian-archive-keyring
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hope not to bother my fellow debian users at debian forums...read that they think new Linux Mint Debian Edition would "populate" their site...as Ikey is afraid too. Don´t worry I will keep posting here :oops:
Last edited by feddds on Sat Sep 18, 2010 11:53 am, edited 1 time in total.
feddds
Level 1
Level 1
 
Posts: 11
Joined: Mon Jan 12, 2009 4:47 pm

Linux Mint is funded by ads and donations.
 

Re: upgraded and something went wrong

Postby zerozero on Thu Sep 16, 2010 5:14 pm

gpg: clave F42584E6: "Lenny Stable Release Key <debian-release@lists.debian.org>" sin cambios
gpg: clave 55BE302B: "Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster@debian.org>" sin cambios
gpg: clave 6D849617: "Debian-Volatile Archive Automatic Signing Key (5.0/lenny)" sin cambios


I presume you changed your sources.list, as i can see above Lenny.
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: upgraded and something went wrong

Postby altair4 on Fri Sep 17, 2010 6:15 am

I'm not exactly sure about the special characters ( i.e., /, (, ) ) but from a Samba and SMB persecutive the hostname is too long. It must be 15 characters or less. I don't know if that's a network wide requirement or just pertains to Samba / SMB itself but I'd limit the length.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5515
Joined: Tue Feb 03, 2009 10:27 am

Re: upgraded and something went wrong (solved)

Postby feddds on Sat Sep 18, 2010 11:52 am

Worked just Ikey said. Nice commands!.

Thanks. Feddds.
feddds
Level 1
Level 1
 
Posts: 11
Joined: Mon Jan 12, 2009 4:47 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests