Problem doing updates (Solved)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Problem doing updates (Solved)

Postby doktordave on Mon Feb 21, 2011 6:45 pm

I've been away for a few days, and started to take care of updates. When running apt-get update, I get the following message:

Code: Select all
W: GPG error: http://ftp.us.debian.org testing Release: The following signatures were invalid: BADSIG AED4B06F473041FA Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>

The apparent entry in my sources.list file causing the issue seems to be:

Code: Select all
deb http://ftp.us.debian.org/debian testing main contrib non-free

Any advice on what's going on, or how to fix?
Last edited by doktordave on Tue Feb 22, 2011 8:15 am, edited 1 time in total.
User avatar
doktordave
Level 2
Level 2
 
Posts: 60
Joined: Wed Apr 08, 2009 8:57 am
Location: Danville, VA

Linux Mint is funded by ads and donations.
 

W: Failed to fetch http://ftp.debian.org/debian/dists/testin

Postby drden on Mon Feb 21, 2011 6:55 pm

Hello all,
I'm a newbie to Linux Mint. If you help me I will be your friend, or give you a piece of candy!
I have this error after I did an update around Feb 18? 2011.
Any help would be appreciated... I don't really know what else to do.

I have the latest version of Mint Debian. There was an error with the last update because the internet shut down.
I never re-started the computer, I just closed the update program and re-started it. It seemed to work fine with the internet on
but now I get an error when I update.

Below this line is my error message:

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ftp.debian.org testing Release: The following signatures were invalid: BADSIG AED4B06F473041FA Debian Archive Automatic Signing Key (6.0/squeeze) <ftpmaster@debian.org>

W: Failed to fetch http://ftp.debian.org/debian/dists/testing/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.

End of error message

Thanks for the help! I really don't want to switch back to "MS Win-Don'ts"! Great work on this OS everyone! I love it!!!
drden
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 21, 2011 6:25 pm

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby Roken on Mon Feb 21, 2011 6:57 pm

There seems to be a general problem with this - also reported in IRC and at the Debian forums

I suggest waiting until it gets fixed.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby vrkalak on Mon Feb 21, 2011 7:33 pm

Does this issue appear in Squeeze or only in 'testing' ?

I am using both, Squeeze in one OS, and am currently in my Debian/Mint 'testing' install . . . I recently updated and do not have this problem.

I did notice that this same issue has appeared in the Debian User Forums, as well. Hopefully, a 'fix' will come swiftly.
Image
:: LinuxMint-Debian-Edition (Fluxbox) :: Manjaro/Arch (Xfce) ::
Registered Linux User: #497031 :: DeviantART Page
User avatar
vrkalak
Level 10
Level 10
 
Posts: 3264
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby Roken on Mon Feb 21, 2011 7:35 pm

Disabling testing solves it - so it seems like testing only.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby Roken on Mon Feb 21, 2011 8:01 pm

Testing respoitory is working again
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby doktordave on Mon Feb 21, 2011 8:17 pm

Using Testing here. I had 100 updates, they seem to have worked OK. Still getting the error message at this time. Most likely it will get worked out in due time.
User avatar
doktordave
Level 2
Level 2
 
Posts: 60
Joined: Wed Apr 08, 2009 8:57 am
Location: Danville, VA

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby craig10x on Mon Feb 21, 2011 8:23 pm

I get that too...but it is on and off...somedays it does that and other days it doesn't...so it seems to be a widespread kind of bug...and since it was mentioned it was reported, i would imagine it will eventually get fixed...doesn't seem to affect the updates from coming in (thankfully) :wink:

I am also using the default (debian testing of course)...
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby TBABill on Mon Feb 21, 2011 8:38 pm

Seems to be fixed now. I just got a lump of about 14 updates the first time it ran without errors to look for updates.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby gotjazz on Tue Feb 22, 2011 3:06 am

yeah it's been doing that lately - just keep trying again. one out of three apt-get updates manage to get it here :)
Image
User avatar
gotjazz
Level 4
Level 4
 
Posts: 386
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: W: Failed to fetch http://ftp.debian.org/debian/dists/te

Postby doktordave on Tue Feb 22, 2011 8:14 am

Yeah, it seems to have sorted itself out OK. Changed to a different error, and then a bit later all was good again. Thank you to all who looked into this.
User avatar
doktordave
Level 2
Level 2
 
Posts: 60
Joined: Wed Apr 08, 2009 8:57 am
Location: Danville, VA

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 13 guests