LMDE BREAKAGES - tracking TESTING

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby viking777 on Fri May 11, 2012 9:13 am

If you prefer, I can start a new thread for the Cinnamon-specific stuff if that is more appropriate


That didn't even cross my mind Lippy, I wouldn't say it is absolutely necessary but do so if you wish.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby mockturtl on Fri May 11, 2012 11:54 am

GeneC wrote:
Code: Select all
The following packages will be REMOVED:
  gnome-utils-common libgail-gnome-module libgnomepanel2.24-cil libpanel-applet2-0 python-gnomeapplet


Same issues here. (I do get a bunch of MATE updates from tridex by adjusting my pin priority from all 700 to 500; didn't realize I hadn't fixed that on this box.)

Code: Select all
$ sudo aptitude full-upgrade

The following NEW packages will be installed:
  libgdict-common{ab} libupnp6{ab}
The following packages will be upgraded:
  gnome-dictionary gnome-panel{b} gnome-panel-data libgdict-1.0-6 vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse
8 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.8 MB of archives. After unpacking 2,386 kB will be used.
The following packages have unmet dependencies:
 libupnp6 : Conflicts: libupnp3 but 1:1.6.6-5.1 is installed.
 libgdict-common : Breaks: gnome-utils-common (< 3.3) but 3.2.1-3 is installed.
 gnome-panel : Breaks: libpanel-applet2-0 but 2.30.2-4+b1 is installed.
I guess gnome-utils is going away. I removed it and -common, and now my PrintScreen key doesn't work. :x

I hope everything gnome-panel wants to remove is GNOME2 cruft.

Code: Select all
$ sudo aptitude full-upgrade
The following packages will be upgraded:
  gnome-panel{b} gnome-panel-data
2 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,604 kB of archives. After unpacking 32.8 kB will be freed.
The following packages have unmet dependencies:
 gnome-panel : Breaks: libpanel-applet2-0 but 2.30.2-4+b1 is installed.
The following actions will resolve these dependencies:

(... no, wrong, nope ...)

The following actions will resolve these dependencies:

     Remove the following packages:
1)     deskbar-applet             
2)     gnome-netstatus-applet     
3)     libgail-gnome-module       
4)     libgnomepanel2.24-cil       
5)     libpanel-applet2-0         
6)     python-gnomeapplet         

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  deskbar-applet{a} gnome-netstatus-applet{a} libgail-gnome-module{a} libgnomepanel2.24-cil{a} libpanel-applet2-0{a} python-gnomeapplet{a}
The following packages will be upgraded:
  gnome-panel gnome-panel-data
After a reboot, my window borders (Cinnamon) look a bit screwy; not sure if that's related. Gnome Shell and Fallback seem to work fine.

libupnp should be a normal version bump, but my APT is confused by the VLC dependency. Eventually aptitude finds a strategy:

Code: Select all
$ sudo aptitude remove libupnp3

(... no, no, no ... page through ...)

The following actions will resolve these dependencies:

     Install the following packages:                           
1)     libupnp6 [1:1.6.17-1.1 (testing)]                       

     Upgrade the following packages:                           
2)     vlc [2.0.1-4 (now) -> 2.0.1-4+b1 (testing)]             
3)     vlc-nox [2.0.1-4 (now) -> 2.0.1-4+b1 (testing)]         
4)     vlc-plugin-notify [2.0.1-4 (now) -> 2.0.1-4+b1 (testing)]
5)     vlc-plugin-pulse [2.0.1-4 (now) -> 2.0.1-4+b1 (testing)]

     Leave the following dependencies unresolved:               
6)     vlc recommends vlc-plugin-pulse (= 2.0.1-4)
But there's another conflict in VLC from the debian-multimedia repo.

Code: Select all
apt-cache policy vlc-nox
vlc-nox:
  Installed: 2.0.1-4+b1
  Candidate: 1:2.0.1-0.6
  Version table:
     1:2.0.1-0.6 0
        500 http://www.debian-multimedia.org/ testing/main i386 Packages
 *** 2.0.1-4+b1 0
        500 http://ftp.us.debian.org/debian/ testing/main i386 Packages
        100 /var/lib/dpkg/status
I'm sticking with the official release.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby mockturtl on Fri May 11, 2012 11:57 am

The debian-multimedia repo has changed to deb-multimedia.org.

10/05/2012 :
New domain name deb-multimedia.org
You must edit your /etc/apt/sources.list to replaces the old repository name by the new one.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby zerozero on Fri May 11, 2012 1:56 pm

mockturtl wrote:The debian-multimedia repo has changed to deb-multimedia.org.

10/05/2012 :
New domain name deb-multimedia.org
You must edit your /etc/apt/sources.list to replaces the old repository name by the new one.

good find :wink: for now the old repo is still synced with the new one, but it's always a good idea to be prepared.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby squeezy on Sun May 13, 2012 11:51 am

So that's why there was a new Multimedia key installed recently! Thanks for that info. It clears up a little mystery for me :D
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby KBD47 on Sun May 13, 2012 7:47 pm

When I switched my sources to Wheezy, Banshee got removed and so did Rhythmbox. Now there are dependency problems. Just wondering if it is safe to enable sid to get those back, or is that likely to cause new problems?
Thanks.
kbd47
KBD47
Level 6
Level 6
 
Posts: 1028
Joined: Fri Jul 29, 2011 12:03 am

Re: LMDE BREAKAGES - tracking TESTING - updated 7 May

Postby zerozero on Tue May 15, 2012 7:25 am

Today's update removes cinnamon
Code: Select all
Calculating upgrade... Done
The following packages will be REMOVED:
  cinnamon gir1.2-muffin-3.0 gir1.2-sushi-1.0 libclutter-gtk-0.10-0 libcogl5 libebook1.2-10
  libebook1.2-9 libecal1.2-8 libedata-book-1.2-9 libedata-book1.2-2 libedata-book1.2-8
  libedata-cal-1.2-11 libedata-cal1.2-10 libedataserverui-3.0-0 libedataserverui1.2-11
  libedataserverui1.2-8 libept1 libmuffin-dev libmuffin0 libsushi-1.0-0 muffin


this is a funny day today :mrgreen:
purging cinnamon to see if the DU gets in:
Code: Select all
Start-Date: 2012-05-15  12:27:23
Commandline: /usr/sbin/synaptic
Purge: cinnamon:amd64 (1.4.0-lmde1)
End-Date: 2012-05-15  12:27:38

Start-Date: 2012-05-15  12:28:07
Commandline: /usr/sbin/synaptic
Purge: muffin:amd64 (1.0.2-lmde1), gir1.2-muffin-3.0:amd64 (1.0.2-lmde1), libmuffin0:amd64 (1.0.2-lmde1), muffin-common:amd64 (1.0.2-lmde1), libmuffin-dev:amd64 (1.0.2-lmde1)
End-Date: 2012-05-15  12:28:21

nahh :lol:
ok, so purging libcogl5 and installing libcogl9 brings us close
Code: Select all
Start-Date: 2012-05-15  12:35:49
Commandline: /usr/sbin/synaptic
Install: libcogl9:amd64 (1.10.2-3, automatic)
Upgrade: gnome-sushi:amd64 (0.4.0-1, 0.4.1-1+b1), libical0:amd64 (0.44-3, 0.48-2), libevolution:amd64 (3.2.2-1, 3.2.2-1+b1), gir1.2-rb-3.0:amd64 (2.96-3, 2.96-5), gnome-shell:amd64 (3.2.2.1-2, 3.2.2.1-4+b1), libcogl-pango0:amd64 (1.8.2-1, 1.10.2-3), rhythmbox-data:amd64 (2.96-3, 2.96-5), evolution-plugins:amd64 (3.2.2-1, 3.2.2-1+b1), evolution:amd64 (3.2.2-1, 3.2.2-1+b1), rhythmbox:amd64 (2.96-3, 2.96-5), libcheese-gtk21:amd64 (3.4.0-2, 3.4.1-1+b1), libcheese3:amd64 (3.4.0-2, 3.4.1-1+b1), librhythmbox-core5:amd64 (2.96-3, 2.96-5), libmutter0:amd64 (3.2.2-1, 3.2.2-3), libchamplain-0.12-0:amd64 (0.12.2-1, 0.12.2-1+b1), gir1.2-coglpango-1.0:amd64 (1.8.2-1, 1.10.2-3), libcluttergesture-0.0.2-0:amd64 (0.0.2.1-6, 0.0.2.1-6+b2), libclutter-1.0-0:amd64 (1.8.4-1, 1.10.4-3), cheese-common:amd64 (3.4.0-2, 3.4.1-1), libcogl-dev:amd64 (1.8.2-1, 1.10.2-3), gnome-shell-common:amd64 (3.2.2.1-2, 3.2.2.1-4), libmx-1.0-2:amd64 (1.4.5-1, 1.4.5-1+b1), libcogl-pango-dev:amd64 (1.8.2-1, 1.10.2-3), libclutter-1.0-dev:amd64 (1.8.4-1, 1.10.4-3), libclutter-gst-1.0-0:amd64 (1.5.4-1, 1.5.4-1+b2), libical-dev:amd64 (0.44-3, 0.48-2), rhythmbox-plugins:amd64 (2.96-3, 2.96-5), gir1.2-cogl-1.0:amd64 (1.8.2-1, 1.10.2-3), libclutter-gtk-1.0-0:amd64 (1.0.4-1, 1.2.0-2), gir1.2-clutter-1.0:amd64 (1.8.4-1, 1.10.4-3)
Remove: libclutter-gtk-0.10-0:amd64 (0.10.8-3), gir1.2-sushi-1.0:amd64 (0.2.1-3), libsushi-1.0-0:amd64 (0.2.1-3)
Purge: libcogl5:amd64 (1.8.2-1)
End-Date: 2012-05-15  12:36:57

but the next DU removes a lot of evolution related lib
Code: Select all
Start-Date: 2012-05-15  12:38:16
Commandline: apt-get dist-upgrade
Install: lua-socket:amd64 (2.0.2-8, automatic), libapt-inst1.5:amd64 (0.9.3, automatic), packagekit-tools:amd64 (0.7.4-2, automatic), libboost-iostreams1.49.0:amd64 (1.49.0-2, automatic), libapt-pkg4.12:amd64 (0.9.3, automatic), libgettextpo0:amd64 (0.18.1.1-7, automatic), libasprintf0c2:amd64 (0.18.1.1-7, automatic), libept1.4.12:amd64 (1.0.6.1, automatic)
Upgrade: python-packagekit:amd64 (0.7.3-2, 0.7.4-2), libpam0g:amd64 (1.1.3-7, 1.1.3-7.1), aptitude-doc-en:amd64 (0.6.6-1, 0.6.7-1), python3-apt:amd64 (0.8.3+nmu1, 0.8.4), libebackend-1.2-1:amd64 (3.2.2-1, 3.2.2-3), gir1.2-clutter-gst-1.0:amd64 (1.5.4-1, 1.5.4-1+b2), libpam-modules-bin:amd64 (1.1.3-7, 1.1.3-7.1), libedataserverui-3.0-dev:amd64 (3.2.2-1, 3.2.2-3), libcupsfilters1:amd64 (1.0.2-1, 1.0.16-2+b1), packagekit-backend-aptcc:amd64 (0.7.3-2, 0.7.4-2), libgupnp-1.0-4:amd64 (0.18.2-1, 0.18.3-1), aptitude:amd64 (0.6.6-1, 0.6.7-1), python-apt:amd64 (0.8.3+nmu1, 0.8.4), gettext-base:amd64 (0.18.1.1-5, 0.18.1.1-7), python-apt-common:amd64 (0.8.3+nmu1, 0.8.4), libmx-bin:amd64 (1.4.5-1, 1.4.5-1+b1), mutter-common:amd64 (3.2.2-1, 3.2.2-3), libedata-book-1.2-11:amd64 (3.2.2-1, 3.2.2-3), autopoint:amd64 (0.18.1.1-5, 0.18.1.1-7), apt-utils:amd64 (0.8.15.10, 0.9.3), gir1.2-ebook-1.2:amd64 (3.2.2-1, 3.2.2-3), libedata-cal-1.2-13:amd64 (3.2.2-1, 3.2.2-3), gettext:amd64 (0.18.1.1-5, 0.18.1.1-7), apt:amd64 (0.8.15.10, 0.9.3), liblua5.1-socket2:amd64 (2.0.2-6, 2.0.2-8), libcapture-tiny-perl:amd64 (0.17-1, 0.18-1), libclutter-1.0-common:amd64 (1.8.4-1, 1.10.4-3), libclutter-imcontext-0.1-0:amd64 (0.1.4-2, 0.1.4-2+b2), libedataserver-1.2-15:amd64 (3.2.2-1, 3.2.2-3), libebook-1.2-12:amd64 (3.2.2-1, 3.2.2-3), libpam-modules:amd64 (1.1.3-7, 1.1.3-7.1), libedataserver1.2-dev:amd64 (3.2.2-1, 3.2.2-3), libcamel-1.2-29:amd64 (3.2.2-1, 3.2.2-3), libebook1.2-dev:amd64 (3.2.2-1, 3.2.2-3), gir1.2-ecalendar-1.2:amd64 (3.2.2-1, 3.2.2-3), libecal-1.2-10:amd64 (3.2.2-1, 3.2.2-3), libcamel1.2-dev:amd64 (3.2.2-1, 3.2.2-3), packagekit:amd64 (0.7.3-2, 0.7.4-2), libecal1.2-dev:amd64 (3.2.2-1, 3.2.2-3), libpam-runtime:amd64 (1.1.3-7, 1.1.3-7.1), synaptic:amd64 (0.75.9, 0.75.10), libpackagekit-glib2-14:amd64 (0.7.3-2, 0.7.4-2), evolution-data-server-common:amd64 (3.2.2-1, 3.2.2-3), evolution-data-server:amd64 (3.2.2-1, 3.2.2-3), gir1.2-mutter-3.0:amd64 (3.2.2-1, 3.2.2-3), libapt-pkg-perl:amd64 (0.1.26, 0.1.26+b1), rsyslog:amd64 (5.8.10-1, 5.8.11-1), libedataserverui-3.0-1:amd64 (3.2.2-1, 3.2.2-3), gir1.2-edataserver-1.2:amd64 (3.2.2-1, 3.2.2-3), libcogl-common:amd64 (1.8.2-1, 1.10.2-3), cups-filters:amd64 (1.0.2-1, 1.0.16-2+b1), libchamplain-gtk-0.12-0:amd64 (0.12.2-1, 0.12.2-1+b1), gir1.2-gtkclutter-1.0:amd64 (1.0.4-1, 1.2.0-2)
Remove: libecal1.2-8:amd64 (3.0.3-2), libedata-cal-1.2-11:amd64 (3.0.3-2), libedata-book-1.2-9:amd64 (3.0.3-2), libedataserverui1.2-8:amd64 (2.30.3-2), libept1:amd64 (1.0.5), libedata-cal1.2-10:amd64 (2.32.3-1), libedata-book1.2-2:amd64 (2.30.3-2), libedata-book1.2-8:amd64 (2.32.3-1), libedataserverui1.2-11:amd64 (2.32.3-1), libedataserverui-3.0-0:amd64 (3.0.3-2), libebook1.2-10:amd64 (3.0.3-2), libebook1.2-9:amd64 (2.30.3-2)
End-Date: 2012-05-15  12:40:21

apparently evolution is working (but i'm not a regular user)

at the same time in wheezy
Code: Select all
Start-Date: 2012-05-15  12:39:48
Commandline: apt-get dist-upgrade
Install: libcogl9:amd64 (1.10.2-3, automatic), lightsoff:amd64 (3.4.1-2, automatic), swell-foop:amd64 (3.4.1-2, automatic), guile-2.0-libs:amd64 (2.0.5+1-3, automatic), libgettextpo0:amd64 (0.18.1.1-7, automatic), libasprintf0c2:amd64 (0.18.1.1-7, automatic)
Upgrade: gnome-sushi:amd64 (0.4.0-1, 0.4.1-1+b1), libpam0g:amd64 (1.1.3-7, 1.1.3-7.1), libical0:amd64 (0.44-3, 0.48-2), ekiga:amd64 (3.2.7-4.2, 3.2.7-5), libevolution:amd64 (3.2.2-1, 3.2.2-1+b1), gir1.2-rb-3.0:amd64 (2.96-3, 2.96-5), openconnect:amd64 (3.17-1, 3.18-1), gnome-shell:amd64 (3.2.2.1-2, 3.2.2.1-4+b1), libcogl-pango0:amd64 (1.8.2-1, 1.10.2-3), aisleriot:amd64 (3.2.2-1, 3.4.1-1), libebackend-1.2-1:amd64 (3.2.2-1, 3.2.2-3), gtali:amd64 (3.2.1-2, 3.4.1-2), gir1.2-clutter-gst-1.0:amd64 (1.5.4-1, 1.5.4-1+b2), glchess:amd64 (3.2.1-2, 3.4.1-2), rhythmbox-data:amd64 (2.96-3, 2.96-5), libpam-modules-bin:amd64 (1.1.3-7, 1.1.3-7.1), gnome-games:amd64 (3.2.1-2, 3.4.1-2), evolution-plugins:amd64 (3.2.2-1, 3.2.2-1+b1), cheese:amd64 (3.4.0-2, 3.4.1-1+b1), evolution:amd64 (3.2.2-1, 3.2.2-1+b1), gnobots2:amd64 (3.2.1-2, 3.4.1-2), libcupsfilters1:amd64 (1.0.2-1, 1.0.16-2+b1), rhythmbox:amd64 (2.96-3, 2.96-5), libcheese-gtk21:amd64 (3.4.0-2, 3.4.1-1+b1), libgupnp-1.0-4:amd64 (0.18.2-1, 0.18.3-1), gnome-sudoku:amd64 (3.2.1-2, 3.4.1-2), libcheese3:amd64 (3.4.0-2, 3.4.1-1+b1), gettext-base:amd64 (0.18.1.1-5, 0.18.1.1-7), libmx-bin:amd64 (1.4.5-1, 1.4.5-1+b1), librhythmbox-core5:amd64 (2.96-3, 2.96-5), mutter-common:amd64 (3.2.2-1, 3.2.2-3), libedata-book-1.2-11:amd64 (3.2.2-1, 3.2.2-3), gnibbles:amd64 (3.2.1-2, 3.4.1-2), autopoint:amd64 (0.18.1.1-5, 0.18.1.1-7), libedata-cal-1.2-13:amd64 (3.2.2-1, 3.2.2-3), libmutter0:amd64 (3.2.2-1, 3.2.2-3), gettext:amd64 (0.18.1.1-5, 0.18.1.1-7), libchamplain-0.12-0:amd64 (0.12.2-1, 0.12.2-1+b1), gir1.2-coglpango-1.0:amd64 (1.8.2-1, 1.10.2-3), libcapture-tiny-perl:amd64 (0.17-1, 0.18-1), libcluttergesture-0.0.2-0:amd64 (0.0.2.1-6, 0.0.2.1-6+b2), libclutter-1.0-common:amd64 (1.8.4-1, 1.10.4-3), gnotski:amd64 (3.2.1-2, 3.4.1-2), libclutter-imcontext-0.1-0:amd64 (0.1.4-2, 0.1.4-2+b2), libedataserver-1.2-15:amd64 (3.2.2-1, 3.2.2-3), libebook-1.2-12:amd64 (3.2.2-1, 3.2.2-3), libclutter-1.0-0:amd64 (1.8.4-1, 1.10.4-3), cheese-common:amd64 (3.4.0-2, 3.4.1-1), libopenconnect1:amd64 (3.17-1, 3.18-1), libpam-modules:amd64 (1.1.3-7, 1.1.3-7.1), libcamel-1.2-29:amd64 (3.2.2-1, 3.2.2-3), iagno:amd64 (3.2.1-2, 3.4.1-2), glines:amd64 (3.2.1-2, 3.4.1-2), gnome-shell-common:amd64 (3.2.2.1-2, 3.2.2.1-4), eog-plugins:amd64 (3.2.2-1+b1, 3.4.0-1), libecal-1.2-10:amd64 (3.2.2-1, 3.2.2-3), libmx-1.0-2:amd64 (1.4.5-1, 1.4.5-1+b1), python-libtiff:amd64 (0.3.0~svn78-2, 0.3.0~svn78-3), libpam-runtime:amd64 (1.1.3-7, 1.1.3-7.1), gnotravex:amd64 (3.2.1-2, 3.4.1-2), gnect:amd64 (3.2.1-2, 3.4.1-2), libclutter-gst-1.0-0:amd64 (1.5.4-1, 1.5.4-1+b2), quadrapassel:amd64 (3.2.1-2, 3.4.1-2), mahjongg:amd64 (3.2.1-2, 3.4.1-2), evolution-data-server-common:amd64 (3.2.2-1, 3.2.2-3), gnome-games-data:amd64 (3.2.1-2, 3.4.1-2), evolution-data-server:amd64 (3.2.2-1, 3.2.2-3), gir1.2-mutter-3.0:amd64 (3.2.2-1, 3.2.2-3), rsyslog:amd64 (5.8.10-1, 5.8.11-1), libedataserverui-3.0-1:amd64 (3.2.2-1, 3.2.2-3), rhythmbox-plugin-cdrecorder:amd64 (2.96-3, 2.96-5), libcogl-common:amd64 (1.8.2-1, 1.10.2-3), rhythmbox-plugins:amd64 (2.96-3, 2.96-5), cups-filters:amd64 (1.0.2-1, 1.0.16-2+b1), libchamplain-gtk-0.12-0:amd64 (0.12.2-1, 0.12.2-1+b1), gir1.2-cogl-1.0:amd64 (1.8.2-1, 1.10.2-3), libclutter-gtk-1.0-0:amd64 (1.0.4-1, 1.2.0-2), gir1.2-clutter-1.0:amd64 (1.8.4-1, 1.10.4-3), gir1.2-gtkclutter-1.0:amd64 (1.0.4-1, 1.2.0-2), gnomine:amd64 (3.2.1-2, 3.4.1-2)
Remove: libcogl5:amd64 (1.8.2-1)
End-Date: 2012-05-15  12:43:32
zerozero@debian:~$
clean :shock:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Lippy on Tue May 15, 2012 1:07 pm

For me, the dependencies all seem to go through OK; it only wants to remove the Cinnamon related packages and libcogl5. I'm choosing to hold back the Clutter update in order to keep Cinnamon for now, but it's a lot of packages to keep frozen. I might just end up compiling Cinnamon 1.4 UP1 instead in order to stay more current. I'm also deciding to hold back the update to ffmpeg and a few of its dependencies as it appears to be a downgrade and I think DMO will bump the epoch on their packages in order to rectify this soon.

All in all, that's a total of 67 packages held back right now. Not too shabby! :lol:
LMDE (tracking Testing) with Cinnamon; Intel Core 2 Duo E8400, Nvidia GeForce GTX 260 (using Nouveau)
Lippy
Level 2
Level 2
 
Posts: 68
Joined: Thu Oct 06, 2011 12:28 pm

sources.list Problem

Postby Chris M on Thu May 17, 2012 12:45 am

The timing might be the issue here - all of this happened around midnight East Cost US time, so maybe syncing could be at play. But, I did a safe update (sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade) and got the following:

Code: Select all
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://www.deb-multimedia.org testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907

W: Failed to fetch http://www.deb-multimedia.org/dists/testing/Release 

W: Some index files failed to download. They have been ignored, or old ones used instead.


So I hacked it out with this "fix" (maybe a mistake), and also installed deb-multimedia-keyring

Then I got this:

Code: Select all
W: Failed to fetch http://ftp.us.debian.org/debian/dists/testing/main/i18n/Translation-enIndex  MD5Sum mismatch

W: Failed to fetch http://ftp.us.debian.org/debian/dists/testing/non-free/i18n/Translation-enIndex  MD5Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.


apt-get update was the problem.

I tried another "fix" on the web that didn't cut it.

My original sources.list was:

Code: Select all
# deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.us.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.deb-multimedia.org testing main non-free


I went to Craigevil's and changed my sources.list to:

Code: Select all
# deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org wheezy/updates main contrib non-free
deb http://www.deb-multimedia.org testing main non-free


No more errors. That's what I love about Testing. It's self-healing :D

Weird. Like I said, it may have been a late night syncing issue.

There were quite a few items that updated prior to running into trouble, though. Who knows.
Chris M
Level 2
Level 2
 
Posts: 85
Joined: Mon Nov 29, 2010 10:01 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby diazepan11 on Thu May 17, 2012 3:19 am

I can't upgrade fontconfig from 2.8.0.2-1ubuntu3 to 2.9 (on testing)
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Lippy on Thu May 17, 2012 9:26 am

diazepan11 wrote:I can't upgrade fontconfig from 2.8.0.2-1ubuntu3 to 2.9 (on testing)

That's probably because the Mint repositories have a higher pinning than the Debian ones, and that's holding the package back from upgrading. Here's one way you could workaround this.

Code: Select all
gksu gedit /etc/apt/preferences

Set the Pin-Priority of both Mint repositories to 500 like the others, then attempt to upgrade fontconfig. You can set them back to 700 again afterwards if you want, as it won't attempt to downgrade fontconfig once you have 2.9 installed.
LMDE (tracking Testing) with Cinnamon; Intel Core 2 Duo E8400, Nvidia GeForce GTX 260 (using Nouveau)
Lippy
Level 2
Level 2
 
Posts: 68
Joined: Thu Oct 06, 2011 12:28 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby diazepan11 on Thu May 17, 2012 11:08 am

Lippy wrote:
diazepan11 wrote:I can't upgrade fontconfig from 2.8.0.2-1ubuntu3 to 2.9 (on testing)

That's probably because the Mint repositories have a higher pinning than the Debian ones, and that's holding the package back from upgrading. Here's one way you could workaround this.

Code: Select all
gksu gedit /etc/apt/preferences

Set the Pin-Priority of both Mint repositories to 500 like the others, then attempt to upgrade fontconfig. You can set them back to 700 again afterwards if you want, as it won't attempt to downgrade fontconfig once you have 2.9 installed.


Thank you.
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby iLobster on Fri May 18, 2012 3:49 am

diazepan11 wrote:I can't upgrade fontconfig from 2.8.0.2-1ubuntu3 to 2.9 (on testing)


Solve libfontconfig1 trouble only by downloading this packet and two more manually.
viewtopic.php?f=199&t=100493&p=580842#p580842

Lippy wrote:
diazepan11 wrote:I can't upgrade fontconfig from 2.8.0.2-1ubuntu3 to 2.9 (on testing)

That's probably because the Mint repositories have a higher pinning than the Debian ones, and that's holding the package back from upgrading.

I have no mint repos :)
iLobster
Level 2
Level 2
 
Posts: 69
Joined: Fri Jul 08, 2011 9:07 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Fri May 18, 2012 10:42 am

iLobster wrote:I have no mint repos :)

that is really odd :) with mint repo disabled that incompatibility shouldn't be there in the first place.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby viking777 on Sat May 19, 2012 4:39 am

Du this morning (19May) removes ifupdown.

Either hold the package or let it be removed and then install the debian sid package instead.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Sat May 19, 2012 11:24 am

viking, either the issue was already solved or for some reason it doesn't happen here:
Code: Select all
Calculating upgrade... Done
The following packages will be REMOVED:
  virtualbox-guest-x11
The following NEW packages will be installed:
  libmtdev1
The following packages will be upgraded:
  docbook gir1.2-gtk-3.0 ifupdown libgail-3-0 libgif4 libgmp10 libgmpxx4ldbl libgtk-3-0
  libgtk-3-bin libgtk-3-common libgtk-3-dev libmpfr4 libstreamanalyzer0 libstreams0 netbase
  os-prober xnest xserver-common xserver-xephyr xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-video-vesa
23 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.

Code: Select all
amadeu@amadeu ~ $ apt policy ifupdown
ifupdown:
  Installed: 0.7~alpha5+really0.6.16
  Candidate: 0.7~rc3
  Version table:
     0.7~rc3 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
 *** 0.7~alpha5+really0.6.16 0
        100 /var/lib/dpkg/status
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby viking777 on Sat May 19, 2012 11:29 am

OK thanks. That will teach me not to get up early on Saturday :lol:

Code: Select all
apt-cache policy ifupdown
ifupdown:
  Installed: 0.7~rc3
  Candidate: 0.7~rc3
  Version table:
 *** 0.7~rc3 0
        100 /var/lib/dpkg/status
     0.7~alpha5+really0.6.16 0
        500 http://ftp.uk.debian.org/debian/ testing/main amd64 Packages
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Chris M on Sun May 20, 2012 11:36 pm

Sunday night, May 20, US East Cost minor UD hold back on LMDX x64:

libavcodec52 and libavformat52 updates are being held back

Forcing libavcodec52 would remove:

libavformat52
libmjpegtools-1.9
libquicktime1
Chris M
Level 2
Level 2
 
Posts: 85
Joined: Mon Nov 29, 2010 10:01 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Transitman on Mon May 21, 2012 12:33 am

Chris M wrote:Sunday night, May 20, US East Cost minor UD hold back on LMDX x64:

libavcodec52 and libavformat52 updates are being held back

Forcing libavcodec52 would remove:

libavformat52
libmjpegtools-1.9
libquicktime1


Follow this link for explanation of problem - report.php?f=199&p=582026

Also, removal of libavcodec52 and the other 3 can be done safely, as their replacements are already installed.
I just went through this several hours ago.
Transitman
Level 2
Level 2
 
Posts: 98
Joined: Sun Dec 02, 2007 1:48 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby craigevil on Mon May 21, 2012 1:02 am

Chris M wrote:Sunday night, May 20, US East Cost minor UD hold back on LMDX x64:

libavcodec52 and libavformat52 updates are being held back

Forcing libavcodec52 would remove:

libavformat52
libmjpegtools-1.9
libquicktime1


Wonders if this is because of apt-pinning used in LMDE.

I haven't had libavcodec52 installed for quite a while. But I do have libavcodec53 from debian-multimedia.org.

libavcodec53:
Installed: 7:0.10.3-dmo1
Candidate: 7:0.10.3-dmo1
Version table:
*** 7:0.10.3-dmo1 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
6:0.8.2-2 0
500 http://ftp-mirror.internap.com/pub/debian/ unstable/main i386 Packages

libquicktime2:
Installed: 3:1.2.3-0.3
Candidate: 3:1.2.3-0.3
Version table:
*** 3:1.2.3-0.3 0
100 /var/lib/dpkg/status
2:1.2.4-2+b1 0
500 http://ftp-mirror.internap.com/pub/debian/ unstable/main i386 Packages

mjpegtools:
Installed: 1:2.0.0-dmo1
Candidate: 1:2.0.0-dmo1
Version table:
*** 1:2.0.0-dmo1 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests