LMDE BREAKAGES - tracking TESTING

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby devicerandom on Mon Jun 11, 2012 1:42 pm

zerozero wrote:devicerandom, are those mysql > sqlite replaces similar to the ones jackmetal saw on the top of this page?


Yes, but I see no actual statement if this is a problem and/or if there are solutions...
devicerandom
Level 1
Level 1
 
Posts: 16
Joined: Sun May 13, 2012 9:44 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby mockturtl on Mon Jun 11, 2012 2:17 pm

devicerandom wrote:
zerozero wrote:devicerandom, are those mysql > sqlite replaces similar to the ones jackmetal saw on the top of this page?


Yes, but I see no actual statement if this is a problem and/or if there are solutions...
The [2012-05-30] release of mysql 5.5 wanted to remove mysql 5.1. This is probably okay (try installing it by itself, and see if anything else will be removed).

But the [2012-06-08] update to version 5.5.24+dfsg-2 has a critical bug and should be skipped. The patch 5.5.24+dfsg-3 will enter wheezy tomorrow.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby mockturtl on Mon Jun 11, 2012 4:28 pm

zerozero wrote:gnome-shell 3.4 migrated to testing
check, please, your extensions and themes (both shell and gtk) compatibility.
If you need to rebuild an extension from a git repo, and it doesn't provide a debian/ folder, use

Code: Select all
./autogen.sh --prefix=/usr && make && sudo checkinstall


You probably want to tweak the default package name and version. (It uses the directory name; something like "gnome-shell-extension-weather-neroth-3.4" will provide good defaults.) You can remove it later with dpkg or apt-get, inspect it with apt-cache, etc.

You may need to mkdir -p /usr/share/gnome-shell/extensions for checkinstall to succeed.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Wed Jun 20, 2012 9:25 am

A quick question for folks on Testing + KDE. This am I saw there were 102 upgrades, mostly updated KDE 4.7.4 packages. Has anyone taken these updates and had problems or should I be the semi-official guinea pig? I was going to switch to Sid today but when I saw these packages coming in I decided I'd better deal with these first.

ETA: Here's my update report:
The following NEW packages will be installed:
aptitude-common
The following packages will be upgraded:
aptitude aptitude-doc-en at dolphin geoip-database kde-baseapps
kde-baseapps-bin kde-baseapps-data kde-plasma-desktop
kde-runtime kde-runtime-data kde-wallpapers
kde-wallpapers-default kdebase-runtime kdelibs-bin
kdelibs5-data kdelibs5-dev kdelibs5-plugins kdepasswd
kdepimlibs-kio-plugins kdoctools kfind khelpcenter4
konq-plugins konqueror konqueror-nsplugins libakonadi-contact4
libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4
libakonadi-kmime4 libatk-adaptor libatk-adaptor-data
libgpgme++2 libkabc4 libkactivities-bin libkactivities6
libkcal4 libkcalcore4 libkcalutils4 libkcmutils4
libkde3support4 libkdeclarative5 libkdecore5 libkdesu5
libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4
libkio5 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4
libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4
libkntlm4 libkonq-common libkonq5-dev libkonq5-templates
libkonq5abi1 libkonqsidebarplugin4a libkontactinterface4
libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4
libkprintutils4 libkpty4 libkresources4 libkrosscore4
libkrossui4 libktexteditor4 libktnef4 libkunitconversion4
libkutils4 libmailtransport4 libmicroblog4 libnepomuk4
libnepomukquery4a libnepomukutils4 libplasma3 libqgpgme1
libselinux1 libsemanage-common libsemanage1 libsolid4
libsyndication4 libthreadweaver4 oxygen-icon-theme
plasma-scriptengine-javascript plasma-widget-folderview
ssl-cert
101 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 157 MB of archives.
After this operation, 1,406 kB of additional disk space will be used.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby jlsmith722 on Wed Jun 20, 2012 9:39 am

BP
I took the update this morning.
For me it was an update from 4.7.? to 4.8.4-1
Code: Select all
kde-baseapps:
  Installed: 4:4.8.4-1
  Candidate: 4:4.8.4-1
  Version table:
 *** 4:4.8.4-1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
jim@newdeb ~ $

the folder view is not working for me and some widgets do not work. But maybe it is me as I am just beginning to explore KDE.

Jim
[size=85]Being intelligent is not a felony. But most societies evaluate it as at least a misdemeanor.
Robert Heinlein
User avatar
jlsmith722
Level 1
Level 1
 
Posts: 48
Joined: Fri Mar 05, 2010 9:38 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Wed Jun 20, 2012 9:57 am

@jlsmith:
Thanks for the quick response. That version change looks right to me. I'm currently on 4.8.3 so when I saw the bump to 4.8.4 I had to smile. I'm not on 4.7.x anymore because I moved to the kde-qt repos a week or so ago. The folder view issue doesn't bother me since I don't use it but I'll have to check out the plsamoids I do use. Luckily some of what I use was compiled from source so if I need to I can just build them again. I'll just have to make sure how to remove them before I rebuild. I think it's just sudo make uninstall from my build folder but I'll confirm before I run it.

If I have any plasmoid issues after the upgrade I'll post an update with which ones don't want to play well with the new packages for anyone who needs the info.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Wed Jun 20, 2012 3:37 pm

just a "FYI" on this kde4.8.4 it's not the most stable kde seen specially with nepomuk enabled.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Wed Jun 20, 2012 3:43 pm

Based on System Settings > Help > About KDE I'm still at 8.4.3, even after taking this am's dist-upgrades. The good news is that it looks like my plasmoids are all behaving properly so far.

@zerozero:
Thanks for the warning. I'll make sure nepo is disabled, although it usually is on my boxes. And I'll be extra careful when I move to Sid, now looking like it will tomorrow before I pull that trigger.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Wed Jun 20, 2012 4:29 pm

BostonPeng wrote:Based on System Settings > Help > About KDE I'm still at 8.4.3, even after taking this am's dist-upgrades. The good news is that it looks like my plasmoids are all behaving properly so far.

yeahh because of this:
craigevil wrote:kdelibs is still at 4.8.3 because of upstream issues. Stay tuned for more info...........................

Unfortunately because of kdelibs still being at 4.8.3 inxi -S shows 4.8.3 as do the about tabs on most apps.
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Wed Jun 20, 2012 4:30 pm

D'oh! I completely forgot about that. Thanks for the reminder zero. Add another round on my tab.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Fri Jun 22, 2012 9:12 am

I snagged my DU today and found somethings with the xml-core and kernel upgrade that I'm not sure are issues or not. The upgrade list is
Code: Select all
The following packages will be upgraded:
  aptdaemon aptdaemon-data dnsmasq-base docbook-xml fonts-cantarell fonts-liberation foomatic-db-engine
  iptables libgraphicsmagick3 libvirtodbc0 linux-headers-3.2.0-2-486 linux-headers-3.2.0-2-common
  linux-image-3.2.0-2-486 linux-libc-dev python-aptdaemon python-aptdaemon.gtk3widgets python-defer
  synaptic virtuoso-minimal virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common xml-core
22 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


As the upgrade was being performed I noticed these messages in my terminal
Code: Select all
Preparing to replace xml-core 0.13 (using .../xml-core_0.13+nmu1_all.deb) ...
update-catalog: Suppressing action on super catalog. Invoking trigger instead.
update-catalog: Please rebuild the package being set up with a version of debhelper fixing #477751.
Unpacking replacement xml-core ...

Code: Select all
Setting up linux-image-3.2.0-2-486 (3.2.20-1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
update-initramfs: Generating /boot/initrd.img-3.2.0-2-486
 run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
Generating grub.cfg ...
Found background image: linuxmint.png
Found Debian background: linuxmint.png
Found linux image: /boot/vmlinuz-3.2.0-2-486
Found initrd image: /boot/initrd.img-3.2.0-2-486
done

Code: Select all
Setting up linux-headers-3.2.0-2-common (3.2.20-1) ...
Setting up linux-headers-3.2.0-2-486 (3.2.20-1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-2-486
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
Setting up linux-libc-dev:i386 (3.2.20-1) ...

Code: Select all
Setting up docbook-xml (4.5-7.1) ...
Processing triggers for menu ...
W: Operation was interrupted before it could finish
:~$

Is this something I need to address? I tried to attach the complete text file I created of the DU in case it's needed but I kept getting extension not allowed errors so I threw it up on my Dropbox so it can be accessed.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby GeneBenson on Fri Jun 22, 2012 6:15 pm

Hi BostonPeng,

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-2-486 /boot/vmlinuz-3.2.0-2-486
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.


I used to get this error as well. For me it was caused by ndiswrapper-dkms being installed as part of the initial LMDE setup. I don't need ndiswrapper-dkms since I have a wired connection. After removing it I have not seen this error again. The message seems to be just a warning because I never had any problems resulting from a new kernel being installed.

Preparing to replace xml-core 0.13 (using .../xml-core_0.13+nmu1_all.deb) ...
update-catalog: Suppressing action on super catalog. Invoking trigger instead.
update-catalog: Please rebuild the package being set up with a version of debhelper fixing #477751.


Also saw this as well, but can't offer any help with this one. I believe it's referring to this bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477751
GeneBenson
Level 3
Level 3
 
Posts: 173
Joined: Fri Sep 17, 2010 9:55 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Sat Jun 23, 2012 8:29 am

Thanks Gene. I had a feeling I didn't need to worry too much but it's good to see what prompted the errors. I can't remove ndiswrapper-dkms since I use WiFi as my net access but it's evidently not that big a deal if it hasn't raised more cries. As far as bug #477751 goes I'm sure it will be fixed eventually. Until I see problems arising from it I won't worry about it either.

I hope you and everyone has a nice weekend, without the gully washer I found when I waled out of the door this morning. It's moved out but it was definitely a ducky start to the day.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby defcon on Mon Jun 25, 2012 10:26 am

Cant install mint-artwork-xfce
It depends on mint-artwork-debian, and this one depends on gtk2-engines-clearlooks which is not available :-(
User avatar
defcon
Level 3
Level 3
 
Posts: 144
Joined: Sun Oct 17, 2010 11:17 pm
Location: Germany

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby GregE on Mon Jun 25, 2012 8:29 pm

defcon wrote:Cant install mint-artwork-xfce
It depends on mint-artwork-debian, and this one depends on gtk2-engines-clearlooks which is not available :-(


Are you trying to add Xfce to an existing LMDE that is Cinnamon/Gnome/Mate? It has always been difficult to recreate the look and feel of LMDE Xfce Edition when retrofitted. A clean install of the Xfce Edition will work.

If someone has an easy way to convert an existing install to Xfce it would be helpful to share. It is easy to just add Xfce and start with the standard Xfce layout of a toolbar at the top and the second toolbar launcher at the bottom and normal Xfce menus. But that is not the same as the Linuxmint setup. You could remove half of your installed system, but instead it is probably better to new install.
User avatar
GregE
Level 4
Level 4
 
Posts: 453
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby defcon on Tue Jun 26, 2012 1:53 am

No, it was the Xfce edition. Updated from latest to testing.
User avatar
defcon
Level 3
Level 3
 
Posts: 144
Joined: Sun Oct 17, 2010 11:17 pm
Location: Germany

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby GregE on Tue Jun 26, 2012 3:26 am

defcon wrote:No, it was the Xfce edition. Updated from latest to testing.


OK. sorry to assume.

gtk2-engines-clearlooks is an imaginary package that is part of gtk2-engines and the update to gtk2-engines is what kills the dependency. If you go back and search this forum you will find a discussion of this issue. I will butt out now. ZeroZero may be able to give you a better answer.
User avatar
GregE
Level 4
Level 4
 
Posts: 453
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Tue Jun 26, 2012 6:54 am

gtk2-engines-clearlooks doesn't exists (anymore) but mint-artwork-* depends on it. the issue is old

Edit: clarifying:
Code: Select all
amadeu@zerozero:~$ apt policy gtk2-engines
gtk2-engines:
  Installed: 1:2.20.2-1
  Candidate: 1:2.20.2-1
  Version table:
 *** 1:2.20.2-1 0
        500 http://debian.linuxmint.com/latest/ testing/main amd64 Packages
        100 /var/lib/dpkg/status

Code: Select all
amadeu@zerozero:~$ apt content gtk2-engines
/.
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/gtk-2.0
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libredmond95.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libhcengine.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libthinice.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libglide.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libmist.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libindustrial.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libcrux-engine.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/libclearlooks.so
/usr/share
/usr/share/doc
/usr/share/doc/gtk2-engines
/usr/share/doc/gtk2-engines/copyright
/usr/share/doc/gtk2-engines/changelog.Debian.gz
/usr/share/doc/gtk2-engines/changelog.gz
/usr/share/doc/gtk2-engines/README
/usr/share/doc/gtk2-engines/NEWS.gz
/usr/share/doc/gtk2-engines/AUTHORS
/usr/share/gtk-engines
/usr/share/gtk-engines/glide.xml
/usr/share/gtk-engines/industrial.xml
/usr/share/gtk-engines/hcengine.xml
/usr/share/gtk-engines/thinice.xml
/usr/share/gtk-engines/crux-engine.xml
/usr/share/gtk-engines/redmond95.xml
/usr/share/gtk-engines/clearlooks.xml
/usr/share/gtk-engines/mist.xml
/usr/share/themes
/usr/share/themes/Crux
/usr/share/themes/Crux/gtk-2.0
/usr/share/themes/Crux/gtk-2.0/gtkrc
/usr/share/themes/Clearlooks
/usr/share/themes/Clearlooks/gtk-2.0
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc
/usr/share/themes/ThinIce
/usr/share/themes/ThinIce/gtk-2.0
/usr/share/themes/ThinIce/gtk-2.0/gtkrc
/usr/share/themes/Redmond
/usr/share/themes/Redmond/gtk-2.0
/usr/share/themes/Redmond/gtk-2.0/gtkrc
/usr/share/themes/Mist
/usr/share/themes/Mist/gtk-2.0
/usr/share/themes/Mist/gtk-2.0/gtkrc
/usr/share/themes/Industrial
/usr/share/themes/Industrial/gtk-2.0
/usr/share/themes/Industrial/gtk-2.0/gtkrc
amadeu@zerozero:~$

and mint-artwork-* depends on clearlooks
all is fine (for now) in latest/incoming but the updates to gtk2-engines conflict with mint-artwork-*
will be interesting to see the solution for UP5
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby defcon on Wed Jun 27, 2012 3:26 am

When UP5 is planned?
User avatar
defcon
Level 3
Level 3
 
Posts: 144
Joined: Sun Oct 17, 2010 11:17 pm
Location: Germany

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby iLobster on Thu Jun 28, 2012 2:16 am

In short: evolution update to 3.4.3. tries to remove cinnamon (I use half-unoffical 1.4-UP2 with libcogl5 dependeicy fix). As I know UP3 is almost same as UP2.
So there is need for "cinnamon1.4-UP4" or whatever.
iLobster
Level 2
Level 2
 
Posts: 69
Joined: Fri Jul 08, 2011 9:07 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: brainiac744, woodsman and 3 guests