broken packages, libvorbis0a

Post your update and upgrade related errors here
Forum rules
Before you post please read this

broken packages, libvorbis0a

Postby nalsdixit on Sat Mar 05, 2011 9:51 pm

I have been having an issue with broken packages I am unable to resolve.

When I run updates In the terminal I end up with a problem with “libvorbis0a” update

as below:

nals@nals ~ $ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libvorbisenc2 : Depends: libvorbis0a (= 1.3.2-1) but 1.3.1-1 is installed
libvorbisfile3 : Depends: libvorbis0a (= 1.3.2-1) but 1.3.1-1 is installed
E: Unmet dependencies. Try using -f.
nals@nals ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
mint-elementary-icons libvlccore-dev libvlc-dev debian-system-adjustments
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libvorbis0a
The following packages will be upgraded:
libvorbis0a
1 upgraded, 0 newly installed, 0 to remove and 15 not upgraded.
3 not fully installed or removed.
Need to get 0 B/101 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libvorbis0a
Authentication warning overridden.
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb: subprocess <decompress> returned error exit status 2
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
Reading changelogs... Done
(Reading database ... 147500 files and directories currently installed.)
Preparing to replace libvorbis0a 1.3.1-1 (using .../libvorbis0a_1.3.2-1_i386.deb) ...
Unpacking replacement libvorbis0a ...
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb (--unpack):
short read on buffer copy for backend dpkg-deb during `./usr/lib/libvorbis.so.0.4.5'
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
nals@nals ~ $

when I try to install via mint update, or try to fix broken packages I get:

E: /var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb: short read on buffer copy for backend dpkg-deb during `./usr/lib/libvorbis.so.0.4.5'


what should I do

tks

nals
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Linux Mint is funded by ads and donations.
 

Re: broken packages, libvorbis0a

Postby dawgdoc on Sat Mar 05, 2011 11:07 pm

The libvorbis0a package itself seems to be good, I was able to upgrade it to the 1.3.2-1 version when it became available the other day.

Based on the print out above, did you run the command it suggested? sudo apt-get -f install
Also, check to see if you have these 2 packages installed. libc6 version >=2.3 and libogg0 version >= 1.1.0, libvorbis0a depends on having them installed. It conflicts with libvorbis0, but I would think a message would have shown up asking if you wanted to remove it during the apt-get upgrade process.

I just checked in Synaptic for my Install history. I installed libvorbis0a, libvorbisenc2 and libvorbisfile3 on Feb 25 without any issues.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 13 Gnome x32 PAE, LMDE
READING: The Autobiography of Benvenuto Cellini
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2690
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: broken packages, libvorbis0a

Postby zerozero on Sat Mar 05, 2011 11:33 pm

hi,
can you please post the output of
Code: Select all
cat /etc/apt/sources.list

Thanks
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6484
Joined: Tue Jul 07, 2009 2:29 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Sun Mar 06, 2011 4:56 am

here is the list:

nals@nals ~ $ cat /etc/apt/sources.list
deb http://ftp.jaist.ac.jp/pub/Linux/LinuxMint/ debian main upstream import romeo
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Re: broken packages, libvorbis0a

Postby richyrich on Sun Mar 06, 2011 5:51 am

deb http://ftp.jaist.ac.jp/pub/Linux/LinuxMint/ debian main upstream import romeo

is missing the dists subfolder, and the backport repository . . should look like this :

Code: Select all
deb http://ftp.jaist.ac.jp/pub/Linux/LinuxMint/dists/debian main upstream import backport romeo


and to check / generate the rest of your sources.list with the best debian repositories for your location : http://debgen.simplylinux.ch/

hope this helps, good luck !
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Mon Mar 07, 2011 11:33 pm

i added the following to the software sources but still get the same error message

deb http://ftp.jaist.ac.jp/pub/Linux/LinuxMint/dists/debian main upstream import backport romeo

is there something else i need to change in the software source ?

tks

nals
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Re: broken packages, libvorbis0a

Postby richyrich on Mon Mar 07, 2011 11:52 pm

Errors were encountered while processing:
/var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb


You can try this from the terminal, they should cleanup and reconfigure your package database.

Code: Select all
sudo su

Code: Select all
apt-get -y autoremove && aptitude -y autoclean && aptitude -y clean && dpkg --configure -a && aptitude update
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: broken packages, libvorbis0a

Postby zerozero on Tue Mar 08, 2011 7:39 am

one thing intrigues me here since the beginning: you had 15 not upgraded pkgs on sunday, and by that time LMDE was updating clean (at least with a regular install).
Can you see in synaptic which pkgs are been hold and can this be related with your sopcast install?
how did you install it, from here, which pkgs it upgrade?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6484
Joined: Tue Jul 07, 2009 2:29 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Tue Mar 08, 2011 10:55 pm

here is what happened when i ran in terminal the suggested commands


nals@nals ~ $ sudo su
[sudo] password for nals:
nals nals # apt-get -y autoremove && aptitude -y autoclean && aptitude -y clean && dpkg --configure -a && aptitude update
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/www.debian-multimedia.org_dists_testing_non-free_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
nals nals #

zero zero: as of now i get no package updates in mint update, similar message to above

do not think is related to sopcast, as that was months ago, and updates were happening smoothly until recently
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Re: broken packages, libvorbis0a

Postby richyrich on Tue Mar 08, 2011 11:22 pm

Code: Select all
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update


these should do it . . .

let us know, richy
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Wed Mar 09, 2011 2:40 am

thank you richy rich

that fixed the updating, but i still having a probelm with the libvorbis0a package

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libvorbisenc2 : Depends: libvorbis0a (= 1.3.2-1) but 1.3.1-1 is installed
libvorbisfile3 : Depends: libvorbis0a (= 1.3.2-1) but 1.3.1-1 is installed
E: Unmet dependencies. Try using -f.
nals@nals ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
mint-elementary-icons libvlccore-dev libvlc-dev debian-system-adjustments
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libvorbis0a
The following packages will be upgraded:
libvorbis0a
1 upgraded, 0 newly installed, 0 to remove and 51 not upgraded.
3 not fully installed or removed.
Need to get 0 B/101 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libvorbis0a
Authentication warning overridden.
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
dpkg-deb: subprocess <decompress> returned error exit status 2
Reading changelogs... Done
(Reading database ... 147508 files and directories currently installed.)
Preparing to replace libvorbis0a 1.3.1-1 (using .../libvorbis0a_1.3.2-1_i386.deb) ...
Unpacking replacement libvorbis0a ...
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb (--unpack):
short read on buffer copy for backend dpkg-deb during `./usr/lib/libvorbis.so.0.4.5'
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
nals@nals ~ $

what do i do to fix this issue ?

tks

nals
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Re: broken packages, libvorbis0a

Postby richyrich on Wed Mar 09, 2011 3:05 am

dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
dpkg-deb: subprocess <decompress> returned error exit status 2

Preparing to replace libvorbis0a 1.3.1-1 (using .../libvorbis0a_1.3.2-1_i386.deb) ...
Unpacking replacement libvorbis0a ...
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: invalid distance too far back'
dpkg-deb: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libvorbis0a_1.3.2-1_i386.deb (--unpack):


Yup . . errors from both of the attempts to unpack the libvorbis pkg. .

Hmmm, what if you re-downloaded a clean copy of the libvorbis deb file, and then right-click -> Install with Gdebi ? ? ?

Try this one from the Canadian repository : http://cdn.debian.net/debian/pool/main/ ... 1_i386.deb
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Wed Mar 09, 2011 5:29 am

thank you, dowwnloaded and tried install with gdebi

'your system has broken dependencies the application cannot continue until this is fixed. to fix run 'gsudo synaptic' or sudo apt-get install -f in a terminal window'

so i tried to fix the 2 broken packages, and get

E:var/cache/apt/archives/libvorvis0a 1.3.2.1-i386.deb: short read on buffer copy for back-end dpkg-deb during './usr/lib/libvorbis.so.0.4.5'

so i cannot fix the packages

nals
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Re: broken packages, libvorbis0a

Postby richyrich on Wed Mar 09, 2011 6:08 am

./usr/lib/libvorbis.so.0.4.5'
Where did this OLD version com from ? . . what a schmozzle . . .

We were dealing with these versions earlier :
Preparing to replace libvorbis0a 1.3.1-1 (using .../libvorbis0a_1.3.2-1_i386.deb) .


Can you find the old libvorbis (or any one) in Synaptic ? Can it be un-installed from their ?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: broken packages, libvorbis0a

Postby nalsdixit on Wed Mar 09, 2011 8:58 pm

tried to unistall libvorbis from synaptic. computer hung while it was doing it (i was doing other stuff as well). thereafter cannot boot up. will do a fresh install

thanks for your help

nals
nalsdixit
Level 3
Level 3
 
Posts: 122
Joined: Mon Sep 14, 2009 11:38 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: metalhamster and 4 guests