problem updating LMDE, please assist?

Post your update and upgrade related errors here
Forum rules

problem updating LMDE, please assist?

Postby germanix on Sun Mar 13, 2011 4:49 pm

I have just installed LMDE and am in the process of updating via the terminal. I used the command: "sudo apt-get update && apt-get dist-upgrade". During this process the update came to a halt with the following question:
unable to lock the administration directory (/var/lib/dpkg/ are you root?
I do not know what to enter here? Please assist!
a man without religion is like a fish without a bicycle.
Image
User avatar
germanix
Level 3
Level 3
 
Posts: 152
Joined: Thu Jul 24, 2008 2:53 pm
Location: Germany

Linux Mint is funded by ads and donations.
 

Re: problem updating LMDE, please assist?

Postby gosa on Sun Mar 13, 2011 5:17 pm

Please someone correct me if I'm wrong, but I think you need to enter the command "sudo" in front of all you want to run...
sudo apt-get update && sudo apt-get dist-upgrade
gosa
Level 4
Level 4
 
Posts: 302
Joined: Mon Nov 01, 2010 5:12 am
Location: Spain

Re: problem updating LMDE, please assist?

Postby zerozero on Sun Mar 13, 2011 5:18 pm

the command is not conplet, germanix
should be
Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade

edit: just saw gosa comment saying the same :)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

(Solved) problem updating LMDE, please assist?

Postby germanix on Sun Mar 13, 2011 6:06 pm

Thanks all. That seems to have solved the problem. LMDE is now installed and running. Only problem now is getting the internet connection working. Will start a new thread for that. Thanks for your help. Have a nice day.
a man without religion is like a fish without a bicycle.
Image
User avatar
germanix
Level 3
Level 3
 
Posts: 152
Joined: Thu Jul 24, 2008 2:53 pm
Location: Germany


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests