LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby Brian49 on Sun Jun 10, 2012 11:51 am

GregE wrote:new version coming through

These latest updates (to 2.88dsf-27) haven't fixed the keyboard/mouse issue here.

As far as I can see, we still don't have a diagnosis of what exactly is causing the problem. Presumably some component of the X-server is being prevented from loading.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby craigevil on Sun Jun 10, 2012 12:43 pm

Brian49 wrote:
GregE wrote:new version coming through

These latest updates (to 2.88dsf-27) haven't fixed the keyboard/mouse issue here.

As far as I can see, we still don't have a diagnosis of what exactly is causing the problem. Presumably some component of the X-server is being prevented from loading.


The really weird thing is it only affects random people, even with the exact same hardware person (a) may be affected, while person (b) isn't.

It does seem to affect mostly people with usb mouse/kbd.

Code: Select all
The following packages will be upgraded:
  ffmpeg flashplayer-mozilla kde-config-flash-player libavcodec54 libavdevice54 libavfilter2 libavformat54 libavutil51
  libpostproc52 libswresample0 libswscale2 libxine1 libxine1-bin libxine1-ffmpeg libxine1-misc-plugins libxine1-x
16 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 19.0 MB of archives.


Code: Select all
$ inxi -Sr
System:    Host: debian Kernel: 3.3.0-trunk-486 i686 (32 bit) Desktop: KDE 4.8.3 Distro: Debian GNU/Linux wheezy/sid
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp-mirror.internap.com/pub/debian/ unstable main contrib non-free
           deb-src http://ftp-mirror.internap.com/pub/debian/ unstable main contrib non-free
           deb http://ftp-mirror.internap.com/pub/debian/ experimental main contrib non-free
           deb http://www.deb-multimedia.org/ sid main non-free
           deb http://dl.google.com/linux/chrome/deb/ stable main
           deb http://dl.google.com/linux/musicmanager/deb/ stable main
           deb http://download.jitsi.org/deb/ unstable/


Code: Select all
$ inxi -Fx
System:    Host: debian Kernel: 3.3.0-trunk-486 i686 (32 bit, gcc: 4.6.3)
           Desktop: KDE 4.8.3 (Qt 4.8.1) Distro: Debian GNU/Linux wheezy/sid
Machine:   Mobo: IBM model: 27223YU Bios: IBM version: 1PET41WW (1.09 ) date: 03/03/2003
CPU:       Single core Intel Pentium M (-UP-) cache: 1024 KB flags: (sse sse2) bmips: 2591.56 clocked at 1300.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV200 [Mobility Radeon 7500] bus-ID: 01:00.0
           X.Org: 1.12.1.902 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 0x209) GLX Version: 2.1 Mesa 8.0.2 Direct Rendering: Yes
Audio:     Card: Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller driver: snd_intel8x0 ports: 1c00 18c0 bus-ID: 00:1f.5
           Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network:   Card-1: Intel 82801DB PRO/100 VE (MOB) Ethernet Controller
           driver: e100 ver: 3.5.24-k2-NAPI port: 8000 bus-ID: 02:08.0
           IF: eth0 state: down mac: 00:06:1b:cd:f5:82
           Card-2: Intel PRO/Wireless LAN 2100 3B Mini PCI Adapter driver: ipw2100 ver: git-1.2.2 bus-ID: 02:02.0
           IF: eth1 state: up mac: 00:04:23:5b:b5:88
Drives:    HDD Total Size: 17.2GB (73.2% used) 1: id: /dev/sda model: IC25N020ATCS04 size: 17.2GB
           2: USB id: /dev/sdc model: Mass_Storage size: 0.0GB
Partition: ID: / size: 16G used: 12G (82%) fs: ext3 ID: /boot size: 228M used: 38M (18%) fs: ext2
           ID: swap-1 size: 0.51GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 49.0C mobo: 49.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 126 Uptime: 1 day Memory: 643.1/2025.7MB Runlevel: 2 Gcc sys: 4.7.0 Client: Shell inxi: 1.8.5
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby GeneC on Sun Jun 10, 2012 1:03 pm

This fixed it for me.

viewtopic.php?f=198&t=70230&start=1120#p591080

1) as root, delete the link /run
2) make a directory /run
3) reboot
/var/run will automagically change to a link.


It appears Brian is the only one still with the problem?

I got the impression that it effected LMDE, but folks with a Straight Debian base did not see to see this problem at all. :?:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky (Debian Testing)
LMDE Xfce (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1534
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby Brian49 on Sun Jun 10, 2012 2:00 pm

I've found a way of fixing the problem here, or perhaps I should say evading it.

When installing the latest "sysv" updates via the terminal, I noticed that the file /etc/init.d/mountall-bootclean.sh was being replaced with a newer version. So after completing the updates, I went to the System/Services dialog and disabled the service mountall-bootclean. When I restarted the computer, the keyboard and mouse were working.

Among other things, mountall-bootclean cleans /var/run. So it looks as though that is indeed where the trouble lies, although it's still not clear in what way.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby wayne128 on Sun Jun 10, 2012 8:30 pm

wayne128 wrote:d.u. LMDE-xfce-Sid partition.

same keyboard/mouse issue. :evil:

in addition to above, after unplugged kb/mouse to get then working, there is no sound everywhere.
until I issue command for alsa force-reload, then sound returns.


d.u. to get upgraded packages to version -27
Code: Select all
wayne@lmde32x210204rc ~ $ apt-cache policy sysvinit sysvinit-utils sysv-rc initscripts
sysvinit:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
sysvinit-utils:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
sysv-rc:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status
initscripts:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.jp.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status


still no kb/mouse :(


apply this
Code: Select all
1) as root, delete the link /run
2) make a directory /run
3) reboot
/var/run will automagically change to a link.


specifically, su to root to get # prompt
then
rm /run
mkdir /run

reboot ( on terminal it wont work) just press power button for hard reset.

now computer boots normally with working kb/mouse
check sound also, it is back. :)

meanwhile (pure) Debian Sid-gnome+kde had no problem , still using -26 version
so for my hardware, this bug affects only lmde-xfce partition on the same computer.

One more up point for pure Debian Sid :)
wayne128
Level 10
Level 10
 
Posts: 3259
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - May 20th

Postby wayne128 on Sun Jun 10, 2012 8:35 pm

GeneC wrote:Doesn't anything go wrong with SID anymore.. :?: :lol:

The recent past
SID
Image

This Month.
Sidney
Image



Gene,
now just go back and read your post...

hmm.... Sid seems to read your post and decides to teach us some lessons , but selectively??:lol: :lol: :lol:
wayne128
Level 10
Level 10
 
Posts: 3259
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby wayne128 on Mon Jun 11, 2012 5:01 am

fully d.u. on Debian Sid-g3+kde partition.

all good with -27 versions of sysv..etc
no issue on kb/mouse and sound.
one more thumb up for Debian Sid. :mrgreen:


Code: Select all
wayne@debian:~$ apt-cache policy sysvinit sysvinit-utils sysv-rc initscripts
sysvinit:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.au.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
sysvinit-utils:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.au.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
sysv-rc:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.au.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
initscripts:
  Installed: 2.88dsf-27
  Candidate: 2.88dsf-27
  Version table:
 *** 2.88dsf-27 0
        500 http://ftp.au.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
wayne128
Level 10
Level 10
 
Posts: 3259
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby craigevil on Mon Jun 11, 2012 6:53 pm

Parts of kde 4.8.4 are in sid.

kdelibs is still at 4.8.3 because of upstream issues. Stay tuned for more info...........................

Unfortunately because of kdelibs still being at 4.8.3 inxi -S shows 4.8.3 as do the about tabs on most apps.

craig@debian:~$ apt-cache policy kdelibs-bin
kdelibs-bin:
Installed: 4:4.8.3-2
Candidate: 4:4.8.3-2
Version table:
*** 4:4.8.3-2 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages
100 /var/lib/dpkg/status

$ apt-cache policy dolphin
dolphin:
Installed: 4:4.8.4-1
Candidate: 4:4.8.4-1
Version table:
*** 4:4.8.4-1 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages
100 /var/lib/dpkg/status

Code: Select all
$ inxi -Sr
System:    Host: debian Kernel: 3.4.0-trunk-486 i686 (32 bit) Desktop: KDE 4.8.3 Distro: Debian GNU/Linux wheezy/sid
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://mirrors.kernel.org/debian/ unstable main contrib non-free
           deb http://mirrors.kernel.org/debian/ experimental main contrib non-free
           deb http://www.deb-multimedia.org/ sid main non-free
           deb http://dl.google.com/linux/chrome/deb/ stable main
           deb http://dl.google.com/linux/musicmanager/deb/ stable main
           deb http://download.jitsi.org/deb/ unstable/


cryptsetup showed a 'grave' bug when I ran d-u, but I went ahead and upgraded, I have not rebooted yet to see if there are any problems.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby zerozero on Mon Jun 11, 2012 7:01 pm

i'm having major issues with 4.8.4 in chakra, actually it's the second time it's uploaded and pulled out. nepomuk/strigi are totally broken, they are requiring a new soprano that at the moment breaks kdelibs (well you see, biggest mess).
we are skipping 4.8.4 and building 4.9 beta2 at the moment.
zerozero
Level 16
Level 16
 
Posts: 6466
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby craigevil on Mon Jun 11, 2012 7:03 pm

zerozero wrote:i'm having major issues with 4.8.4 in chakra, actually it's the second time it's uploaded and pulled out. nepomuk/strigi are totally broken, they are requiring a new soprano that at the moment breaks kdelibs (well you see, biggest mess).
we are skipping 4.8.4 and building 4.9 beta2 at the moment.


Yes the whole lot of bugs is because of nepomuk.

http://lists.kde.org/?l=kde-core-devel& ... 028298&w=2
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby BostonPeng on Thu Jun 14, 2012 11:04 am

craigevil wrote:
zerozero wrote:i'm having major issues with 4.8.4 in chakra, actually it's the second time it's uploaded and pulled out. nepomuk/strigi are totally broken, they are requiring a new soprano that at the moment breaks kdelibs (well you see, biggest mess).
we are skipping 4.8.4 and building 4.9 beta2 at the moment.


Yes the whole lot of bugs is because of nepomuk.

http://lists.kde.org/?l=kde-core-devel& ... 028298&w=2

Hi again y'all! I decided I want to move my laptop to Sid (It's running beautifully on Testing/KDE 4.8.3) and I saw the above and wondered if it's safe to take Sid upgrades. Also did I hear Sid has an even newer version of KDE or is it held up with the nepomunk sexual assault of the poor pooch?

ETA: Typos. Boy, I don't know. "help" should have been "held," it's fixed now. Sorry about any confusion.
Last edited by BostonPeng on Thu Jun 14, 2012 12:45 pm, edited 1 time in total.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby Brian49 on Thu Jun 14, 2012 12:33 pm

Today's update to libept1.4.12, from 1.0.6.1 to 1.07, makes it impossible to launch Synaptic. As far as I can tell, the reason is that Synaptic looks for a libept file which can no longer be found after the update.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby GeneC on Thu Jun 14, 2012 1:21 pm

Same here...

Code: Select all
gene@zordon:~$ apt-cache policy libept1.4.12
libept1.4.12:
  Installed: 1.0.7
  Candidate: 1.0.7
  Version table:
 *** 1.0.7 0
        700 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status



Looking into it.

XFCE loads ok
On same installation.
Gnome Shell broke.
No composting, no panel, no keyboard, no window borders...big mess..... :lol:
Thanks GOD for AWN dock...
Image


EDIT:

Purged then re-installed synaptic... No good
Code: Select all
gene@zordon:~$ sudo synaptic
[sudo] password for gene:
synaptic: error while loading shared libraries: libept.so.1.0.5.4.12: cannot open shared object file: No such file or directory
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky (Debian Testing)
LMDE Xfce (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1534
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby GeneC on Thu Jun 14, 2012 1:52 pm

Downgraded to the package in testing and got synaptic back...

Code: Select all
gene@zordon:~$ apt-cache policy libept1.4.12
libept1.4.12:
  Installed: 1.0.6.1
  Candidate: 1.0.6.1
  Version table:
 *** 1.0.6.1 0
        700 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status


Now, to see about Gnome Shell..... :roll:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky (Debian Testing)
LMDE Xfce (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1534
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby GeneC on Thu Jun 14, 2012 2:14 pm

Got Gnome Shell back as well

Had to re-install Nvidia.
Perhaps the updates to mesa broke it?
Code: Select all
Upgraded the following packages:
........................
libgl1-mesa-dri (8.0.2-2) to 8.0.3-1
libgl1-mesa-glx (8.0.2-2) to 8.0.3-1
libglapi-mesa (8.0.2-2) to 8.0.3-1
libglu1-mesa (8.0.2-2) to 8.0.3-1
.......................
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky (Debian Testing)
LMDE Xfce (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1534
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 7th

Postby BostonPeng on Thu Jun 14, 2012 2:18 pm

Brian49 wrote:Today's update to libept1.4.12, from 1.0.6.1 to 1.07, makes it impossible to launch Synaptic. As far as I can tell, the reason is that Synaptic looks for a libept file which can no longer be found after the update.

I'm wanting to switch back to Sid but this news this am makes me wait. Is libept something I can pin and just get other updates? I depend on Synaptic to read changelogs before taking updates so I'm very hesitant to snag anything I know would break it.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby GeneC on Thu Jun 14, 2012 2:22 pm

BP

Yes, just pin that package.
Code: Select all
gene@zordon:~$ apt-cache policy libept1.4.12
libept1.4.12:
  Installed: 1.0.6.1
  Candidate: 1.0.6.1
  Version table:
*** 1.0.6.1 0
        700 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status


If you feel safer wait a day or two before DU. Its sure to be fixed.. :wink:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon)
Sparky (Debian Testing)
LMDE Xfce (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1534
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby BostonPeng on Thu Jun 14, 2012 2:34 pm

Thanks Gene. I'm snagging podcasts now but when I'm done I'll see what kind of time I'm looking at. Then I'll decided whether to make the switch today or wait a day or two. Now that I finally decided to go back to Sid I'm wanting to make the switch sooner rather than later. And people say I'm patient. :lol:
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby GregE on Thu Jun 14, 2012 6:49 pm

libept 1.08 released already. Synaptic fixed.
User avatar
GregE
Level 4
Level 4
 
Posts: 453
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - (Tracking SID!) - Jun 14th

Postby wayne128 on Thu Jun 14, 2012 8:31 pm

Thanks Gene and Greg for the synaptic / libept thing

I d.u. and have no issue running synaptic.
Code: Select all
wayne@debian:~$ apt-cache policy libept1.4.12
libept1.4.12:
  Installed: 1.0.8
  Candidate: 1.0.8


@BostonPeng.. so it is safe as far as this synaptic issue on Sid
but then if you wish to switch to Sid, it is better to Clone your OS to usb drive before attempting to switch.. :mrgreen:

@Gene
Code: Select all
2. Gnome-Shell is also broken, not sure what is the cause there?
I re-installed Nvidia and got the shell back


For me, I am on ati not nvidia, no issue after d.u., still gnome-shell running
wayne128
Level 10
Level 10
 
Posts: 3259
Joined: Tue Jul 13, 2010 12:15 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests