LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Dont upgrade SID PYTHON!

Postby GeneC on Fri Apr 15, 2011 5:05 pm

Dont upgrade SID PYTHON!

From the DEBIAN forum
http://forums.debian.net/viewtopic.php?f=20&t=62919&sid=48fa6c99c294b5540f1dab19b017a87b




dont upgrade sid python
by craigevil » 2011-04-15 20:03

Python is wacked at the moment do not upgrade if you are running sid. Do not upgrade python, python-minimal, or python-central.
----------------------------------------------
CODE: SELECT ALL
The following packages will be REMOVED:
apt-listchanges apt-xapian-index gdebi gdebi-core gimp guidance-power-manager hplip-gui kraft libpurple-bin lsb lsb-core
lsb-cxx lsb-desktop lsb-graphics lsb-release obmenu python-cairo python-chardet python-cups python-cupshelpers python-debian
python-gconf python-glade2 python-gtk2 python-gtkspell python-kde4 python-keybinder python-notify python-numpy python-pygame python-qt4 python-qt4-dbus python-reportbug python-sip python-trml2pdf python-vte python-wicd realplay reportbug slingshot smart-notifier system-config-printer-kde terminator uzbl weather-util wicd-daemon wicd-gtk wicd-kde zeroinstall-injector

The following packages have been kept back:
hpijs hplip hplip-cups libhpmud0 libsane-hpaio python python-minimal
The following packages will be upgraded:
apt apt-doc apt-utils cpp-4.5 curl g++-4.5 gcc-4.5 gcc-4.5-base glib-networking grub-common grub-pc icedove-gcontactsync
kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libcurl3 libcurl3-gnutls libdb4.7 libdb5.1 libdca0 libglib2.0-0
libglib2.0-data libglibmm-2.4-1c2a libgudev-1.0-0 libkde3support4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
libkfile4 libkhtml5 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4
libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkunitconversion4 libkutils4 libmpc2
libnepomuk4 libnepomukquery4a liborc-0.4-0 libpam-gnome-keyring libplasma3 libsdl1.2debian libsdl1.2debian-alsa libsolid4
libssl1.0.0 libstdc++6-4.5-dev libthreadweaver4 libudev0 libvlc5 libvlccore4 mencoder mplayer openssl python-central udev
vlc vlc-data vlc-nox
71 upgraded, 0 newly installed, 49 to remove and 7 not upgraded.

---------------------------------------------------

Debian Sid Kernel Liquorix IBM Thinkpad R40 Intel M 1.3 CPU 1GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

craigevil

Posts: 3347
Joined: 2006-09-17 03:17
Location: down the rabbit hole
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Fri Apr 15, 2011 7:42 pm

odd, GeneC, my output is a bit different, python is broken, but doesn't break "everything" :roll:

Code: Select all
Calculating upgrade... Done
The following packages have been kept back:
  gnome-icon-theme-extras python python-minimal seahorse
The following packages will be upgraded:
  alien apt apt-utils faenza-icon-theme git git-man grub-common grub-pc
  kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libglibmm-2.4-1c2a
  libkde3support4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4
  libkpty4 libkrosscore4 libktexteditor4 libkutils4 libnepomuk4
  libnepomukquery4a liborc-0.4-0 libplasma3 libsolid4 libthreadweaver4
  mencoder mintsystem mplayer python-debian rsync
45 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 56.7 MB of archives.
After this operation, 2,839 kB of additional disk space will be used.
Do you want to continue [Y/n]?
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby autocrosser on Fri Apr 15, 2011 8:37 pm

I've been seeing problems with Python in experimental for about 2 weeks now--upgrading would take out about half of the installed software...as soon as it clears experimental, I'll post.....
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230
User avatar
autocrosser
Level 4
Level 4
 
Posts: 421
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Fri Apr 15, 2011 8:42 pm

Thanks for the info
So I hold on to DU on my aptosid and Debian-gnome sid also
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Sun Apr 17, 2011 6:37 pm

I noticed that nasty behavior in python too. Anyone have a link to the bug report thread?
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby autocrosser on Sun Apr 17, 2011 6:49 pm

I just got Python 2.7 updated this morning with no ill-affects in my experimental install...Has not made it to my Sid install as of yet.
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230
User avatar
autocrosser
Level 4
Level 4
 
Posts: 421
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby sidneyk on Sun Apr 17, 2011 10:31 pm

I've seen this, too. I have Gnome 3 with Gnome shell running and if I try to manually upgrade certain python packages it wants to take it nearly everything, so of course I say quit and get the heck out of there and just let it be held back awhile longer until they get it fixed. I'm pretty sure it's python that's affecting some aspects of the mint system packages with the Gnome 3 packages installed and the different config mechanisms it comes with. For example, as mentioned previously, mintmenu used to work under Gnome 3 / shell though you had to manually start it up, but for about a week now, whenever I try to start it it just generates a page of all kinds of python related errors and does not start. Of course, any of the other older menu type apps also do not run now. I guess progression and regression must walk hand in hand sometimes.
User avatar
sidneyk
Level 1
Level 1
 
Posts: 35
Joined: Thu Mar 10, 2011 12:54 pm
Location: Bonner Springs, KS, USA

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Mon Apr 18, 2011 12:35 pm

Most of python installs fine now. The problems remain with python-cairo and python-pyorbit which use virtual package python2.5-cairo, which appears to be broken currently:

python-cairo:
Code: Select all
sudoku@amitabha ~ $ sudo aptitude install python-cairo
The following packages will be upgraded:
  python-cairo
1 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 84.2 kB of archives. After unpacking 81.9 kB will be used.
The following packages have unmet dependencies:
  python-gtk2: Depends: python2.5-cairo which is a virtual package.
The following actions will resolve these dependencies:

      Remove the following packages:                                     
1)      alacarte                                                         
2)      apturl                                                           
3)      compizconfig-settings-manager                                     
4)      deskbar-applet                                                   
5)      fusion-icon                                                       
6)      gdebi                                                             
7)      gedit                                                             
8)      gimp                                                             
9)      gnome-about                                                       
10)     gnome-applets                                                     
11)     gnome-control-center                                             
12)     gnome-mag                                                         
13)     gnome-menus                                                       
14)     gnome-panel                                                       
15)     gnome-session                                                     
16)     gnomenu                                                           
17)     gtk-recordmydesktop                                               
18)     gufw                                                             
19)     gwibber                                                           
20)     gwibber-service                                                   
21)     gwibber-service-facebook                                         
22)     gwibber-service-identica                                         
23)     gwibber-service-twitter                                           
24)     mint-common                                                       
25)     mint-meta-common                                                 
26)     mint-meta-debian                                                 
27)     mintbackup                                                       
28)     mintdesktop                                                       
29)     mintinstall                                                       
30)     mintmenu                                                         
31)     mintnanny                                                         
32)     mintsystem                                                       
33)     mintupdate                                                       
34)     mintupload                                                       
35)     mintwelcome                                                       
36)     mintwifi                                                         
37)     ndisgtk                                                           
38)     python-bugbuddy                                                   
39)     python-evolution                                                 
40)     python-gksu2                                                     
41)     python-glade2                                                     
42)     python-gmenu                                                     
43)     python-gnome2                                                     
44)     python-gnomeapplet                                               
45)     python-gnomedesktop                                               
46)     python-gnomekeyring                                               
47)     python-gtk2                                                       
48)     python-gtksourceview2                                             
49)     python-gtkspell                                                   
50)     python-keybinder                                                 
51)     python-notify                                                     
52)     python-pyatspi                                                   
53)     python-sexy                                                       
54)     python-vte                                                       
55)     python-webkit                                                     
56)     python-wnck                                                       
57)     rhythmbox                                                         
58)     rhythmbox-plugins                                                 
59)     software-properties-gtk                                           
60)     startupmanager                                                   
61)     system-config-printer                                             
62)     totem-plugins                                                     

      Leave the following dependencies unresolved:                       
63)     capplets-data recommends gnome-control-center (>= 1:2.30.1-3)     
64)     gedit-common recommends gedit                                     
65)     gnome-applets recommends deskbar-applet                           
66)     gnome-applets recommends python-gtk2                             
67)     gnome-panel-data recommends gnome-panel                           
68)     gnome-panel recommends gnome-control-center                       
69)     gnome-panel recommends alacarte                                   
70)     gnome-system-tools recommends gnome-control-center (>= 1:2.10.1-1)
71)     metacity recommends gnome-session | x-session-manager             
72)     mousetweaks recommends gnome-control-center                       
73)     rhythmbox recommends rhythmbox-plugins                           
74)     synaptic recommends software-properties-gtk                       
75)     totem recommends totem-plugins                                   
76)     gnomenu recommends deskbar-applet                                 
77)     gnomenu recommends python-keybinder                               
78)     libgimp2.0 recommends gimp                                       
79)     gimp-data recommends gimp         


python-pyorbit:
Code: Select all
sudoku@amitabha ~ $ sudo aptitude install python-pyorbit
The following packages will be upgraded:
  python-pyorbit
1 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 111 kB of archives. After unpacking 61.4 kB will be used.
The following packages have unmet dependencies:
  python-gnome2: Depends: python2.5-pyorbit which is a virtual package.
The following actions will resolve these dependencies:

      Remove the following packages:                         
1)      deskbar-applet                                       
2)      gnome-about                                         
3)      gnome-applets                                       
4)      gnome-mag                                           
5)      gnome-panel                                         
6)      gnome-session                                       
7)      gufw                                                 
8)      mint-meta-common                                     
9)      mint-meta-debian                                     
10)     mintmenu                                             
11)     python-gnome2                                       
12)     python-gnomeapplet                                   
13)     python-pyatspi                                       
14)     rhythmbox                                           
15)     rhythmbox-plugins                                   
16)     startupmanager                                       
17)     system-config-printer                               

      Leave the following dependencies unresolved:           
18)     alacarte recommends gnome-panel                     
19)     gnome-control-center recommends gnome-session       
20)     gedit recommends python-gnome2                       
21)     gnome-applets recommends python-gnome2               
22)     gnome-panel-data recommends gnome-panel             
23)     metacity recommends gnome-session | x-session-manager
24)     gnomenu recommends deskbar-applet   


here's the bug thread:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=623033
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Wed Apr 20, 2011 6:39 am

ok, my Debian-gnome tracking Sid had similar problem.
However, interesting , Aptosid had no problem, perhaps they have resolved, so DU went smoothly.
Aptosid always gave me pleasant surprise!.

Here is the list, it wants to remove so many gnome desktop and gedit etc, so just HOLD on

273 upgraded, 26 newly installed, 31 to remove and 1 not upgraded.
Need to get 375 MB of archives.
After this operation, 7,687 kB disk space will be freed.



The following packages will be REMOVED:
Code: Select all
  console-terminus deskbar-applet gedit gedit-plugins gnome gnome-about
  gnome-accessibility gnome-applets gnome-core gnome-desktop-environment
  gnome-games gnome-mag gnome-orca gnome-panel gnome-session hamster-applet
  libsdl1.2debian-alsa python-gconf python-gnome2 python-gnomeapplet
  python-gtksourceview2 python-pyatspi rhythmbox rhythmbox-plugin-cdrecorder
  rhythmbox-plugins software-center system-config-printer totem-coherence
  totem-plugins update-manager-gnome update-notifier

The following NEW packages will be installed:
Code: Select all
  console-setup-linux gir1.2-gdkpixbuf-2.0 glib-networking
  gnome-themes-standard gsettings-desktop-schemas libcap2-bin
  libchamplain-0.8-1 libchamplain-gtk-0.8-1 libencode-locale-perl
  libfile-listing-perl libgck0 libgcr-3-0 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libhtml-form-perl libhttp-cookies-perl libhttp-daemon-perl
  libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libjte1
  liblwp-mediatypes-perl libnet-http-perl libquvi0 libwww-robotrules-perl

The following packages have been kept back:
Code: Select all
 seahorse

The following packages will be upgraded:
Code: Select all
  acpid alsa-base alsa-utils apache2.2-bin apt apt-utils avahi-daemon bluez
  busybox console-setup cpp cpp-4.5 cups cups-bsd cups-client cups-common
  cups-pk-helper cups-ppdc dbus dbus-x11 empathy empathy-common esound-common
  evolution evolution-common evolution-exchange evolution-plugins exim4
  exim4-base exim4-config exim4-daemon-light fontconfig fontconfig-config
  gcc-4.4-base gcc-4.5-base gcc-4.6-base gcj-4.4-base gcj-4.4-jre
  gcj-4.4-jre-headless gcj-4.4-jre-lib gcj-jre gcj-jre-headless geoip-database
  gimp gimp-data gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-glib-2.0
  gir1.2-gtk-2.0 gnome-keyring gnome-office grub-common grub-pc
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-good gtk2-engines-pixbuf
  hpijs hplip hplip-cups hplip-data initscripts keyboard-configuration less
  libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libasound2 libatk1.0-0
  libatk1.0-data libavahi-client3 libavahi-common-data libavahi-common3
  libavahi-core7 libavahi-glib1 libavahi-gobject0 libavahi-ui0 libbluetooth3
  libboost-iostreams1.46.1 libc-bin libc6 libc6-i386 libclutter-gtk-0.10-0
  libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1
  libcurl3-gnutls libdb4.6 libdb4.7 libdb4.7-java libdb4.7-java-gcj libdb4.8
  libdb5.1 libdbus-1-3 libdca0 libdrm-intel1 libdrm-nouveau1a libdrm-radeon1
  libdrm2 libdv4 libesd0 libevolution libffi5 libfontconfig1 libgail-common
  libgail18 libgcc1 libgcj-bc libgcj-common libgcj10 libgcj10-awt
  libgdk-pixbuf2.0-0 libgee2 libgeoip1 libgfortran3 libgimp2.0
  libgirepository-1.0-1 libgl1-mesa-dri libgl1-mesa-glx libglib2.0-0
  libglib2.0-data libglibmm-2.4-1c2a libglu1-mesa libgnome-keyring0 libgomp1
  libgphoto2-2 libgphoto2-l10n libgphoto2-port0 libgssdp-1.0-2 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgtkhtml-editor-3.14-0
  libgtkhtml-editor-3.14-common libgtkhtml3.14-19 libgudev-1.0-0
  libgupnp-1.0-3 libhpmud0 libimobiledevice1 libisofs6 liblapack3gf
  libldap-2.4-2 libmodplug1 libmpc2 libmysqlclient16 libncurses5 libncursesw5
  liborc-0.4-0 libpam-gnome-keyring libpangomm-1.4-1 libpcap0.8 libpcsclite1
  libpixman-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libportaudio2 libpython2.6 libquadmath0 libreoffice
  libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-emailmerge
  libreoffice-evolution libreoffice-filter-binfilter
  libreoffice-filter-mobiledev libreoffice-gcj libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libsane-hpaio libschroedinger-1.0-0 libsdl1.2debian libservlet2.5-java
  libslang2 libsoundtouch0 libsoup-gnome2.4-1 libsoup2.4-1 libstdc++6 libtdb1
  libtelepathy-glib0 libtiff4 libtotem-plparser17 libudev0 libupower-glib1
  libv4l-0 libva1 libwww-perl libxapian22 libzbar0 linux-sound-base locales
  man-db media-player-info mutt mysql-common nautilus-sendto-empathy
  ncurses-base ncurses-bin ncurses-term openoffice.org
  openoffice.org-evolution openoffice.org-gcj openoffice.org-gnome
  openoffice.org-help-en-us openoffice.org-thesaurus-en-us openssh-client
  os-prober pcscd pm-utils policykit-1 python python-beautifulsoup
  python-cairo python-configobj python-debian python-gdbm python-glade2
  python-gobject python-gobject-cairo python-gtk2 python-httplib2 python-mako
  python-markupsafe python-minimal python-numpy python-pam
  python-pkg-resources python-pyorbit python-support python-twisted-bin
  python-twisted-conch python-twisted-core python-twisted-web python-uno
  python-xapian python2.6 python2.6-minimal rsyslog shotwell simple-scan
  sysv-rc sysvinit sysvinit-utils tcl8.5 tomboy ttf-lyx ttf-opensymbol udev
  uno-libs3 upower ure vim-common vim-tiny wget wpasupplicant
  xserver-xorg-video-ati xserver-xorg-video-intel xserver-xorg-video-nouveau
  xserver-xorg-video-radeon

273 upgraded, 26 newly installed, 31 to remove and 1 not upgraded.
Need to get 375 MB of archives.
After this operation, 7,687 kB disk space will be freed.
Do you want to continue [Y/n]?
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby GeneC on Wed Apr 20, 2011 7:18 pm

Hmm! :?

Python stilll apears to be broken.

I tried "pinning" python-cairo and python-pyorbit, but upgrade still want to remove a lot of the same stuff that wayne128 mentioned.
Have to wait a while longer.

Code: Select all
The following packages will be REMOVED:
  deskbar-applet esound esound-clients gedit gnome-about gnome-applets gnome-core gnome-mag gnome-panel gnome-session gufw gwibber libsdl1.2debian-alsa mint-meta-common
  mint-meta-debian mintmenu python-gconf python-gnome2 python-gnomeapplet python-gtksourceview2 python-pyatspi python-xklavier rhythmbox rhythmbox-plugins startupmanager
  system-config-printer timer-applet totem-plugins ubuntu-tweak

The following NEW packages will be installed:
  gir1.2-glib-2.0 glib-networking gnome-themes-standard gsettings-desktop-schemas libcap2-bin libexo-1-0 libgck0 libgcr-3-0 libgirepository-1.0-1 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libquvi0 libthunar-vfs-1-common python-gobject-cairo python2.7 python2.7-minimal

The following packages have been kept back:
  seahorse

The following packages will be upgraded:
  acpid alien alsa-base alsa-utils apache2.2-bin apt apt-utils avahi-daemon bind9-host binutils bluez bogofilter bogofilter-bdb bogofilter-common chromium
  chromium-browser chromium-inspector console-setup console-setup-linux cpp-4.4 cpp-4.5 cups cups-bsd cups-client cups-common cups-pk-helper cups-ppdc curl dbus dbus-x11
  dhcp3-client dhcp3-common dnsutils dpkg dpkg-dev dselect esound-common evolution evolution-common evolution-plugins exim4 exim4-base exim4-config exim4-daemon-light
  file fontconfig g++-4.4 g++-4.5 gcc-4.4 gcc-4.4-base gcc-4.5 gcc-4.5-base gcc-4.6-base gcj-4.4-base gcj-4.4-jre-lib gdm3 gimp-data git git-man gnome-keyring grub-common
  grub-pc gstreamer0.10-plugins-bad gtk2-engines-pixbuf hal hpijs initscripts iputils-ping isc-dhcp-client isc-dhcp-common less lib32asound2 lib32gcc1 lib32ncurses5
  lib32stdc++6 lib32v4l-0 libasound2 libasound2-plugins libatk1.0-0 libatk1.0-data libavahi-client3 libavahi-common-data libavahi-common3 libavahi-core7 libavahi-glib1
  libavahi-gobject0 libavahi-ui0 libbind9-60 libbluetooth3 libclutter-gtk-0.10-0 libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3
  libcurl3-gnutls libdb4.7 libdb4.7-java libdb4.7-java-gcj libdb4.8 libdb5.1 libdbus-1-3 libdca0 libdjvulibre-text libdjvulibre21 libdns69 libdpkg-perl libdrm-intel1
  libdrm-nouveau1a libdrm-radeon1 libdrm2 libdv4 libesd0 libevolution libexo-common libffi5 libgail-common libgail18 libgcc1 libgcj10 libgdk-pixbuf2.0-0 libgeoip1
  libgfortran3 libgimp2.0 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglib2.0-0 libglib2.0-data libglibmm-2.4-1c2a libglu1-mesa libgnome-keyring0 libgomp1
  libgphoto2-2 libgphoto2-port0 libgssapi-krb5-2 libgssdp-1.0-2 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkhtml-editor-3.14-0 libgtkhtml-editor-3.14-common
  libgtkhtml3.14-19 libgudev-1.0-0 libgupnp-1.0-3 libhal-storage1 libhal1 libhpmud0 libimobiledevice1 libisc62 libisccc60 libisccfg62 libisofs6 libk5crypto3 libkrb5-3
  libkrb5support0 libldap-2.4-2 liblwres60 libmagic1 libmodplug1 libmpc2 libncurses5 libncursesw5 liborc-0.4-0 libpam-gnome-keyring libpangomm-1.4-1 libpcap0.8 libpci3
  libpcsclite1 libplist1 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libportaudio2 libpython2.6 libquadmath0 libsdl1.2debian libservlet2.5-java
  libslang2 libsoup-gnome2.4-1 libsoup2.4-1 libssl1.0.0 libstdc++6 libstdc++6-4.4-dev libstdc++6-4.5-dev libtelepathy-glib0 libthunar-vfs-1-2 libtiff4 libtotem-plparser17
  libudev0 libunistring0 libupower-glib1 libv4l-0 libva-x11-1 libva1 libvlc5 libxfce4util-bin libxfce4util-common libxfce4util4 libxfcegui4-4 libxfconf-0-2 libxml2
  libxml2-utils libxslt1.1 linux-sound-base man-db media-player-info mesa-common-dev ncurses-base ncurses-bin ncurses-term openssl pciutils pcscd pm-utils policykit-1
  python python-apt python-beautifulsoup python-cairo python-central python-configobj python-crypto python-dbus python-debian python-egenix-mxdatetime
  python-egenix-mxtools python-gdbm python-glade2 python-gobject python-gtk2 python-httplib2 python-imaging python-launchpadlib python-lazr.restfulclient python-lazr.uri
  python-libxml2 python-mako python-markupsafe python-minimal python-numpy python-pam python-parted python-pkg-resources python-pycurl python-pyorbit python-simplejson
  python-support python-twisted-bin python-twisted-core python-twisted-web python-wadllib python-zope.interface python2.6 python2.6-minimal rsync rsyslog sysv-rc sysvinit
  sysvinit-utils thunar-data ttf-opensymbol udev uno-libs3 ure vim-common vim-tiny w3m wpasupplicant xfburn xfce-keyboard-shortcuts xfconf xserver-xorg-video-ati
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-radeon xsltproc

279 upgraded, 17 newly installed, 29 to remove and 1 not upgraded.
Need to get 280 MB of archives.
After this operation, 9,014 kB of additional disk space will be used.




Strange, the guys on APTOSID Forums seem to be in better shape.

http://aptosid.com/index.php?name=PNphpBB2&file=viewtopic&t=1140&sid=b15c7d32c0e3938d481011a6581986f9
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Wed Apr 20, 2011 8:30 pm

yes, my aptosid-kde was du and no problem.

so out of curiosity I do the same for aptosid-xfce and no problem also.
apparently xfce4.8 was up on Debian Sid repos.

after du, xfce4.8 was up and running, however, there is no network icon on Thunar 1.2.1.
other distros with xfce4.8 have the network icon on Thunar.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Fri Apr 22, 2011 11:00 pm

Check few more times over past few days.

Still getting similar results, sid wants to remove many things related to gnome desktop.

Read also Debian forum on this.
http://forums.debian.net/viewtopic.php?f=10&t=63227

I continue to HOLD for all my du on partitions related to Debian Sid.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Sat Apr 23, 2011 9:45 am

Almost ironic that the problems with python now also break the functionality of reportbug! I got the following error when trying to append to the python-cairo bug report:

Code: Select all
sudoku@amitabha ~ $ reportbug python-cairo
/usr/lib/pymodules/python2.6/reportbug/ui/gtk2_ui.py:476: GtkWarning: IA__gtk_widget_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed
  gtk.main ()
Traceback (most recent call last):
  File "/usr/bin/reportbug", line 2127, in <module>
    main()
  File "/usr/bin/reportbug", line 1052, in main
    return iface.user_interface()
  File "/usr/bin/reportbug", line 2019, in user_interface
    issource=self.options.source)
  File "/usr/lib/pymodules/python2.6/reportbug/utils.py", line 756, in generate_blank_report
    return unicode(rep)
  File "/usr/lib/pymodules/python2.6/reportbug/bugreport.py", line 131, in __unicode__
    self.followup, reportto, self.package, headers)
TypeError: %d format: a number is required, not str
Segmentation fault


This Python thing is a real mess. You'd think Debian was run by Ubuntu or something for breaking something so critical to the system core without having a rollback plan in place.
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby GeneC on Sat Apr 23, 2011 10:22 am

TheGreatSudoku wrote:Almost ironic that the problems with python now also break the functionality of reportbug! I got the following error when trying to append to the python-cairo bug report:

Code: Select all
sudoku@amitabha ~ $ reportbug python-cairo....................


This Python thing is a real mess. You'd think Debian was run by Ubuntu or something for breaking something so critical to the system core without having a rollback plan in place.


:lol:

Curious why it does not seem to be effecting the Aptosid guys as seriously?

http://aptosid.com/index.php?name=PNphpBB2&file=viewforum&f=3&sid=550ed68c3b5c913fd16989c27c096455
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Sat Apr 23, 2011 10:28 am

GeneC wrote:
:lol:

Curious why it does not seem to be effecting the Aptosid guys as seriously?

http://aptosid.com/index.php?name=PNphpBB2&file=viewforum&f=3&sid=550ed68c3b5c913fd16989c27c096455


:lol: :mrgreen: please , because I need to run aptosid :lol: :mrgreen:
by the way, aptosid had either kde or xfce. no gnome.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby GeneC on Sat Apr 23, 2011 10:32 am

wayne128 wrote:
:lol: :mrgreen: please , because I need to run aptosid :lol: :mrgreen:
by the way, aptosid had either kde or xfce. no gnome.


No Gnome!
OK!... :)
No wonder..
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Sat Apr 23, 2011 5:40 pm

and the python packages now install normally, without calling for the removal of any packages. We'll see if reportbug works next time I run into a bug I want to file. I'm glad to see the Python situation is no longer Ubuntu-ed up :lol:
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby GeneC on Sat Apr 23, 2011 7:57 pm

TheGreatSudoku wrote:and the python packages now install normally, without calling for the removal of any packages. We'll see if reportbug works next time I run into a bug I want to file. I'm glad to see the Python situation is no longer Ubuntu-ed up :lol:


D-U went fine here as well.
320 packages! :shock:

No GNOME stuff was going to be removed.

I thought I might loose my sound. I saw where=

Code: Select all
Removed the following packages:
esound
esound-clients
libsdl1.2debian-alsa
python-xklavier


I had replaced Pulse Audio with ALSA and esound.

But saw where some new ALSA packages were being upgraded, and took a chance.

Worked fine, still have good sound.
Everything I checked so far works just fine. :)

SID always fixes itself. Just have to be patient and wait sometimes.
This time a lit longer than ususal.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Sat Apr 23, 2011 8:09 pm

thanks for the update

here I copy and post first before du Debian-gnome -Sid, seeing major change from last check.


The following packages will be REMOVED:
gnome-games libcryptui0 python-gtkglext1 seahorse-plugins
The following NEW packages will be installed:
libcryptui0a libdb5.1-java libdb5.1-java-gcj libio-socket-ssl-perl
libnet-libidn-perl libnet-ssleay-perl
The following packages will be upgraded:
acpid alsa-base alsa-utils bind9-host binutils ca-certificates cpp-4.4
cpp-4.5 cups cups-bsd cups-client cups-common cups-ppdc dbus dbus-x11
dnsutils evolution evolution-common evolution-plugins fuse-utils gcc-4.4
gcc-4.4-base gcc-4.5 gcc-4.5-base gcc-4.6-base gcj-4.4-base gcj-4.4-jre
gcj-4.4-jre-headless gcj-4.4-jre-lib gdm3 gnome-keyring guile-1.8-libs
icedtea-6-jre-cacao libasound2 libbind9-60 libcups2 libcupscgi1
libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3-gnutls
libdb4.6 libdb4.7 libdb4.8 libdb5.1 libdbus-1-3 libdjvulibre-text
libdjvulibre21 libdns69 libdv4 libevolution libffi5 libfuse2 libgcc1
libgcj10 libgcj10-awt libgck0 libgcr-3-0 libgfortran3 libgnome-keyring0
libgomp1 libgphoto2-2 libgphoto2-l10n libgphoto2-port0 libgudev-1.0-0
libhtml-tree-perl libimobiledevice1 libisc62 libisccc60 libisccfg62
liblucene2-java liblwres60 libnet-http-perl libnm-glib-vpn1 libnm-glib2
libnm-util1 liborc-0.4-0 libpam-gnome-keyring libpangomm-1.4-1 libperl5.10
libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpython2.6
libquadmath0 libreadline6 libreoffice libreoffice-base libreoffice-base-core
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-emailmerge libreoffice-filter-binfilter
libreoffice-filter-mobiledev libreoffice-gcj libreoffice-gnome
libreoffice-gtk libreoffice-help-en-us libreoffice-impress
libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
libservlet2.5-java libstdc++6 libtelepathy-glib0 libudev0 libv4l-0
libva-x11-1 libva1 linux-image-2.6.38-2-amd64 linux-libc-dev
linux-sound-base media-player-info network-manager network-manager-gnome
openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib perl perl-base
perl-modules policykit-1 python-apt python-cairo python-debian python-gconf
python-gdbm python-glade2 python-gnome2 python-gobject python-gobject-cairo
python-gtk2 python-gtksourceview2 python-mako python-pkg-resources
python-pyorbit python-twisted-bin python-twisted-conch python-twisted-core
python-twisted-web python-uno python2.6 python2.6-minimal readline-common
seahorse simple-scan sun-java6-bin sun-java6-jre sun-java6-plugin ttf-lyx
ttf-opensymbol tzdata tzdata-java ucf udev uno-libs3 ure wpasupplicant
x-ttcidfont-conf xserver-xorg-video-intel
166 upgraded, 6 newly installed, 4 to remove and 0 not upgraded.
Need to get 155 MB/363 MB of archives.
After this operation, 451 kB disk space will be freed.
Do you want to continue [Y/n]?
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby ukbrian on Sun Apr 24, 2011 3:54 am

User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests