LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Sat Apr 30, 2011 8:10 pm

libgcj-bc is offically listed as a "broken" package:

Code: Select all

sudoku@amitabha ~/Downloads $ sudo aptitude install libgcj-bc
[sudo] password for sudoku:
The following packages will be REMOVED: 
  g++-4.5{u} libstdc++6-4.5-dev{u}
The following packages will be upgraded:
  libgcj-bc{b}
1 packages upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 1,136 B of archives. After unpacking 25.6 MB will be freed.
The following packages have unmet dependencies:
  libgcj-bc: Depends: libgcj10 (>= 4.6.0-1) but 4.4.6-2 is installed.
The following actions will resolve these dependencies:

     Remove the following packages:                   
1)     libdb4.7-java-gcj                               
2)     libdb5.1-java-gcj                               
3)     libgcj-bc                                       
4)     liblog4j1.2-java-gcj                           

     Leave the following dependencies unresolved:     
5)     libdb5.1-java recommends libdb5.1-java-gcj     
6)     liblog4j1.2-java recommends liblog4j1.2-java-gcj
7)     libdb4.7-java recommends libdb4.7-java-gcj


The bug report (which alleges a fix has been implemeted):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624632
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Linux Mint is funded by ads and donations.
 

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Tue May 03, 2011 8:24 am

Do not du on Sid because of perl and xorg

1. link to upgrade warning by aptosid:
http://aptosid.com/index.php?module=new ... lay&sid=26

2. link to warning by antiX
http://antix.freeforums.org/perl-remove ... t3082.html

Here is my list on Debian gnome Sid:


The following packages will be REMOVED:
Code: Select all
aspell aspell-en debconf-i18n dictionaries-common gnome-applets
  gnome-system-tools hpijs hplip-cups hunspell-kk libcairo-perl
  libdigest-sha1-perl libfont-freetype-perl libglib-perl libgnome2-canvas-perl
  libgnome2-perl libgnome2-vfs-perl libgtk2-perl libhpmud0 libhtml-form-perl
  libhtml-format-perl libhtml-parser-perl libhtml-tree-perl
  libhttp-cookies-perl libhttp-daemon-perl libhttp-message-perl
  libhttp-negotiate-perl libio-socket-ssl-perl liblocale-gettext-perl
  libnet-dbus-perl libnet-libidn-perl libnet-ssleay-perl liboobs-1-4
  libpango-perl libperl5.10 libsane-hpaio libsnmp15 libtext-charwidth-perl
  libtext-iconv-perl libtext-wrapi18n-perl libuuid-perl libwww-perl
  libxml-parser-perl libxml-twig-perl linux-base linux-image-2.6-amd64
  linux-image-2.6.32-5-amd64 linux-image-2.6.38-1-amd64
  linux-image-2.6.38-2-amd64 myspell-en-us mythes-en-us
  openoffice.org-thesaurus-en-us perlmagick system-tools-backends tasksel
  tasksel-data xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-ati xserver-xorg-video-mach64

The following NEW packages will be installed:
Code: Select all
 libclass-isa-perl libmtp-runtime libpod-plainer-perl libswitch-perl

The following packages will be upgraded:
Code: Select all
 binutils espeak espeak-data guile-1.8-libs iso-codes libaa1 libc-bin
  libc-dev-bin libc6 libc6-dev libc6-i386 libdb4.6 libdb4.7 libdb4.8
  libegl1-mesa libegl1-mesa-drivers libespeak1 libgl1-mesa-dri libgl1-mesa-glx
  libglu1-mesa libgpgme11 libgpod-common libgpod4 libgupnp-1.0-3 libieee1284-3
  liblcms1 libmimic0 libmtp8 libpam-modules libpam-runtime libpam0g
  libqt4-dbus libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support
  libqt4-script libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
  libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libreoffice
  libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-emailmerge
  libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gcj
  libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer locales
  locales-all perl perl-base perl-modules python-reportbug python-uno
  qt4-qtconfig reportbug shotwell ttf-opensymbol uno-libs3 ure vino
  xserver-common xserver-xephyr xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-i128 xserver-xorg-video-intel xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo

112 upgraded, 4 newly installed, 59 to remove and 0 not upgraded.
Need to get 217 MB of archives.
After this operation, 372 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Tue May 03, 2011 10:58 am

wow :)
wayne this really sounds like sid :lol:

Code: Select all
Calculating upgrade... Done
The following packages will be REMOVED:
  apt-file aspell aspell-en broadcom-sta-modules-2.6.32-5-686
  broadcom-sta-modules-2.6.37-1-686 broadcom-sta-modules-2.6.38-1-686
  command-not-found debconf-i18n dictionaries-common dvdrip gmusicbrowser
  gnome-applets gnome-system-tools gtk2-ex-formfactory-perl hpijs
  libalgorithm-diff-xs-perl libapt-pkg-perl libasync-interrupt-perl
  libaudio-scrobbler-perl libcairo-perl libdigest-sha1-perl libevent-perl
  libevent-rpc-perl libglib-perl libgnome2-canvas-perl libgnome2-perl
  libgnome2-vfs-perl libgstreamer-perl libgtk2-notify-perl libgtk2-perl
  libgtk2-trayicon-perl libhpmud0 libhtml-form-perl libhtml-format-perl
  libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl
  libhttp-daemon-perl libhttp-message-perl libhttp-negotiate-perl
  libio-socket-ssl-perl liblist-moreutils-perl liblocale-gettext-perl
  libnet-dbus-perl libnet-libidn-perl libnet-ssleay-perl liboobs-1-4
  libpango-perl libperl5.10 libpurple-bin libpurple0 libsnmp15
  libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libuuid-perl
  libwww-perl libxml-parser-perl libxml-twig-perl linux-base
  linux-image-2.6-686 linux-image-2.6.32-5-686 linux-image-2.6.37-1-686
  linux-image-2.6.37-2-686 linux-image-2.6.38-1-686 linux-image-2.6.38-2-686
  madwifi-source mint-meta-common mint-meta-debian module-assistant pidgin
  pidgin-plugin-pack pidgin-themes system-tools-backends tasksel tasksel-data
  xchat xscreensaver-data-extra xscreensaver-screensaver-bsod
  xserver-xorg-input-wacom xserver-xorg-video-ati xserver-xorg-video-mach64
The following NEW packages will be installed:
  gcj-4.6-base gcj-4.6-jre-lib libclass-isa-perl libgcj12 libpod-plainer-perl
  libswitch-perl
The following packages have been kept back:
  gnome-icon-theme-extras
The following packages will be upgraded:
  bzr cpp cvs debconf espeak espeak-data g++ gcc guile-1.8-libs iso-codes
  libaa1 libc-bin libc-dev-bin libc6 libc6-dbg libc6-dev libc6-i686 libdb4.7
  libdb4.8 libespeak1 libftdi1 libgcj-bc libgcj-common libgeoip1
  libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libgpgme11 libgphoto2-2
  libgphoto2-l10n libgphoto2-port0 libgpod-common libgpod4 libgupnp-1.0-3
  libieee1284-3 libjte1 liblcms1 libmimic0 libmlt++3 libmlt-data libmlt4
  libmozjs2d libpam-modules libpam-runtime libpam0g libqt4-assistant
  libqt4-core libqt4-dbus libqt4-declarative libqt4-designer libqt4-gui
  libqt4-help libqt4-network libqt4-opengl libqt4-qt3support libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
  libqt4-test libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4
  libsvn1 libunshield0 locales melt mencoder mint-x-icons mintsystem mplayer
  network-manager-gnome perl perl-base perl-modules python-bzrlib python-cups
  python-levenshtein python-mutagen python-pam subversion unshield
  xserver-common xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xulrunner-1.9.1
117 upgraded, 6 newly installed, 82 to remove and 1 not upgraded.
Need to get 159 MB of archives.
After this operation, 423 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
amadeu@inspiron1545-laptop ~ $

and here's my output :D
amazing, an update that wants to remove all installed kernels 8)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Wed May 04, 2011 10:39 am

DU is still a no-go, though things look better today, we went from 82 to 26 removals :lol:
maybe tomorrow 8)

Code: Select all
Calculating upgrade... Done
The following packages will be REMOVED:
  dvdrip gmusicbrowser gnome-applets gnome-system-tools
  gtk2-ex-formfactory-perl hpijs libcairo-perl libgnome2-canvas-perl
  libgnome2-perl libgstreamer-perl libgtk2-notify-perl libgtk2-perl
  libgtk2-trayicon-perl libhpmud0 libnet-dbus-perl liboobs-1-4 libpango-perl
  libperl5.10 libpurple-bin libpurple0 libsnmp15 pidgin pidgin-plugin-pack
  pidgin-themes system-tools-backends xchat
The following NEW packages will be installed:
  gcj-4.6-base gcj-4.6-jre-lib libclass-isa-perl libgcj12 libmtp-runtime
  libpod-plainer-perl libswitch-perl
The following packages have been kept back:
  gnome-icon-theme-extras
The following packages will be upgraded:
  acpi alsa-base alsa-utils bzr cpp cvs debconf debconf-i18n
  dictionaries-common espeak espeak-data exim4-base exim4-daemon-light g++ gcc
  graphviz guile-1.8-libs imagemagick iso-codes libaa1
  libalgorithm-diff-xs-perl libapt-pkg-perl libasync-interrupt-perl libc-bin
  libc-dev-bin libc6 libc6-dbg libc6-dev libc6-i686 libcdt4 libcgraph5
  libdb4.7 libdb4.8 libdigest-sha1-perl libespeak1 libevent-perl libftdi1
  libgcj-bc libgcj-common libgeoip1 libgl1-mesa-dri libgl1-mesa-glx
  libglib-perl libglu1-mesa libgnome2-vfs-perl libgpgme11 libgphoto2-2
  libgphoto2-l10n libgphoto2-port0 libgpod-common libgpod4 libgraph4
  libgraphicsmagick3 libgupnp-1.0-3 libgvc5 libgvpr1 libhtml-parser-perl
  libieee1284-3 libjte1 liblcms1 libldap-2.4-2 liblist-moreutils-perl
  liblocale-gettext-perl libmagickcore3 libmagickwand3 libmimic0 libmlt++3
  libmlt-data libmlt4 libmozjs2d libmtp8 libnet-libidn-perl libnet-ssleay-perl
  libpam-modules libpam-runtime libpam0g libpathplan4 libqt3-mt
  libqt4-assistant libqt4-core libqt4-dbus libqt4-declarative libqt4-designer
  libqt4-gui libqt4-help libqt4-network libqt4-opengl libqt4-qt3support
  libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-webkit libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 libsvga1 libsvn1
  libtext-charwidth-perl libtext-iconv-perl libunshield0 libuuid-perl
  libwxbase2.8-0 libwxgtk2.8-0 libxdot4 libxml-parser-perl linux-sound-base
  locales melt mencoder mint-x-icons mintsystem mplayer network-manager-gnome
  perl perl-base perl-modules python-bzrlib python-cups python-levenshtein
  python-mutagen python-pam shotwell subversion sun-java6-bin sun-java6-jre
  sun-java6-plugin telepathy-salut unshield vim-common vim-tiny x11-utils
  xserver-common xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm
  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128
  xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xulrunner-1.9.1
170 upgraded, 7 newly installed, 26 to remove and 1 not upgraded.
Need to get 219 MB of archives.
After this operation, 11.8 MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.
amadeu@inspiron1545-laptop ~ $
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby secipolla on Wed May 04, 2011 8:44 pm

Use aptitude (full-upgrade). It will always offer to install just the packages that won't need others being removed.
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Wed May 04, 2011 8:51 pm

usually i prefer apt to aptitude, just because i'm more familiar with;
but being as you say, there's no major difference between aptitude full-upgrade and apt upgrade?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Wed May 04, 2011 9:49 pm

here is mine on Debian-gnome-Sid

as I do not use hp printer and thus do not have issue on hpijs/cups,
there is now newer kernel 2.6.38.5 from liquorix.

now I am thinking should I hit Y or n :lol:

too the risk, Y
and sid does not want to update :lol:
Code: Select all
Do you want to continue [Y/n]? y
Err http://ftp.us.debian.org/debian/ unstable/main libc6-i386 amd64 2.13-2
  The HTTP server sent an invalid Content-Range header [IP: 128.30.2.36 80]
Err http://ftp.us.debian.org/debian/ unstable/main libc6-dev amd64 2.13-2
  Bad header line [IP: 128.30.2.36 80]
0% [Waiting for headers]^C




Code: Select all
The following packages will be REMOVED:
 [code] hpijs hplip-cups libcairo-perl libgnome2-canvas-perl libgnome2-perl
  libgtk2-perl libhpmud0 libpango-perl libperl5.10 libsane-hpaio libsnmp15[/code]
The following NEW packages will be installed:
[code]  libclass-isa-perl libmtp-runtime libperl5.12 libpod-plainer-perl
  libswitch-perl linux-headers-2.6.38-5.dmz.1-liquorix-amd64
  linux-image-2.6.38-5.dmz.1-liquorix-amd64[/code]
The following packages will be upgraded:
  [code]acpi alsa-base alsa-utils binutils dictionaries-common dpkg espeak
  espeak-data exim4-base exim4-daemon-light gnome-menus guile-1.8-libs
  imagemagick iso-codes libaa1 libc-bin libc-dev-bin libc6 libc6-dev
  libc6-i386 libcdt4 libdb4.6 libdb4.7 libdb4.8 libdigest-sha1-perl
  libegl1-mesa libegl1-mesa-drivers libespeak1 libfont-freetype-perl
  libgl1-mesa-dri libgl1-mesa-glx libglib-perl libglu1-mesa libgnome-menu2
  libgnome2-vfs-perl libgpgme11 libgpod-common libgpod4 libgraph4
  libgraphicsmagick3 libgtop2-7 libgtop2-common libgupnp-1.0-3 libgvc5
  libhtml-parser-perl libieee1284-3 libimobiledevice1 liblcms1 libldap-2.4-2
  liblocale-gettext-perl libmagick++3 libmagickcore3 libmagickcore3-extra
  libmagickwand3 libmimic0 libmpfr4 libmtp8 libnet-dbus-perl
  libnet-libidn-perl libnet-ssleay-perl libopenraw1 libpam-modules
  libpam-runtime libpam0g libpathplan4 libplist1 libqt4-dbus libqt4-designer
  libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql
  libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-webkit libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-filter-binfilter
  libreoffice-filter-mobiledev libreoffice-gcj libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libselinux1 libsvga1 libtelepathy-farsight0 libtext-charwidth-perl
  libtext-iconv-perl libtokyocabinet8 libuuid-perl libxdot4 libxml-parser-perl
  linux-headers-2.6-liquorix-amd64 linux-image-2.6-liquorix-amd64
  linux-sound-base locales locales-all modemmanager network-manager-gnome perl
  perl-base perl-modules perlmagick python-gdbm python-gmenu python-reportbug
  python-uno qt4-qtconfig reportbug shotwell sun-java6-bin sun-java6-jre
  sun-java6-plugin telepathy-salut ttf-opensymbol uno-libs3 ure vino x11-utils
  xserver-common xserver-xephyr xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm
  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo
172 upgraded, 7 newly installed, 11 to remove and 0 not upgraded.
Need to get 233 MB/309 MB of archives.
After this operation, 167 MB of additional disk space will be used.
Do you want to continue [Y/n]? [/code]
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Wed May 04, 2011 9:56 pm

wayne if this is the perl upgrade from 5.10 to 5.12 i will wait untill everything is settled :)

last time i went though this upgrade it was bad :mrgreen:

http://forum.mandriva.com/en/viewtopic. ... 5&t=130082
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Wed May 04, 2011 11:05 pm

zerozero wrote:wayne if this is the perl upgrade from 5.10 to 5.12 i will wait untill everything is settled :)

last time i went though this upgrade it was bad :mrgreen:

http://forum.mandriva.com/en/viewtopic. ... 5&t=130082



zerozero, thanks for the warning, my debian-gnome-sid still old working waiting for perl to settle down

however I went to check aptosid-kde-sid, no perl thingy, so du and it went ok, pleasant surprise, always :lol:
then I went to du aptosid-xfce-sid, also OK, it loaded xfce4.8 and reboot all working, another pleasant surprise :lol:

meanwhile, Debian-xfce-sid broke big time,
reinstall on one new partition from fresh, haha, white screen of death
reinstall yet another new partition from fresh, haha, gdm screen OK, no mouse pointer, no keyboard, cannot do antything. don't anyhow play with sid , :idea: always must have other working partitions ( i have many) before playing :mrgreen: :mrgreen:
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Wed May 04, 2011 11:33 pm

:lol: you've been caught by sid there :lol:

that's the thing: my lmde-sid is the only os in the lappy, so i need it to work (sid=reliable :mrgreen: )
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Thu May 05, 2011 12:57 am

secipolla wrote:Use aptitude (full-upgrade). It will always offer to install just the packages that won't need others being removed.


thanks secipolla for pointing out aptitude.

so i use aptitude fro debian-gnome-sid and got some serious bugs and thus no go on du.

Code: Select all
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of libc6 (2.11.2-13 -> 2.13-2) <unfixed>
 #617759 - icedove: symbol lookup error: /usr/lib/icedove/components/libdbusservice.so: undefined symbol: NS_Alloc
serious bugs of libc6 (2.11.2-13 -> 2.13-2) <unfixed>
 #625607 - cmake: Segfaults on sparc
serious bugs of guile-1.8-libs (1.8.8+1-2 -> 1.8.8+1-3) <unfixed>
 #625243 - guile-1.8-libs: postinst fails on upgrade: "guile-1.8: not found"
Summary:
 libc6(2 bugs), guile-1.8-libs(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] n
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby secipolla on Fri May 06, 2011 11:12 am

zerozero wrote:usually i prefer apt to aptitude, just because i'm more familiar with;
but being as you say, there's no major difference between aptitude full-upgrade and apt upgrade?

aptitude full-upgrade is like apt-get dist-upgrade. But now you're saying it, yes, the solution I talked about would be just like apt-get upgrade (aptitude offers several ways to deal with the removals).
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Sat May 07, 2011 10:13 am

Today have a check,
Sid did not want to remove anything...
so I take as good to go, du and it works.

old history: lots of removal.
Code: Select all
The following packages will be REMOVED:
 [code] hpijs hplip-cups libcairo-perl libgnome2-canvas-perl libgnome2-perl
  libgtk2-perl libhpmud0 libpango-perl libperl5.10 libsane-hpaio libsnmp15
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby craigevil on Sat May 07, 2011 11:45 am

Not OK here:
The following packages will be REMOVED:
hpijs hplip hplip-cups hplip-gui libhpmud0 libperl5.10 libpurple-bin libpurple0 libsane-hpaio libsnmp15 pidgin
pidgin-blinklight pidgin-extprefs pidgin-facebookchat pidgin-lastfm pidgin-openpgp pidgin-plugin-pack pidgin-privacy-please pidgin-themes pidgin-twitter
The following NEW packages will be installed:
libperl5.12
The following packages have been kept back:
k9copy libudev0 udev
The following packages will be upgraded:
irssi libalgorithm-diff-xs-perl libapt-pkg-perl libbit-vector-perl libcairo-perl libcrypt-blowfish-perl
libcrypt-openssl-bignum-perl libcurses-perl libdate-calc-perl libdbi-perl libdigest-sha1-perl libevent-perl libglib-perl
libgtk2-perl libhtml-parser-perl libio-pty-perl liblist-moreutils-perl liblocale-gettext-perl libnet-dns-perl libpango-perl
libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libuuid-perl libyaml-syck-perl perl perl-base perl-modules
perl-tk xchat
30 upgraded, 1 newly installed, 20 to remove and 3 not upgraded.
Need to get 0 B/19.4 MB of archives.
After this operation, 12.0 MB disk space will be freed.


With perl-base on hold:
The following packages have been kept back:
irssi k9copy libalgorithm-diff-xs-perl libapt-pkg-perl libbit-vector-perl libcairo-perl libcrypt-blowfish-perl
libcrypt-openssl-bignum-perl libcurses-perl libdate-calc-perl libdbi-perl libdigest-sha1-perl libevent-perl libglib-perl
libgtk2-perl libhtml-parser-perl libio-pty-perl liblist-moreutils-perl liblocale-gettext-perl libnet-dns-perl libpango-perl
libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libudev0 libuuid-perl libyaml-syck-perl perl perl-base
perl-modules perl-tk udev xchat
0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.


Using aptitude full-upgrade:
Code: Select all
 # aptitude full-upgrade
The following NEW packages will be installed:
  libperl5.12{a}
The following packages will be REMOVED:
  tcl8.4{u}
The following packages will be upgraded:
  irssi libalgorithm-diff-xs-perl libapt-pkg-perl libbit-vector-perl libcairo-perl libcrypt-blowfish-perl
  libcrypt-openssl-bignum-perl libcurses-perl libdate-calc-perl libdbi-perl libdigest-sha1-perl libevent-perl libglib-perl
  libgtk2-perl libhtml-parser-perl libio-pty-perl liblist-moreutils-perl liblocale-gettext-perl libnet-dns-perl
  libpango-perl libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libudev0 libuuid-perl libyaml-syck-perl perl
  perl-base perl-modules perl-tk xchat
The following packages are RECOMMENDED but will NOT be installed:
  libclass-isa-perl libpod-plainer-perl libswitch-perl tcl8.5
31 packages upgraded, 1 newly installed, 1 to remove and 2 not upgraded.
Need to get 120 kB/19.5 MB of archives. After unpacking 9,892 kB will be used.
The following packages have unmet dependencies:
  libpurple0: Depends: perlapi-5.10.1 which is a virtual package.
  udev: Depends: libudev0 (= 167-3) but 168-1 is to be installed.
  libperl5.10: Depends: perl-base (= 5.10.1-20) but 5.12.3-6 is to be installed.
  pidgin: Depends: perlapi-5.10.1 which is a virtual package.
The following actions will resolve these dependencies:

      Remove the following packages:                       
1)      hpijs                                             
2)      hplip                                             
3)      hplip-cups                                         
4)      hplip-gui                                         
5)      libhpmud0                                         
6)      libperl5.10                                       
7)      libpurple-bin                                     
8)      libpurple0                                         
9)      libsane-hpaio                                     
10)     libsnmp15                                         
11)     pidgin                                             
12)     pidgin-blinklight                                 
13)     pidgin-extprefs                                   
14)     pidgin-facebookchat                               
15)     pidgin-lastfm                                     
16)     pidgin-openpgp                                     
17)     pidgin-plugin-pack                                 
18)     pidgin-privacy-please                             
19)     pidgin-themes                                     
20)     pidgin-twitter                                     

      Keep the following packages at their current version:
21)     libudev0 [167-3 (now)]                             



Accept this solution? [Y/n/q/?]




Using aptitude upgrade:
Code: Select all
# aptitude upgrade -s
Resolving dependencies...               
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby TheGreatSudoku on Tue May 10, 2011 9:17 pm

05/10/2011 9:10pm EST

The Perl packages all now install with a minimum of removal (xchat and perl5.10 were removed when I upgraded, neither of which I need).

gstreamer0.10-plugins-good is currently broken

xserver-xorg-core still has the segfault bug in it, I'm waiting for it to clear apt-listbugs before upgrading it.
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby zerozero on Tue May 10, 2011 9:28 pm

thanks for the heads-up 8)
tomorrow morning i'll give it a go
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby autocrosser on Wed May 11, 2011 10:14 am

Confirmed on the perl packages---all went well on the update.....
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230
User avatar
autocrosser
Level 4
Level 4
 
Posts: 423
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby craigevil on Wed May 11, 2011 5:31 pm

All upgrade here except for udev, and k9copy.

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
k9copy libudev0 udev
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

udev still has a couple of scary bugs and k9copy is being autoheld.
http://bugs.debian.org/cgi-bin/pkgrepor ... archive=no

No issues with the new Xorg.
# apt-cache policy xserver-xorg-core
xserver-xorg-core:
Installed: 2:1.10.1-2
Candidate: 2:1.10.1-2
Version table:
*** 2:1.10.1-2 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages
100 /var/lib/dpkg/status
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby wayne128 on Wed May 11, 2011 11:07 pm

Today I du
aptosid-xfce
aptosid-kde
Debian-gnome-sid
all works. :mrgreen:
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE (Tracking SID, or other non-standard) BREAKAGES!

Postby autocrosser on Thu May 12, 2011 1:14 am

WARNING!!!!! I just upgraded my Sid & lost it all......libc6 & depends looks like it blew up my Sid, version is - 2.13-3--I rebooted into my Experimental & updated everything but libc6 in my available updates without problems. Chroot is not available for my Sid either....Sid was a bad, bad boy this evening........
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230
User avatar
autocrosser
Level 4
Level 4
 
Posts: 423
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests