LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GregE on Tue Apr 10, 2012 7:55 pm

Regulus74 wrote:Sorry for the OT but what are the advantages of Liquorix kernel?


As well as what Gene listed Liquorix is one way to use the BFS scheduler in the kernel. BFS charmingly stands for Brain F..k Scheduler, BFS is supposed to be better optimised for a home PC. I have used them on and off for years, and they have solved problems for me in the past. If you do not have any issues then they may not be of much use to you. Some people never use anything else.

:)
User avatar
GregE
Level 4
Level 4
 
Posts: 440
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Linux Mint is funded by ads and donations.
 

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GregE on Tue Apr 10, 2012 8:25 pm

Dan,

I was going to suggest sudo apt-get clean as well, definitely worth a go.

Plus the other culprit might be a kernel module. Do you have nvidia/fglrx, virtualbox or wireless modules loaded? They can always be put back once the error is cleared.

:)
User avatar
GregE
Level 4
Level 4
 
Posts: 440
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby dcihon on Wed Apr 11, 2012 8:53 am

GeneC,
No matter what I do I can't get rid of that kernel.
Here is what uname -a returns
danc@danc-linux-mint:~$ uname -a
Linux danc-linux-mint 3.0.0-1-amd64 #1 SMP Tue Sep 20 07:03:13 UTC 2011 x86_64 GNU/Linux

Here is what I get when I go into Synaptic and try to remove 3.2.0-2
Let's see if I can explain this:
I select linux-image-3.2.0-2-amd64
Synaptic says it is going to remove linux-image-3.1.0-1-amd64
Huh?
So I click apply
Here is what I get:
Code: Select all
Reading database ... 343128 files and directories currently installed.)
Removing linux-image-3.1.0-1-amd64 ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.1.0-1-amd64 /boot/vmlinuz-3.1.0-1-amd64
update-initramfs: Deleting /boot/initrd.img-3.1.0-1-amd64
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.1.0-1-amd64 /boot/vmlinuz-3.1.0-1-amd64
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... Generating /boot/grub/default file and setting the default boot entry to 0
entry not specified.
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.1.0-1-amd64.postrm line 235.
dpkg: error processing linux-image-3.1.0-1-amd64 (--remove):
 subprocess installed post-removal script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 linux-image-3.1.0-1-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up linux-image-3.2.0-2-amd64 (3.2.14-1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-2-amd64 /boot/vmlinuz-3.2.0-2-amd64
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-2-amd64 /boot/vmlinuz-3.2.0-2-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-2-amd64
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-2-amd64 /boot/vmlinuz-3.2.0-2-amd64
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-2-amd64 /boot/vmlinuz-3.2.0-2-amd64
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-2-amd64 /boot/vmlinuz-3.2.0-2-amd64
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... Generating /boot/grub/default file and setting the default boot entry to 0
entry not specified.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-2-amd64.postinst line 696, <STDIN> line 7.
dpkg: error processing linux-image-3.2.0-2-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up linux-image-3.2.2-030202-generic (3.2.2-030202.201201252035) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.2-030202-generic /boot/vmlinuz-3.2.2-030202-generic
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.2-030202-generic /boot/vmlinuz-3.2.2-030202-generic
update-initramfs: Generating /boot/initrd.img-3.2.2-030202-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.2-030202-generic /boot/vmlinuz-3.2.2-030202-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.2-030202-generic /boot/vmlinuz-3.2.2-030202-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.2-030202-generic /boot/vmlinuz-3.2.2-030202-generic
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... Generating /boot/grub/default file and setting the default boot entry to 0
entry not specified.
Usage: grub-set-default [OPTION] entry
Set the default boot entry for GRUB.

  -h, --help              print this message and exit
  -v, --version           print the version information and exit
  --root-directory=DIR    Use the directory DIR instead of the root directory

ENTRY is a number or the special keyword `default\'.

Report bugs to <bug-grub@gnu.org>.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.2-030202-generic.postinst line 1010.
dpkg: error processing linux-image-3.2.2-030202-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up linux-image-3.0.0-9.dmz.1-liquorix-amd64 (3.0.0-11) ...
Running depmod.
WARNING: could not open /lib/modules/3.0.0-9.dmz.1-liquorix-amd64/modules.builtin: No such file or directory
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.0.0-9.dmz.1-liquorix-amd64 /boot/vmlinuz-3.0.0-9.dmz.1-liquorix-amd64
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.0.0-9.dmz.1-liquorix-amd64 /boot/vmlinuz-3.0.0-9.dmz.1-liquorix-amd64
update-initramfs: Generating /boot/initrd.img-3.0.0-9.dmz.1-liquorix-amd64
WARNING: could not open /var/tmp/mkinitramfs_nA9HsW/lib/modules/3.0.0-9.dmz.1-liquorix-amd64/modules.builtin: No such file or directory
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.0.0-9.dmz.1-liquorix-amd64 /boot/vmlinuz-3.0.0-9.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.0.0-9.dmz.1-liquorix-amd64 /boot/vmlinuz-3.0.0-9.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.0.0-9.dmz.1-liquorix-amd64 /boot/vmlinuz-3.0.0-9.dmz.1-liquorix-amd64
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... Generating /boot/grub/default file and setting the default boot entry to 0
entry not specified.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.0.0-9.dmz.1-liquorix-amd64.postinst line 774.
dpkg: error processing linux-image-3.0.0-9.dmz.1-liquorix-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 linux-image-3.2.0-2-amd64
 linux-image-3.2.2-030202-generic
 linux-image-3.0.0-9.dmz.1-liquorix-amd64



As you can see I have a kernel nightmare.
Not sure where to start to clean up this mess.
Maybe I should start over?
That is question.
Thanks
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GeneC on Wed Apr 11, 2012 9:13 am

Dan

I wish I could give you some good advice, but this is over my head. Image
If you have a recent clone, what I would do at this point is to re-install it.
If not, starting from scratch might not be too bad a thing to do right now, as new LMDE .iso's are in RC (or wait for the approved release).
http://ftp.heanet.ie/pub/linuxmint.com/testing/?C=M;O=A

Perhaps, wait a little bit. Maybe someone has a fix. :?:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby dcihon on Wed Apr 11, 2012 11:28 am

GeneC,
Thanks for trying to help.
Do you know where I can look to see the release schedule for when the final release will be?
Thanks
Dan
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GeneC on Wed Apr 11, 2012 12:01 pm

Dan

Mint doesn't use release schedules. Its just "release when ready".

I'd watch the Blog for notice. I'd bet in just a week or two. :wink:
http://blog.linuxmint.com/
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby dcihon on Wed Apr 11, 2012 12:10 pm

Thanks
OK
I've made the decision to re install.
Start fresh.
Wish me luck.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GeneC on Wed Apr 11, 2012 12:56 pm

While you wait is a good time to learn to use "Clonezilla" :wink:
(Seriously, a must have with SID)

http://clonezilla.org/show-live-doc-con ... disk_image

http://clonezilla.org/downloads.php
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby zerozero on Wed Apr 11, 2012 7:08 pm

Dan,
there's something you are not telling us :wink: :lol: and that last output shows it
Errors were encountered while processing:
linux-image-3.2.0-2-amd64
linux-image-3.2.2-030202-generic >> where is this kernel coming from?
linux-image-3.0.0-9.dmz.1-liquorix-amd64

anyway,
try this
Code: Select all
sudo dpkg --remove --force-remove-reinstreq linux-image-3.2.0-2-amd64
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby äxl on Wed Apr 11, 2012 7:23 pm

Try zerozero's solution first. Maybe you don't have to read on. ;)

I had a problem with a dpkg that I couldn't get rid off once. (I had it from Launchpad and wanted to downgrade to an official release.)
It complained about postinst and postrm. I wanted to get rid off it real bad so I just deleted the specific files.
I worked. But be sure that you're not deleting the kernel you're still working with. Your output seems confusing ...
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GregE on Wed Apr 11, 2012 8:06 pm

zerozero wrote:
Errors were encountered while processing:
linux-image-3.2.0-2-amd64
linux-image-3.2.2-030202-generic >> where is this kernel coming from?
linux-image-3.0.0-9.dmz.1-liquorix-amd64


ZZ, nice pickup. Does/did Dan have a mixture of 64bit and 32bit kernels? I would have thought that impossible without Multi-arch. Even then you would not do it.

Dan, have you re-installed? Axi's idea is not without merit - as a last resort. You could manually remove all the offending images and folders in /boot and manually re-run grub. If you intend to re-install then it does not matter if it does not work.
User avatar
GregE
Level 4
Level 4
 
Posts: 440
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby zerozero on Wed Apr 11, 2012 8:19 pm

i would like to hear from Dan first, but google tells me that linux-image-3.2.2-030202-generic is an ubuntu kernel.
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby dcihon on Wed Apr 11, 2012 11:07 pm

Guys,
Thanks for all the suggestions.
I started over.
I didn't intentionally leave anything out.
Between leaving posts I was trying all kinds of things that didn't work and only made things worse.
I was trying all the choices in smxi which I never used before.
So I installed some other kernels and tried to use them but the system never would.
I don't know what I did originally to cause this.
Since I have started over I will start to pay closer attention to what changes I am loading with the SID updates.
Things were going so well I just started allowing updates and taking for granted all would work without any problems.
Another Lesson learned.
Clonezilla here I come.
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing
User avatar
dcihon
Level 4
Level 4
 
Posts: 276
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby äxl on Thu Apr 12, 2012 3:25 am

GregE wrote:Axi


Ouch. äxl please. ÄXL. ;)

@dcihon: There are btw other ways to do a backup where you don't have to install an external package.
Preinstalled command line tools like dd (full partition also with image packing) or rsync (incremental with update and delete function) can also do the job.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GregE on Thu Apr 12, 2012 5:21 am

äxl wrote:
GregE wrote:Axi


Ouch. äxl please. ÄXL. ;)


Apologies, my only excuse is that I was not wearing my glasses.

:)
User avatar
GregE
Level 4
Level 4
 
Posts: 440
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE (Tracking SID, or..) BREAKAGES! - Mar 22

Postby GeneC on Thu Apr 12, 2012 6:39 am

CAUTION:

Today's DU wants to remove stuff
LMDE/SID/XFCE

Code: Select all
Calculating upgrade... Done

The following packages will be REMOVED:

  banshee docky giver libglade2.0-cil libgnome2.24-cil libgnomedesktop2.20-cil libgnomepanel2.24-cil libgtk-sharp-beans-cil libgtk2.0-cil libmono-addins-gui0.2-cil
  libnotify0.4-cil librsvg2-2.18-cil libwnck2.20-cil pinta tomboy

The following packages will be upgraded:

  cryptsetup fonts-opensymbol git git-man imagemagick imagemagick-common libcryptsetup4 libglib2.0-cil libglibmm-2.4-1c2a libmagickcore5 libmagickcore5-extra
  libmagickwand5 libpci3 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-tango libreoffice-writer libslang2 libsmbclient libsvga1 libtdb1 libwbclient0 libxml2 libxml2-utils pciutils
  python-egenix-mxdatetime python-egenix-mxtools python-libxml2 python-uno samba samba-common samba-common-bin ttf-opensymbol ucf uno-libs3 ure wajig

50 upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
Need to get 134 MB of archives.
After this operation, 32.6 MB disk space will be freed.
Do you want to continue [Y/n]? n




It appears to be
Code: Select all
 libglib2.0-cil libgtk2.0-cil


As, a SAFE upgrade is=
Code: Select all
Reading state information... Done
The following packages have been kept back:

  libglib2.0-cil libgtk2.0-cil

The following packages will be upgraded:
  cryptsetup fonts-opensymbol git git-man imagemagick imagemagick-common libcryptsetup4 libglade2.0-cil libglibmm-2.4-1c2a libmagickcore5 libmagickcore5-extra
  libmagickwand5 libpci3 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-tango libreoffice-writer libslang2 libsmbclient libsvga1 libtdb1 libwbclient0 libxml2 libxml2-utils pciutils
  python-egenix-mxdatetime python-egenix-mxtools python-libxml2 python-uno samba samba-common samba-common-bin ttf-opensymbol ucf uno-libs3 ure wajig
50 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 134 MB of archives.
After this operation, 217 kB of additional disk space will be used.
Do you want to continue [Y/n]?
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID) - BREAKAGES - Apr 12

Postby Brian49 on Thu Apr 12, 2012 11:10 am

An update to the alsa-utils package has just come through, from 1.0.25-1 to 1.0.25-2, installing which, mysteriously, would involve the removal of eight packages including the kernel.
Brian49
Level 5
Level 5
 
Posts: 601
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE (Tracking SID) - BREAKAGES - Apr 12

Postby GeneC on Thu Apr 12, 2012 11:17 am

Hmm

That's odd
I checked back a full week and did not see any new alsa-utils upgrades?
Its not in experimental either. Where to heck are you getting 1.0.25-2 from? :lol:
http://packages.debian.org/search?suite ... alsa-utils

What I have installed.
Code: Select all
gene@zordon:~$ apt-cache policy alsa-utils
alsa-utils:
  Installed: 1.0.25-1
  Candidate: 1.0.25-1
  Version table:
 *** 1.0.25-1 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


I still have the same problems as stated two posts back. :?
Last edited by GeneC on Thu Apr 12, 2012 11:26 am, edited 1 time in total.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID) - BREAKAGES - Apr 12

Postby Brian49 on Thu Apr 12, 2012 11:22 am

GeneC wrote:I checked back a full week and did not see any new alsa-utils upgrades?

The update to 1.0.25-2 appeared in the repository within the past hour.
Brian49
Level 5
Level 5
 
Posts: 601
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE (Tracking SID) - BREAKAGES - Apr 12

Postby GeneC on Thu Apr 12, 2012 11:29 am

I am using the Main Server, are you using another mirror?

I still dont see it available?
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

LMDE (Cinnamon)
Debian (Gnome Shell 3.8.4 - Testing)
Siduction (XFCE -Debian SID)
Makulu 5 (XFCE-Testing)
User avatar
GeneC
Level 6
Level 6
 
Posts: 1461
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Ken_g6 and 5 guests